Bug 303310 - crash when running some KDE progs and additionally staring bleachbit
Summary: crash when running some KDE progs and additionally staring bleachbit
Status: RESOLVED DUPLICATE of bug 254741
Alias: None
Product: kdelibs
Classification: Unclassified
Component: knotify (show other bugs)
Version: 4.0
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Olivier Goffart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-10 15:31 UTC by Axel Krebs
Modified: 2012-07-10 15:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Krebs 2012-07-10 15:31:36 UTC
Application: knotify4 (4.0)
KDE Platform Version: 4.8.4 (4.8.4) (Compiled from sources)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-26-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

It a shame. simple action crash the KDE system. 

Why don't take care, that KDE don't interfere harmfuilly, at least. 

Running some KDE progs, as digiKam 4.6 when starting bleachbit, additionally. 

Why do certain mistakes come back in new versions? 
Does take KDE take care of a stringent quality system at all?

Hope they might learn...

The crash can be reproduced some of the time.

-- Backtrace:
Application: KNotify (knotify4), signal: Bus error
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9297c72780 (LWP 2212))]

Thread 2 (Thread 0x7f9284b81700 (LWP 2213)):
#0  0x00007f9294de4b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9292429036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9292429164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9295565426 in QEventDispatcherGlib::processEvents (this=0x7f92800008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f9295534c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9295534ed7 in QEventLoop::exec (this=0x7f9284b80dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f9295433fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f92955149ff in QInotifyFileSystemWatcherEngine::run (this=0x1fe40f0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f9295436fcb in QThreadPrivate::start (arg=0x1fe40f0) at thread/qthread_unix.cpp:298
#9  0x00007f92928f5e9a in start_thread (arg=0x7f9284b81700) at pthread_create.c:308
#10 0x00007f9294df04bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9297c72780 (LWP 2212)):
[KCrash Handler]
#6  0x00007f9295d47fc5 in lock (this=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1231
#7  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7fff05f9dca0) at ../../kdecore/util/kshareddatacache.cpp:1255
#8  0x00007f9295d48b50 in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fff05f9dca0, _d=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1278
#9  0x00007f9295d428a9 in KSharedDataCache::insert (this=0x1e90c40, key=..., data=...) at ../../kdecore/util/kshareddatacache.cpp:1471
#10 0x00007f9297603e3b in KIconLoaderPrivate::insertCachedPixmapWithPath (this=0x1f21ae0, key=..., data=..., path=...) at ../../kdeui/icons/kiconloader.cpp:834
#11 0x00007f9297604761 in KIconLoader::loadIcon (this=0x1f06b10, _name=..., group=KIconLoader::Desktop, size=16, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1307
#12 0x00007f92975fbc3f in KIconEngine::pixmap (this=<optimized out>, size=..., mode=<optimized out>, state=<optimized out>) at ../../kdeui/icons/kiconengine.cpp:104
#13 0x00007f9296258835 in QIcon::pixmap (this=<optimized out>, size=..., mode=<optimized out>, state=<optimized out>) at image/qicon.cpp:684
#14 0x00007f929624a84b in QWidgetPrivate::setWindowIcon_sys (this=0x203c900, forceReset=false) at kernel/qwidget_x11.cpp:1506
#15 0x00007f92961f6d05 in QWidget::create (this=0x24ecc50, window=0, initializeWindow=true, destroyOldWindow=true) at kernel/qwidget.cpp:1540
#16 0x00007f9296200bba in QWidget::setVisible (this=0x24ecc50, visible=<optimized out>) at kernel/qwidget.cpp:7699
#17 0x00007f92976c1392 in setVisible (this=0x24ecc50, visible=<optimized out>) at ../../kdeui/util/kpassivepopup.cpp:291
#18 KPassivePopup::setVisible (this=0x24ecc50, visible=<optimized out>) at ../../kdeui/util/kpassivepopup.cpp:273
#19 0x0000000000414ee0 in NotifyByPopup::notify (this=0x1fe4990, id=<optimized out>, config=0x24f0d28) at ../../knotify/notifybypopup.cpp:135
#20 0x000000000040b5bd in KNotify::emitEvent (this=0x7fff05f9fa70, e=0x24f0d20) at ../../knotify/knotify.cpp:230
#21 0x000000000040c39d in KNotify::event (this=0x7fff05f9fa70, event=..., appname=..., contexts=..., title=..., text=..., image=..., actions=..., timeout=0, winId=0) at ../../knotify/knotify.cpp:149
#22 0x000000000040c8b0 in KNotifyAdaptor::event (this=0x1fe41b0, event=..., fromApp=..., contexts=..., title=..., text=..., image=..., actions=..., timeout=0, winId=0) at ../../knotify/knotify.cpp:289
#23 0x000000000040ccd8 in qt_static_metacall (_a=0x7fff05f9ee00, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./knotify.moc:218
#24 KNotifyAdaptor::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=0x7fff05f9ee00) at ./knotify.moc:208
#25 0x000000000040cdbb in KNotifyAdaptor::qt_metacall (this=0x1fe41b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff05f9ee00) at ./knotify.moc:260
#26 0x00007f92958b037b in QDBusConnectionPrivate::deliverCall (this=0x1e1e990, object=0x1fe41b0, msg=..., metaTypes=..., slotIdx=8) at qdbusintegrator.cpp:947
#27 0x00007f92958b14dd in QDBusConnectionPrivate::activateCall (this=0x1e1e990, object=0x1fe41b0, flags=273, msg=...) at qdbusintegrator.cpp:857
#28 0x00007f92958b1e3b in QDBusConnectionPrivate::activateObject (this=0x1e1e990, node=..., msg=..., pathStartPos=<optimized out>) at qdbusintegrator.cpp:1423
#29 0x00007f92958b1f2b in QDBusActivateObjectEvent::placeMetaCall (this=0x24f2a00) at qdbusintegrator.cpp:1537
#30 0x00007f929554f446 in QObject::event (this=0x7fff05f9fa70, e=<optimized out>) at kernel/qobject.cpp:1195
#31 0x00007f92961ad894 in notify_helper (e=0x24f2a00, receiver=0x7fff05f9fa70, this=0x1e324f0) at kernel/qapplication.cpp:4559
#32 QApplicationPrivate::notify_helper (this=0x1e324f0, receiver=0x7fff05f9fa70, e=0x24f2a00) at kernel/qapplication.cpp:4531
#33 0x00007f92961b2713 in QApplication::notify (this=0x7fff05f9faa0, receiver=0x7fff05f9fa70, e=0x24f2a00) at kernel/qapplication.cpp:4420
#34 0x00007f92976559e6 in KApplication::notify (this=0x7fff05f9faa0, receiver=0x7fff05f9fa70, event=0x24f2a00) at ../../kdeui/kernel/kapplication.cpp:311
#35 0x00007f9295535e9c in QCoreApplication::notifyInternal (this=0x7fff05f9faa0, receiver=0x7fff05f9fa70, event=0x24f2a00) at kernel/qcoreapplication.cpp:876
#36 0x00007f9295539c6a in sendEvent (event=0x24f2a00, receiver=0x7fff05f9fa70) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#37 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1e062b0) at kernel/qcoreapplication.cpp:1500
#38 0x00007f9295564f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#39 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#40 0x00007f9292428d53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007f92924290a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007f9292429164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x00007f92955653bf in QEventDispatcherGlib::processEvents (this=0x1e07770, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#44 0x00007f9296255d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x00007f9295534c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#46 0x00007f9295534ed7 in QEventLoop::exec (this=0x7fff05f9fa00, flags=...) at kernel/qeventloop.cpp:204
#47 0x00007f9295539f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#48 0x0000000000409747 in main (argc=1, argv=0x7fff05f9fe28) at ../../knotify/main.cpp:73

Possible duplicates by query: bug 284770.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-10 15:34:26 UTC

*** This bug has been marked as a duplicate of bug 254741 ***