Bug 303307 - Crash hwen running some KDE applications and Bleachbit
Summary: Crash hwen running some KDE applications and Bleachbit
Status: RESOLVED DUPLICATE of bug 254741
Alias: None
Product: ksysguard
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-10 15:19 UTC by Axel Krebs
Modified: 2012-07-10 15:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Krebs 2012-07-10 15:19:06 UTC
Application: ksysguard (4.8.4 (4.8.4))
KDE Platform Version: 4.8.4 (4.8.4) (Compiled from sources)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-26-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

just running some progs, all crashed when running bleachbit after a while

The crash can be reproduced every time.

-- Backtrace:
Application: Systemmonitor (ksysguard), signal: Bus error
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f91ecc6c780 (LWP 2283))]

Thread 2 (Thread 0x7f91d60de700 (LWP 4500)):
#0  0x00007f91ec52db03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f91e393d036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f91e393d164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f91ea166426 in QEventDispatcherGlib::processEvents (this=0x7f91c80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f91ea135c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f91ea135ed7 in QEventLoop::exec (this=0x7f91d60dddd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f91ea034fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f91ea1159ff in QInotifyFileSystemWatcherEngine::run (this=0x19bf1e0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f91ea037fcb in QThreadPrivate::start (arg=0x19bf1e0) at thread/qthread_unix.cpp:298
#9  0x00007f91e4445e9a in start_thread (arg=0x7f91d60de700) at pthread_create.c:308
#10 0x00007f91ec5394bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f91ecc6c780 (LWP 2283)):
[KCrash Handler]
#6  0x00007f91ea948fc5 in lock (this=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1231
#7  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7fff240c1bb0) at ../../kdecore/util/kshareddatacache.cpp:1255
#8  0x00007f91ea949b50 in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fff240c1bb0, _d=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1278
#9  0x00007f91ea943156 in KSharedDataCache::find (this=0x1074f80, key=..., destination=0x7fff240c1c80) at ../../kdecore/util/kshareddatacache.cpp:1630
#10 0x00007f91eadc9019 in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x1092290, key=..., data=..., path=...) at ../../kdeui/icons/kiconloader.cpp:861
#11 0x00007f91eadc9392 in KIconLoader::loadIcon (this=0x10911b0, _name=..., group=KIconLoader::Small, size=16, state=0, overlays=..., path_store=0x0, canReturnNull=true) at ../../kdeui/icons/kiconloader.cpp:1225
#12 0x00007f91eaf4f63c in KWindowSystem::icon (win=56623202, width=16, height=16, scale=true, flags=15) at ../../kdeui/windowmanagement/kwindowsystem_x11.cpp:688
#13 0x00007f91eaf4fdd3 in KWindowSystem::icon (win=<optimized out>, width=<optimized out>, height=<optimized out>, scale=<optimized out>) at ../../kdeui/windowmanagement/kwindowsystem_x11.cpp:621
#14 0x00007f91ec226867 in ProcessModelPrivate::updateWindowInfo (this=0x115ce30, wid=56623202, properties=12681216, newWindow=<optimized out>) at ../../../../libs/ksysguard/processui/ProcessModel.cpp:541
#15 0x00007f91ea14b281 in QMetaObject::activate (sender=0x115a7d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff240c25c0) at kernel/qobject.cpp:3547
#16 0x00007f91eaf50ec2 in KWindowSystem::windowAdded (this=<optimized out>, _t1=56623202) at ./kwindowsystem.moc:143
#17 0x00007f91eaf51449 in KWindowSystemPrivate::addClient (this=0x120b1b0, w=56623202) at ../../kdeui/windowmanagement/kwindowsystem_x11.cpp:269
#18 0x00007f91eaf5fdc6 in NETRootInfo::update (this=0x120b1d8, dirty_props=<optimized out>) at ../../kdeui/windowmanagement/netwm.cpp:2227
#19 0x00007f91eaf60a43 in NETRootInfo::event (this=0x120b1d8, event=0x7fff240c2910, properties=0x7fff240c2820, properties_size=5) at ../../kdeui/windowmanagement/netwm.cpp:2099
#20 0x00007f91eaf53153 in KWindowSystemPrivate::x11Event (this=0x120b1b0, ev=0x7fff240c2910) at ../../kdeui/windowmanagement/kwindowsystem_x11.cpp:172
#21 0x00007f91eae43886 in publicX11Event (e=0x7fff240c2910, this=<optimized out>) at ../../kdeui/kernel/ksystemeventfilter.cpp:43
#22 KSystemEventFilterPrivate::filterEvent (this=0x11a27c0, message=0x7fff240c2910) at ../../kdeui/kernel/ksystemeventfilter.cpp:102
#23 0x00007f91ea129bee in QAbstractEventDispatcher::filterEvent (this=<optimized out>, message=<optimized out>) at kernel/qabstracteventdispatcher.cpp:539
#24 0x00007f91e9562048 in x11EventSourceDispatch (s=0xfc0700, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:143
#25 0x00007f91e393cd53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007f91e393d0a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f91e393d164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f91ea1663bf in QEventDispatcherGlib::processEvents (this=0xf9a4b0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#29 0x00007f91e9561d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#30 0x00007f91ea135c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#31 0x00007f91ea135ed7 in QEventLoop::exec (this=0x7fff240c2cb0, flags=...) at kernel/qeventloop.cpp:204
#32 0x00007f91ea13af67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#33 0x00007f91ec86d3d1 in kdemain (argc=3, argv=<optimized out>) at ../../../ksysguard/gui/ksysguard.cpp:581
#34 0x00007f91ec46876d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=3, ubp_av=0x7fff240c3208, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff240c31f8) at libc-start.c:226
#35 0x0000000000400671 in _start ()

Possible duplicates by query: bug 284770.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-10 15:29:39 UTC

*** This bug has been marked as a duplicate of bug 274741 ***
Comment 2 Jekyll Wu 2012-07-10 15:31:47 UTC

*** This bug has been marked as a duplicate of bug 275741 ***
Comment 3 Jekyll Wu 2012-07-10 15:32:44 UTC

*** This bug has been marked as a duplicate of bug 254741 ***