Bug 261959 - Plasme crashes after using BleachBit
Summary: Plasme crashes after using BleachBit
Status: RESOLVED DUPLICATE of bug 254741
Alias: None
Product: kmix
Classification: Applications
Component: general (show other bugs)
Version: 3.7
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-03 15:09 UTC by Arthur Marceaux dit Clément
Modified: 2011-05-08 13:47 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arthur Marceaux dit Clément 2011-01-03 15:09:15 UTC
Application: kmix (3.7)
KDE Platform Version: 4.5.4 (KDE 4.5.4)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

I used BleachBit to clean deeply my Kubuntu, and Plasma crashed a few seconds later. It does it every time I use this tool.

The crash can be reproduced every time.

-- Backtrace:
Application: KMix (kmix), signal: Bus error
[Current thread is 1 (Thread 0x7f5d82f59780 (LWP 2608))]

Thread 2 (Thread 0x7f5d65c06700 (LWP 2612)):
#0  0x00007f5d82964203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f5d78fbe009 in g_main_context_poll (context=0x26dda60, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:3093
#2  g_main_context_iterate (context=0x26dda60, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2775
#3  0x00007f5d78fbe45c in g_main_context_iteration (context=0x26dda60, may_block=1) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2843
#4  0x00007f5d7f7b21e6 in QEventDispatcherGlib::processEvents (this=0x25ae4f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#5  0x00007f5d7f784a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#6  0x00007f5d7f784dec in QEventLoop::exec (this=0x7f5d65c05d90, flags=) at kernel/qeventloop.cpp:201
#7  0x00007f5d7f68f2fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007f5d7f7645f8 in QInotifyFileSystemWatcherEngine::run (this=0x26f0c60) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f5d7f69227e in QThreadPrivate::start (arg=0x26f0c60) at thread/qthread_unix.cpp:266
#10 0x00007f5d7f407971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#11 0x00007f5d8297092d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f5d82f59780 (LWP 2608)):
[KCrash Handler]
#6  pthread_mutex_timedlock (mutex=0x7f5d67b50008, abstime=0x7fffb4d2fc40) at pthread_mutex_timedlock.c:40
#7  0x00007f5d7ff75963 in lock (this=<value optimized out>) at ../../kdecore/util/kshareddatacache.cpp:797
#8  clear (this=<value optimized out>) at ../../kdecore/util/kshareddatacache.cpp:813
#9  KSharedDataCache::clear (this=<value optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1412
#10 0x00007f5d819f3713 in Plasma::ThemePrivate::discardCache (this=0x2526530, oldThemeName=..., keepSvgElementsCache=false) at ../../plasma/theme.cpp:242
#11 0x00007f5d819f3c87 in Plasma::ThemePrivate::compositingChanged (this=0x2526530) at ../../plasma/theme.cpp:232
#12 0x00007f5d819fa45c in Plasma::Theme::qt_metacall (this=0x2526470, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb4d2fe70) at ./theme.moc:116
#13 0x00007f5d7f79db27 in QMetaObject::activate (sender=0x2528bb0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x20c49ba5e353f7cf) at kernel/qobject.cpp:3280
#14 0x00007f5d81fd8c6d in KSelectionWatcher::Private::x11Event (this=<value optimized out>, ev_P=0x7fffb4d2fc40) at ../../kdeui/util/kmanagerselection.cpp:395
#15 0x00007f5d81f5c06e in publicx11Event (this=<value optimized out>, _event=0x7fffb4d30540) at ../../kdeui/kernel/kapplication.cpp:915
#16 KApplication::x11EventFilter (this=<value optimized out>, _event=0x7fffb4d30540) at ../../kdeui/kernel/kapplication.cpp:966
#17 0x00007f5d8042e751 in qt_x11EventFilter (ev=0x7fffb4d30540) at kernel/qapplication_x11.cpp:408
#18 0x00007f5d8043e4f1 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fffb4d30540) at kernel/qapplication_x11.cpp:3248
#19 0x00007f5d8046b0e2 in x11EventSourceDispatch (s=0x23d0080, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#20 0x00007f5d78fba342 in g_main_dispatch (context=0x23cf120) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2149
#21 g_main_context_dispatch (context=0x23cf120) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2702
#22 0x00007f5d78fbe2a8 in g_main_context_iterate (context=0x23cf120, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2780
#23 0x00007f5d78fbe45c in g_main_context_iteration (context=0x23cf120, may_block=1) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2843
#24 0x00007f5d7f7b2193 in QEventDispatcherGlib::processEvents (this=0x239e690, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#25 0x00007f5d8046aa4e in QGuiEventDispatcherGlib::processEvents (this=0x7f5d67b50008, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00007f5d7f784a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#27 0x00007f5d7f784dec in QEventLoop::exec (this=0x7fffb4d30870, flags=) at kernel/qeventloop.cpp:201
#28 0x00007f5d7f788ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#29 0x00007f5d82c3032a in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_kmix.so
#30 0x00007f5d828a8d8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffb4d30de8) at libc-start.c:226
#31 0x0000000000400659 in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2011-05-08 13:47:06 UTC

*** This bug has been marked as a duplicate of bug 254741 ***