Bug 320603 - kwin crashes by using bleachbit
Summary: kwin crashes by using bleachbit
Status: RESOLVED DUPLICATE of bug 254741
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 4.10.3
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-02 09:52 UTC by Michael
Modified: 2013-06-02 14:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2013-06-02 09:52:46 UTC
Application: kwin (4.10.3)
KDE Platform Version: 4.10.3
Qt Version: 4.8.4
Operating System: Linux 3.9.4-200.fc18.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
i must restart bleachbit 3 times, after a view minutes kwin crashes. after the last crash i can clean/wipe system. a following crash came up whit k-wallet

The crash can be reproduced sometimes.

-- Backtrace:
Application: KWin (kwin), signal: Bus error
Using host libthread_db library "/lib64/libthread_db.so.1".
81	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fe8bcd1b880 (LWP 2556))]

Thread 2 (Thread 0x7fe8b15ee700 (LWP 2558)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:165
#1  0x00000034907868c7 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x3490a94660 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00000034907868f9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x000000346de07d15 in start_thread (arg=0x7fe8b15ee700) at pthread_create.c:308
#4  0x000000346d6f248d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:114

Thread 1 (Thread 0x7fe8bcd1b880 (LWP 2556)):
[KCrash Handler]
#6  0x000000350f63334d in lock (this=0x1e01440) at /usr/src/debug/kdelibs-4.10.3/kdecore/util/kshareddatacache.cpp:1231
#7  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7fff44da8320) at /usr/src/debug/kdelibs-4.10.3/kdecore/util/kshareddatacache.cpp:1255
#8  0x000000350f6339a0 in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fff44da8320, _d=<optimized out>) at /usr/src/debug/kdelibs-4.10.3/kdecore/util/kshareddatacache.cpp:1278
#9  0x000000350f62b9ce in KSharedDataCache::find (this=0x1de6720, key=..., destination=0x7fff44da8390) at /usr/src/debug/kdelibs-4.10.3/kdecore/util/kshareddatacache.cpp:1630
#10 0x0000003aaa9f8789 in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x1e00520, key=..., data=..., path=...) at /usr/src/debug/kdelibs-4.10.3/kdeui/icons/kiconloader.cpp:854
#11 0x0000003aaa9fcdfe in KIconLoader::loadIcon (this=0x1db7c90, _name=..., group=KIconLoader::Small, size=4, state=0, overlays=..., path_store=0x0, canReturnNull=true) at /usr/src/debug/kdelibs-4.10.3/kdeui/icons/kiconloader.cpp:1123
#12 0x0000003aaab6e779 in KWindowSystem::icon (win=<optimized out>, width=32, height=32, scale=true, flags=12) at /usr/src/debug/kdelibs-4.10.3/kdeui/windowmanagement/kwindowsystem_x11.cpp:688
#13 0x000000334d055f5e in KWin::Client::getIcons() () from /lib64/libkdeinit4_kwin.so
#14 0x000000334d082298 in KWin::Client::manage(unsigned long, bool) () from /lib64/libkdeinit4_kwin.so
#15 0x000000334d045d34 in KWin::Workspace::createClient(unsigned long, bool) () from /lib64/libkdeinit4_kwin.so
#16 0x000000334d073fc0 in KWin::Workspace::workspaceEvent(_XEvent*) () from /lib64/libkdeinit4_kwin.so
#17 0x000000334d065bd8 in KWin::Application::x11EventFilter(_XEvent*) () from /lib64/libkdeinit4_kwin.so
#18 0x0000003aa8c3687c in qt_x11EventFilter (ev=0x7fff44da9290) at kernel/qapplication_x11.cpp:435
#19 qt_x11EventFilter (ev=0x7fff44da9290) at kernel/qapplication_x11.cpp:423
#20 0x0000003aa8c43ecb in QApplication::x11ProcessEvent (this=0x7fff44da97f0, event=0x7fff44da9290) at kernel/qapplication_x11.cpp:3372
#21 0x0000003aa8c6b4f9 in QEventDispatcherX11::processEvents (this=0x1d10ba0, flags=...) at kernel/qeventdispatcher_x11.cpp:132
#22 0x0000003477f765ef in QEventLoop::processEvents (this=this@entry=0x7fff44da9500, flags=...) at kernel/qeventloop.cpp:149
#23 0x0000003477f76878 in QEventLoop::exec (this=0x7fff44da9500, flags=...) at kernel/qeventloop.cpp:204
#24 0x0000003477f7b708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1221
#25 0x000000334d06822a in kdemain () from /lib64/libkdeinit4_kwin.so
#26 0x000000346d621a05 in __libc_start_main (main=0x400960 <main>, argc=3, ubp_av=0x7fff44da9938, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff44da9928) at libc-start.c:225
#27 0x0000000000400991 in _start ()

This bug may be a duplicate of or related to bug 313545.

Possible duplicates by query: bug 313839, bug 313545, bug 310111, bug 309824, bug 308099.

Reported using DrKonqi
Comment 1 Thomas Lübking 2013-06-02 10:50:59 UTC
Bleachshit is done by a bunch of morons who have preciselely no idea about what they are doing there and cannot do what they want to do, starting by that you cannot do the lowlevel stuff, that would be required to do it right if it was anything sane in the first place, in python.

Solution: do not use bleachshit - it's more malware than anything else.

*** This bug has been marked as a duplicate of bug 254741 ***
Comment 2 Michael 2013-06-02 14:54:33 UTC
ok, thanks !