Bug 271889 - KDE Run Command crash
Summary: KDE Run Command crash
Status: RESOLVED NOT A BUG
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kshareddatacache (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 271890 271891 272207 273255 281904 281905 283514 284818 296851 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-28 03:18 UTC by rflazaro
Modified: 2012-03-27 14:00 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rflazaro 2011-04-28 03:18:50 UTC
Application: krunner (0.1)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.39-rc4-12-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I was running BleachBit to clean out unnecessary files on my machine

-- Backtrace:
Application: Run Command Interface (kdeinit4), signal: Bus error
[Current thread is 1 (Thread 0x7fd5ec3aa760 (LWP 3201))]

Thread 2 (Thread 0x7fd5d2ca1700 (LWP 3227)):
#0  0x00007fd5eacfa0a4 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007fd5e691a0b6 in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#2  0x00007fd5e691afa9 in ?? () from /lib64/libglib-2.0.so.0
#3  0x00007fd5e691b650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#4  0x00007fd5eb09a976 in QEventDispatcherGlib::processEvents (this=0x7a6370, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fd5eb06f052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fd5eb06f265 in QEventLoop::exec (this=0x7fd5d2ca0d20, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fd5eaf841e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#8  0x00007fd5eb050968 in QInotifyFileSystemWatcherEngine::run (this=0x7abbe0) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007fd5eaf86a5e in QThreadPrivate::start (arg=0x7abbe0) at thread/qthread_unix.cpp:285
#10 0x00007fd5de4d9853 in ?? () from /usr/lib64/libGL.so.1
#11 0x00007fd5eacf7a3f in start_thread () from /lib64/libpthread.so.0
#12 0x00007fd5e9ab267d in clone () from /lib64/libc.so.6
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd5ec3aa760 (LWP 3201)):
[KCrash Handler]
#6  0x00007fd5eb5accdd in lock (this=0x7fff98ae45b0, _d=0x82a5f0) at /usr/src/debug/kdelibs-4.6.0/kdecore/util/kshareddatacache.cpp:1098
#7  cautiousLock (this=0x7fff98ae45b0, _d=0x82a5f0) at /usr/src/debug/kdelibs-4.6.0/kdecore/util/kshareddatacache.cpp:1121
#8  KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fff98ae45b0, _d=0x82a5f0) at /usr/src/debug/kdelibs-4.6.0/kdecore/util/kshareddatacache.cpp:1146
#9  0x00007fd5eb502c43 in KSharedDataCache::clear (this=0x821e20) at /usr/src/debug/kdelibs-4.6.0/kdecore/util/kshareddatacache.cpp:1496
#10 0x00007fd5e1e6a3da in Plasma::ThemePrivate::discardCache (this=0x804a40, caches=...) at /usr/src/debug/kdelibs-4.6.0/plasma/theme.cpp:276
#11 0x00007fd5e1e6a92b in Plasma::ThemePrivate::compositingChanged (this=0x804a40) at /usr/src/debug/kdelibs-4.6.0/plasma/theme.cpp:266
#12 0x00007fd5e1e7142f in Plasma::Theme::qt_metacall (this=0x851140, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0x7fff98ae47a0) at /usr/src/debug/kdelibs-4.6.0/build/plasma/theme.moc:116
#13 0x00007fd5eb084def in QMetaObject::activate (sender=0x7f9210, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#14 0x00007fd5ebebb68d in KSelectionWatcher::Private::x11Event (this=<value optimized out>, ev_P=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/kdeui/util/kmanagerselection.cpp:395
#15 0x00007fd5ebe3a50e in publicx11Event (this=<value optimized out>, _event=0x7fff98ae4ea0) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:916
#16 KApplication::x11EventFilter (this=<value optimized out>, _event=0x7fff98ae4ea0) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:967
#17 0x00007fd5ea28dcc5 in qt_x11EventFilter (ev=0x7fff98ae4ea0) at kernel/qapplication_x11.cpp:436
#18 0x00007fd5ea29bce0 in QApplication::x11ProcessEvent (this=0x6fc430, event=0x7fff98ae4ea0) at kernel/qapplication_x11.cpp:3276
#19 0x00007fd5ea2c40f2 in x11EventSourceDispatch (s=0x700130, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#20 0x00007fd5e691abd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#21 0x00007fd5e691b3b0 in ?? () from /lib64/libglib-2.0.so.0
#22 0x00007fd5e691b650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#23 0x00007fd5eb09a91f in QEventDispatcherGlib::processEvents (this=0x617ca0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#24 0x00007fd5ea2c3d8e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x00007fd5eb06f052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007fd5eb06f265 in QEventLoop::exec (this=0x7fff98ae51c0, flags=...) at kernel/qeventloop.cpp:201
#27 0x00007fd5eb0736ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#28 0x00007fd5d9e05256 in kdemain (argc=1, argv=0x6e2b70) at /usr/src/debug/kdebase-workspace-4.6.0/krunner/main.cpp:65
#29 0x00000000004075e9 in _start ()

Reported using DrKonqi
Comment 1 Aaron J. Seigo 2011-04-28 10:10:28 UTC
*** Bug 271891 has been marked as a duplicate of this bug. ***
Comment 2 Michael Pyne 2011-04-29 00:10:22 UTC
*** Bug 271890 has been marked as a duplicate of this bug. ***
Comment 3 Michael Pyne 2011-04-29 00:21:45 UTC
> I was running BleachBit to clean out unnecessary files on my machine.

Files under /var/tmp (including /var/tmp/kdecache-$USER, where the various
KSharedDataCaches live) are not unnecessary in general.

If you want to remove them, it is safe to simply unlink the file, such as with
the 'rm' command or by deleting them from Dolphin. It's is *not* safe to run
BleachBit on these files unless you do so from outside of KDE, or unless you
ensure that BleachBit is configured not to try to shred or overwrite files for
privacy before deleting them.

If you can reproduce this bug without intentionally destroying the cache data
for the running desktop then please reopen the bug. It would be best to ensure
BleachBit stays out of /var/tmp and other important system paths however.
Comment 4 Andrew Ziem 2011-05-23 20:23:35 UTC
Next release of BleachBit after version 0.8.7 includes whitelist for /var/tmp/kdecache-* , and in the future, please report BleachBit bugs to https://bugs.launchpad.net/bleachbit/
Comment 5 Tommi Tervo 2011-06-12 21:16:41 UTC
*** Bug 273255 has been marked as a duplicate of this bug. ***
Comment 6 Thomas Lübking 2011-09-12 22:57:25 UTC
*** Bug 281904 has been marked as a duplicate of this bug. ***
Comment 7 Thomas Lübking 2011-09-13 10:49:59 UTC
*** Bug 281905 has been marked as a duplicate of this bug. ***
Comment 8 Christoph Feck 2011-10-07 09:32:37 UTC
*** Bug 283514 has been marked as a duplicate of this bug. ***
Comment 9 Michael Pyne 2011-10-25 02:44:55 UTC
*** Bug 284818 has been marked as a duplicate of this bug. ***
Comment 10 Jekyll Wu 2011-12-10 04:08:52 UTC
*** Bug 272207 has been marked as a duplicate of this bug. ***
Comment 11 Jekyll Wu 2012-03-27 14:00:15 UTC
*** Bug 296851 has been marked as a duplicate of this bug. ***