Bug 338713 - Crash after usage of Bleachbit - 1) as root 2) as regular user. I had done this many times with Kubuntu 12.04 and had no problems.
Summary: Crash after usage of Bleachbit - 1) as root 2) as regular user. I had done th...
Status: RESOLVED DUPLICATE of bug 254741
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-01 07:59 UTC by 123design
Modified: 2014-09-01 22:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 123design 2014-09-01 07:59:41 UTC
Application: kate (3.13.3)
KDE Platform Version: 4.13.3
Qt Version: 4.8.6
Operating System: Linux 3.13.0-35-generic x86_64
Distribution: Ubuntu 14.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
Crash after usage of Bleachbit - 1) as root 2) as regular user. I had done this many times with Kubuntu 12.04 and had no problems.

-- Backtrace:
Application: Kate (kate), signal: Bus error
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1b8833e7c0 (LWP 6863))]

Thread 3 (Thread 0x7f1b736b7700 (LWP 6864)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f1b74f50ffb in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f1b74f51039 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f1b85298182 in start_thread (arg=0x7f1b736b7700) at pthread_create.c:312
#4  0x00007f1b87c87fbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f1af0434700 (LWP 6865)):
#0  0x00007f1b87c7ac6d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f1b84db8fe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1b84db90ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1b85b987be in QEventDispatcherGlib::processEvents (this=0x7f1ae80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#4  0x00007f1b85b6a0af in QEventLoop::processEvents (this=this@entry=0x7f1af0433de0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f1b85b6a3a5 in QEventLoop::exec (this=this@entry=0x7f1af0433de0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f1b85a66c5f in QThread::exec (this=this@entry=0x2e8cb10) at thread/qthread.cpp:537
#7  0x00007f1b85b4b823 in QInotifyFileSystemWatcherEngine::run (this=0x2e8cb10) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f1b85a6932f in QThreadPrivate::start (arg=0x2e8cb10) at thread/qthread_unix.cpp:349
#9  0x00007f1b85298182 in start_thread (arg=0x7f1af0434700) at pthread_create.c:312
#10 0x00007f1b87c87fbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f1b8833e7c0 (LWP 6863)):
[KCrash Handler]
#6  0x00007f1b86c33005 in lock (this=0x23e6be0) at ../../kdecore/util/kshareddatacache.cpp:1235
#7  cautiousLock (this=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1259
#8  CacheLocker (_d=0x23e6be0, this=<synthetic pointer>) at ../../kdecore/util/kshareddatacache.cpp:1309
#9  KSharedDataCache::find (this=0x2410960, key=..., destination=destination@entry=0x7fff5ab15770) at ../../kdecore/util/kshareddatacache.cpp:1606
#10 0x00007f1b86325b60 in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x238cfa0, key=..., data=..., path=...) at ../../kdeui/icons/kiconloader.cpp:854
#11 0x00007f1b86325ea6 in KIconLoader::loadIcon (this=0x23dbc20, _name=..., group=group@entry=KIconLoader::Desktop, size=22, state=1, overlays=..., path_store=path_store@entry=0x0, canReturnNull=canReturnNull@entry=false) at ../../kdeui/icons/kiconloader.cpp:1149
#12 0x00007f1b8631e00e in KIconEngine::pixmap (this=<optimized out>, size=..., mode=<optimized out>, state=<optimized out>) at ../../kdeui/icons/kiconengine.cpp:104
#13 0x00007f1b87147c95 in QIcon::pixmap (this=this@entry=0x7fff5ab15d78, size=..., mode=<optimized out>, state=<optimized out>) at image/qicon.cpp:684
#14 0x00007f1b873b1e9c in QCommonStyle::drawControl (this=0x2379c50, element=<optimized out>, opt=0x7fff5ab15d30, p=0x7fff5ab15fb0, widget=0x2888b50) at styles/qcommonstyle.cpp:1592
#15 0x00007f1b7a7c34c4 in ?? () from /usr/lib/kde4/plugins/styles/oxygen.so
#16 0x00007f1b7a7b9185 in ?? () from /usr/lib/kde4/plugins/styles/oxygen.so
#17 0x00007f1b7a7c354e in ?? () from /usr/lib/kde4/plugins/styles/oxygen.so
#18 0x00007f1b8750c2b9 in drawComplexControl (opt=..., cc=QStyle::CC_ToolButton, this=0x7fff5ab15fb0) at ../../include/QtGui/../../src/gui/painting/qstylepainter.h:94
#19 QToolButton::paintEvent (this=0x2888b50) at widgets/qtoolbutton.cpp:558
#20 0x00007f1b870f32f0 in QWidget::event (this=0x2888b50, event=0x7fff5ab16430) at kernel/qwidget.cpp:8533
#21 0x00007f1b870a3e2c in QApplicationPrivate::notify_helper (this=this@entry=0x2314d40, receiver=receiver@entry=0x2888b50, e=e@entry=0x7fff5ab16430) at kernel/qapplication.cpp:4567
#22 0x00007f1b870aa4a0 in QApplication::notify (this=this@entry=0x7fff5ab17560, receiver=receiver@entry=0x2888b50, e=e@entry=0x7fff5ab16430) at kernel/qapplication.cpp:4353
#23 0x00007f1b8636fd1a in KApplication::notify (this=0x7fff5ab17560, receiver=0x2888b50, event=0x7fff5ab16430) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f1b85b6b4dd in QCoreApplication::notifyInternal (this=0x7fff5ab17560, receiver=receiver@entry=0x2888b50, event=event@entry=0x7fff5ab16430) at kernel/qcoreapplication.cpp:953
#25 0x00007f1b870eda11 in sendSpontaneousEvent (event=0x7fff5ab16430, receiver=0x2888b50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
#26 QWidgetPrivate::drawWidget (this=this@entry=0x28cafd0, pdev=pdev@entry=0x2f0bcb0, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0x269eb90) at kernel/qwidget.cpp:5599
#27 0x00007f1b870ee440 in QWidgetPrivate::paintSiblingsRecursive (this=this@entry=0x28c63b0, pdev=pdev@entry=0x2f0bcb0, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0x269eb90) at kernel/qwidget.cpp:5808
#28 0x00007f1b870ed5cc in QWidgetPrivate::drawWidget (this=this@entry=0x28c63b0, pdev=pdev@entry=0x2f0bcb0, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0x269eb90) at kernel/qwidget.cpp:5652
#29 0x00007f1b870ee440 in QWidgetPrivate::paintSiblingsRecursive (this=this@entry=0x26926c0, pdev=pdev@entry=0x2f0bcb0, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0x269eb90) at kernel/qwidget.cpp:5808
#30 0x00007f1b870ed5cc in QWidgetPrivate::drawWidget (this=0x26926c0, pdev=0x2f0bcb0, rgn=..., offset=..., flags=flags@entry=5, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0x269eb90) at kernel/qwidget.cpp:5652
#31 0x00007f1b872b08ae in QWidgetBackingStore::sync (this=0x269eb90) at painting/qbackingstore.cpp:1373
#32 0x00007f1b870e2ea0 in QWidgetPrivate::syncBackingStore (this=this@entry=0x26926c0) at kernel/qwidget.cpp:1894
#33 0x00007f1b870f2e6a in QWidget::event (this=this@entry=0x2693ce0, event=event@entry=0x3048fe0) at kernel/qwidget.cpp:8680
#34 0x00007f1b874ad9b3 in QMainWindow::event (this=this@entry=0x2693ce0, event=event@entry=0x3048fe0) at widgets/qmainwindow.cpp:1478
#35 0x00007f1b86424491 in KMainWindow::event (this=this@entry=0x2693ce0, ev=ev@entry=0x3048fe0) at ../../kdeui/widgets/kmainwindow.cpp:1084
#36 0x00007f1b8645bf09 in KXmlGuiWindow::event (this=0x2693ce0, ev=0x3048fe0) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:126
#37 0x00007f1b867cd52e in ?? () from /usr/lib/libkateinterfaces.so.4
#38 0x00007f1b870a3e2c in QApplicationPrivate::notify_helper (this=this@entry=0x2314d40, receiver=receiver@entry=0x2693ce0, e=e@entry=0x3048fe0) at kernel/qapplication.cpp:4567
#39 0x00007f1b870aa4a0 in QApplication::notify (this=this@entry=0x7fff5ab17560, receiver=receiver@entry=0x2693ce0, e=e@entry=0x3048fe0) at kernel/qapplication.cpp:4353
#40 0x00007f1b8636fd1a in KApplication::notify (this=0x7fff5ab17560, receiver=0x2693ce0, event=0x3048fe0) at ../../kdeui/kernel/kapplication.cpp:311
#41 0x00007f1b85b6b4dd in QCoreApplication::notifyInternal (this=0x7fff5ab17560, receiver=receiver@entry=0x2693ce0, event=event@entry=0x3048fe0) at kernel/qcoreapplication.cpp:953
#42 0x00007f1b85b6eb3d in sendEvent (event=0x3048fe0, receiver=0x2693ce0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#43 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x22cc670) at kernel/qcoreapplication.cpp:1577
#44 0x00007f1b85b6efe3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#45 0x00007f1b85b98f83 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#46 postEventSourceDispatch (s=0x2309b50) at kernel/qeventdispatcher_glib.cpp:287
#47 0x00007f1b84db8e04 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#48 0x00007f1b84db9048 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#49 0x00007f1b84db90ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#50 0x00007f1b85b987a1 in QEventDispatcherGlib::processEvents (this=0x22cdb50, flags=...) at kernel/qeventdispatcher_glib.cpp:434
#51 0x00007f1b87145bb6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#52 0x00007f1b85b6a0af in QEventLoop::processEvents (this=this@entry=0x7fff5ab17320, flags=...) at kernel/qeventloop.cpp:149
#53 0x00007f1b85b6a3a5 in QEventLoop::exec (this=this@entry=0x7fff5ab17320, flags=...) at kernel/qeventloop.cpp:204
#54 0x00007f1b85b6fb79 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#55 0x00007f1b87f59d15 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_kate.so
#56 0x00007f1b87baeec5 in __libc_start_main (main=0x4006d0, argc=3, argv=0x7fff5ab176e8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff5ab176d8) at libc-start.c:287
#57 0x00000000004006fe in _start ()

Possible duplicates by query: bug 336685, bug 333475, bug 329564.


Reproducible: Didn't try




Crash after usage of Bleachbit - 1) as root 2) as regular user. I had done this many times with Kubuntu 12.04 and had no problems.
Comment 1 Christoph Feck 2014-09-01 22:06:18 UTC

*** This bug has been marked as a duplicate of bug 254741 ***