Bug 338717 - Crash after bleachbit usage 1st as root and after finish as regular user
Summary: Crash after bleachbit usage 1st as root and after finish as regular user
Status: RESOLVED DUPLICATE of bug 254741
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-01 08:13 UTC by 123design
Modified: 2014-09-01 09:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 123design 2014-09-01 08:13:46 UTC
Application: kwin (4.11.10)
KDE Platform Version: 4.13.3
Qt Version: 4.8.6
Operating System: Linux 3.13.0-35-generic x86_64
Distribution: Ubuntu 14.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:

Crash after bleachbit usage 1st as root and after finish as regular user

-- Backtrace:
Application: KWin (kwin), signal: Bus error
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f970ab8a800 (LWP 2986))]

Thread 3 (Thread 0x7f96daf8c700 (LWP 3001)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f970954affb in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f970954b039 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f9702022182 in start_thread (arg=0x7f96daf8c700) at pthread_create.c:312
#4  0x00007f970a35bfbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f96e9307700 (LWP 3476)):
#0  0x00007fffd13c6a1f in ?? ()
#1  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f970ab8a800 (LWP 2986)):
[KCrash Handler]
#6  0x00007f9704e49005 in lock (this=0xa3f8a0) at ../../kdecore/util/kshareddatacache.cpp:1235
#7  cautiousLock (this=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1259
#8  CacheLocker (_d=0xa3f8a0, this=<synthetic pointer>) at ../../kdecore/util/kshareddatacache.cpp:1309
#9  KSharedDataCache::find (this=0xa3fc70, key=..., destination=destination@entry=0x7fffd139c450) at ../../kdecore/util/kshareddatacache.cpp:1606
#10 0x00007f9708f55b60 in KIconLoaderPrivate::findCachedPixmapWithPath (this=0xa1f780, key=..., data=..., path=...) at ../../kdeui/icons/kiconloader.cpp:854
#11 0x00007f9708f55ea6 in KIconLoader::loadIcon (this=0x9eba50, _name=..., group=group@entry=KIconLoader::Small, size=size@entry=32, state=state@entry=0, overlays=..., path_store=path_store@entry=0x0, canReturnNull=canReturnNull@entry=true) at ../../kdeui/icons/kiconloader.cpp:1149
#12 0x00007f97090c373b in KWindowSystem::icon (win=<optimized out>, width=32, height=32, scale=<optimized out>, flags=12) at ../../kdeui/windowmanagement/kwindowsystem_x11.cpp:706
#13 0x00007f970a68b897 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwin.so
#14 0x00007f970a6baf7b in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwin.so
#15 0x00007f970a67b59d in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwin.so
#16 0x00007f970a6ad38a in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwin.so
#17 0x00007f970a6a1af0 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwin.so
#18 0x00007f9703a4e5dc in qt_x11EventFilter (ev=0x7fffd139cdb0) at kernel/qapplication_x11.cpp:442
#19 0x00007f9703a5ee40 in QApplication::x11ProcessEvent (this=0x7fffd139d1a0, event=event@entry=0x7fffd139cdb0) at kernel/qapplication_x11.cpp:3461
#20 0x00007f9703a88470 in QEventDispatcherX11::processEvents (this=0x896af0, flags=...) at kernel/qeventdispatcher_x11.cpp:132
#21 0x00007f970464b0af in QEventLoop::processEvents (this=this@entry=0x7fffd139d010, flags=...) at kernel/qeventloop.cpp:149
#22 0x00007f970464b3a5 in QEventLoop::exec (this=this@entry=0x7fffd139d010, flags=...) at kernel/qeventloop.cpp:204
#23 0x00007f9704650b79 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#24 0x00007f970a6a29d6 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwin.so
#25 0x00007f970a282ec5 in __libc_start_main (main=0x4006d0, argc=3, argv=0x7fffd139d2e8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffd139d2d8) at libc-start.c:287
#26 0x00000000004006fe in _start ()

Possible duplicates by query: bug 336685, bug 333475, bug 329564.


Reproducible: Always
Comment 1 Martin Flöser 2014-09-01 08:29:43 UTC
please see: http://blog.martin-graesslin.com/blog/2012/07/do-not-use-bleachbit/
Comment 2 Thomas Lübking 2014-09-01 09:56:26 UTC
It's unbelievable that this broken snake oil is still around :-(

*** This bug has been marked as a duplicate of bug 254741 ***