Bug 338715 - I have used Bleach bit -1st as root, afterwards as regular user like the hundred times with kubuntu 12.04
Summary: I have used Bleach bit -1st as root, afterwards as regular user like the hund...
Status: RESOLVED DUPLICATE of bug 254741
Alias: None
Product: kmix
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-01 08:10 UTC by 123design
Modified: 2014-09-01 22:07 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 123design 2014-09-01 08:10:06 UTC
Application: kmix (4.5)
KDE Platform Version: 4.13.3
Qt Version: 4.8.6
Operating System: Linux 3.13.0-35-generic x86_64
Distribution: Ubuntu 14.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I have usedBleach bit -1st as root, afterwards as regular user like the hundred times with kubuntu 12.04

-- Backtrace:
Application: KMix (kmix), signal: Bus error
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f3dafd46800 (LWP 3163))]

Thread 4 (Thread 0x7f3d87067700 (LWP 3173)):
#0  0x00007f3dafd9ca1f in ?? ()
#1  0x0000000000000005 in ?? ()
#2  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f3d86605700 (LWP 3193)):
#0  0x00007f3da55bd569 in __GI___pthread_mutex_lock (mutex=0x7f3d74000a80) at ../nptl/pthread_mutex_lock.c:125
#1  0x00007f3da4a76991 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f3da4a34699 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f3da4a34f03 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f3da4a350ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f3dac41d7be in QEventDispatcherGlib::processEvents (this=0x7f3d740008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0x00007f3dac3ef0af in QEventLoop::processEvents (this=this@entry=0x7f3d86604da0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f3dac3ef3a5 in QEventLoop::exec (this=this@entry=0x7f3d86604da0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f3dac2ebc5f in QThread::exec (this=this@entry=0x236c2f0) at thread/qthread.cpp:537
#9  0x00007f3dac3d0823 in QInotifyFileSystemWatcherEngine::run (this=0x236c2f0) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f3dac2ee32f in QThreadPrivate::start (arg=0x236c2f0) at thread/qthread_unix.cpp:349
#11 0x00007f3da55bb182 in start_thread (arg=0x7f3d86605700) at pthread_create.c:312
#12 0x00007f3daf60cfbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f3d885a7700 (LWP 3680)):
#0  0x00007f3daf5ffc6d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f3dadf8c031 in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#2  0x00007f3dadf7d83c in pa_mainloop_poll () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#3  0x00007f3dadf7dece in pa_mainloop_iterate () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#4  0x00007f3dadf7df80 in pa_mainloop_run () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#5  0x00007f3dadf8bfe3 in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#6  0x00007f3da4f7ef08 in ?? () from /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecommon-4.0.so
#7  0x00007f3da55bb182 in start_thread (arg=0x7f3d885a7700) at pthread_create.c:312
#8  0x00007f3daf60cfbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f3dafd46800 (LWP 3163)):
[KCrash Handler]
#6  0x00007f3dacbed005 in lock (this=0x1c6caf0) at ../../kdecore/util/kshareddatacache.cpp:1235
#7  cautiousLock (this=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1259
#8  CacheLocker (_d=0x1c6caf0, this=<synthetic pointer>) at ../../kdecore/util/kshareddatacache.cpp:1309
#9  KSharedDataCache::find (this=0x1c22b70, key=..., destination=destination@entry=0x7fff2e5fc750) at ../../kdecore/util/kshareddatacache.cpp:1606
#10 0x00007f3daeda2b60 in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x1c227d0, key=..., data=..., path=...) at ../../kdeui/icons/kiconloader.cpp:854
#11 0x00007f3daeda2ea6 in KIconLoader::loadIcon (this=0x1c47fd0, _name=..., group=KIconLoader::Desktop, size=22, state=state@entry=0, overlays=..., path_store=path_store@entry=0x0, canReturnNull=canReturnNull@entry=false) at ../../kdeui/icons/kiconloader.cpp:1149
#12 0x00007f3daed9aea2 in KIconEngine::paint (this=<optimized out>, painter=0x7fff2e5fcaf0, rect=..., mode=<optimized out>, state=<optimized out>) at ../../kdeui/icons/kiconengine.cpp:88
#13 0x00007f3dad101d90 in QIcon::paint (this=this@entry=0x7fff2e5fcb30, painter=painter@entry=0x7fff2e5fcaf0, rect=..., alignment=..., mode=mode@entry=QIcon::Normal, state=state@entry=QIcon::Off) at image/qicon.cpp:730
#14 0x00007f3dad6968ac in QSystemTrayIconWidget::paintEvent (this=0x1ef7d60) at util/qxembedsystemtrayicon_x11.cpp:186
#15 0x00007f3dad0ad2f0 in QWidget::event (this=0x1ef7d60, event=0x7fff2e5fcf50) at kernel/qwidget.cpp:8533
#16 0x00007f3dad05de2c in QApplicationPrivate::notify_helper (this=this@entry=0x1b82f60, receiver=receiver@entry=0x1ef7d60, e=e@entry=0x7fff2e5fcf50) at kernel/qapplication.cpp:4567
#17 0x00007f3dad0644a0 in QApplication::notify (this=this@entry=0x1b5d760, receiver=receiver@entry=0x1ef7d60, e=e@entry=0x7fff2e5fcf50) at kernel/qapplication.cpp:4353
#18 0x00007f3daedecd1a in KApplication::notify (this=0x1b5d760, receiver=0x1ef7d60, event=0x7fff2e5fcf50) at ../../kdeui/kernel/kapplication.cpp:311
#19 0x00007f3dac3f04dd in QCoreApplication::notifyInternal (this=0x1b5d760, receiver=receiver@entry=0x1ef7d60, event=event@entry=0x7fff2e5fcf50) at kernel/qcoreapplication.cpp:953
#20 0x00007f3dad0a7a11 in sendSpontaneousEvent (event=0x7fff2e5fcf50, receiver=0x1ef7d60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
#21 QWidgetPrivate::drawWidget (this=this@entry=0x1f0fd00, pdev=pdev@entry=0x1ef7d70, rgn=..., offset=..., flags=flags@entry=3, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0x0) at kernel/qwidget.cpp:5599
#22 0x00007f3dad268afb in QWidgetPrivate::repaint_sys (this=this@entry=0x1f0fd00, rgn=...) at painting/qbackingstore.cpp:1656
#23 0x00007f3dad09ce47 in QWidgetPrivate::syncBackingStore (this=this@entry=0x1f0fd00) at kernel/qwidget.cpp:1891
#24 0x00007f3dad0ace6a in QWidget::event (this=0x1ef7d60, event=0x1f24860) at kernel/qwidget.cpp:8680
#25 0x00007f3dad05de2c in QApplicationPrivate::notify_helper (this=this@entry=0x1b82f60, receiver=receiver@entry=0x1ef7d60, e=e@entry=0x1f24860) at kernel/qapplication.cpp:4567
#26 0x00007f3dad0644a0 in QApplication::notify (this=this@entry=0x1b5d760, receiver=receiver@entry=0x1ef7d60, e=e@entry=0x1f24860) at kernel/qapplication.cpp:4353
#27 0x00007f3daedecd1a in KApplication::notify (this=0x1b5d760, receiver=0x1ef7d60, event=0x1f24860) at ../../kdeui/kernel/kapplication.cpp:311
#28 0x00007f3dac3f04dd in QCoreApplication::notifyInternal (this=0x1b5d760, receiver=receiver@entry=0x1ef7d60, event=event@entry=0x1f24860) at kernel/qcoreapplication.cpp:953
#29 0x00007f3dac3f3b3d in sendEvent (event=0x1f24860, receiver=0x1ef7d60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#30 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1adb1f0) at kernel/qcoreapplication.cpp:1577
#31 0x00007f3dac3f3fe3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#32 0x00007f3dac41df83 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#33 postEventSourceDispatch (s=0x1b7c900) at kernel/qeventdispatcher_glib.cpp:287
#34 0x00007f3da4a34e04 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#35 0x00007f3da4a35048 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#36 0x00007f3da4a350ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#37 0x00007f3dac41d7a1 in QEventDispatcherGlib::processEvents (this=0x1adcaf0, flags=...) at kernel/qeventdispatcher_glib.cpp:434
#38 0x00007f3dad0ffbb6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007f3dac3ef0af in QEventLoop::processEvents (this=this@entry=0x7fff2e5fd620, flags=...) at kernel/qeventloop.cpp:149
#40 0x00007f3dac3ef3a5 in QEventLoop::exec (this=this@entry=0x7fff2e5fd620, flags=...) at kernel/qeventloop.cpp:204
#41 0x00007f3dac3f4b79 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#42 0x00007f3daf91e63a in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_kmix.so
#43 0x00007f3daf533ec5 in __libc_start_main (main=0x4006d0, argc=3, argv=0x7fff2e5fd878, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff2e5fd868) at libc-start.c:287
#44 0x00000000004006fe in _start ()

Possible duplicates by query: bug 336685, bug 333475, bug 329564.


Reproducible: Always




I have used Bleach bit -1st as root, afterwards as regular user like the hundred times with kubuntu 12.04
Comment 1 Christoph Feck 2014-09-01 22:07:33 UTC

*** This bug has been marked as a duplicate of bug 254741 ***