Bug 271893 - KMix crashed
Summary: KMix crashed
Status: RESOLVED DUPLICATE of bug 254741
Alias: None
Product: kmix
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-28 03:24 UTC by rflazaro
Modified: 2011-05-01 15:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rflazaro 2011-04-28 03:24:17 UTC
Application: kmix (3.8)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.39-rc4-12-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I was running BleachBit to clean out unnecessary files on my machine

-- Backtrace:
Application: KMix (kdeinit4), signal: Bus error
[KCrash Handler]
#6  0x00007fd5eb5accdd in lock (this=0x7fff98ae2af0, _d=0x7379e0) at /usr/src/debug/kdelibs-4.6.0/kdecore/util/kshareddatacache.cpp:1098
#7  cautiousLock (this=0x7fff98ae2af0, _d=0x7379e0) at /usr/src/debug/kdelibs-4.6.0/kdecore/util/kshareddatacache.cpp:1121
#8  KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fff98ae2af0, _d=0x7379e0) at /usr/src/debug/kdelibs-4.6.0/kdecore/util/kshareddatacache.cpp:1146
#9  0x00007fd5eb502d60 in KSharedDataCache::find (this=0x79f220, key=..., destination=0x7fff98ae2bd0) at /usr/src/debug/kdelibs-4.6.0/kdecore/util/kshareddatacache.cpp:1462
#10 0x00007fd5ebe241dc in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x738520, key=..., data=..., path=...) at /usr/src/debug/kdelibs-4.6.0/kdeui/icons/kiconloader.cpp:868
#11 0x00007fd5ebe2bd6e in KIconLoader::loadIcon (this=0x793c50, _name=<value optimized out>, group=KIconLoader::Small, size=22, state=0, overlays=..., path_store=0x0, canReturnNull=false) at /usr/src/debug/kdelibs-4.6.0/kdeui/icons/kiconloader.cpp:1231
#12 0x00007fd5d9ded0a6 in MDWSlider::loadIcon (this=<value optimized out>, filename=...) at /usr/src/debug/kdemultimedia-4.6.0/kmix/gui/mdwslider.cpp:561
#13 0x00007fd5d9ded11a in MDWSlider::setIcon (this=0x862060, filename=<value optimized out>) at /usr/src/debug/kdemultimedia-4.6.0/kmix/gui/mdwslider.cpp:572
#14 0x00007fd5d9dedfe2 in MDWSlider::createWidgets (this=0x862060, showMuteButton=true, showCaptureLED=true) at /usr/src/debug/kdemultimedia-4.6.0/kmix/gui/mdwslider.cpp:285
#15 0x00007fd5d9deff1b in MDWSlider::MDWSlider (this=0x862060, md=<value optimized out>, showMuteLED=true, showCaptureLED=<value optimized out>, small=<value optimized out>, orientation=<value optimized out>, parent=0x83bbe0, view=0x83bbe0, par_ctl=0x8bb660) at /usr/src/debug/kdemultimedia-4.6.0/kmix/gui/mdwslider.cpp:76
#16 0x00007fd5d9de9bf9 in ViewSliders::add (this=0x83bbe0, md=0x87c260) at /usr/src/debug/kdemultimedia-4.6.0/kmix/gui/viewsliders.cpp:133
#17 0x00007fd5d9de6866 in ViewBase::createDeviceWidgets (this=0x83bbe0) at /usr/src/debug/kdemultimedia-4.6.0/kmix/gui/viewbase.cpp:119
#18 0x00007fd5d9df1cde in KMixerWidget::possiblyAddView (this=0x8ca6e0, vbase=0x83bbe0) at /usr/src/debug/kdemultimedia-4.6.0/kmix/gui/kmixerwidget.cpp:162
#19 0x00007fd5d9df1ef6 in KMixerWidget::createLayout (this=0x8ca6e0, vflags=7) at /usr/src/debug/kdemultimedia-4.6.0/kmix/gui/kmixerwidget.cpp:113
#20 0x00007fd5d9df1fad in KMixerWidget::KMixerWidget (this=0x8ca6e0, mixer=0x82f4a0, parent=<value optimized out>, vflags=7, guiprof=0x8c76c0, actionCollection=0x75dc30) at /usr/src/debug/kdemultimedia-4.6.0/kmix/gui/kmixerwidget.cpp:66
#21 0x00007fd5d9ddd60b in KMixWindow::addMixerWidget (this=0x76f9e0, mixer_ID=<value optimized out>, guiprof=0x8c76c0, insertPosition=-1) at /usr/src/debug/kdemultimedia-4.6.0/kmix/apps/kmix.cpp:858
#22 0x00007fd5d9de0766 in KMixWindow::recreateGUI (this=0x76f9e0, saveConfig=<value optimized out>, mixerId=..., forceNewTab=false) at /usr/src/debug/kdemultimedia-4.6.0/kmix/apps/kmix.cpp:548
#23 0x00007fd5d9de1563 in KMixWindow::recreateGUI (this=<value optimized out>, saveConfig=<value optimized out>) at /usr/src/debug/kdemultimedia-4.6.0/kmix/apps/kmix.cpp:471
#24 0x00007fd5d9de1e6e in KMixWindow::KMixWindow (this=0x76f9e0, invisible=false, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /usr/src/debug/kdemultimedia-4.6.0/kmix/apps/kmix.cpp:99
#25 0x00007fd5d9de335b in KMixApp::newInstance (this=0x6ec950) at /usr/src/debug/kdemultimedia-4.6.0/kmix/apps/KMixApp.cpp:119
#26 0x00007fd5ebda2434 in KUniqueApplicationAdaptor::newInstance (this=0x7700c0, asn_id=<value optimized out>, args=...) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kuniqueapplication.cpp:436
#27 0x00007fd5ebda24d2 in KUniqueApplicationAdaptor::qt_metacall (this=0x7700c0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff98ae4110) at /usr/src/debug/kdelibs-4.6.0/build/kdeui/kuniqueapplication_p.moc:81
#28 0x00007fd5e7ec4b68 in QDBusConnectionPrivate::deliverCall (this=0x6ecd10, object=0x7700c0, msg=..., metaTypes=..., slotIdx=4) at qdbusintegrator.cpp:919
#29 0x00007fd5e7ec546e in QDBusConnectionPrivate::activateCall (this=0x6ecd10, object=0x7700c0, flags=337, msg=...) at qdbusintegrator.cpp:822
#30 0x00007fd5e7ec5c9e in QDBusConnectionPrivate::activateObject (this=0x6ecd10, node=..., msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1379
#31 0x00007fd5e7ec5ed8 in QDBusActivateObjectEvent::placeMetaCall (this=0x6f5dc0) at qdbusintegrator.cpp:1493
#32 0x00007fd5eb083a6a in QObject::event (this=0x6ec950, e=<value optimized out>) at kernel/qobject.cpp:1211
#33 0x00007fd5ea2213c6 in QApplication::event (this=0x6ec950, e=0x6f5dc0) at kernel/qapplication.cpp:2486
#34 0x00007fd5ea21ed14 in QApplicationPrivate::notify_helper (this=0x6f6250, receiver=0x6ec950, e=0x6f5dc0) at kernel/qapplication.cpp:4445
#35 0x00007fd5ea22722a in QApplication::notify (this=<value optimized out>, receiver=0x6ec950, e=0x6f5dc0) at kernel/qapplication.cpp:4324
#36 0x00007fd5ebd139e6 in KApplication::notify (this=0x6ec950, receiver=0x6ec950, event=0x6f5dc0) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#37 0x00007fd5eb06fbfc in QCoreApplication::notifyInternal (this=0x6ec950, receiver=0x6ec950, event=0x6f5dc0) at kernel/qcoreapplication.cpp:732
#38 0x00007fd5eb0733f5 in sendEvent (receiver=0x0, event_type=0, data=0x6103e0) at kernel/qcoreapplication.h:215
#39 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x6103e0) at kernel/qcoreapplication.cpp:1373
#40 0x00007fd5eb09a783 in sendPostedEvents (s=<value optimized out>) at kernel/qcoreapplication.h:220
#41 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#42 0x00007fd5e691abd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#43 0x00007fd5e691b3b0 in ?? () from /lib64/libglib-2.0.so.0
#44 0x00007fd5e691b650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#45 0x00007fd5eb09a91f in QEventDispatcherGlib::processEvents (this=0x617ca0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#46 0x00007fd5ea2c3d8e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#47 0x00007fd5eb06f052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#48 0x00007fd5eb06f265 in QEventLoop::exec (this=0x7fff98ae4e90, flags=...) at kernel/qeventloop.cpp:201
#49 0x00007fd5eb0736ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#50 0x00007fd5d9ddafea in kdemain (argc=3, argv=0x6b9610) at /usr/src/debug/kdemultimedia-4.6.0/kmix/apps/main.cpp:76
#51 0x00000000004075e9 in _start ()

This bug may be a duplicate of or related to bug 271890.

Possible duplicates by query: bug 271890.

Reported using DrKonqi
Comment 1 Dario Andres 2011-05-01 15:03:17 UTC
[Comment from a bug report cleaner]
This bug is related to the KDE shared cache component (probably related to the temporary files cleanup). See bug 254741. Regards

*** This bug has been marked as a duplicate of bug 254741 ***