Bug 303312 - Crash when running some KDE progs and starting bleachbit, additionally
Summary: Crash when running some KDE progs and starting bleachbit, additionally
Status: RESOLVED DUPLICATE of bug 254741
Alias: None
Product: ksmserver
Classification: Unclassified
Component: general (show other bugs)
Version: 0.4
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-10 15:43 UTC by Axel Krebs
Modified: 2012-07-10 15:47 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Krebs 2012-07-10 15:43:05 UTC
Application: ksmserver (0.4)
KDE Platform Version: 4.8.4 (4.8.4) (Compiled from sources)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-26-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

When running some progs, and starting bleachbit, additionally, KDE crashes.

Is it not possible to run more than one KDE prog at the time given?

Or to check croiss-relation bewtween progs before anou ncing a new KDE version?

Why these questions?

Very simple: as KDE will die, if is not better than others... and there are good ones... mint, gnome(?)

The crash can be reproduced some of the time.

-- Backtrace:
Application: Der KDE-Sitzungsmanager (kdeinit4), signal: Bus error
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  0x00007fe7560a7fc5 in lock (this=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1231
#7  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7ffffbe339d0) at ../../kdecore/util/kshareddatacache.cpp:1255
#8  0x00007fe7560a8b50 in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7ffffbe339d0, _d=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1278
#9  0x00007fe7560a28a9 in KSharedDataCache::insert (this=0x21cd550, key=..., data=...) at ../../kdecore/util/kshareddatacache.cpp:1471
#10 0x00007fe75685be3b in KIconLoaderPrivate::insertCachedPixmapWithPath (this=0x21b21e0, key=..., data=..., path=...) at ../../kdeui/icons/kiconloader.cpp:834
#11 0x00007fe75685c761 in KIconLoader::loadIcon (this=0x212db00, _name=..., group=KIconLoader::Desktop, size=16, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1307
#12 0x00007fe756853c3f in KIconEngine::pixmap (this=<optimized out>, size=..., mode=<optimized out>, state=<optimized out>) at ../../kdeui/icons/kiconengine.cpp:104
#13 0x00007fe754f40835 in QIcon::pixmap (this=<optimized out>, size=..., mode=<optimized out>, state=<optimized out>) at image/qicon.cpp:684
#14 0x00007fe754f3284b in QWidgetPrivate::setWindowIcon_sys (this=0x224d800, forceReset=false) at kernel/qwidget_x11.cpp:1506
#15 0x00007fe754eded05 in QWidget::create (this=0x21b1ed0, window=0, initializeWindow=true, destroyOldWindow=true) at kernel/qwidget.cpp:1540
#16 0x00007fe754ee8bba in QWidget::setVisible (this=0x21b1ed0, visible=<optimized out>) at kernel/qwidget.cpp:7699
#17 0x00007fe74320600e in show (this=0x21b1ed0) at /usr/include/qt4/QtGui/qwidget.h:494
#18 KSMShutdownFeedback::start () at ../../ksmserver/shutdowndlg.cpp:138
#19 0x00007fe7432145f4 in KSMServer::shutdown (this=0x2233e80, confirm=<optimized out>, sdtype=KWorkSpace::ShutdownTypeNone, sdmode=KWorkSpace::ShutdownModeInteractive) at ../../ksmserver/shutdown.cpp:156
#20 0x00007fe75440ada2 in _SmsProcessMessage () from /usr/lib/x86_64-linux-gnu/libSM.so.6
#21 0x00007fe7541fbec4 in IceProcessMessages () from /usr/lib/x86_64-linux-gnu/libICE.so.6
#22 0x00007fe74320278a in KSMServer::processData (this=0x2233e80) at ../../ksmserver/server.cpp:774
#23 0x00007fe7432029e5 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=0x2233e80, _c=<optimized out>) at ./server.moc:117
#24 KSMServer::qt_static_metacall (_o=0x2233e80, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./server.moc:106
#25 0x00007fe755b27281 in QMetaObject::activate (sender=0x21c3850, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7ffffbe347a0) at kernel/qobject.cpp:3547
#26 0x00007fe755b742fe in QSocketNotifier::activated (this=<optimized out>, _t1=12) at .moc/release-shared/moc_qsocketnotifier.cpp:103
#27 0x00007fe755b3060b in QSocketNotifier::event (this=0x21c3850, e=0x7ffffbe34e10) at kernel/qsocketnotifier.cpp:317
#28 0x00007fe754e95894 in notify_helper (e=0x7ffffbe34e10, receiver=0x21c3850, this=0x2117660) at kernel/qapplication.cpp:4559
#29 QApplicationPrivate::notify_helper (this=0x2117660, receiver=0x21c3850, e=0x7ffffbe34e10) at kernel/qapplication.cpp:4531
#30 0x00007fe754e9a713 in QApplication::notify (this=0x2117230, receiver=0x21c3850, e=0x7ffffbe34e10) at kernel/qapplication.cpp:4420
#31 0x00007fe7568ad9e6 in KApplication::notify (this=0x2117230, receiver=0x21c3850, event=0x7ffffbe34e10) at ../../kdeui/kernel/kapplication.cpp:311
#32 0x00007fe755b12e9c in QCoreApplication::notifyInternal (this=0x2117230, receiver=0x21c3850, event=0x7ffffbe34e10) at kernel/qcoreapplication.cpp:876
#33 0x00007fe755b41a97 in sendEvent (event=0x7ffffbe34e10, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#34 socketNotifierSourceDispatch (source=0x2123c00) at kernel/qeventdispatcher_glib.cpp:110
#35 0x00007fe751809d53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#36 0x00007fe75180a0a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#37 0x00007fe75180a164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#38 0x00007fe755b423bf in QEventDispatcherGlib::processEvents (this=0x20547d0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#39 0x00007fe754f3dd5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#40 0x00007fe755b11c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#41 0x00007fe755b11ed7 in QEventLoop::exec (this=0x7ffffbe35020, flags=...) at kernel/qeventloop.cpp:204
#42 0x00007fe755b16f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#43 0x00007fe7431fdc4a in kdemain (argc=1, argv=<optimized out>) at ../../ksmserver/main.cpp:311
#44 0x00000000004086a4 in launch (argc=1, _name=0x20d1df8 "ksmserver", args=<optimized out>, cwd=0x20d1e02 "/home/ak", envc=<optimized out>, envs=<optimized out>, reset_env=true, tty=0x20d229e "", avoid_loops=false, startup_id_str=0x20d22a7 "") at ../../kinit/kinit.cpp:746
#45 0x0000000000409a16 in handle_launcher_request (sock=5, who=<optimized out>) at ../../kinit/kinit.cpp:1238
#46 0x0000000000409efb in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1422
#47 0x000000000040532f in main (argc=4, argv=0x7fff00000001, envp=0x7ffffbe367a0) at ../../kinit/kinit.cpp:1919

Possible duplicates by query: bug 303310, bug 284770.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-10 15:47:41 UTC
Hi, could you stop reporting such crashes ?  You know I would close it as duplicate of bug 254741 and the problem itself is invalid  .....

Just don't use bleachbit  to clean KDE stuff.

*** This bug has been marked as a duplicate of bug 254741 ***