Bug 274884 - Bleachbit crashing KWin
Summary: Bleachbit crashing KWin
Status: RESOLVED DUPLICATE of bug 254741
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-04 07:32 UTC by trennor
Modified: 2011-06-04 23:11 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Attachement was generated by Crash Reporting Assistant (with some assistance from me; see above) (2.41 KB, application/octet-stream)
2011-06-04 07:32 UTC, trennor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description trennor 2011-06-04 07:32:51 UTC
Created attachment 60597 [details]
Attachement was generated by Crash Reporting Assistant (with some assistance from me; see above)

Version:           unspecified (using KDE 4.6.3) 
OS:                Linux

If I run Bleachbit, (user version), KWin crashes. 

Reproducible: Sometimes


Actual Results:  
KWin shuts down, bug report daemon starts up, and can produce a backtrace (attached) but doesn't seem to be able to generate what it considers to be a complete report; complains there's not enough information. Yet, I can save at least part of a report. See attachment.

Expected Results:  
No crash! 

What should the software have done instead? 

I've no  idea; I'm a user, not a programmer or scripter.
Comment 1 Beat Wolf 2011-06-04 10:44:59 UTC
i'm pretty sure this is a isse with bleachbit that deletes temporary files it is not supposed to delete. There was another similar bugreport where the author of bleachbit said he fixed it by no longer deleting kde* filde in /tmp.

So, this is to 99% sure a bleachbit bug and not a kwin bug.
Comment 2 Martin Flöser 2011-06-04 10:49:14 UTC
and even if it is a kwin issue, the backtrace is missing debug symbols and is pretty useless in this regard (Dr.Konqui should have said so and offered to install debug packages).
Comment 3 Thomas Lübking 2011-06-04 12:43:37 UTC
It crashes in KSharedDataCache::find() from KIconLoader -> this is just bug #254741 and it's SnakeOil's (*) - sorry "BleachBit's" fault by randomly shredding SHM objects, seems fixed in BB - see bug #271889

I feel brave enough to dupe this until a better backtrace can render me wrong.

*** This bug has been marked as a duplicate of bug 254741 ***
Comment 4 Andrew Ziem 2011-06-04 23:11:27 UTC
See http://bleachbit.sourceforge.net how to get notified of the BleachBit 0.8.8 beta which includes a fix.  Until then, don't shred system temporary files, or in BleachBit add a whitelist for /var/tmp/kdecache-yourusername