Bug 338714 - I have usedBleach bit -1st as root, afterwards as regular user like the hundred times with kubuntu 12.04
Summary: I have usedBleach bit -1st as root, afterwards as regular user like the hundr...
Status: RESOLVED DUPLICATE of bug 254741
Alias: None
Product: klipper
Classification: Unclassified
Component: general (show other bugs)
Version: 0.9.7
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Martin Flöser
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-01 08:07 UTC by 123design
Modified: 2014-09-01 10:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 123design 2014-09-01 08:07:27 UTC
Application: kded4 (4.13.3)
KDE Platform Version: 4.13.3
Qt Version: 4.8.6
Operating System: Linux 3.13.0-35-generic x86_64
Distribution: Ubuntu 14.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I have usedBleach bit -1st as root, afterwards as regular user like the hundred times with kubuntu 12.04

-- Backtrace:
Application: KDE Daemon (kded4), signal: Bus error
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1370ee57c0 (LWP 2694))]

Thread 6 (Thread 0x7f13534f5700 (LWP 2696)):
#0  0x00007f136b88a9b0 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f136b848718 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f136b848f03 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f136b8490ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f136fb847be in QEventDispatcherGlib::processEvents (this=0x7f134c0008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#5  0x00007f136fb560af in QEventLoop::processEvents (this=this@entry=0x7f13534f4e20, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f136fb563a5 in QEventLoop::exec (this=this@entry=0x7f13534f4e20, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f136fa52c5f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#8  0x00007f136fa5532f in QThreadPrivate::start (arg=0x24e38a0) at thread/qthread_unix.cpp:349
#9  0x00007f136bf2b182 in start_thread (arg=0x7f13534f5700) at pthread_create.c:312
#10 0x00007f136e757fbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 5 (Thread 0x7f13429f6700 (LWP 2712)):
#0  0x00007f136e74ac6d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f136b848fe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f136b84930a in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1342efee16 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f136b86df15 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f136bf2b182 in start_thread (arg=0x7f13429f6700) at pthread_create.c:312
#6  0x00007f136e757fbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 4 (Thread 0x7f1341fe9700 (LWP 2798)):
#0  0x00007fffd57bda1f in ?? ()
#1  0x000000000000007c in ?? ()
#2  0x00007f1370ee78a0 in ?? ()
#3  0x0000000000000001 in ?? ()
#4  0x00007f1328002930 in ?? ()
#5  0x00007f1341fe8c28 in ?? ()
#6  0x00007f1341fe8bc0 in ?? ()
#7  0x000000007fffffff in ?? ()
#8  0x00007f136fb846f0 in ?? () at kernel/qeventdispatcher_glib.cpp:223 from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f1341fe8c30 in ?? ()
#10 0x00007f136e76646d in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#11 0x00007f136faa9ad7 in do_gettime (frac=0x7f1341fe8b70, sec=0x7f1341fe8b68) at tools/qelapsedtimer_unix.cpp:127
#12 qt_gettime () at tools/qelapsedtimer_unix.cpp:144
#13 0x00007f136fb85f05 in updateCurrentTime (this=0xffffffffffdff000) at kernel/qeventdispatcher_unix.cpp:354
#14 QTimerInfoList::timerWait (this=0xffffffffffdff000, tm=...) at kernel/qeventdispatcher_unix.cpp:460
#15 0x00007f136fb8467c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f1341fe8c24) at kernel/qeventdispatcher_glib.cpp:143
#16 0x00007f136fb84725 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:176
#17 0x00007f136b84868d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007f136b848f03 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f136b8490ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f136fb847be in QEventDispatcherGlib::processEvents (this=0x7f13280008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#21 0x00007f136fb560af in QEventLoop::processEvents (this=this@entry=0x7f1341fe8de0, flags=...) at kernel/qeventloop.cpp:149
#22 0x00007f136fb563a5 in QEventLoop::exec (this=this@entry=0x7f1341fe8de0, flags=...) at kernel/qeventloop.cpp:204
#23 0x00007f136fa52c5f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#24 0x00007f13508e2027 in KCupsConnection::run() () from /usr/lib/libkcupslib.so
#25 0x00007f136fa5532f in QThreadPrivate::start (arg=0x26286b0) at thread/qthread_unix.cpp:349
#26 0x00007f136bf2b182 in start_thread (arg=0x7f1341fe9700) at pthread_create.c:312
#27 0x00007f136e757fbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7f13417e8700 (LWP 2799)):
#0  0x00007fffd57bda1f in ?? ()
#1  0x00007f13417e7bb0 in ?? ()
#2  0x00007f1370ee78a0 in ?? ()
#3  0x0000000000000001 in ?? ()
#4  0x00007f132c002530 in ?? ()
#5  0x00007f13417e7c68 in ?? ()
#6  0x00007f13417e7c00 in ?? ()
#7  0x000000007fffffff in ?? ()
#8  0x00007f136fb846f0 in ?? () at kernel/qeventdispatcher_glib.cpp:223 from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f13417e7c70 in ?? ()
#10 0x00007f136e76646d in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#11 0x00007f136faa9ad7 in do_gettime (frac=0x7f13417e7bb0, sec=0x7f13417e7ba8) at tools/qelapsedtimer_unix.cpp:127
#12 qt_gettime () at tools/qelapsedtimer_unix.cpp:144
#13 0x00007f136fb85f05 in updateCurrentTime (this=0xffffffffffdff000) at kernel/qeventdispatcher_unix.cpp:354
#14 QTimerInfoList::timerWait (this=0xffffffffffdff000, tm=...) at kernel/qeventdispatcher_unix.cpp:460
#15 0x00007f136fb8467c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f13417e7c64) at kernel/qeventdispatcher_glib.cpp:143
#16 0x00007f136fb84725 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:176
#17 0x00007f136b84868d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007f136b848f03 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f136b8490ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f136fb847be in QEventDispatcherGlib::processEvents (this=0x7f132c0008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#21 0x00007f136fb560af in QEventLoop::processEvents (this=this@entry=0x7f13417e7e20, flags=...) at kernel/qeventloop.cpp:149
#22 0x00007f136fb563a5 in QEventLoop::exec (this=this@entry=0x7f13417e7e20, flags=...) at kernel/qeventloop.cpp:204
#23 0x00007f136fa52c5f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#24 0x00007f136fa5532f in QThreadPrivate::start (arg=0x261b300) at thread/qthread_unix.cpp:349
#25 0x00007f136bf2b182 in start_thread (arg=0x7f13417e8700) at pthread_create.c:312
#26 0x00007f136e757fbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f1340fe7700 (LWP 2800)):
#0  0x00007fffd57bda1f in ?? ()
#1  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1370ee57c0 (LWP 2694)):
[KCrash Handler]
#6  0x00007f13700d490e in lock (this=0x2394f00) at ../../kdecore/util/kshareddatacache.cpp:1235
#7  cautiousLock (this=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1259
#8  CacheLocker (_d=0x2394f00, this=<synthetic pointer>) at ../../kdecore/util/kshareddatacache.cpp:1309
#9  KSharedDataCache::insert (this=0x22e03a0, key=..., data=...) at ../../kdecore/util/kshareddatacache.cpp:1447
#10 0x00007f137088c9d4 in KIconLoaderPrivate::insertCachedPixmapWithPath (this=0x22fe3b0, key=..., data=..., path=...) at ../../kdeui/icons/kiconloader.cpp:827
#11 0x00007f137088d41f in KIconLoader::loadIcon (this=0x22c5730, _name=..., group=group@entry=KIconLoader::Desktop, size=16, state=0, overlays=..., path_store=path_store@entry=0x0, canReturnNull=canReturnNull@entry=false) at ../../kdeui/icons/kiconloader.cpp:1231
#12 0x00007f137088500e in KIconEngine::pixmap (this=<optimized out>, size=..., mode=<optimized out>, state=<optimized out>) at ../../kdeui/icons/kiconengine.cpp:104
#13 0x00007f136ef94c95 in QIcon::pixmap (this=<optimized out>, size=..., mode=<optimized out>, state=<optimized out>) at image/qicon.cpp:684
#14 0x00007f136d54adc0 in ?? () from /usr/lib/x86_64-linux-gnu/libdbusmenu-qt.so.2
#15 0x00007f136d54b847 in ?? () from /usr/lib/x86_64-linux-gnu/libdbusmenu-qt.so.2
#16 0x00007f136d54ddc6 in ?? () from /usr/lib/x86_64-linux-gnu/libdbusmenu-qt.so.2
#17 0x00007f136d54e217 in ?? () from /usr/lib/x86_64-linux-gnu/libdbusmenu-qt.so.2
#18 0x00007f136d54ec35 in ?? () from /usr/lib/x86_64-linux-gnu/libdbusmenu-qt.so.2
#19 0x00007f136d54ee09 in DBusMenuExporter::DBusMenuExporter(QString const&, QMenu*, QDBusConnection const&) () from /usr/lib/x86_64-linux-gnu/libdbusmenu-qt.so.2
#20 0x00007f13709e995a in KDBusMenuExporter (dbusConnection=..., menu=0x25b61a0, dbusObjectPath=..., this=0x2b584c0) at ../../kdeui/notifications/kstatusnotifieritem.cpp:61
#21 KStatusNotifierItem::setContextMenu (this=0x2593730, menu=0x25b61a0) at ../../kdeui/notifications/kstatusnotifieritem.cpp:456
#22 0x00007f13709ebd4c in KStatusNotifierItemPrivate::init (this=0x4cceda0, extraId=...) at ../../kdeui/notifications/kstatusnotifieritem.cpp:750
#23 0x00007f13709ebfb5 in KStatusNotifierItem::KStatusNotifierItem (this=0x2593730, parent=<optimized out>) at ../../kdeui/notifications/kstatusnotifieritem.cpp:105
#24 0x00007f1327074a92 in ?? () from /usr/lib/kde4/kded_notificationhelper.so
#25 0x00007f13270756d1 in ?? () from /usr/lib/kde4/kded_notificationhelper.so
#26 0x00007f1327073104 in ?? () from /usr/lib/kde4/kded_notificationhelper.so
#27 0x00007f136fb6b87a in QMetaObject::activate (sender=0x27212d0, m=m@entry=0x7f1370370c80 <KDirWatch::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fffd5698200) at kernel/qobject.cpp:3539
#28 0x00007f136ffc15e2 in KDirWatch::dirty (this=<optimized out>, _t1=...) at ./kdirwatch.moc:112
#29 0x00007f136fb6fc1e in QObject::event (this=0x27212d0, e=<optimized out>) at kernel/qobject.cpp:1194
#30 0x00007f136eef0e2c in QApplicationPrivate::notify_helper (this=this@entry=0x2439d60, receiver=receiver@entry=0x27212d0, e=e@entry=0x4cd1490) at kernel/qapplication.cpp:4567
#31 0x00007f136eef74a0 in QApplication::notify (this=this@entry=0x7fffd5698950, receiver=receiver@entry=0x27212d0, e=e@entry=0x4cd1490) at kernel/qapplication.cpp:4353
#32 0x00007f13708d6d1a in KApplication::notify (this=0x7fffd5698950, receiver=0x27212d0, event=0x4cd1490) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00007f136fb574dd in QCoreApplication::notifyInternal (this=0x7fffd5698950, receiver=receiver@entry=0x27212d0, event=event@entry=0x4cd1490) at kernel/qcoreapplication.cpp:953
#34 0x00007f136fb5ab3d in sendEvent (event=0x4cd1490, receiver=0x27212d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#35 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x21f0150) at kernel/qcoreapplication.cpp:1577
#36 0x00007f136fb5afe3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#37 0x00007f136fb84f83 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#38 postEventSourceDispatch (s=0x2438200) at kernel/qeventdispatcher_glib.cpp:287
#39 0x00007f136b848e04 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#40 0x00007f136b849048 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007f136b8490ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#42 0x00007f136fb847a1 in QEventDispatcherGlib::processEvents (this=0x21f26d0, flags=...) at kernel/qeventdispatcher_glib.cpp:434
#43 0x00007f136ef92bb6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#44 0x00007f136fb560af in QEventLoop::processEvents (this=this@entry=0x7fffd5698820, flags=...) at kernel/qeventloop.cpp:149
#45 0x00007f136fb563a5 in QEventLoop::exec (this=this@entry=0x7fffd5698820, flags=...) at kernel/qeventloop.cpp:204
#46 0x00007f136fb5bb79 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#47 0x00007f136eeef37c in QApplication::exec () at kernel/qapplication.cpp:3828
#48 0x00007f1358dc5d1b in kdemain (argc=1, argv=0x241f620) at ../../kded/kded.cpp:940
#49 0x00000000004083ee in launch (argc=argc@entry=1, _name=_name@entry=0x40afc7 "kded4", args=args@entry=0x0, cwd=cwd@entry=0x0, envc=envc@entry=0, envs=<optimized out>, envs@entry=0x0, reset_env=reset_env@entry=false, tty=tty@entry=0x0, avoid_loops=avoid_loops@entry=false, startup_id_str=startup_id_str@entry=0x40ae56 "0") at ../../kinit/kinit.cpp:738
#50 0x00000000004059a3 in main (argc=4, argv=<optimized out>, envp=0x7fffd56990b0) at ../../kinit/kinit.cpp:1853

Possible duplicates by query: bug 336685, bug 333475, bug 329564.


Reproducible: Sometimes

Steps to Reproduce:
1. Just made right-mouse click and it crashed and restarted
2.
3.



I have usedBleach bit -1st as root, afterwards as regular user like the hundred times with kubuntu 12.04
Comment 1 Martin Flöser 2014-09-01 10:15:55 UTC

*** This bug has been marked as a duplicate of bug 254741 ***