Bug 338718 - I just had used bleachbit to clean the system - first as root, afterwards as a regular user
Summary: I just had used bleachbit to clean the system - first as root, afterwards as ...
Status: RESOLVED DUPLICATE of bug 254741
Alias: None
Product: plasma4
Classification: Unclassified
Component: desktop (show other bugs)
Version: unspecified
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-01 08:16 UTC by 123design
Modified: 2014-09-01 22:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 123design 2014-09-01 08:16:00 UTC
Application: plasma-desktop (4.11.10)
KDE Platform Version: 4.13.3
Qt Version: 4.8.6
Operating System: Linux 3.13.0-35-generic x86_64
Distribution: Ubuntu 14.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:

 I just had used bleachbit to clean the system - first as root, afterwards as a regular user

-- Backtrace:
Application: Обвивка на работен плот Plasma (plasma-desktop), signal: Bus error
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f848a6b8800 (LWP 3002))]

Thread 5 (Thread 0x7f845b8cd700 (LWP 3006)):
#0  0x00007fffcf3f9a1f in ?? ()
#1  0x0000000000000005 in ?? ()
#2  0x00007f848a6ba8d0 in ?? ()
#3  0x0000000000000002 in ?? ()
#4  0x00007f844c002f30 in ?? ()
#5  0x00007f845b8ccbe8 in ?? ()
#6  0x00007f845b8ccb80 in ?? ()
#7  0x000000007fffffff in ?? ()
#8  0x00007f8486b706f0 in ?? () at kernel/qeventdispatcher_glib.cpp:223 from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f845b8ccbf0 in ?? ()
#10 0x00007f8489fb646d in __GI___clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#11 0x00007f8486a95ad7 in do_gettime (frac=0x7f845b8ccb30, sec=0x7f845b8ccb28) at tools/qelapsedtimer_unix.cpp:127
#12 qt_gettime () at tools/qelapsedtimer_unix.cpp:144
#13 0x00007f8486b71f05 in updateCurrentTime (this=0xffffffffffdff000) at kernel/qeventdispatcher_unix.cpp:354
#14 QTimerInfoList::timerWait (this=0xffffffffffdff000, tm=...) at kernel/qeventdispatcher_unix.cpp:460
#15 0x00007f8486b7067c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f845b8ccbe4) at kernel/qeventdispatcher_glib.cpp:143
#16 0x00007f8486b70725 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:176
#17 0x00007f847d4f568d in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007f847d4f5f03 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f847d4f60ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f8486b707be in QEventDispatcherGlib::processEvents (this=0x7f844c0008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#21 0x00007f8486b420af in QEventLoop::processEvents (this=this@entry=0x7f845b8ccda0, flags=...) at kernel/qeventloop.cpp:149
#22 0x00007f8486b423a5 in QEventLoop::exec (this=this@entry=0x7f845b8ccda0, flags=...) at kernel/qeventloop.cpp:204
#23 0x00007f8486a3ec5f in QThread::exec (this=this@entry=0x2935c50) at thread/qthread.cpp:537
#24 0x00007f8486b23823 in QInotifyFileSystemWatcherEngine::run (this=0x2935c50) at io/qfilesystemwatcher_inotify.cpp:265
#25 0x00007f8486a4132f in QThreadPrivate::start (arg=0x2935c50) at thread/qthread_unix.cpp:349
#26 0x00007f847dc07182 in start_thread (arg=0x7f845b8cd700) at pthread_create.c:312
#27 0x00007f8489fa7fbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 4 (Thread 0x7f844ae91700 (LWP 3008)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f848335affb in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f848335b039 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f847dc07182 in start_thread (arg=0x7f844ae91700) at pthread_create.c:312
#4  0x00007f8489fa7fbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7f83c8fcc700 (LWP 3009)):
#0  0x00007f847dc09558 in __GI___pthread_mutex_lock (mutex=0x7f83bc000a80) at ../nptl/pthread_mutex_lock.c:122
#1  0x00007f847d537991 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f847d4f5a6c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f847d4f5f7b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f847d4f60ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f8486b707be in QEventDispatcherGlib::processEvents (this=0x7f83bc0008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0x00007f8486b420af in QEventLoop::processEvents (this=this@entry=0x7f83c8fcbda0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f8486b423a5 in QEventLoop::exec (this=this@entry=0x7f83c8fcbda0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f8486a3ec5f in QThread::exec (this=this@entry=0x29a2430) at thread/qthread.cpp:537
#9  0x00007f8486b23823 in QInotifyFileSystemWatcherEngine::run (this=0x29a2430) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f8486a4132f in QThreadPrivate::start (arg=0x29a2430) at thread/qthread_unix.cpp:349
#11 0x00007f847dc07182 in start_thread (arg=0x7f83c8fcc700) at pthread_create.c:312
#12 0x00007f8489fa7fbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f83ae85e700 (LWP 3018)):
#0  0x00007f8489f9ac6d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f847d4f5fe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f847d4f60ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8486b707be in QEventDispatcherGlib::processEvents (this=0x7f83a80008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#4  0x00007f8486b420af in QEventLoop::processEvents (this=this@entry=0x7f83ae85dda0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f8486b423a5 in QEventLoop::exec (this=this@entry=0x7f83ae85dda0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f8486a3ec5f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#7  0x00007f83b580c027 in KCupsConnection::run() () from /usr/lib/libkcupslib.so
#8  0x00007f8486a4132f in QThreadPrivate::start (arg=0x4555780) at thread/qthread_unix.cpp:349
#9  0x00007f847dc07182 in start_thread (arg=0x7f83ae85e700) at pthread_create.c:312
#10 0x00007f8489fa7fbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f848a6b8800 (LWP 3002)):
[KCrash Handler]
#6  0x00007f8487340005 in lock (this=0x46ee150) at ../../kdecore/util/kshareddatacache.cpp:1235
#7  cautiousLock (this=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1259
#8  CacheLocker (_d=0x46ee150, this=<synthetic pointer>) at ../../kdecore/util/kshareddatacache.cpp:1309
#9  KSharedDataCache::find (this=this@entry=0x35bda10, key=..., destination=destination@entry=0x7fffcf3d7c60) at ../../kdecore/util/kshareddatacache.cpp:1606
#10 0x00007f8487867ab5 in KImageCache::findPixmap (this=0x35bda10, key=..., destination=destination@entry=0x7fffcf3d7cc0) at ../../kdeui/util/kimagecache.cpp:150
#11 0x00007f8489b529b3 in Plasma::Theme::findInCache (this=this@entry=0x2158ff0, key=..., pix=...) at ../../plasma/theme.cpp:1035
#12 0x00007f8489ae9530 in Plasma::FrameSvgPrivate::generateBackground (this=this@entry=0x352cb40, frame=frame@entry=0x4bab3b0) at ../../plasma/framesvg.cpp:671
#13 0x00007f8489aea750 in Plasma::FrameSvgPrivate::alphaMask (this=0x352cb40) at ../../plasma/framesvg.cpp:602
#14 0x00007f8489aeb002 in Plasma::FrameSvg::mask (this=<optimized out>) at ../../plasma/framesvg.cpp:459
#15 0x00007f8489b245bd in Plasma::ToolTip::resizeEvent (this=0x5559030, e=0x7fffcf3d83a0) at ../../plasma/private/tooltip.cpp:341
#16 0x00007f8485f2c2be in QWidget::event (this=0x5559030, event=0x7fffcf3d83a0) at kernel/qwidget.cpp:8541
#17 0x00007f8485edce2c in QApplicationPrivate::notify_helper (this=this@entry=0x20a2e20, receiver=receiver@entry=0x5559030, e=e@entry=0x7fffcf3d83a0) at kernel/qapplication.cpp:4567
#18 0x00007f8485ee34a0 in QApplication::notify (this=this@entry=0x208eb90, receiver=receiver@entry=0x5559030, e=e@entry=0x7fffcf3d83a0) at kernel/qapplication.cpp:4353
#19 0x00007f8487808d1a in KApplication::notify (this=0x208eb90, receiver=0x5559030, event=0x7fffcf3d83a0) at ../../kdeui/kernel/kapplication.cpp:311
#20 0x00007f8486b434dd in QCoreApplication::notifyInternal (this=0x208eb90, receiver=receiver@entry=0x5559030, event=event@entry=0x7fffcf3d83a0) at kernel/qcoreapplication.cpp:953
#21 0x00007f8485f282f1 in sendEvent (event=0x7fffcf3d83a0, receiver=0x5559030) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#22 QWidgetPrivate::sendPendingMoveAndResizeEvents (this=this@entry=0x37ea460, recursive=recursive@entry=false, disableUpdates=<optimized out>, disableUpdates@entry=false) at kernel/qwidget.cpp:7446
#23 0x00007f8485f298f3 in QWidgetPrivate::show_helper (this=this@entry=0x37ea460) at kernel/qwidget.cpp:7497
#24 0x00007f8485f2b6b4 in QWidget::setVisible (this=0x5559030, visible=<optimized out>) at kernel/qwidget.cpp:7778
#25 0x00007f8489b5c80d in show (this=<optimized out>) at /usr/include/qt4/QtGui/qwidget.h:497
#26 Plasma::ToolTipManagerPrivate::showToolTip (this=0x22e5430) at ../../plasma/tooltipmanager.cpp:430
#27 0x00007f8489b5cb49 in Plasma::ToolTipManager::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at ./tooltipmanager.moc:64
#28 0x00007f8486b5787a in QMetaObject::activate (sender=0x2283390, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#29 0x00007f8486b5ba31 in QObject::event (this=0x2283390, e=<optimized out>) at kernel/qobject.cpp:1156
#30 0x00007f8485edce2c in QApplicationPrivate::notify_helper (this=this@entry=0x20a2e20, receiver=receiver@entry=0x2283390, e=e@entry=0x7fffcf3d8a60) at kernel/qapplication.cpp:4567
#31 0x00007f8485ee34a0 in QApplication::notify (this=this@entry=0x208eb90, receiver=receiver@entry=0x2283390, e=e@entry=0x7fffcf3d8a60) at kernel/qapplication.cpp:4353
#32 0x00007f8487808d1a in KApplication::notify (this=0x208eb90, receiver=0x2283390, event=0x7fffcf3d8a60) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x00007f8486b434dd in QCoreApplication::notifyInternal (this=0x208eb90, receiver=0x2283390, event=0x7fffcf3d8a60) at kernel/qcoreapplication.cpp:953
#34 0x00007f8486b73323 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#35 QTimerInfoList::activateTimers (this=0x20a40d0) at kernel/qeventdispatcher_unix.cpp:621
#36 0x00007f8486b70629 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:193
#37 idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:240
#38 0x00007f847d4f5e04 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#39 0x00007f847d4f6048 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#40 0x00007f847d4f60ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007f8486b707a1 in QEventDispatcherGlib::processEvents (this=0x1f8aaf0, flags=...) at kernel/qeventdispatcher_glib.cpp:434
#42 0x00007f8485f7ebb6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x00007f8486b420af in QEventLoop::processEvents (this=this@entry=0x7fffcf3d8cd0, flags=...) at kernel/qeventloop.cpp:149
#44 0x00007f8486b423a5 in QEventLoop::exec (this=this@entry=0x7fffcf3d8cd0, flags=...) at kernel/qeventloop.cpp:204
#45 0x00007f8486b47b79 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#46 0x00007f848a2af67c in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#47 0x00007f8489eceec5 in __libc_start_main (main=0x4006e0, argc=1, argv=0x7fffcf3d8f28, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffcf3d8f18) at libc-start.c:287
#48 0x000000000040070e in _start ()

Possible duplicates by query: bug 336685, bug 333475, bug 330525, bug 329564.


Reproducible: Always
Comment 1 Christoph Feck 2014-09-01 22:08:23 UTC

*** This bug has been marked as a duplicate of bug 254741 ***