Bug 272284 - Bleachbit Crash
Summary: Bleachbit Crash
Status: RESOLVED DUPLICATE of bug 254741
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-03 00:13 UTC by Lawrence H. Bulk
Modified: 2011-05-06 17:16 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (9.04 KB, text/plain)
2011-05-05 20:03 UTC, Lawrence H. Bulk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lawrence H. Bulk 2011-05-03 00:13:14 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2) (Compiled from sources)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed: I ran Bleachbit under root (Konsole[Terminal]->sudo bleachbit. When it completed (showing 4 errors the first time and 6 errors the second - I had rebooted the computer, a Toshiba Satellite 1905-S277, between runs), I closed out Bleachbit and then, when I closed the Konsole, the computer crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Bus error
[Current thread is 1 (Thread 0xb78b8ad0 (LWP 1235))]

Thread 4 (Thread 0xb56e4b70 (LWP 1237)):
#0  0x00a88416 in __kernel_vsyscall ()
#1  0x00efdf76 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0x0338484b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x033741af in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x03374524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x0133a577 in QEventDispatcherGlib::processEvents (this=0x92cf6d0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x0130c289 in QEventLoop::processEvents (this=0xb56e4280, flags=...) at kernel/qeventloop.cpp:149
#7  0x0130c522 in QEventLoop::exec (this=0xb56e4280, flags=...) at kernel/qeventloop.cpp:201
#8  0x012162a0 in QThread::exec (this=0x9307230) at thread/qthread.cpp:492
#9  0x012edfdb in QInotifyFileSystemWatcherEngine::run (this=0x9307230) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x01218da2 in QThreadPrivate::start (arg=0x9307230) at thread/qthread_unix.cpp:320
#11 0x074eae99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00f0c73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xae83eb70 (LWP 1239)):
#0  0x074ee7a4 in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x00f1a656 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0x03373648 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x0337403a in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x03374524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x0133a577 in QEventDispatcherGlib::processEvents (this=0x93879b8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0x0130c289 in QEventLoop::processEvents (this=0xae83e280, flags=...) at kernel/qeventloop.cpp:149
#7  0x0130c522 in QEventLoop::exec (this=0xae83e280, flags=...) at kernel/qeventloop.cpp:201
#8  0x012162a0 in QThread::exec (this=0x9383e28) at thread/qthread.cpp:492
#9  0x012edfdb in QInotifyFileSystemWatcherEngine::run (this=0x9383e28) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x01218da2 in QThreadPrivate::start (arg=0x9383e28) at thread/qthread_unix.cpp:320
#11 0x074eae99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00f0c73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xad83cb70 (LWP 1244)):
#0  0x074ed36b in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x00f1a616 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0x033740e1 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x0337492b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x046a6304 in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#5  0x0339d2df in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0x074eae99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#7  0x00f0c73e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb78b8ad0 (LWP 1235)):
[KCrash Handler]
#7  0x008f0aca in lock (this=0xbfe419fc, _d=0x8f4ab20) at ../../kdecore/util/kshareddatacache.cpp:1098
#8  cautiousLock (this=0xbfe419fc, _d=0x8f4ab20) at ../../kdecore/util/kshareddatacache.cpp:1121
#9  KSharedDataCache::Private::CacheLocker::CacheLocker (this=0xbfe419fc, _d=0x8f4ab20) at ../../kdecore/util/kshareddatacache.cpp:1146
#10 0x008ecdd5 in KSharedDataCache::find (this=0x8f4a1d0, key=..., destination=0xbfe41a9c) at ../../kdecore/util/kshareddatacache.cpp:1462
#11 0x03f36480 in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x8f50f88, key=..., data=..., path=...) at ../../kdeui/icons/kiconloader.cpp:868
#12 0x03f393d7 in KIconLoader::loadIcon (this=0x8f4da50, _name=..., group=KIconLoader::Desktop, size=48, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1231
#13 0x03f30d76 in KIconEngine::pixmap (this=0x9dce1f0, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:93
#14 0x0162dca2 in QIcon::pixmap (this=0xbfe41dc4, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:676
#15 0x005a5431 in pixmap (this=0xbfe41de8, mainText=..., subText=..., icon=...) at /usr/include/qt4/QtGui/qicon.h:80
#16 Plasma::ToolTipContent::ToolTipContent (this=0xbfe41de8, mainText=..., subText=..., icon=...) at ../../plasma/tooltipcontent.cpp:108
#17 0x042ef1cd in DesktopToolBox::toolTipAboutToShow (this=0x90f36a0) at ../../../../../plasma/desktop/shell/toolbox/desktoptoolbox.cpp:285
#18 0x042efda3 in DesktopToolBox::qt_metacall (this=0x90f36a0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfe41efc) at ./desktoptoolbox_p.moc:89
#19 0x013136ba in QMetaObject::metacall (object=0x90f36a0, cl=QMetaObject::InvokeMetaMethod, idx=31, argv=0xbfe41efc) at kernel/qmetaobject.cpp:237
#20 0x01316641 in QMetaMethod::invoke (this=0xbfe4208c, object=0x90f36a0, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1578
#21 0x0131736d in QMetaObject::invokeMethod (obj=0x90f36a0, member=0x68da40 "toolTipAboutToShow", type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1151
#22 0x005a6e2d in invokeMethod (this=0x8fbd300) at /usr/include/qt4/QtCore/qobjectdefs.h:424
#23 Plasma::ToolTipManagerPrivate::showToolTip (this=0x8fbd300) at ../../plasma/tooltipmanager.cpp:372
#24 0x005a73d1 in Plasma::ToolTipManager::qt_metacall (this=0x8fbd610, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfe4246c) at ./tooltipmanager.moc:88
#25 0x013136ba in QMetaObject::metacall (object=0x8fbd610, cl=QMetaObject::InvokeMetaMethod, idx=6, argv=0xbfe4246c) at kernel/qmetaobject.cpp:237
#26 0x013234ff in QMetaObject::activate (sender=0x8fbd660, m=0x14485a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3287
#27 0x013702f7 in QTimer::timeout (this=0x8fbd660) at .moc/release-shared/moc_qtimer.cpp:134
#28 0x013293ee in QTimer::timerEvent (this=0x8fbd660, e=0xbfe4298c) at kernel/qtimer.cpp:271
#29 0x01322214 in QObject::event (this=0x8fbd660, e=0xbfe4298c) at kernel/qobject.cpp:1190
#30 0x01577d24 in QApplicationPrivate::notify_helper (this=0x8ef3710, receiver=0x8fbd660, e=0xbfe4298c) at kernel/qapplication.cpp:4462
#31 0x0157c8ce in QApplication::notify (this=0x8ee9e50, receiver=0x8fbd660, e=0xbfe4298c) at kernel/qapplication.cpp:3862
#32 0x03f8b3ca in KApplication::notify (this=0x8ee9e50, receiver=0x8fbd660, event=0xbfe4298c) at ../../kdeui/kernel/kapplication.cpp:311
#33 0x0130d0bb in QCoreApplication::notifyInternal (this=0x8ee9e50, receiver=0x8fbd660, event=0xbfe4298c) at kernel/qcoreapplication.cpp:731
#34 0x0133d1e4 in sendEvent (this=0x8ef6c8c) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#35 QTimerInfoList::activateTimers (this=0x8ef6c8c) at kernel/qeventdispatcher_unix.cpp:604
#36 0x01339e27 in timerSourceDispatch (source=0x8ef6cc0) at kernel/qeventdispatcher_glib.cpp:184
#37 idleTimerSourceDispatch (source=0x8ef6cc0) at kernel/qeventdispatcher_glib.cpp:231
#38 0x03373aa8 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0x03374270 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0x03374524 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#41 0x0133a53c in QEventDispatcherGlib::processEvents (this=0x8e9caa8, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#42 0x0162b775 in QGuiEventDispatcherGlib::processEvents (this=0x8e9caa8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x0130c289 in QEventLoop::processEvents (this=0xbfe42c24, flags=...) at kernel/qeventloop.cpp:149
#44 0x0130c522 in QEventLoop::exec (this=0xbfe42c24, flags=...) at kernel/qeventloop.cpp:201
#45 0x01310ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#46 0x015758e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#47 0x0025c5a5 in kdemain (argc=1, argv=0xbfe42e34) at ../../../../plasma/desktop/shell/main.cpp:118
#48 0x080485cb in main (argc=1, argv=0xbfe42e34) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 271894, bug 271891, bug 271890, bug 271889, bug 271480.

Reported using DrKonqi
Comment 1 Lawrence H. Bulk 2011-05-05 20:03:22 UTC
Created attachment 59661 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed: I again ran "sudo bleachbit" in the Konsole (Terminal) and again, after the program was complete, I closed it. When I then closed the Konsole, the Desktop crashed.

It always does recover after a minute or two. (This time it recovered even before the Backtrace was completed.)

I have also noticed that when I run BleachBit, not everything is cleaned; there are always errors, sometime 4 or 6, sometimes more (today there were 12).

I am running under root so everything should be cleaned but this is not the case here. I should note that I have every choice in BleachBit selected for cleaning even though I do not actually have most of the programs installed. (This is what I have done when I was using Ubuntu 10.04 and 10.10 [Gnome] on this computer and I never had such a problem.)

-- Backtrace (Reduced):
#7  0x07ac0aca in lock (this=0xbfcfc6bc, _d=0x85cf348) at ../../kdecore/util/kshareddatacache.cpp:1098
#8  cautiousLock (this=0xbfcfc6bc, _d=0x85cf348) at ../../kdecore/util/kshareddatacache.cpp:1121
#9  KSharedDataCache::Private::CacheLocker::CacheLocker (this=0xbfcfc6bc, _d=0x85cf348) at ../../kdecore/util/kshareddatacache.cpp:1146
#10 0x07abcdd5 in KSharedDataCache::find (this=0x859e290, key=..., destination=0xbfcfc75c) at ../../kdecore/util/kshareddatacache.cpp:1462
#11 0x010a8480 in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x85d5bd0, key=..., data=..., path=...) at ../../kdeui/icons/kiconloader.cpp:868
Comment 2 Aaron J. Seigo 2011-05-06 17:16:22 UTC

*** This bug has been marked as a duplicate of bug 254741 ***