Bug 338716 - I have usedBleach bit -1st as root, afterwards as regular user like the hundred times with kubuntu 12.04
Summary: I have usedBleach bit -1st as root, afterwards as regular user like the hundr...
Status: RESOLVED DUPLICATE of bug 254741
Alias: None
Product: krunner
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Vishesh Handa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-01 08:12 UTC by 123design
Modified: 2014-09-01 22:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 123design 2014-09-01 08:12:05 UTC
Application: krunner (4.11.10)
KDE Platform Version: 4.13.3
Qt Version: 4.8.6
Operating System: Linux 3.13.0-35-generic x86_64
Distribution: Ubuntu 14.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
I have usedBleach bit -1st as root, afterwards as regular user like the hundred times with kubuntu 12.04

-- Backtrace:
Application: Run Command Interface (krunner), signal: Bus error
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb561070800 (LWP 3137))]

Thread 7 (Thread 0x7fb5430be700 (LWP 3153)):
#0  0x00007fb56097fc6d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fb55590ffe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb5559100ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb55d7a77be in QEventDispatcherGlib::processEvents (this=0x7fb53c0008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#4  0x00007fb55d7790af in QEventLoop::processEvents (this=this@entry=0x7fb5430bdda0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb55d7793a5 in QEventLoop::exec (this=this@entry=0x7fb5430bdda0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fb55d675c5f in QThread::exec (this=this@entry=0xef9720) at thread/qthread.cpp:537
#7  0x00007fb55d75a823 in QInotifyFileSystemWatcherEngine::run (this=0xef9720) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007fb55d67832f in QThreadPrivate::start (arg=0xef9720) at thread/qthread_unix.cpp:349
#9  0x00007fb555def182 in start_thread (arg=0x7fb5430be700) at pthread_create.c:312
#10 0x00007fb56098cfbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 6 (Thread 0x7fb536701700 (LWP 7711)):
#0  0x00007fb56097fc6d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fb55590ffe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb5559100ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb55d7a77be in QEventDispatcherGlib::processEvents (this=0x7fb5280008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#4  0x00007fb55d7790af in QEventLoop::processEvents (this=this@entry=0x7fb536700da0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb55d7793a5 in QEventLoop::exec (this=this@entry=0x7fb536700da0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fb55d675c5f in QThread::exec (this=this@entry=0xf06f00) at thread/qthread.cpp:537
#7  0x00007fb55d75a823 in QInotifyFileSystemWatcherEngine::run (this=0xf06f00) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007fb55d67832f in QThreadPrivate::start (arg=0xf06f00) at thread/qthread_unix.cpp:349
#9  0x00007fb555def182 in start_thread (arg=0x7fb536701700) at pthread_create.c:312
#10 0x00007fb56098cfbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 5 (Thread 0x7fb535f00700 (LWP 7713)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fb55d678816 in wait (time=18446744073709551615, this=0xf45980) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x105f7e8, mutex=0xf1ea40, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fb55870be6c in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x105f7c0, th=0x1235940) at ../../../threadweaver/Weaver/WeaverImpl.cpp:370
#4  0x00007fb55870e903 in ThreadWeaver::WorkingHardState::applyForWork (this=0xf051a0, th=0x1235940, previous=0x1216690) at ../../../threadweaver/Weaver/WorkingHardState.cpp:68
#5  0x00007fb55870d61f in ThreadWeaver::Thread::run (this=0x1235940) at ../../../threadweaver/Weaver/Thread.cpp:98
#6  0x00007fb55d67832f in QThreadPrivate::start (arg=0x1235940) at thread/qthread_unix.cpp:349
#7  0x00007fb555def182 in start_thread (arg=0x7fb535f00700) at pthread_create.c:312
#8  0x00007fb56098cfbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 4 (Thread 0x7fb5356ff700 (LWP 7714)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fb55d678816 in wait (time=18446744073709551615, this=0xf45980) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x105f7e8, mutex=0xf1ea40, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fb55870be6c in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x105f7c0, th=0xf152d0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:370
#4  0x00007fb55870e903 in ThreadWeaver::WorkingHardState::applyForWork (this=0xf051a0, th=0xf152d0, previous=0xfcac30) at ../../../threadweaver/Weaver/WorkingHardState.cpp:68
#5  0x00007fb55870d61f in ThreadWeaver::Thread::run (this=0xf152d0) at ../../../threadweaver/Weaver/Thread.cpp:98
#6  0x00007fb55d67832f in QThreadPrivate::start (arg=0xf152d0) at thread/qthread_unix.cpp:349
#7  0x00007fb555def182 in start_thread (arg=0x7fb5356ff700) at pthread_create.c:312
#8  0x00007fb56098cfbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7fb534efe700 (LWP 7715)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fb55d678816 in wait (time=18446744073709551615, this=0xf45980) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x105f7e8, mutex=0xf1ea40, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fb55870be6c in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x105f7c0, th=0xd9f270) at ../../../threadweaver/Weaver/WeaverImpl.cpp:370
#4  0x00007fb55870e903 in ThreadWeaver::WorkingHardState::applyForWork (this=0xf051a0, th=0xd9f270, previous=0x16174a0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:68
#5  0x00007fb55870d61f in ThreadWeaver::Thread::run (this=0xd9f270) at ../../../threadweaver/Weaver/Thread.cpp:98
#6  0x00007fb55d67832f in QThreadPrivate::start (arg=0xd9f270) at thread/qthread_unix.cpp:349
#7  0x00007fb555def182 in start_thread (arg=0x7fb534efe700) at pthread_create.c:312
#8  0x00007fb56098cfbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7fb5346fd700 (LWP 7716)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fb55d678816 in wait (time=18446744073709551615, this=0xf45980) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x105f7e8, mutex=0xf1ea40, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fb55870be6c in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x105f7c0, th=0xccb160) at ../../../threadweaver/Weaver/WeaverImpl.cpp:370
#4  0x00007fb55870e903 in ThreadWeaver::WorkingHardState::applyForWork (this=0xf051a0, th=0xccb160, previous=0x14e16b0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:68
#5  0x00007fb55870d61f in ThreadWeaver::Thread::run (this=0xccb160) at ../../../threadweaver/Weaver/Thread.cpp:98
#6  0x00007fb55d67832f in QThreadPrivate::start (arg=0xccb160) at thread/qthread_unix.cpp:349
#7  0x00007fb555def182 in start_thread (arg=0x7fb5346fd700) at pthread_create.c:312
#8  0x00007fb56098cfbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7fb561070800 (LWP 3137)):
[KCrash Handler]
#6  0x00007fb55dcf9ee8 in lock (this=0x154d6b0) at ../../kdecore/util/kshareddatacache.cpp:1235
#7  cautiousLock (this=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1259
#8  CacheLocker (_d=0x154d6b0, this=<synthetic pointer>) at ../../kdecore/util/kshareddatacache.cpp:1309
#9  KSharedDataCache::clear (this=0xe4c160) at ../../kdecore/util/kshareddatacache.cpp:1650
#10 0x00007fb55faa8e51 in KImageCache::clear (this=<optimized out>) at ../../kdeui/util/kimagecache.cpp:167
#11 0x00007fb5600042fc in Plasma::ThemePrivate::discardCache (this=0xf0be10, caches=...) at ../../plasma/theme.cpp:380
#12 0x00007fb5600043c9 in Plasma::ThemePrivate::notifyOfChanged (this=0xf0be10) at ../../plasma/theme.cpp:437
#13 0x00007fb56000c719 in Plasma::Theme::qt_static_metacall (_o=0x1, _id=-1, _a=0x7fff0fa5e890, _c=<optimized out>) at ./theme.moc:101
#14 0x00007fb55d78e87a in QMetaObject::activate (sender=0x103bcd0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#15 0x00007fb55d792a31 in QObject::event (this=0x103bcd0, e=<optimized out>) at kernel/qobject.cpp:1156
#16 0x00007fb55e16ce2c in QApplicationPrivate::notify_helper (this=this@entry=0xce5a60, receiver=receiver@entry=0x103bcd0, e=e@entry=0x7fff0fa5ec90) at kernel/qapplication.cpp:4567
#17 0x00007fb55e1734a0 in QApplication::notify (this=this@entry=0xccb860, receiver=receiver@entry=0x103bcd0, e=e@entry=0x7fff0fa5ec90) at kernel/qapplication.cpp:4353
#18 0x00007fb55fa49d1a in KApplication::notify (this=0xccb860, receiver=0x103bcd0, event=0x7fff0fa5ec90) at ../../kdeui/kernel/kapplication.cpp:311
#19 0x00007fb55d77a4dd in QCoreApplication::notifyInternal (this=0xccb860, receiver=0x103bcd0, event=0x7fff0fa5ec90) at kernel/qcoreapplication.cpp:953
#20 0x00007fb55d7aa323 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#21 QTimerInfoList::activateTimers (this=0xce15b0) at kernel/qeventdispatcher_unix.cpp:621
#22 0x00007fb55d7a7629 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:193
#23 idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:240
#24 0x00007fb55590fe04 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007fb555910048 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007fb5559100ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007fb55d7a77a1 in QEventDispatcherGlib::processEvents (this=0xc44af0, flags=...) at kernel/qeventdispatcher_glib.cpp:434
#28 0x00007fb55e20ebb6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x00007fb55d7790af in QEventLoop::processEvents (this=this@entry=0x7fff0fa5ef00, flags=...) at kernel/qeventloop.cpp:149
#30 0x00007fb55d7793a5 in QEventLoop::exec (this=this@entry=0x7fff0fa5ef00, flags=...) at kernel/qeventloop.cpp:204
#31 0x00007fb55d77eb79 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#32 0x00007fb560c7f5a5 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_krunner.so
#33 0x00007fb5608b3ec5 in __libc_start_main (main=0x4006d0, argc=1, argv=0x7fff0fa5f158, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff0fa5f148) at libc-start.c:287
#34 0x00000000004006fe in _start ()

Possible duplicates by query: bug 336685, bug 333475, bug 329564.


Reproducible: Always
Comment 1 Christoph Feck 2014-09-01 22:08:06 UTC

*** This bug has been marked as a duplicate of bug 254741 ***