Bug 261961 - Ksmserver crashed while shutting down
Summary: Ksmserver crashed while shutting down
Status: RESOLVED DUPLICATE of bug 254741
Alias: None
Product: ksmserver
Classification: Unclassified
Component: general (show other bugs)
Version: 0.4
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-03 15:32 UTC by Arthur Marceaux dit Clément
Modified: 2011-01-03 17:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arthur Marceaux dit Clément 2011-01-03 15:32:30 UTC
Application: ksmserver (0.4)
KDE Platform Version: 4.5.4 (KDE 4.5.4)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic x86_64
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

I just was shutting down my computer when ksmserver crashed. I now have a black screen and the bug report window.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Le gestionnaire de session de KDE (ksmserver), signal: Bus error
[KCrash Handler]
#6  pthread_mutex_timedlock (mutex=0x7fe6f5b2c008, abstime=0x7fffea95bcc0) at pthread_mutex_timedlock.c:40
#7  0x00007fe70426a38a in KSharedDataCache::Private::CacheLocker::CacheLocker(KSharedDataCache::Private const*) () from /usr/lib/libkdecore.so.5
#8  0x00007fe704267a9a in KSharedDataCache::find (this=0x1c2ba40, key=..., destination=0x7fffea95bf40) at ../../kdecore/util/kshareddatacache.cpp:1378
#9  0x00007fe70599e25c in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x1c4dbc0, key=..., data=..., path=<value optimized out>) at ../../kdeui/icons/kiconloader.cpp:867
#10 0x00007fe7059a5961 in KIconLoader::loadIcon (this=0x1c4e560, _name=<value optimized out>, group=KIconLoader::NoGroup, size=32, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1230
#11 0x00007fe706b0d3aa in KSMShutdownDlg::KSMShutdownDlg (this=0x1cddf40, parent=<value optimized out>, maysd=<value optimized out>, choose=<value optimized out>, sdtype=KWorkSpace::ShutdownTypeHalt) at ../../ksmserver/shutdowndlg.cpp:429
#12 0x00007fe706b0debc in KSMShutdownDlg::confirmShutdown (maysd=247, choose=207, sdtype=@0x7fffea95c7cc, bootOption=...) at ../../ksmserver/shutdowndlg.cpp:680
#13 0x00007fe706b19ec4 in KSMServer::shutdown (this=0x1c88c70, confirm=<value optimized out>, sdtype=KWorkSpace::ShutdownTypeHalt, sdmode=KWorkSpace::ShutdownModeInteractive) at ../../ksmserver/shutdown.cpp:157
#14 0x00007fe706b1d6a8 in logout (this=0x1c32110, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffea95cbe0) at ksmserverinterfaceadaptor.cpp:51
#15 KSMServerInterfaceAdaptor::qt_metacall (this=0x1c32110, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffea95cbe0) at ksmserverinterfaceadaptor.moc:108
#16 0x00007fe703dcd0ee in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>) at qdbusintegrator.cpp:919
#17 0x00007fe703dce36f in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x1c32110, flags=273, msg=...) at qdbusintegrator.cpp:822
#18 0x00007fe703dcee65 in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1379
#19 0x00007fe703dcf108 in QDBusActivateObjectEvent::placeMetaCall (this=0x1cd5c30) at qdbusintegrator.cpp:1493
#20 0x00007fe703a88bde in QObject::event (this=0x1c88c70, e=0x7fe6f5b2c008) at kernel/qobject.cpp:1219
#21 0x00007fe702bc0fdc in QApplicationPrivate::notify_helper (this=0x1bea9e0, receiver=0x1c88c70, e=0x1cd5c30) at kernel/qapplication.cpp:4396
#22 0x00007fe702bc6aed in QApplication::notify (this=0x1bea870, receiver=0x1c88c70, e=0x1cd5c30) at kernel/qapplication.cpp:4277
#23 0x00007fe7059f0576 in KApplication::notify (this=0x1bea870, receiver=0x1c88c70, event=0x1cd5c30) at ../../kdeui/kernel/kapplication.cpp:310
#24 0x00007fe703a76cdc in QCoreApplication::notifyInternal (this=0x1bea870, receiver=0x1c88c70, event=0x1cd5c30) at kernel/qcoreapplication.cpp:732
#25 0x00007fe703a79c22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x1bc4560) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x1bc4560) at kernel/qcoreapplication.cpp:1373
#27 0x00007fe703aa3653 in sendPostedEvents (s=0x1bef140) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#28 postEventSourceDispatch (s=0x1bef140) at kernel/qeventdispatcher_glib.cpp:277
#29 0x00007fe6fb6a8342 in g_main_dispatch (context=0x1beda20) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2149
#30 g_main_context_dispatch (context=0x1beda20) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2702
#31 0x00007fe6fb6ac2a8 in g_main_context_iterate (context=0x1beda20, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2780
#32 0x00007fe6fb6ac45c in g_main_context_iteration (context=0x1beda20, may_block=1) at /build/buildd/glib2.0-2.26.0/glib/gmain.c:2843
#33 0x00007fe703aa3193 in QEventDispatcherGlib::processEvents (this=0x1bc4070, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#34 0x00007fe702c73a4e in QGuiEventDispatcherGlib::processEvents (this=0x7fe6f5b2c008, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x00007fe703a75a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#36 0x00007fe703a75dec in QEventLoop::exec (this=0x7fffea95d8a0, flags=) at kernel/qeventloop.cpp:201
#37 0x00007fe703a79ebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#38 0x00007fe706b026d7 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../ksmserver/main.cpp:311
#39 0x00007fe70678bd8e in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffea95de68) at libc-start.c:226
#40 0x0000000000400669 in _start ()

This bug may be a duplicate of or related to bug 254741.

Possible duplicates by query: bug 261960, bug 254741.

Reported using DrKonqi
Comment 1 Nicolas L. 2011-01-03 17:29:14 UTC

*** This bug has been marked as a duplicate of bug 254741 ***