Bug 263822 - Amarok Crashes all the time at start.
Summary: Amarok Crashes all the time at start.
Status: RESOLVED DUPLICATE of bug 254741
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kshareddatacache (show other bugs)
Version: 4.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-21 08:10 UTC by Light Yagami
Modified: 2011-01-21 17:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Light Yagami 2011-01-21 08:10:31 UTC
Application: knotify4 (4.0)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic-pae i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed: Started Amarok selecting a largue number of songs and clicking in open with amarok makes kwin crash when amarok starts. Tried 4 times more and same issue happens, maybe some update or setting is related to this.

- Custom settings of the application: Might be Settings>COnfigure Amarok>Notifications>ON-screen display. Not sure but might be related to that setting cause when i start amarok playing a song the notification pops up and I think that makes KDE to crush.

The crash can be reproduced every time.

-- Backtrace:
Application: KNotify (knotify4), signal: Bus error
[Current thread is 1 (Thread 0xb5637710 (LWP 1822))]

Thread 5 (Thread 0xaeae7b70 (LWP 1976)):
#0  0xb77f0424 in __kernel_vsyscall ()
#1  0xb5d1e884 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb6170df4 in pthread_cond_timedwait () from /lib/libc.so.6
#3  0xb3c87b3f in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 4 (Thread 0xae2e6b70 (LWP 1977)):
#0  0xb77f0424 in __kernel_vsyscall ()
#1  0xb6154df6 in poll () from /lib/libc.so.6
#2  0xb5bc2a1b in g_poll () from /lib/libglib-2.0.so.0
#3  0xb5bb543c in ?? () from /lib/libglib-2.0.so.0
#4  0xb5bb5848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0xb646e59f in QEventDispatcherGlib::processEvents (this=0x8524630, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0xb643e609 in QEventLoop::processEvents (this=0xae2e6280, flags=) at kernel/qeventloop.cpp:149
#7  0xb643ea8a in QEventLoop::exec (this=0xae2e6280, flags=...) at kernel/qeventloop.cpp:201
#8  0xb633ab7e in QThread::exec (this=0x84bb978) at thread/qthread.cpp:490
#9  0xb3cd881a in ?? () from /usr/lib/qt4/plugins/phonon_backend/phonon_xine.so
#10 0xb633ddf9 in QThreadPrivate::start (arg=0x84bb978) at thread/qthread_unix.cpp:266
#11 0xb5d19cc9 in start_thread () from /lib/libpthread.so.0
#12 0xb616369e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xadae5b70 (LWP 1978)):
#0  0xb77f0424 in __kernel_vsyscall ()
#1  0xb6154df6 in poll () from /lib/libc.so.6
#2  0xb5cbf562 in ?? () from /usr/lib/libpulse.so.0
#3  0xb5cabab9 in pa_mainloop_poll () from /usr/lib/libpulse.so.0
#4  0xb5cada73 in pa_mainloop_iterate () from /usr/lib/libpulse.so.0
#5  0xb5cadb44 in pa_mainloop_run () from /usr/lib/libpulse.so.0
#6  0xb5cbf303 in ?? () from /usr/lib/libpulse.so.0
#7  0xb59debd5 in ?? () from /usr/lib/libpulsecommon-0.9.21.so
#8  0xb5d19cc9 in start_thread () from /lib/libpthread.so.0
#9  0xb616369e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xa92e3b70 (LWP 1979)):
#0  0xb77f0424 in __kernel_vsyscall ()
#1  0xb5d1e4dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb6170d9d in pthread_cond_wait () from /lib/libc.so.6
#3  0xb3c99b54 in ?? () from /usr/lib/libxine.so.1
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 1 (Thread 0xb5637710 (LWP 1822)):
[KCrash Handler]
#7  0xb5d1cb50 in pthread_mutex_timedlock () from /lib/libpthread.so.0
#8  0xb6836de7 in KSharedDataCache::Private::CacheLocker::CacheLocker(KSharedDataCache::Private const*) () from /usr/lib/libkdecore.so.5
#9  0xb68325e4 in KSharedDataCache::find (this=0x83e5d30, key=..., destination=0xbffe880c) at ../../kdecore/util/kshareddatacache.cpp:1355
#10 0xb75a4558 in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x839d5f0, key=..., data=..., path=...) at ../../kdeui/icons/kiconloader.cpp:862
#11 0xb75acbcf in KIconLoader::loadIcon (this=0x83e3780, _name=..., group=KIconLoader::Desktop, size=16, state=0, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1218
#12 0xb75a32d6 in KIconEngine::pixmap (this=0x845eec8, size=..., mode=QIcon::Normal, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:93
#13 0xb6a65626 in QIcon::pixmap (this=0xbffe8bbc, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:676
#14 0xb6a4fab3 in QWidgetPrivate::setWindowIcon_sys (this=0x849ae90, forceReset=false) at kernel/qwidget_x11.cpp:1460
#15 0xb6a007c8 in QWidget::create (this=0x8ae0ae8, window=0, initializeWindow=<value optimized out>, destroyOldWindow=<value optimized out>) at kernel/qwidget.cpp:1455
#16 0xb6a04d55 in QWidget::setVisible (this=0x8ae0ae8, visible=true) at kernel/qwidget.cpp:7524
#17 0xb768b285 in KPassivePopup::setVisible (this=0x8ae0ae8, visible=true) at ../../kdeui/util/kpassivepopup.cpp:291
#18 0xb7688949 in show (this=0x8ae0ae8) at /usr/include/qt4/QtGui/qwidget.h:487
#19 KPassivePopup::show (this=0x8ae0ae8) at ../../kdeui/util/kpassivepopup.cpp:305
#20 0xb7688986 in KPassivePopup::show (this=0x8ae0ae8, p=...) at ../../kdeui/util/kpassivepopup.cpp:311
#21 0x0805b9a1 in NotifyByPopup::notify (this=0x8488cb0, id=167, config=0x84b6780) at ../../knotify/notifybypopup.cpp:110
#22 0x0804f725 in KNotify::emitEvent (this=0xbffe9b54, e=0x84b6778) at ../../knotify/knotify.cpp:181
#23 0x0804f9bb in KNotify::event (this=0xbffe9b54, event=..., appname=..., contexts=..., title=..., text=..., image=..., actions=..., timeout=-1, winId=0) at ../../knotify/knotify.cpp:130
#24 0x0804fcba in KNotifyAdaptor::event (this=0x84264a8, event=..., fromApp=..., contexts=..., title=..., text=..., image=..., actions=..., timeout=-1, winId=<value optimized out>) at ../../knotify/knotify.cpp:238
#25 0x08050f9d in KNotifyAdaptor::qt_metacall (this=0x84264a8, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbffe913c) at ./knotify.moc:227
#26 0xb65939dc in QDBusConnectionPrivate::deliverCall (this=0x8366030, object=0x84264a8, msg=..., metaTypes=..., slotIdx=8) at qdbusintegrator.cpp:919
#27 0xb6594d25 in QDBusConnectionPrivate::activateCall (this=0x8366030, object=0x84264a8, flags=273, msg=...) at qdbusintegrator.cpp:829
#28 0xb6595770 in QDBusConnectionPrivate::activateObject (this=0x8366030, node=..., msg=..., pathStartPos=7) at qdbusintegrator.cpp:1379
#29 0xb6595a2a in QDBusActivateObjectEvent::placeMetaCall (this=0x8ad3b48) at qdbusintegrator.cpp:1493
#30 0xb64526a2 in QObject::event (this=0xbffe9b54, e=0xbffe86c8) at kernel/qobject.cpp:1219
#31 0xb69a0fdc in QApplicationPrivate::notify_helper (this=0x8378848, receiver=0xbffe9b54, e=0x8ad3b48) at kernel/qapplication.cpp:4396
#32 0xb69a704e in QApplication::notify (this=0xbffe9b68, receiver=0xbffe9b54, e=0x8ad3b48) at kernel/qapplication.cpp:3798
#33 0xb75fb68a in KApplication::notify (this=0xbffe9b68, receiver=0xbffe9b54, event=0x8ad3b48) at ../../kdeui/kernel/kapplication.cpp:310
#34 0xb643fb3b in QCoreApplication::notifyInternal (this=0xbffe9b68, receiver=0xbffe9b54, event=0x8ad3b48) at kernel/qcoreapplication.cpp:732
#35 0xb6442d8b in sendEvent (receiver=0x0, event_type=0, data=0x8350f20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8350f20) at kernel/qcoreapplication.cpp:1373
#37 0xb6442f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#38 0xb646ea74 in sendPostedEvents (s=0x8370d10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#39 postEventSourceDispatch (s=0x8370d10) at kernel/qeventdispatcher_glib.cpp:277
#40 0xb5bb1855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#41 0xb5bb5668 in ?? () from /lib/libglib-2.0.so.0
#42 0xb5bb5848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#43 0xb646e565 in QEventDispatcherGlib::processEvents (this=0x83509d0, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#44 0xb6a62be5 in QGuiEventDispatcherGlib::processEvents (this=0x83509d0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0xb643e609 in QEventLoop::processEvents (this=0xbffe9ab4, flags=) at kernel/qeventloop.cpp:149
#46 0xb643ea8a in QEventLoop::exec (this=0xbffe9ab4, flags=...) at kernel/qeventloop.cpp:201
#47 0xb644300f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#48 0xb699fe07 in QApplication::exec () at kernel/qapplication.cpp:3672
#49 0x0804eacd in main (argc=1, argv=0xbffe9ce4) at ../../knotify/main.cpp:73

Possible duplicates by query: bug 261960, bug 254741.

Reported using DrKonqi
Comment 1 Christoph Feck 2011-01-21 17:49:32 UTC
Did you run "bleach bit"?

*** This bug has been marked as a duplicate of bug 254741 ***