Bug 271894 - Lancelot crashed
Summary: Lancelot crashed
Status: RESOLVED DUPLICATE of bug 254741
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-lancelot (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Ivan Čukić
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-28 03:25 UTC by rflazaro
Modified: 2011-05-01 15:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rflazaro 2011-04-28 03:25:27 UTC
Application: lancelot (1.9.5)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.39-rc4-12-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I was running BleachBit to clean out unnecessary files on my machine

-- Backtrace:
Application: Lancelot (lancelot), signal: Bus error
[Current thread is 1 (Thread 0x7f4d2938d7a0 (LWP 3153))]

Thread 6 (Thread 0x7f4d0f540700 (LWP 3154)):
#0  0x00007f4d23c6c67e in __pthread_mutex_unlock_usercnt () from /lib64/libpthread.so.0
#1  0x00007f4d1cff6678 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#2  0x00007f4d26b76976 in QEventDispatcherGlib::processEvents (this=0x842d20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#3  0x00007f4d26b4b052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#4  0x00007f4d26b4b265 in QEventLoop::exec (this=0x7f4d0f53fce0, flags=...) at kernel/qeventloop.cpp:201
#5  0x00007f4d26a601e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#6  0x00007f4d26b2c968 in QInotifyFileSystemWatcherEngine::run (this=0xabaa80) at io/qfilesystemwatcher_inotify.cpp:248
#7  0x00007f4d26a62a5e in QThreadPrivate::start (arg=0xabaa80) at thread/qthread_unix.cpp:285
#8  0x00007f4d20238853 in ?? () from /usr/lib64/libGL.so.1
#9  0x00007f4d23c68a3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f4d257ab67d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f4cfcb62700 (LWP 3341)):
#0  0x00007f4d23c6d38c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f4d26a6314b in wait (this=<value optimized out>, mutex=0xaf8d80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xaf8d80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f4d21214254 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0xb57ca0, th=0xa28c40) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f4d212172a5 in waitForAvailableJob (this=0xb08570, th=0xa28c40) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WeaverImpl.cpp:356
#5  ThreadWeaver::WorkingHardState::applyForWork (this=0xb08570, th=0xa28c40) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WorkingHardState.cpp:71
#6  0x00007f4d2121464f in ThreadWeaver::ThreadRunHelper::run (this=0x7f4cfcb61d30, parent=0xb57ca0, th=0xa28c40) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:87
#7  0x00007f4d212146d8 in ThreadWeaver::Thread::run (this=0xa28c40) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:142
#8  0x00007f4d26a62a5e in QThreadPrivate::start (arg=0xa28c40) at thread/qthread_unix.cpp:285
#9  0x00007f4d20238853 in ?? () from /usr/lib64/libGL.so.1
#10 0x00007f4d23c68a3f in start_thread () from /lib64/libpthread.so.0
#11 0x00007f4d257ab67d in clone () from /lib64/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f4cfc361700 (LWP 3342)):
#0  0x00007f4d23c6d38c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f4d26a6314b in wait (this=<value optimized out>, mutex=0xaf8d80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xaf8d80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f4d21214254 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0xb57ca0, th=0xc30d30) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f4d212172a5 in waitForAvailableJob (this=0xb08570, th=0xc30d30) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WeaverImpl.cpp:356
#5  ThreadWeaver::WorkingHardState::applyForWork (this=0xb08570, th=0xc30d30) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WorkingHardState.cpp:71
#6  0x00007f4d212172be in ThreadWeaver::WorkingHardState::applyForWork (this=0xb08570, th=0xc30d30) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007f4d2121464f in ThreadWeaver::ThreadRunHelper::run (this=0x7f4cfc360d30, parent=0xb57ca0, th=0xc30d30) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:87
#8  0x00007f4d212146d8 in ThreadWeaver::Thread::run (this=0xc30d30) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:142
#9  0x00007f4d26a62a5e in QThreadPrivate::start (arg=0xc30d30) at thread/qthread_unix.cpp:285
#10 0x00007f4d20238853 in ?? () from /usr/lib64/libGL.so.1
#11 0x00007f4d23c68a3f in start_thread () from /lib64/libpthread.so.0
#12 0x00007f4d257ab67d in clone () from /lib64/libc.so.6
#13 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f4cfbb60700 (LWP 3343)):
#0  0x00007f4d23c6d38c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f4d26a6314b in wait (this=<value optimized out>, mutex=0xaf8d80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xaf8d80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f4d21214254 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0xb57ca0, th=0xea62a0) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f4d212172a5 in waitForAvailableJob (this=0xb08570, th=0xea62a0) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WeaverImpl.cpp:356
#5  ThreadWeaver::WorkingHardState::applyForWork (this=0xb08570, th=0xea62a0) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WorkingHardState.cpp:71
#6  0x00007f4d2121464f in ThreadWeaver::ThreadRunHelper::run (this=0x7f4cfbb5fd30, parent=0xb57ca0, th=0xea62a0) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:87
#7  0x00007f4d212146d8 in ThreadWeaver::Thread::run (this=0xea62a0) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:142
#8  0x00007f4d26a62a5e in QThreadPrivate::start (arg=0xea62a0) at thread/qthread_unix.cpp:285
#9  0x00007f4d20238853 in ?? () from /usr/lib64/libGL.so.1
#10 0x00007f4d23c68a3f in start_thread () from /lib64/libpthread.so.0
#11 0x00007f4d257ab67d in clone () from /lib64/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f4cfb35f700 (LWP 3344)):
#0  0x00007f4d23c6d38c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f4d26a6314b in wait (this=<value optimized out>, mutex=0xaf8d80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0xaf8d80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f4d21214254 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0xb57ca0, th=0xaef690) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f4d212172a5 in waitForAvailableJob (this=0xb08570, th=0xaef690) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WeaverImpl.cpp:356
#5  ThreadWeaver::WorkingHardState::applyForWork (this=0xb08570, th=0xaef690) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WorkingHardState.cpp:71
#6  0x00007f4d212172be in ThreadWeaver::WorkingHardState::applyForWork (this=0xb08570, th=0xaef690) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007f4d2121464f in ThreadWeaver::ThreadRunHelper::run (this=0x7f4cfb35ed30, parent=0xb57ca0, th=0xaef690) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:87
#8  0x00007f4d212146d8 in ThreadWeaver::Thread::run (this=0xaef690) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:142
#9  0x00007f4d26a62a5e in QThreadPrivate::start (arg=0xaef690) at thread/qthread_unix.cpp:285
#10 0x00007f4d20238853 in ?? () from /usr/lib64/libGL.so.1
#11 0x00007f4d23c68a3f in start_thread () from /lib64/libpthread.so.0
#12 0x00007f4d257ab67d in clone () from /lib64/libc.so.6
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f4d2938d7a0 (LWP 3153)):
[KCrash Handler]
#6  0x00007f4d27300cdd in lock (this=0x7fffdb0645f0, _d=0xe08120) at /usr/src/debug/kdelibs-4.6.0/kdecore/util/kshareddatacache.cpp:1098
#7  cautiousLock (this=0x7fffdb0645f0, _d=0xe08120) at /usr/src/debug/kdelibs-4.6.0/kdecore/util/kshareddatacache.cpp:1121
#8  KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fffdb0645f0, _d=0xe08120) at /usr/src/debug/kdelibs-4.6.0/kdecore/util/kshareddatacache.cpp:1146
#9  0x00007f4d27256c43 in KSharedDataCache::clear (this=0xc1dca0) at /usr/src/debug/kdelibs-4.6.0/kdecore/util/kshareddatacache.cpp:1496
#10 0x00007f4d289ef3da in Plasma::ThemePrivate::discardCache (this=0x869d20, caches=...) at /usr/src/debug/kdelibs-4.6.0/plasma/theme.cpp:276
#11 0x00007f4d289ef92b in Plasma::ThemePrivate::compositingChanged (this=0x869d20) at /usr/src/debug/kdelibs-4.6.0/plasma/theme.cpp:266
#12 0x00007f4d289f642f in Plasma::Theme::qt_metacall (this=0x7c98a0, _c=QMetaObject::InvokeMetaMethod, _id=2, _a=0x7fffdb0647e0) at /usr/src/debug/kdelibs-4.6.0/build/plasma/theme.moc:116
#13 0x00007f4d26b60def in QMetaObject::activate (sender=0x8074e0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3272
#14 0x00007f4d278cc68d in KSelectionWatcher::Private::x11Event (this=<value optimized out>, ev_P=<value optimized out>) at /usr/src/debug/kdelibs-4.6.0/kdeui/util/kmanagerselection.cpp:395
#15 0x00007f4d2784b50e in publicx11Event (this=<value optimized out>, _event=0x7fffdb064ee0) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:916
#16 KApplication::x11EventFilter (this=<value optimized out>, _event=0x7fffdb064ee0) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:967
#17 0x00007f4d25f86cc5 in qt_x11EventFilter (ev=0x7fffdb064ee0) at kernel/qapplication_x11.cpp:436
#18 0x00007f4d25f94ce0 in QApplication::x11ProcessEvent (this=0x6aa7a0, event=0x7fffdb064ee0) at kernel/qapplication_x11.cpp:3276
#19 0x00007f4d25fbd0f2 in x11EventSourceDispatch (s=0x6c7590, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#20 0x00007f4d1cff5bd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#21 0x00007f4d1cff63b0 in ?? () from /lib64/libglib-2.0.so.0
#22 0x00007f4d1cff6650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#23 0x00007f4d26b7691f in QEventDispatcherGlib::processEvents (this=0x6388c0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#24 0x00007f4d25fbcd8e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x00007f4d26b4b052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007f4d26b4b265 in QEventLoop::exec (this=0x7fffdb065200, flags=...) at kernel/qeventloop.cpp:201
#27 0x00007f4d26b4f6ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#28 0x000000000040e2d6 in _start ()

This bug may be a duplicate of or related to bug 271891.

Possible duplicates by query: bug 271891, bug 271890, bug 271480.

Reported using DrKonqi
Comment 1 Dario Andres 2011-05-01 15:03:19 UTC
[Comment from a bug report cleaner]
This bug is related to the KDE shared cache component (probably related to the temporary files cleanup). See bug 254741. Regards

*** This bug has been marked as a duplicate of bug 254741 ***