Bug 310310 - Crash when autosaving
Summary: Crash when autosaving
Status: RESOLVED FIXED
Alias: None
Product: calligracommon
Classification: Applications
Component: general (show other bugs)
Version: 2.7 Pre-Alpha
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Calligra Bugs
URL:
Keywords: release_blocker
: 309556 312307 314733 314871 315026 315267 317086 317416 317704 317738 317945 318207 318409 319380 319439 319938 320268 320683 320684 321221 321677 322864 322911 322924 323809 332285 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-11-19 08:57 UTC by Halla Rempt
Modified: 2014-03-18 21:20 UTC (History)
27 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (9.81 KB, text/plain)
2013-02-11 01:18 UTC, Kenneth Perry
Details
New crash information added by DrKonqi (12.32 KB, text/plain)
2013-02-18 07:19 UTC, bosyber
Details
New crash information added by DrKonqi (10.20 KB, text/plain)
2013-02-20 19:55 UTC, stevemacintyre
Details
autosave patch (1.67 KB, patch)
2013-04-28 19:49 UTC, Halla Rempt
Details
New crash information added by DrKonqi (10.60 KB, text/plain)
2013-05-26 18:34 UTC, Smittie
Details
New crash information added by DrKonqi (10.49 KB, text/plain)
2013-05-26 18:58 UTC, Smittie
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Halla Rempt 2012-11-19 08:57:48 UTC
Elle Stone reports constant crashes when autosaving:
Thread 1 (Thread 0x7fe82adb07c0 (LWP 5099)):
[KCrash Handler]
#5  0x00007fe828e989b4 in KParts::ReadWritePart::isModified() const () from /usr/lib64/libkparts.so.4
#6  0x00007fe829154f30 in KoDocument::slotAutoSave (this=this@entry=0x2e6c6f0) at /home/elle/kde4/src/calligra/libs/main/KoDocument.cpp:475
#7  0x00007fe8291553e8 in KoDocument::qt_static_metacall (_o=0x2e6c6f0, _c=<optimized out>, _id=<optimized out>, _a=0x7fff8626eee0) at /home/elle/kde4/build/calligra/libs/main/KoDocument.moc:97
#8  0x00007fe82a2ac39f in QMetaObject::activate (sender=0x2e620e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3556
#9  0x00007fe82a2aa31c in QObject::event (this=0x2e620e0, e=<optimized out>) at kernel/qobject.cpp:1166
#10 0x00007fe822c2b74c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#11 0x00007fe822c2fbca in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#12 0x00007fe829148a68 in KoApplication::notify (this=<optimized out>, receiver=0x2e620e0, event=0x7fff8626f690) at /home/elle/kde4/src/calligra/libs/main/KoApplication.cpp:504
#13 0x00007fe82a295b0e in QCoreApplication::notifyInternal (this=0x7fff8626faa0, receiver=0x2e620e0, event=0x7fff8626f690) at kernel/qcoreapplication.cpp:915
#14 0x00007fe82a2c6561 in sendEvent (event=0x7fff8626f690, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#15 QTimerInfoList::activateTimers (this=0x22ac898) at kernel/qeventdispatcher_unix.cpp:626
#16 0x00007fe82a2c6ba0 in QEventDispatcherUNIX::activateTimers (this=this@entry=0x2028a70) at kernel/qeventdispatcher_unix.cpp:883
#17 0x00007fe82a2c6cf8 in QEventDispatcherUNIX::processEvents (this=0x2028a70, flags=...) at kernel/qeventdispatcher_unix.cpp:945
#18 0x00007fe822ccc87f in ?? () from /usr/lib64/libQtGui.so.4
#19 0x00007fe82a29485f in QEventLoop::processEvents (this=this@entry=0x7fff8626f9e0, flags=...) at kernel/qeventloop.cpp:149
#20 0x00007fe82a294ae8 in QEventLoop::exec (this=0x7fff8626f9e0, flags=...) at kernel/qeventloop.cpp:204
#21 0x00007fe82a299788 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#22 0x00007fe82a7d1d1f in kdemain (argc=<optimized out>, argv=<optimized out>) at /home/elle/kde4/src/calligra/krita/main.cc:74
#23 0x00007fe821516455 in __libc_start_main () from /lib64/libc.so.6
#24 0x00000000004009d1 in _start () at ../sysdeps/x86_64/elf/start.S:113


Reproducible: Always
Comment 1 Kenneth Perry 2013-02-11 01:18:50 UTC
Created attachment 77118 [details]
New crash information added by DrKonqi

krita (2.6.0) on KDE Platform 4.10.00 using Qt 4.8.3

- What I was doing when the application crashed:

Drawing in krita with tablet, crashed unexpectedly. Backtrace seems related to autosave.

-- Backtrace (Reduced):
#6  0x00007f14156506a4 in KParts::ReadWritePart::isModified (this=0x30d8cd0) at ../../kparts/part.cpp:1031
#7  0x00007f1417885380 in KoDocument::slotAutoSave (this=0x31db8f0) at /build/buildd/calligra-2.6.0/libs/main/KoDocument.cpp:475
#8  0x00007f14178856a5 in KoDocument::qt_static_metacall (_o=0x30d8cd0, _c=QMetaObject::InvokeMetaMethod, _id=-988544, _a=0x7fff337e64d0) at /build/buildd/calligra-2.6.0/obj-x86_64-linux-gnu/libs/main/KoDocument.moc:97
[...]
#10 0x00007f1415d0f26c in QObject::event (this=0x2ba1350, e=<optimized out>) at kernel/qobject.cpp:1157
#11 0x00007f14166dbe9c in QApplicationPrivate::notify_helper (this=this@entry=0x1ecc410, receiver=receiver@entry=0x2ba1350, e=e@entry=0x7fff337e6bd0) at kernel/qapplication.cpp:4562
Comment 2 Halla Rempt 2013-02-13 08:57:34 UTC
*** Bug 315026 has been marked as a duplicate of this bug. ***
Comment 3 Halla Rempt 2013-02-13 09:00:53 UTC
I'm wondering whether it's maybe a threading issue -- one thread marks the documents as modified, while the gui thread tries to read that status to dermine whether it needs to autosave.
Comment 4 bosyber 2013-02-18 07:19:18 UTC
Created attachment 77397 [details]
New crash information added by DrKonqi

krita (2.6.0) on KDE Platform 4.10.00 using Qt 4.8.3

- What I was doing when the application crashed:
Copying a bit from a PDF, pasting as a new image in Krita to try some effects on it, I wanted to save
it first, it crashed.
Note that I had the same bit copied and then also saved as a png which I had opened in Krita as well (but with too low resolution, hence I tried it differently).

-- Backtrace (Reduced):
#6  0x00007f97d07b26a4 in KParts::ReadWritePart::isModified (this=0x4b8de60) at ../../kparts/part.cpp:1031
#7  0x00007f97d29e7380 in KoDocument::slotAutoSave (this=0x4ff91c0) at /build/buildd/calligra-2.6.0/libs/main/KoDocument.cpp:475
#8  0x00007f97d29e76a5 in KoDocument::qt_static_metacall (_o=0x4b8de60, _c=QMetaObject::InvokeMetaMethod, _id=-988544, _a=0x7fffbc523000) at /build/buildd/calligra-2.6.0/obj-x86_64-linux-gnu/libs/main/KoDocument.moc:97
[...]
#10 0x00007f97d0e7126c in QObject::event (this=0x318bc50, e=<optimized out>) at kernel/qobject.cpp:1157
#11 0x00007f97d183de9c in QApplicationPrivate::notify_helper (this=this@entry=0x1ccd6a0, receiver=receiver@entry=0x318bc50, e=e@entry=0x7fffbc523700) at kernel/qapplication.cpp:4562
Comment 5 Halla Rempt 2013-02-18 09:26:48 UTC
The really annoying thing is that I cannot reproduce it. Maybe someone who can reproduce it could test with git master and this patch applied?


diff --git a/libs/main/KoDocument.cpp b/libs/main/KoDocument.cpp
index eca8a24..5db88a2 100644
--- a/libs/main/KoDocument.cpp
+++ b/libs/main/KoDocument.cpp
@@ -71,6 +71,7 @@
 #include <QDBusConnection>
 #endif
 #include <QApplication>
+#include <QMutex>
 
 // Define the protocol used here for embedded documents' URL
 // This used to "store" but KUrl didn't like it,
@@ -101,6 +102,9 @@ QString KoDocument::newObjectName()
     return name;
 }
 
+
+static QMutex s_autosaveMutex;
+
 class KoDocument::Private
 {
 public:
@@ -463,6 +467,7 @@ bool KoDocument::isAutoErrorHandlingEnabled() const
 
 void KoDocument::slotAutoSave()
 {
+    s_autosaveMutex.lock();
     if (isModified() && d->modifiedAfterAutosave && !d->isLoading) {
         // Give a warning when trying to autosave an encrypted file when no password is known (should not happen)
         if (d->specialOutputFlag == SaveEncrypted && d->password.isNull()) {
@@ -486,6 +491,7 @@ void KoDocument::slotAutoSave()
             }
         }
     }
+    s_autosaveMutex.unlock();
 }
 
 void KoDocument::setReadWrite(bool readwrite)
lines 1-38/38 (END)
Comment 6 Halla Rempt 2013-02-18 10:51:13 UTC
Git commit 9e1f49263bccfb830663d4312c035a78c4f7499e by Boudewijn Rempt.
Committed on 18/02/2013 at 11:48.
Pushed by rempt into branch 'master'.

Try to make the autosave saver.

M  +7    -0    libs/main/KoDocument.cpp

http://commits.kde.org/calligra/9e1f49263bccfb830663d4312c035a78c4f7499e
Comment 7 stevemacintyre 2013-02-20 19:55:40 UTC
Created attachment 77471 [details]
New crash information added by DrKonqi

krita (2.6.0) on KDE Platform 4.10.00 using Qt 4.8.3

- What I was doing when the application crashed:

Was in the middle of sketching when the program closed unexpectedly.

-- Backtrace (Reduced):
#6  0x00007f14479ac6a4 in KParts::ReadWritePart::isModified (this=0x38f5100) at ../../kparts/part.cpp:1031
#7  0x00007f1449be1380 in KoDocument::slotAutoSave (this=0x30e3dd0) at /build/buildd/calligra-2.6.0/libs/main/KoDocument.cpp:475
#8  0x00007f1449be16a5 in KoDocument::qt_static_metacall (_o=0x38f5100, _c=QMetaObject::InvokeMetaMethod, _id=-988544, _a=0x7ffff1ab7080) at /build/buildd/calligra-2.6.0/obj-x86_64-linux-gnu/libs/main/KoDocument.moc:97
[...]
#10 0x00007f144806b26c in QObject::event (this=0x3616160, e=<optimized out>) at kernel/qobject.cpp:1157
#11 0x00007f1448a37e9c in QApplicationPrivate::notify_helper (this=this@entry=0x24a3070, receiver=receiver@entry=0x3616160, e=e@entry=0x7ffff1ab7780) at kernel/qapplication.cpp:4562
Comment 8 Halla Rempt 2013-02-23 10:13:18 UTC
Git commit 6b32bea8594e187fe67d585b6ebe191c187e20db by Boudewijn Rempt.
Committed on 18/02/2013 at 11:48.
Pushed by rempt into branch 'calligra/2.6'.

Try to make the autosave saver.

M  +7    -0    libs/main/KoDocument.cpp

http://commits.kde.org/calligra/6b32bea8594e187fe67d585b6ebe191c187e20db
Comment 9 Jekyll Wu 2013-03-04 05:36:03 UTC
*** Bug 314871 has been marked as a duplicate of this bug. ***
Comment 10 Jekyll Wu 2013-03-04 05:36:06 UTC
*** Bug 315267 has been marked as a duplicate of this bug. ***
Comment 11 Jekyll Wu 2013-03-04 05:38:57 UTC
*** Bug 314733 has been marked as a duplicate of this bug. ***
Comment 12 Jekyll Wu 2013-03-04 05:40:04 UTC
*** Bug 309556 has been marked as a duplicate of this bug. ***
Comment 13 Jekyll Wu 2013-03-04 05:41:40 UTC
*** Bug 312307 has been marked as a duplicate of this bug. ***
Comment 14 Halla Rempt 2013-03-10 10:28:44 UTC
Is there anyone who can reproduce the problem reliably and who can test with my patch? It's already in master and 2.6. If that isn't enough, I need to investigate again.
Comment 15 Franz Trischberger 2013-03-17 19:58:29 UTC
I had got this crash some hours ago. Managed to close drkonqi without saving the backtrace, but it was the same (slotAutoSave -> isModified).
I am running 2.6.2, so I should run with that patch enabled (also looked into the tarball to confirm).
I can't reproduce the issue. Was running one instance with several windows. Just playing around with the tablet. Opened a browser, left krita be for some minutes -> suddenly crashed.
I did not save anything ("artwork" was not intended to be kept ;)).

So I tried to "replay": Opened one instance, did some fast drawing, opened another window (CTRL+N), draw, and so on. Went to other tasks. Did not crash until now (2 hours?) :(
Comment 16 Franz Trischberger 2013-03-18 07:00:50 UTC
reproduced with words xD

Application: Calligra Words (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8cc318c780 (LWP 8585))]

Thread 2 (Thread 0x7f8cb7d6d700 (LWP 8586)):
#0  g_mutex_get_impl (mutex=0x7f8cb00009a0) at gthread-posix.c:120
#1  0x00007f8cc444ba99 in g_mutex_unlock (mutex=<optimized out>) at gthread-posix.c:229
#2  0x00007f8cc440ff1b in g_main_context_prepare (context=0x7f8cb00009a0, priority=0x7f8cb7d6cc98) at gmain.c:2984
#3  0x00007f8cc44105bb in g_main_context_iterate (dispatch=1, block=1, context=0x7f8cb00009a0, self=<optimized out>) at gmain.c:3270
#4  g_main_context_iterate (context=0x7f8cb00009a0, block=1, dispatch=1, self=<optimized out>) at gmain.c:3227
#5  0x00007f8cc44107c4 in g_main_context_iteration (context=0x7f8cb00009a0, may_block=1) at gmain.c:3351
#6  0x00007f8cc7ccd256 in QEventDispatcherGlib::processEvents (this=0x7f8cb00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0x00007f8cc7c9d6b2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#8  0x00007f8cc7c9d907 in QEventLoop::exec (this=0x7f8cb7d6cdb0, flags=...) at kernel/qeventloop.cpp:204
#9  0x00007f8cc7b9db57 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#10 0x00007f8cc7c7d83f in QInotifyFileSystemWatcherEngine::run (this=0x1956090) at io/qfilesystemwatcher_inotify.cpp:256
#11 0x00007f8cc7ba0bbc in QThreadPrivate::start (arg=0x1956090) at thread/qthread_unix.cpp:338
#12 0x00007f8cc790fec6 in start_thread () from /lib64/libpthread.so.0
#13 0x00007f8cc68836ed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f8cc318c780 (LWP 8585)):
[KCrash Handler]
#6  0x00007f8cc09241d4 in KParts::ReadWritePart::isModified (this=0x1a04580) at /var/tmp/paludis/kde-base-kdelibs-4.10.1/work/kdelibs-4.10.1/kparts/part.cpp:1031
#7  0x00007f8cbc15703e in KoDocument::slotAutoSave (this=0x19a0670) at /var/tmp/paludis/app-office-calligra-2.6.2/work/calligra-2.6.2/libs/main/KoDocument.cpp:481
#8  0x00007f8cbc1573b5 in KoDocument::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /var/tmp/paludis/app-office-calligra-2.6.2/work/calligra-2.6.2_build/libs/main/KoDocument.moc:97
#9  0x00007f8cc7cb25b9 in QMetaObject::activate (sender=0x19a9120, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#10 0x00007f8cc7cb7469 in QObject::event (this=0x19a9120, e=<optimized out>) at kernel/qobject.cpp:1156
#11 0x00007f8cc7011fd4 in notify_helper (e=0x7fff82475980, receiver=0x19a9120, this=0x1403880) at kernel/qapplication.cpp:4562
#12 QApplicationPrivate::notify_helper (this=0x1403880, receiver=0x19a9120, e=0x7fff82475980) at kernel/qapplication.cpp:4534
#13 0x00007f8cc7017691 in QApplication::notify (this=0x7fff82475c30, receiver=0x19a9120, e=0x7fff82475980) at kernel/qapplication.cpp:3944
#14 0x00007f8cbc14677e in KoApplication::notify (this=<optimized out>, receiver=0x19a9120, event=0x7fff82475980) at /var/tmp/paludis/app-office-calligra-2.6.2/work/calligra-2.6.2/libs/main/KoApplication.cpp:522
#15 0x00007f8cc7c9eb4c in QCoreApplication::notifyInternal (this=0x7fff82475c30, receiver=0x19a9120, event=0x7fff82475980) at kernel/qcoreapplication.cpp:946
#16 0x00007f8cc7ccf132 in sendEvent (event=0x7fff82475980, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#17 QTimerInfoList::activateTimers (this=0x1405790) at kernel/qeventdispatcher_unix.cpp:622
#18 0x00007f8cc7ccca4d in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#19 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#20 0x00007f8cc7ccca71 in idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:233
#21 0x00007f8cc44103b3 in g_main_dispatch (context=0x1404d00) at gmain.c:2715
#22 g_main_context_dispatch (context=0x1404d00) at gmain.c:3219
#23 0x00007f8cc4410700 in g_main_context_iterate (dispatch=1, block=<optimized out>, context=0x1404d00, self=<optimized out>) at gmain.c:3290
#24 g_main_context_iterate (context=0x1404d00, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3227
#25 0x00007f8cc44107c4 in g_main_context_iteration (context=0x1404d00, may_block=1) at gmain.c:3351
#26 0x00007f8cc7ccd1ef in QEventDispatcherGlib::processEvents (this=0x12747d0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#27 0x00007f8cc70b3e7e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007f8cc7c9d6b2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#29 0x00007f8cc7c9d907 in QEventLoop::exec (this=0x7fff82475bf0, flags=...) at kernel/qeventloop.cpp:204
#30 0x00007f8cc7ca25f5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#31 0x00007f8cc87952f5 in kdemain (argc=<optimized out>, argv=0x12747b0) at /var/tmp/paludis/app-office-calligra-2.6.2/work/calligra-2.6.2/words/part/main.cpp:43
#32 0x0000000000406f84 in launch (argc=1, _name=0x12fa968 "/usr/bin/calligrawords", args=<optimized out>, cwd=0x0, envc=<optimized out>, envs=<optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x12fa99a "desktop_franz;1363589297;986849;2519_TIME4205514") at /var/tmp/paludis/kde-base-kdelibs-4.10.1/work/kdelibs-4.10.1/kinit/kinit.cpp:726
#33 0x0000000000408056 in handle_launcher_request (sock=7, who=<optimized out>) at /var/tmp/paludis/kde-base-kdelibs-4.10.1/work/kdelibs-4.10.1/kinit/kinit.cpp:1218
#34 0x0000000000408593 in handle_requests (waitForPid=0) at /var/tmp/paludis/kde-base-kdelibs-4.10.1/work/kdelibs-4.10.1/kinit/kinit.cpp:1411
#35 0x000000000040951e in main (argc=2, argv=0x7fff824769d0, envp=0x7fff82476ca0) at /var/tmp/paludis/kde-base-kdelibs-4.10.1/work/kdelibs-4.10.1/kinit/kinit.cpp:1899

1) start words
2) open an empty document - do not modify it!
3) double click (!) "new document" action.
Make sure you get *2* windows! If not -> goto 2)
4) Select the window with "words <2>" in the title!
Modify it
5) close the other window (the one that was opened first)
6) wait....
-> crash

IMHO there seems to be something wrong with the parent KPart.

(Background:
Krita crashed yesterday after I gave the pencil to a friend. He wanted to create a new document, moved the pen to "new" but managed to not click "strong" - the tablet produced many clicks, which lead to many "new document" screens. I closed them and in the next autosave cycle krita crashed.)

// sidenote:
In this moment sheets crashed with exactly the same backtrace :)
Comment 17 Franz Trischberger 2013-03-18 09:47:55 UTC
The steps mentioned above don't work as easily with krita (does krita delay creation of document until first modification?)
But it seems to work at least sometimes.
Instead of immediately closing the first window one needs to modify it, modify the other images and at a certain point go to the first window, undo all steps and then close it. But this seems to be not enough. One thing I THINK I realised when krita crashed was that I had windows with the "new image" screen with an already closed parent window open.

I really tried hard to find a way to reproduce those crashes with krita, but to this point without success :(
Nevertheless I think it's caused by the same buggy code path that also crashes words and sheets - and those are perfectly reproducable with 100% success guaranty ;)
Comment 18 Halla Rempt 2013-03-18 09:51:37 UTC
That sounds likely. I'm trying to reproduce with words now.
Comment 19 Halla Rempt 2013-03-27 08:50:39 UTC
*** Bug 317416 has been marked as a duplicate of this bug. ***
Comment 20 Franz Trischberger 2013-03-27 09:06:33 UTC
Boudewijn:
It seems to be easier to imediately hit this with a higher autosave timeout, e.g. 3 minutes instead of only 1.
A probably easier way is:
* open words
* create an empty document
* double click new
* <Alt+Tab> to switch to to the first window + close tha
* in the second window -> create empty document.

Immediatley crashed here (with 2min autosave timer) 4 times out of 5 tries, the 4th crashed 2 minutes later.
You probably need to be fast to get the problematic setup before the first autosave cycle hits you (it's NOT 2 minutes - just watch "ls -a ~ | grep od" while creating a new document + modifying it).

If you need assistance (testing patches, debugging, etc.) just call me :)
Comment 21 Halla Rempt 2013-04-02 07:28:03 UTC
This is still happening for lots of people.
Comment 22 Halla Rempt 2013-04-02 07:28:13 UTC
*** Bug 317704 has been marked as a duplicate of this bug. ***
Comment 23 Halla Rempt 2013-04-09 17:44:35 UTC
*** Bug 317945 has been marked as a duplicate of this bug. ***
Comment 24 Christoph Feck 2013-04-11 22:33:01 UTC
*** Bug 318207 has been marked as a duplicate of this bug. ***
Comment 25 Jekyll Wu 2013-04-18 09:59:05 UTC
*** Bug 317738 has been marked as a duplicate of this bug. ***
Comment 26 Jekyll Wu 2013-04-18 09:59:36 UTC
*** Bug 318409 has been marked as a duplicate of this bug. ***
Comment 27 ronald guest 2013-04-19 21:11:45 UTC
On 04/18/2013 04:59 AM, Jekyll Wu wrote:
> Jekyll Wu <mailto:adaptee@gmail.com> changed bug 310310
> <https://bugs.kde.org/show_bug.cgi?id=310310>
> What 	Removed 	Added
> CC 		valenstyn@gmail.com
>
> *Comment # 26 <https://bugs.kde.org/show_bug.cgi?id=310310#c26> on bug
> 310310 <https://bugs.kde.org/show_bug.cgi?id=310310> from Jekyll Wu
> <mailto:adaptee@gmail.com> *
>
> ***Bug 318409  <show_bug.cgi?id=318409>  has been marked as a duplicate of this bug. ***
>
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You are on the CC list for the bug.
>
Thanks for you replies.  I deleted the programs then downloaded them 
again.  This was done with the thought of the fixes would be included in 
the downloads or their updates.
You are most kind to take your time and fix attention on my problem. 
Thank you very much.

Ronald
Comment 28 Halla Rempt 2013-04-28 19:49:20 UTC
Created attachment 79520 [details]
autosave patch
Comment 29 Halla Rempt 2013-04-29 10:47:05 UTC
Git commit c9cb24a2585522f77690f309125e1b03c2b6cee4 by Boudewijn Rempt.
Committed on 29/04/2013 at 11:30.
Pushed by rempt into branch 'master'.

Guart the part pointer with QPointer, like the document pointer

M  +1    -1    libs/main/KoView.cpp

http://commits.kde.org/calligra/c9cb24a2585522f77690f309125e1b03c2b6cee4
Comment 30 Halla Rempt 2013-04-29 10:47:05 UTC
Git commit c6844960e658f50c63265c366b94e020aa1e4272 by Boudewijn Rempt.
Committed on 29/04/2013 at 12:44.
Pushed by rempt into branch 'master'.

Try to make the parts/document relation more robust in Krita

M  +2    -7    krita/benchmarks/kis_projection_benchmark.cpp
M  +1    -3    krita/plugins/extensions/dockers/defaultdockers/kis_drop_button.cpp
M  +1    -4    krita/plugins/extensions/imagesplit/imagesplit.cpp
M  +1    -4    krita/plugins/extensions/separate_channels/kis_channel_separator.cc
M  +1    -4    krita/plugins/filters/fastcolortransfer/kis_wdg_fastcolortransfer.cpp
M  +1    -0    krita/plugins/formats/flipbook/kis_flipbook_import.cpp
M  +1    -4    krita/sdk/tests/filestest.h
M  +5    -8    krita/sdk/tests/ui_manager_test.h
M  +5    -9    krita/ui/actions/kis_selection_action_factories.cpp
M  +7    -8    krita/ui/kis_doc2.cc
M  +1    -3    krita/ui/kis_doc2.h
M  +2    -4    krita/ui/kis_factory2.cc
M  +2    -8    krita/ui/kis_file_layer.cpp
M  +0    -1    krita/ui/kis_file_layer.h
M  +1    -5    krita/ui/kis_flipbook_item.cpp
M  +1    -5    krita/ui/kis_import_catcher.cc
M  +1    -5    krita/ui/kis_layer_manager.cc
M  +1    -4    krita/ui/kis_mimedata.cpp
M  +1    -3    krita/ui/kis_node_manager.cpp
M  +1    -0    krita/ui/kis_part2.cpp
M  +1    -0    krita/ui/kis_part2.h
M  +0    -1    krita/ui/kis_selection_manager.cc
M  +9    -16   krita/ui/kis_view2.cpp
M  +1    -2    krita/ui/kis_view2.h
M  +2    -0    krita/ui/tests/kis_action_manager_test.cpp
M  +1    -3    krita/ui/tests/kis_doc2_test.cpp
M  +1    -4    krita/ui/tests/kis_kra_loader_test.cpp
M  +2    -12   krita/ui/tests/kis_kra_saver_test.cpp
M  +1    -4    krita/ui/tests/kis_node_model_test.cpp
M  +1    -5    krita/ui/tests/kis_shape_controller_test.cpp
M  +3    -3    krita/ui/tests/kis_zoom_and_pan_test.cpp
M  +2    -9    krita/ui/tests/util.h

http://commits.kde.org/calligra/c6844960e658f50c63265c366b94e020aa1e4272
Comment 31 Halla Rempt 2013-04-29 10:48:00 UTC
Meh... I have been able to reproduce _once_ -- and lost some real work for I had a day off and used Krita to paint. I've been trying to make the system more solid in any case. Could anyone who compiled git master and can reproduce this bug better than me give current git master  a try?
Comment 32 Franz Trischberger 2013-05-05 08:47:48 UTC
I tried quite hard to crash words with current master, but did not succeed, so it looks like this issue got fixed by your recent commits. Before those tests with master I made sure I can still make it (2.6.3) crash, and both - words and krita - died on the first attempt.
Comment 33 Jekyll Wu 2013-05-06 02:11:02 UTC
*** Bug 319380 has been marked as a duplicate of this bug. ***
Comment 34 Halla Rempt 2013-05-06 09:37:41 UTC
Hi Franz!

Thanks so much for testing, this gives me confidence for the 2.7 release :-)
Comment 35 Jekyll Wu 2013-05-07 02:59:37 UTC
*** Bug 319439 has been marked as a duplicate of this bug. ***
Comment 36 Jekyll Wu 2013-05-07 02:59:55 UTC
*** Bug 317086 has been marked as a duplicate of this bug. ***
Comment 37 Siddharth 2013-05-17 07:15:25 UTC
Git commit 52df6fb6115b861729f785cf7b2e63f4e7f6bf71 by Siddharth Sharma, on behalf of Boudewijn Rempt.
Committed on 29/04/2013 at 11:30.
Pushed by siddharthsharma into branch 'krita-psd-plugin-siddharth'.

Guart the part pointer with QPointer, like the document pointer

M  +1    -1    libs/main/KoView.cpp

http://commits.kde.org/calligra/52df6fb6115b861729f785cf7b2e63f4e7f6bf71
Comment 38 Siddharth 2013-05-17 07:15:25 UTC
Git commit 5ac2f4a0cf6afabb215b37af2115fa58dc41cce1 by Siddharth Sharma, on behalf of Boudewijn Rempt.
Committed on 29/04/2013 at 12:44.
Pushed by siddharthsharma into branch 'krita-psd-plugin-siddharth'.

Try to make the parts/document relation more robust in Krita

M  +2    -7    krita/benchmarks/kis_projection_benchmark.cpp
M  +1    -3    krita/plugins/extensions/dockers/defaultdockers/kis_drop_button.cpp
M  +1    -4    krita/plugins/extensions/imagesplit/imagesplit.cpp
M  +1    -4    krita/plugins/extensions/separate_channels/kis_channel_separator.cc
M  +1    -4    krita/plugins/filters/fastcolortransfer/kis_wdg_fastcolortransfer.cpp
M  +1    -0    krita/plugins/formats/flipbook/kis_flipbook_import.cpp
M  +1    -4    krita/sdk/tests/filestest.h
M  +5    -8    krita/sdk/tests/ui_manager_test.h
M  +5    -9    krita/ui/actions/kis_selection_action_factories.cpp
M  +7    -8    krita/ui/kis_doc2.cc
M  +1    -3    krita/ui/kis_doc2.h
M  +2    -4    krita/ui/kis_factory2.cc
M  +2    -8    krita/ui/kis_file_layer.cpp
M  +0    -1    krita/ui/kis_file_layer.h
M  +1    -5    krita/ui/kis_flipbook_item.cpp
M  +1    -5    krita/ui/kis_import_catcher.cc
M  +1    -5    krita/ui/kis_layer_manager.cc
M  +1    -4    krita/ui/kis_mimedata.cpp
M  +1    -3    krita/ui/kis_node_manager.cpp
M  +1    -0    krita/ui/kis_part2.cpp
M  +1    -0    krita/ui/kis_part2.h
M  +0    -1    krita/ui/kis_selection_manager.cc
M  +9    -16   krita/ui/kis_view2.cpp
M  +1    -2    krita/ui/kis_view2.h
M  +2    -0    krita/ui/tests/kis_action_manager_test.cpp
M  +1    -3    krita/ui/tests/kis_doc2_test.cpp
M  +1    -4    krita/ui/tests/kis_kra_loader_test.cpp
M  +2    -12   krita/ui/tests/kis_kra_saver_test.cpp
M  +1    -4    krita/ui/tests/kis_node_model_test.cpp
M  +1    -5    krita/ui/tests/kis_shape_controller_test.cpp
M  +3    -3    krita/ui/tests/kis_zoom_and_pan_test.cpp
M  +2    -9    krita/ui/tests/util.h

http://commits.kde.org/calligra/5ac2f4a0cf6afabb215b37af2115fa58dc41cce1
Comment 39 Jekyll Wu 2013-05-17 11:54:43 UTC
*** Bug 319938 has been marked as a duplicate of this bug. ***
Comment 40 Jekyll Wu 2013-05-25 16:55:09 UTC
*** Bug 320268 has been marked as a duplicate of this bug. ***
Comment 41 Smittie 2013-05-26 18:34:56 UTC
Created attachment 80096 [details]
New crash information added by DrKonqi

krita (2.6.3) on KDE Platform 4.10.2 using Qt 4.8.4

- What I was doing when the application crashed:

This is 100% reproducible on my system. Krita crashes after about 10 minutes whenever it is open, rendering Krita almost unusable. There is some indication that this is related to auto-save which I am going to try. I am happy to provide additional information or refile this as a separate bug if anyone feels it is not related.

-- Backtrace (Reduced):
#6  0x00007f71216b7834 in KParts::ReadWritePart::isModified (this=0x132d5b0) at ../../kparts/part.cpp:1031
#7  0x00007f71238f01e0 in KoDocument::isModified (this=this@entry=0x133b690) at /build/buildd/calligra-2.6.3/libs/main/KoDocument.cpp:556
#8  0x00007f71238f57cd in KoDocument::slotAutoSave (this=0x133b690) at /build/buildd/calligra-2.6.3/libs/main/KoDocument.cpp:481
#9  0x00007f71238f5b05 in KoDocument::qt_static_metacall (_o=0x132d5b0, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x7fffbce711f0) at /build/buildd/calligra-2.6.3/obj-x86_64-linux-gnu/libs/main/KoDocument.moc:97
[...]
#11 0x00007f7121d7c3ec in QObject::event (this=0x133ba10, e=<optimized out>) at kernel/qobject.cpp:1156
Comment 42 Smittie 2013-05-26 18:58:12 UTC
Created attachment 80097 [details]
New crash information added by DrKonqi

krita (2.6.3) on KDE Platform 4.10.2 using Qt 4.8.4

- What I was doing when the application crashed:

Editing a jpeg in a document with two layers. Auto-save was turned off. Wacom tablet was attached. Additional information gladly supplied upon request.

-- Backtrace (Reduced):
#6  0x00007fe118ebb834 in KParts::ReadWritePart::isModified (this=0x2ad9030) at ../../kparts/part.cpp:1031
#7  0x00007fe11b0f41e0 in KoDocument::isModified (this=this@entry=0x2acf800) at /build/buildd/calligra-2.6.3/libs/main/KoDocument.cpp:556
#8  0x00007fe11b0f97cd in KoDocument::slotAutoSave (this=0x2acf800) at /build/buildd/calligra-2.6.3/libs/main/KoDocument.cpp:481
#9  0x00007fe11b0f9b05 in KoDocument::qt_static_metacall (_o=0x2ad9030, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x7fff5302d9d0) at /build/buildd/calligra-2.6.3/obj-x86_64-linux-gnu/libs/main/KoDocument.moc:97
[...]
#11 0x00007fe1195803ec in QObject::event (this=0x2acfb80, e=<optimized out>) at kernel/qobject.cpp:1156
Comment 43 Jekyll Wu 2013-06-04 01:45:49 UTC
*** Bug 320684 has been marked as a duplicate of this bug. ***
Comment 44 Jekyll Wu 2013-06-04 01:45:52 UTC
*** Bug 320683 has been marked as a duplicate of this bug. ***
Comment 45 Jekyll Wu 2013-06-16 15:20:03 UTC
*** Bug 321221 has been marked as a duplicate of this bug. ***
Comment 46 Jekyll Wu 2013-06-27 15:25:27 UTC
*** Bug 321677 has been marked as a duplicate of this bug. ***
Comment 47 Jekyll Wu 2013-07-26 23:31:14 UTC
*** Bug 322864 has been marked as a duplicate of this bug. ***
Comment 48 Friedrich W. H. Kossebau 2013-07-28 15:53:32 UTC
*** Bug 322911 has been marked as a duplicate of this bug. ***
Comment 49 Jekyll Wu 2013-07-29 00:53:39 UTC
*** Bug 322924 has been marked as a duplicate of this bug. ***
Comment 50 Friedrich W. H. Kossebau 2013-08-20 22:01:41 UTC
*** Bug 323809 has been marked as a duplicate of this bug. ***
Comment 51 Halla Rempt 2013-12-12 15:51:18 UTC
Fixed in 2.8.
Comment 52 Jekyll Wu 2014-03-18 21:20:47 UTC
*** Bug 332285 has been marked as a duplicate of this bug. ***