Bug 323809 - A failure occured while the Calligra Plan Handbook was being reviewed for assistance in "load levelling" in project management.
Summary: A failure occured while the Calligra Plan Handbook was being reviewed for ass...
Status: RESOLVED DUPLICATE of bug 310310
Alias: None
Product: calligraplan
Classification: Applications
Component: general (show other bugs)
Version: 2.5.5
Platform: Kubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Friedrich W. H. Kossebau
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-20 21:54 UTC by K. A. Sayeed
Modified: 2013-08-20 22:01 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description K. A. Sayeed 2013-08-20 21:54:16 UTC
Application: calligraplan (2.6.3)
KDE Platform Version: 4.10.5
Qt Version: 4.8.4
Operating System: Linux 3.8.0-26-generic x86_64
Distribution: Ubuntu 13.04

-- Information about the crash:
- What I was doing when the application crashed:

1. The Calligra Plan Handbook was being reviewed for assistance in "load levelling".

-- Backtrace:
Application: Plan (calligraplan), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fc334b577c0 (LWP 3930))]

Thread 3 (Thread 0x7fc31788f700 (LWP 3931)):
#0  0x00007fc3344993cd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fc32e6631dc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc32e663304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc332b3a036 in QEventDispatcherGlib::processEvents (this=0x7fc3100008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fc332b0a38f in QEventLoop::processEvents (this=this@entry=0x7fc31788ed90, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fc332b0a618 in QEventLoop::exec (this=this@entry=0x7fc31788ed90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fc332a0c410 in QThread::exec (this=this@entry=0x22d6070) at thread/qthread.cpp:542
#7  0x00007fc332aebedf in QInotifyFileSystemWatcherEngine::run (this=0x22d6070) at io/qfilesystemwatcher_inotify.cpp:256
#8  0x00007fc332a0ebec in QThreadPrivate::start (arg=0x22d6070) at thread/qthread_unix.cpp:338
#9  0x00007fc32eb35f8e in start_thread (arg=0x7fc31788f700) at pthread_create.c:311
#10 0x00007fc3344a5e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7fc3160f5700 (LWP 3935)):
#0  0x00007fc3344993cd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fc32e6631dc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fc32e663304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fc332b3a036 in QEventDispatcherGlib::processEvents (this=0x7fc3080008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fc332b0a38f in QEventLoop::processEvents (this=this@entry=0x7fc3160f4d90, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fc332b0a618 in QEventLoop::exec (this=this@entry=0x7fc3160f4d90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fc332a0c410 in QThread::exec (this=this@entry=0x2548100) at thread/qthread.cpp:542
#7  0x00007fc332aebedf in QInotifyFileSystemWatcherEngine::run (this=0x2548100) at io/qfilesystemwatcher_inotify.cpp:256
#8  0x00007fc332a0ebec in QThreadPrivate::start (arg=0x2548100) at thread/qthread_unix.cpp:338
#9  0x00007fc32eb35f8e in start_thread (arg=0x7fc3160f5700) at pthread_create.c:311
#10 0x00007fc3344a5e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7fc334b577c0 (LWP 3930)):
[KCrash Handler]
#6  0x00007fc332460834 in KParts::ReadWritePart::isModified (this=0x266a3c0) at ../../kparts/part.cpp:1031
#7  0x00007fc3340531e0 in KoDocument::isModified (this=this@entry=0x266ada0) at /build/buildd/calligra-2.6.3/libs/main/KoDocument.cpp:556
#8  0x00007fc3340587cd in KoDocument::slotAutoSave (this=0x266ada0) at /build/buildd/calligra-2.6.3/libs/main/KoDocument.cpp:481
#9  0x00007fc334058b05 in KoDocument::qt_static_metacall (_o=0x266a3c0, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x7fff7c927f60) at /build/buildd/calligra-2.6.3/obj-x86_64-linux-gnu/libs/main/KoDocument.moc:97
#10 0x00007fc332b200ef in QMetaObject::activate (sender=0x2661b70, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#11 0x00007fc332b253ec in QObject::event (this=0x2661b70, e=<optimized out>) at kernel/qobject.cpp:1156
#12 0x00007fc3334f58ec in QApplicationPrivate::notify_helper (this=this@entry=0x1f3b290, receiver=receiver@entry=0x2661b70, e=e@entry=0x7fff7c928660) at kernel/qapplication.cpp:4567
#13 0x00007fc3334f825b in QApplication::notify (this=0x7fff7c928960, receiver=receiver@entry=0x2661b70, e=e@entry=0x7fff7c928660) at kernel/qapplication.cpp:4428
#14 0x00007fc33404ad98 in KoApplication::notify (this=<optimized out>, receiver=0x2661b70, event=0x7fff7c928660) at /build/buildd/calligra-2.6.3/libs/main/KoApplication.cpp:528
#15 0x00007fc332b0b63e in QCoreApplication::notifyInternal (this=0x7fff7c928960, receiver=0x2661b70, event=event@entry=0x7fff7c928660) at kernel/qcoreapplication.cpp:946
#16 0x00007fc332b3cb72 in sendEvent (event=0x7fff7c928660, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#17 QTimerInfoList::activateTimers (this=0x1f36fb0) at kernel/qeventdispatcher_unix.cpp:622
#18 0x00007fc332b399a4 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#19 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#20 0x00007fc332b399c1 in idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:233
#21 0x00007fc32e662f05 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fc32e663248 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fc32e663304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fc332b3a016 in QEventDispatcherGlib::processEvents (this=0x1ea0b30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0x00007fc33359b1ae in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00007fc332b0a38f in QEventLoop::processEvents (this=this@entry=0x7fff7c9288e0, flags=...) at kernel/qeventloop.cpp:149
#27 0x00007fc332b0a618 in QEventLoop::exec (this=this@entry=0x7fff7c9288e0, flags=...) at kernel/qeventloop.cpp:204
#28 0x00007fc332b0fcf6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#29 0x00007fc3334f3ffc in QApplication::exec () at kernel/qapplication.cpp:3828
#30 0x00007fc334775845 in kdemain (argc=<optimized out>, argv=0x7fff7c928a78) at /build/buildd/calligra-2.6.3/plan/main.cpp:41
#31 0x00007fc3343cdea5 in __libc_start_main (main=0x4006d0 <main(int, char**)>, argc=1, ubp_av=0x7fff7c928a78, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff7c928a68) at libc-start.c:260
#32 0x0000000000400701 in _start ()

Possible duplicates by query: bug 322911.

Report to https://bugs.kde.org/

Reproducible: Sometimes

Steps to Reproduce:
1. Start Calligra Plan
2. Open the Plan Handbook
3. Search the Plan Handbook for information
Actual Results:  
1. Calligra Plan fails sometimes.

Expected Results:  
1. No failure.

1. The hardware included a quad processor Asus mother board with 4.0 GB or memory.
2. The OS was Kubuntu 13.04.
Comment 1 Friedrich W. H. Kossebau 2013-08-20 22:01:41 UTC
Thanks for your report!
This is a known bug that plagues all of Calligra :-( and which so far could not be located, as it only happens for a few, but not for developers. Somewhere on autosave it crashes sometimes for whatever reason.

Looks like things are better with the new version 2.7.x, so please update as soon as possible and continue reporting any issues.

*** This bug has been marked as a duplicate of bug 310310 ***