Bug 312307 - Akonadi Nepomuk Feeder crashes while running in the background
Summary: Akonadi Nepomuk Feeder crashes while running in the background
Status: RESOLVED DUPLICATE of bug 310310
Alias: None
Product: calligracommon
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Calligra Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-28 15:21 UTC by Andreas Hencke
Modified: 2013-03-04 05:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Hencke 2012-12-28 15:21:19 UTC
Application: akonadi_nepomuk_feeder (4.9)
KDE Platform Version: 4.9.4
Qt Version: 4.8.3
Operating System: Linux 3.5.0-21-generic i686
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed:
I'm just testing projekt Neon with KDE4.10 and configuring kontact when akonadi nepomuk feeder crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: Akonadi Nepomuk Feeder (akonadi_nepomuk_feeder), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#7  0xb21b0d55 in KParts::ReadWritePart::isModified (this=0x8aa2288) at /build/buildd/project-neon-kdelibs-2+git20121227+r92281/kparts/part.cpp:1031
#8  0xb164fb5c in KoDocument::isModified (this=0x8aa40b8) at /build/buildd/project-neon-calligra-2+git20121228+r73401/libs/main/KoDocument.cpp:549
#9  0xb164f5b1 in KoDocument::slotAutoSave (this=0x8aa40b8) at /build/buildd/project-neon-calligra-2+git20121228+r73401/libs/main/KoDocument.cpp:475
#10 0xb165b2ac in KoDocument::qt_static_metacall (_o=0x8aa40b8, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xbfa7e69c) at /build/buildd/project-neon-calligra-2+git20121228+r73401/obj-i686-linux-gnu/libs/main/KoDocument.moc:96
#11 0xb6b80ed6 in QMetaObject::activate (sender=0x8aa4220, m=0xb6ccd4b8 <QTimer::staticMetaObject>, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3547
#12 0xb6bd1a55 in QTimer::timeout (this=0x8aa4220) at .moc/release-shared/moc_qtimer.cpp:148
#13 0xb6b87ed6 in QTimer::timerEvent (this=0x8aa4220, e=0xbfa7ebb0) at kernel/qtimer.cpp:280
#14 0xb6b7ed34 in QObject::event (this=0x8aa4220, e=0xbfa7ebb0) at kernel/qobject.cpp:1157
#15 0xb5add39c in QApplicationPrivate::notify_helper (this=0x87c7120, receiver=0x8aa4220, e=0xbfa7ebb0) at kernel/qapplication.cpp:4562
#16 0xb5ae1daf in QApplication::notify (this=0xbfa7ebb0, receiver=0x8aa4220, e=0xbfa7ebb0) at kernel/qapplication.cpp:3944
#17 0xb73c7e91 in KApplication::notify (this=0xbfa7eee4, receiver=0x8aa4220, event=0xbfa7ebb0) at ../../kdeui/kernel/kapplication.cpp:311
#18 0xb6b6878e in QCoreApplication::notifyInternal (this=0xbfa7eee4, receiver=0x8aa4220, event=0xbfa7ebb0) at kernel/qcoreapplication.cpp:915
#19 0xb6b9d280 in sendEvent (event=0xbfa7ebb0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#20 QTimerInfoList::activateTimers (this=0x87cba7c) at kernel/qeventdispatcher_unix.cpp:611
#21 0xb6b9a308 in timerSourceDispatch (source=0x87cba48) at kernel/qeventdispatcher_glib.cpp:186
#22 timerSourceDispatch (source=0x87cba48) at kernel/qeventdispatcher_glib.cpp:180
#23 0xb6b9a342 in idleTimerSourceDispatch (source=0x87cbab0) at kernel/qeventdispatcher_glib.cpp:233
#24 0xb51629e3 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#25 0xb5162d80 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#26 0xb5162e61 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#27 0xb6b9a981 in QEventDispatcherGlib::processEvents (this=0x87a7798, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#28 0xb5b939aa in QGuiEventDispatcherGlib::processEvents (this=0x87a7798, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0xb6b6726c in QEventLoop::processEvents (this=this@entry=0xbfa7ee38, flags=...) at kernel/qeventloop.cpp:149
#30 0xb6b67561 in QEventLoop::exec (this=0xbfa7ee38, flags=...) at kernel/qeventloop.cpp:204
#31 0xb6b6ccba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#32 0xb5adafc4 in QApplication::exec () at kernel/qapplication.cpp:3823
#33 0xb6d2e071 in Akonadi::AgentBase::init (r=0x88dc0e8) at ../../akonadi/agentbase.cpp:553
#34 0x08053c06 in Akonadi::AgentBase::init<Akonadi::NepomukFeederAgent> (argc=argc@entry=3, argv=argv@entry=0xbfa7efc4) at /usr/include/akonadi/agentbase.h:343
#35 0x0804deeb in main (argc=3, argv=0xbfa7efc4) at ../../../agents/nepomukfeeder/nepomukfeederagent.cpp:408

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-03-04 02:37:15 UTC
> #7  0xb21b0d55 in KParts::ReadWritePart::isModified (this=0x8aa2288) at /build/buildd/project-neon-kdelibs-2+git20121227+r92281/kparts/part.cpp:1031
> #8  0xb164fb5c in KoDocument::isModified (this=0x8aa40b8) at /build/buildd/project-neon-calligra-2+git20121228+r73401/libs/main/KoDocument.cpp:549
> #9  0xb164f5b1 in KoDocument::slotAutoSave (this=0x8aa40b8) at /build/buildd/project-neon-calligra-2+git20121228+r73401/libs/main/KoDocument.cpp:475
> #10 0xb165b2ac in KoDocument::qt_static_metacall (_o=0x8aa40b8, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xbfa7e69c) at /build/buildd/project-neon-calligra-2+git20121228+r73401/obj-i686-linux-gnu/libs/main/KoDocument.moc:96

forward to calligra developers.
Comment 2 Jekyll Wu 2013-03-04 05:41:40 UTC

*** This bug has been marked as a duplicate of bug 310310 ***