Bug 309556 - 2.6 BETA1: Crash (segfault) when editing a task
Summary: 2.6 BETA1: Crash (segfault) when editing a task
Status: RESOLVED DUPLICATE of bug 310310
Alias: None
Product: calligraplan
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR critical (vote)
Target Milestone: ---
Assignee: Dag Andersen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-04 21:10 UTC by sombragris
Modified: 2013-03-04 05:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sombragris 2012-11-04 21:10:11 UTC
The program crashes when editing a task in Plan. There was no specific action that triggered this. It just crashed. 

Backtrace:
Application: Plan (calligraplan), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f724bc6b7c0 (LWP 17708))]

Thread 2 (Thread 0x7f722cc87700 (LWP 17709)):
#0  0x00007f723d9f8565 in ?? () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f723d9f87b9 in g_mutex_lock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f723d9bc749 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f723d9bce2b in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f723d9bd024 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f7245e24c36 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt/lib/libQtCore.so.4
#6  0x00007f7245df580f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt/lib/libQtCore.so.4
#7  0x00007f7245df5a98 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt/lib/libQtCore.so.4
#8  0x00007f7245cf9230 in QThread::exec() () from /usr/lib64/qt/lib/libQtCore.so.4
#9  0x00007f7245dd63cf in ?? () from /usr/lib64/qt/lib/libQtCore.so.4
#10 0x00007f7245cfc17b in ?? () from /usr/lib64/qt/lib/libQtCore.so.4
#11 0x00007f7245a5beae in start_thread () from /lib64/libpthread.so.0
#12 0x00007f7244cf8fed in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f724bc6b7c0 (LWP 17708)):
[KCrash Handler]
#5  0x00007f724aa7afe4 in KParts::ReadWritePart::isModified() const () from /usr/lib64/libkparts.so.4
#6  0x00007f724b558150 in KoDocument::slotAutoSave() () from /usr/lib64/libkomain.so.11
#7  0x00007f724b558495 in ?? () from /usr/lib64/libkomain.so.11
#8  0x00007f7245e0bebf in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/qt/lib/libQtCore.so.4
#9  0x00007f7245e0b1cc in QObject::event(QEvent*) () from /usr/lib64/qt/lib/libQtCore.so.4
#10 0x00007f7246a7ef5c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt/lib/libQtGui.so.4
#11 0x00007f7246a833da in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt/lib/libQtGui.so.4
#12 0x00007f724b548888 in KoApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkomain.so.11
#13 0x00007f7245df6abe in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt/lib/libQtCore.so.4
#14 0x00007f7245e273b2 in ?? () from /usr/lib64/qt/lib/libQtCore.so.4
#15 0x00007f7245e245b4 in ?? () from /usr/lib64/qt/lib/libQtCore.so.4
#16 0x00007f7245e245d1 in ?? () from /usr/lib64/qt/lib/libQtCore.so.4
#17 0x00007f723d9bcc35 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#18 0x00007f723d9bcf68 in ?? () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f723d9bd024 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#20 0x00007f7245e24c16 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt/lib/libQtCore.so.4
#21 0x00007f7246b1f06e in ?? () from /usr/lib64/qt/lib/libQtGui.so.4
#22 0x00007f7245df580f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt/lib/libQtCore.so.4
#23 0x00007f7245df5a98 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt/lib/libQtCore.so.4
#24 0x00007f7245dfa738 in QCoreApplication::exec() () from /usr/lib64/qt/lib/libQtCore.so.4
#25 0x00007f724b8aca55 in kdemain () from /usr/lib64/libkdeinit4_calligraplan.so
#26 0x00007f7244c24a95 in __libc_start_main () from /lib64/libc.so.6
#27 0x0000000000400901 in _start ()


Reproducible: Always

Steps to Reproduce:
1. Open Plan wih a file.
2. Edit a task; have the edit dialog open.
3. After some time, the program spontaneously crashes.
Actual Results:  
The program crashed

Expected Results:  
The program should not crash ;)
Comment 1 sombragris 2012-11-04 21:10:41 UTC
Forgot to specify version: 2.6 Beta1
Comment 2 Dag Andersen 2012-11-06 07:58:49 UTC
Up front this looks like misconfigured system because this is common code to all calligra apps that has been around for a long time and it has been run countless times by anybody that makes a change to a calligra document.
I cannot reporduce this on ubuntu 12.10.

So are you certain that your system and AlienBobs packages fit together?
(From the backtrace, it seems to be a mismatch between calligralibs and kdelibs)
Could you check if other slackware users with same settup as you can test also?

That said, it is always possible there is a bug somewhere in plan or other parts of calligra that triggers this, but I would be gratefull if you would check the two thing above first.
Comment 3 sombragris 2012-11-06 11:01:47 UTC
Hi Dag, thanks.

As for your questions:

1. I'm certain that the packages are fine.

2. I don't know. I may be the only Slack user testing 2.6 Beta.

However, you may have a point. Some months ago I was bitten by a bug that showed itself in okular. After a lot of  crashes, hangouts, etc... we couldn't locate the source. Finally, it turned out it was a very subtle bug in Slackware's shipped version of gam-server. 

Right now, I see the bug only with 2.6 Beta, and not with the latest Slackware's 2.4.x shipped version. However, this might be exposing another subtle bug in the system. Who knows... I'll try to keep my eyes open.

Thanks!
Comment 4 Camilla Boemann 2012-11-06 12:29:33 UTC
kodocument::isModfied access parentPart and if that hasn't been set up for some reason it might crash - that said i find it weird that dag can't see the bug too if that is the case

i've not tried myself
Comment 5 Jekyll Wu 2013-03-04 05:40:04 UTC

*** This bug has been marked as a duplicate of bug 310310 ***