Bug 314871 - Karbon crash while moving object
Summary: Karbon crash while moving object
Status: RESOLVED DUPLICATE of bug 310310
Alias: None
Product: karbon
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Jan Hambrecht
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-11 06:45 UTC by RussianNeuroMancer
Modified: 2013-03-04 05:36 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description RussianNeuroMancer 2013-02-11 06:45:35 UTC
Application: karbon (2.6.0)
KDE Platform Version: 4.10.00
Qt Version: 4.8.3
Operating System: Linux 3.5.0-23-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed:

Karbon crash while just moving object over the list. (That was one of default objects that I throw at the list to just look what types of objects is available in Karbon.)

-- Backtrace:
Application: Karbon (karbon), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f3adc54c7c0 (LWP 10344))]

Thread 3 (Thread 0x7f3abf77f700 (LWP 10345)):
#0  0x00007f3ad55f5f69 in __pthread_mutex_lock (mutex=0x7f3ab8000a90) at pthread_mutex_lock.c:92
#1  0x00007f3ad4d69e21 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f3ad4d2c996 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f3ad4d2cde8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f3ad4d2cea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f3adaf45c16 in QEventDispatcherGlib::processEvents (this=0x7f3ab80008f0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f3adaf162bf in QEventLoop::processEvents (this=this@entry=0x7f3abf77ecd0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f3adaf16548 in QEventLoop::exec (this=0x7f3abf77ecd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f3adae17b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f3adaef69af in QInotifyFileSystemWatcherEngine::run (this=0x10a7900) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f3adae1aaec in QThreadPrivate::start (arg=0x10a7900) at thread/qthread_unix.cpp:338
#11 0x00007f3acf0633a4 in ?? () from /usr/lib/nvidia-310/libGL.so.1
#12 0x00007f3ad55f3e9a in start_thread (arg=0x7f3abf77f700) at pthread_create.c:308
#13 0x00007f3adbe61cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#14 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f3abdc8a700 (LWP 10349)):
#0  0x00007f3adbe56303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f3ad4d2cd84 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f3ad4d2cea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f3adaf45c16 in QEventDispatcherGlib::processEvents (this=0x7f3ab00008f0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f3adaf162bf in QEventLoop::processEvents (this=this@entry=0x7f3abdc89cd0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f3adaf16548 in QEventLoop::exec (this=0x7f3abdc89cd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f3adae17b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f3adaef69af in QInotifyFileSystemWatcherEngine::run (this=0xc0ce20) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f3adae1aaec in QThreadPrivate::start (arg=0xc0ce20) at thread/qthread_unix.cpp:338
#9  0x00007f3acf0633a4 in ?? () from /usr/lib/nvidia-310/libGL.so.1
#10 0x00007f3ad55f3e9a in start_thread (arg=0x7f3abdc8a700) at pthread_create.c:308
#11 0x00007f3adbe61cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f3adc54c7c0 (LWP 10344)):
[KCrash Handler]
#6  0x00007f3ad9a106a4 in KParts::ReadWritePart::isModified (this=0x4d138c0) at ../../kparts/part.cpp:1031
#7  0x00007f3adb7af380 in KoDocument::slotAutoSave (this=0x34ad3e0) at /build/buildd/calligra-2.6.0/libs/main/KoDocument.cpp:475
#8  0x00007f3adb7af6a5 in KoDocument::qt_static_metacall (_o=0x4d138c0, _c=QMetaObject::InvokeMetaMethod, _id=-988544, _a=0x7fffccd0fcb0) at /build/buildd/calligra-2.6.0/obj-x86_64-linux-gnu/libs/main/KoDocument.moc:97
#9  0x00007f3adaf2cf5f in QMetaObject::activate (sender=0x3fbc200, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#10 0x00007f3adaf2c26c in QObject::event (this=0x3fbc200, e=<optimized out>) at kernel/qobject.cpp:1157
#11 0x00007f3ada2bee9c in QApplicationPrivate::notify_helper (this=this@entry=0x962f20, receiver=receiver@entry=0x3fbc200, e=e@entry=0x7fffccd103b0) at kernel/qapplication.cpp:4562
#12 0x00007f3ada2c330a in QApplication::notify (this=0x7fffccd106b0, receiver=0x3fbc200, e=0x7fffccd103b0) at kernel/qapplication.cpp:4423
#13 0x00007f3adb79fba8 in KoApplication::notify (this=<optimized out>, receiver=0x3fbc200, event=0x7fffccd103b0) at /build/buildd/calligra-2.6.0/libs/main/KoApplication.cpp:537
#14 0x00007f3adaf1756e in QCoreApplication::notifyInternal (this=0x7fffccd106b0, receiver=0x3fbc200, event=0x7fffccd103b0) at kernel/qcoreapplication.cpp:915
#15 0x00007f3adaf48462 in sendEvent (event=0x7fffccd103b0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#16 QTimerInfoList::activateTimers (this=0x9643b0) at kernel/qeventdispatcher_unix.cpp:611
#17 0x00007f3adaf45584 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#18 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#19 0x00007f3adaf455a1 in idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:233
#20 0x00007f3ad4d2cab5 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f3ad4d2cde8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f3ad4d2cea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f3adaf45bf6 in QEventDispatcherGlib::processEvents (this=0x88aad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#24 0x00007f3ada363c1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x00007f3adaf162bf in QEventLoop::processEvents (this=this@entry=0x7fffccd10630, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007f3adaf16548 in QEventLoop::exec (this=0x7fffccd10630, flags=...) at kernel/qeventloop.cpp:204
#27 0x00007f3adaf1b708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#28 0x00007f3adc14ee71 in kdemain (argc=<optimized out>, argv=0x7fffccd107c8) at /build/buildd/calligra-2.6.0/karbon/main.cpp:50
#29 0x00007f3adbd8f76d in __libc_start_main (main=0x400690 <main(int, char**)>, argc=1, ubp_av=0x7fffccd107c8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffccd107b8) at libc-start.c:226
#30 0x00000000004006c1 in _start ()

Possible duplicates by query: bug 312307.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-03-04 05:36:03 UTC

*** This bug has been marked as a duplicate of bug 310310 ***