Bug 321221 - Crash when creating a new sheet after copy & pasting into kate
Summary: Crash when creating a new sheet after copy & pasting into kate
Status: RESOLVED DUPLICATE of bug 310310
Alias: None
Product: calligrasheets
Classification: Applications
Component: general (show other bugs)
Version: 2.6.3
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Calligra Sheets (KSpread) Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-16 13:21 UTC by Matthias Mailänder
Modified: 2013-06-16 15:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Mailänder 2013-06-16 13:21:14 UTC
Application: calligrasheets (2.6.3)
KDE Platform Version: 4.10.4 "release 569"
Qt Version: 4.8.4
Operating System: Linux 3.7.10-1.11-desktop i686
Distribution: "openSUSE 12.3 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:

Copy and pasting rows into kate and creating a new sheet. I am sure this has already been reported. It might be a duplicate of #313704 but the stack trace differs.

The crash can be reproduced every time.

-- Backtrace:
Application: Calligra Sheets (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb543b740 (LWP 21042))]

Thread 2 (Thread 0xadc09b40 (LWP 21043)):
#0  0xb5f3a3cd in clock_gettime () from /lib/libc.so.6
#1  0xb6c7a975 in do_gettime (frac=0xadc08f70, sec=0xadc08f68) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6d613ae in QTimerInfoList::updateCurrentTime (this=0xad302074) at kernel/qeventdispatcher_unix.cpp:354
#4  0x7fffffff in ?? ()
#5  0xb6d6174a in QTimerInfoList::timerWait (this=0xad302074, tm=...) at kernel/qeventdispatcher_unix.cpp:461
#6  0x7fffffff in ?? ()

Thread 1 (Thread 0xb543b740 (LWP 21042)):
[KCrash Handler]
#6  0xb4a53af7 in KParts::ReadWritePart::isModified (this=0x99b39f8) at /usr/src/debug/kdelibs-4.10.4/kparts/part.cpp:1031
#7  0xb0ebadf4 in KoDocument::isModified (this=0xb03b830) at /usr/src/debug/calligra-2.6.3/libs/main/KoDocument.cpp:556
#8  0xb0ec3d95 in KoDocument::slotAutoSave (this=0xb03b830) at /usr/src/debug/calligra-2.6.3/libs/main/KoDocument.cpp:481
#9  0xb0ec414c in KoDocument::qt_static_metacall (_o=_o@entry=0xb03b830, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=14, _a=0xbf80515c) at /usr/src/debug/calligra-2.6.3/build/libs/main/KoDocument.moc:97
#10 0xb6d46c22 in QMetaObject::activate (sender=0xb0ccfe0, m=0xb6e9a4b8 <QTimer::staticMetaObject>, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3548
#11 0xb6d983a5 in QTimer::timeout (this=0xb0ccfe0) at .moc/release-shared/moc_qtimer.cpp:148
#12 0xb6d4dd16 in QTimer::timerEvent (this=0xb0ccfe0, e=0xbf805690) at kernel/qtimer.cpp:280
#13 0xb6d449f4 in QObject::event (this=0xb0ccfe0, e=0xbf805690) at kernel/qobject.cpp:1165
#14 0xb61fcbac in QApplicationPrivate::notify_helper (this=0x9244360, receiver=0xb0ccfe0, e=0xbf805690) at kernel/qapplication.cpp:4562
#15 0xb62015cc in QApplication::notify (this=0xbf805690, receiver=0xb0ccfe0, e=0xbf805690) at kernel/qapplication.cpp:3944
#16 0xb0eafd4a in KoApplication::notify (this=0x120012, receiver=0xb0ccfe0, event=0xbf805690) at /usr/src/debug/calligra-2.6.3/libs/main/KoApplication.cpp:528
#17 0xb6d2e8ce in QCoreApplication::notifyInternal (this=0xbf805980, receiver=0xb0ccfe0, event=0xbf805690) at kernel/qcoreapplication.cpp:946
#18 0xb6d63247 in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#19 QTimerInfoList::activateTimers (this=0x9246834) at kernel/qeventdispatcher_unix.cpp:637
#20 0xb6d60218 in timerSourceDispatch (source=0x9246800) at kernel/qeventdispatcher_glib.cpp:186
#21 timerSourceDispatch (source=0x9246800) at kernel/qeventdispatcher_glib.cpp:180
#22 0xb590c8b3 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0xb590cc50 in ?? () from /usr/lib/libglib-2.0.so.0
#24 0xb590cd31 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0xb6d60891 in QEventDispatcherGlib::processEvents (this=0x916b8b8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#26 0xb62ae4aa in QGuiEventDispatcherGlib::processEvents (this=0x916b8b8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#27 0xb6d2d39c in QEventLoop::processEvents (this=this@entry=0xbf8058f8, flags=...) at kernel/qeventloop.cpp:149
#28 0xb6d2d691 in QEventLoop::exec (this=0xbf8058f8, flags=...) at kernel/qeventloop.cpp:204
#29 0xb6d3294a in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#30 0xb61faa24 in QApplication::exec () at kernel/qapplication.cpp:3823
#31 0xb501c3fd in kdemain (argc=1, argv=0x91b62d0) at /usr/src/debug/calligra-2.6.3/sheets/part/Main.cpp:43
#32 0x0804fb77 in launch (argc=argc@entry=1, _name=_name@entry=0x91bd08c "/usr/bin/calligrasheets", args=<optimized out>, args@entry=0x91bd0a4 "\001", cwd=cwd@entry=0x0, envc=envc@entry=1, envs=<optimized out>, envs@entry=0x91bd0a8 "DISPLAY=:0", reset_env=false, tty=tty@entry=0x0, avoid_loops=false, startup_id_str=startup_id_str@entry=0x91bd0b7 "mPad-X230.site;1371386767;576363;1164_TIME20529893") at /usr/src/debug/kdelibs-4.10.4/kinit/kinit.cpp:726
#33 0x08050944 in handle_launcher_request (sock=sock@entry=8, who=<optimized out>) at /usr/src/debug/kdelibs-4.10.4/kinit/kinit.cpp:1218
#34 0x08050fbf in handle_requests (waitForPid=waitForPid@entry=0) at /usr/src/debug/kdelibs-4.10.4/kinit/kinit.cpp:1411
#35 0x0804c7f0 in main (argc=4, argv=0xbf806324, envp=0xbf806338) at /usr/src/debug/kdelibs-4.10.4/kinit/kinit.cpp:1899

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-06-16 15:20:03 UTC

*** This bug has been marked as a duplicate of bug 310310 ***