Bug 321677 - Karbon crash when modifing path
Summary: Karbon crash when modifing path
Status: RESOLVED DUPLICATE of bug 310310
Alias: None
Product: karbon
Classification: Applications
Component: general (show other bugs)
Version: 2.6.4
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Jan Hambrecht
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-27 14:55 UTC by Nazar554
Modified: 2013-06-27 15:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nazar554 2013-06-27 14:55:29 UTC
Application: karbon (2.6.4)
KDE Platform Version: 4.10.4
Qt Version: 4.8.4
Operating System: Linux 3.9.6-200.fc18.i686 i686
Distribution: "Fedora release 18 (Spherical Cow)"

-- Information about the crash:
- What I was doing when the application crashed:
I had a JPG bitmap image inserted and I used path tool(not freehand) to go along its contour. When I was adding next path node Karbon crashed.

-- Backtrace:
Application: Karbon (karbon), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb6bbb7c0 (LWP 10693))]

Thread 2 (Thread 0xb5370b40 (LWP 10694)):
#0  0x493d2dad in clock_gettime () from /lib/librt.so.1
#1  0x4e7bdcf6 in qt_gettime() () from /lib/libQtCore.so.4
#2  0x4e8a75ff in QTimerInfoList::updateCurrentTime() () from /lib/libQtCore.so.4
#3  0x7fffffff in ?? ()
#4  0x4e8a79bb in QTimerInfoList::timerWait(timeval&) () from /lib/libQtCore.so.4
#5  0x7fffffff in ?? ()

Thread 1 (Thread 0xb6bbb7c0 (LWP 10693)):
[KCrash Handler]
#6  0x425d4d17 in KParts::ReadWritePart::isModified() const () from /lib/libkparts.so.4
#7  0xb7502475 in KoDocument::isModified() const () from /lib/libkomain.so.11
#8  0xb750b596 in KoDocument::slotAutoSave() () from /lib/libkomain.so.11
#9  0xb750b94c in KoDocument::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) () from /lib/libkomain.so.11
#10 0x4e88b24e in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /lib/libQtCore.so.4
#11 0x4e8de4f6 in QTimer::timeout() () from /lib/libQtCore.so.4
#12 0x4e893996 in QTimer::timerEvent(QTimerEvent*) () from /lib/libQtCore.so.4
#13 0x4e88a58c in QObject::event(QEvent*) () from /lib/libQtCore.so.4
#14 0x4342606c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/libQtGui.so.4
#15 0x4342ab2f in QApplication::notify(QObject*, QEvent*) () from /lib/libQtGui.so.4
#16 0xb74f726b in KoApplication::notify(QObject*, QEvent*) () from /lib/libkomain.so.11
#17 0x4e87407e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /lib/libQtCore.so.4
#18 0x4e8a9530 in QTimerInfoList::activateTimers() () from /lib/libQtCore.so.4
#19 0x4e8a6439 in timerSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib/libQtCore.so.4
#20 0x4e8a6473 in idleTimerSourceDispatch(_GSource*, int (*)(void*), void*) () from /lib/libQtCore.so.4
#21 0x4945a15b in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#22 0x4945a500 in g_main_context_iterate.isra.22 () from /lib/libglib-2.0.so.0
#23 0x4945a5e2 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#24 0x4e8a6ac2 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/libQtCore.so.4
#25 0x434d870b in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/libQtGui.so.4
#26 0x4e872a6d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/libQtCore.so.4
#27 0x4e872d69 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/libQtCore.so.4
#28 0x4e87835b in QCoreApplication::exec() () from /lib/libQtCore.so.4
#29 0x43423ee5 in QApplication::exec() () from /lib/libQtGui.so.4
#30 0xb76e7d9d in kdemain () from /lib/libkdeinit4_karbon.so
#31 0x0804878c in main ()

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-06-27 15:25:27 UTC

*** This bug has been marked as a duplicate of bug 310310 ***