Bug 332285 - Stage crashes on notify/autosave
Summary: Stage crashes on notify/autosave
Status: RESOLVED DUPLICATE of bug 310310
Alias: None
Product: calligrastage
Classification: Applications
Component: general (show other bugs)
Version: 2.6.4
Platform: Ubuntu Linux
: NOR grave (vote)
Target Milestone: ---
Assignee: T Zachmann
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-18 16:18 UTC by Fohlen
Modified: 2014-03-18 21:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fohlen 2014-03-18 16:18:45 UTC
Stage crashes when the event loop reaches notify / autosave.


Reproducible: Sometimes

Steps to Reproduce:
1. Open a new document / load a document
2. Wait a few minutes ("Afk")
3. Try to continue working
Actual Results:  
Stage will crash and ask for restart.


Application: Stage (calligrastage), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1d559287c0 (LWP 2768))]

Thread 4 (Thread 0x7f1d3d3d7700 (LWP 2769)):
#0  0x00007f1d55272fbd in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f1d4f43a1dc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1d4f43a6ba in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1d424644f6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f1d4f45deb5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f1d48278764 in ?? () from /usr/lib/nvidia-304/libGL.so.1
#6  0x00007f1d4f90cf8e in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#7  0x00007f1d5527fa0d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 3 (Thread 0x7f1d2bc6e700 (LWP 2770)):
#0  0x00007f1d55272fbd in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f1d4f43a1dc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1d4f43a304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1d53913036 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007f1d538e338f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007f1d538e3618 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007f1d537e5410 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007f1d538c4edf in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007f1d537e7bec in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f1d48278764 in ?? () from /usr/lib/nvidia-304/libGL.so.1
#10 0x00007f1d4f90cf8e in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#11 0x00007f1d5527fa0d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 2 (Thread 0x7f1d28a6c700 (LWP 2786)):
#0  0x00007f1d55277e23 in select () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f1d538c3132 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#2  0x00007f1d537e7bec in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#3  0x00007f1d48278764 in ?? () from /usr/lib/nvidia-304/libGL.so.1
#4  0x00007f1d4f90cf8e in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#5  0x00007f1d5527fa0d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 1 (Thread 0x7f1d559287c0 (LWP 2768)):
[KCrash Handler]
#5  0x00007f1d53239834 in KParts::ReadWritePart::isModified() const () from /usr/lib/libkparts.so.4
#6  0x00007f1d54e317cd in KoDocument::slotAutoSave() () from /usr/lib/libkomain.so.11
#7  0x00007f1d54e31b05 in ?? () from /usr/lib/libkomain.so.11
#8  0x00007f1d538f90ef in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f1d538fe3ec in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#10 0x00007f1d542ce8ec in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#11 0x00007f1d542d125b in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#12 0x00007f1d54e23d98 in KoApplication::notify(QObject*, QEvent*) () from /usr/lib/libkomain.so.11
#13 0x00007f1d538e463e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#14 0x00007f1d53915b72 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#15 0x00007f1d539129a4 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#16 0x00007f1d539129c1 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#17 0x00007f1d4f439f05 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007f1d4f43a248 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f1d4f43a304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f1d53913016 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#21 0x00007f1d5437413e in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#22 0x00007f1d538e338f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#23 0x00007f1d538e3618 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#24 0x00007f1d538e8cf6 in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#25 0x00007f1d55550095 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_calligrastage.so
#26 0x00007f1d551a6ea5 in __libc_start_main () from /lib/x86_64-linux-gnu/libc.so.6
#27 0x0000000000400701 in _start ()
Comment 1 Jekyll Wu 2014-03-18 21:20:47 UTC

*** This bug has been marked as a duplicate of bug 310310 ***