Bug 317738 - crash during autosave
Summary: crash during autosave
Status: RESOLVED DUPLICATE of bug 310310
Alias: None
Product: calligrawords
Classification: Applications
Component: general (show other bugs)
Version: 2.6.2
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Calligra Words Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-02 17:21 UTC by ronald guest
Modified: 2013-04-18 09:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ronald guest 2013-04-02 17:21:16 UTC
Application: calligrawords (2.6.2)
KDE Platform Version: 4.10.1 (Compiled from sources)
Qt Version: 4.8.4
Operating System: Linux 3.8.0-16-generic i686
Distribution: Ubuntu Raring Ringtail (development branch)

-- Information about the crash:
- What I was doing when the application crashed:
I was opening and configuring the newly install calligra suite. The calligra active had  crashed twice prior to calligra word.

-- Backtrace:
Application: Calligra Words (calligrawords), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb3f06740 (LWP 24902))]

Thread 4 (Thread 0xb0cffb40 (LWP 24906)):
#0  0xb51052bc in g_private_get () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb50e75c4 in g_thread_self () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb50c0703 in g_main_context_acquire () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb50c1578 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb50c1c2b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb265dbca in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#6  0xb50e6fc3 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb519ad78 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb76723de in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xaae66b40 (LWP 24910)):
#0  0xb7761424 in __kernel_vsyscall ()
#1  0xb76858e2 in clock_gettime () from /lib/i386-linux-gnu/libc.so.6
#2  0xb63f50d5 in do_gettime (frac=0xaae65f60, sec=0xaae65f58) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0xb64dc80e in QTimerInfoList::updateCurrentTime (this=0xaa501c74) at kernel/qeventdispatcher_unix.cpp:354
#5  0xaae6608c in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 2 (Thread 0xaa016b40 (LWP 24915)):
#0  0xb7761424 in __kernel_vsyscall ()
#1  0xb7662dcb in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb50d02db in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb50c16d0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb50c1831 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb64dbc3f in QEventDispatcherGlib::processEvents (this=0x920b4c8, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb64a83ec in QEventLoop::processEvents (this=this@entry=0xaa016228, flags=...) at kernel/qeventloop.cpp:149
#7  0xb64a86e1 in QEventLoop::exec (this=0xaa016228, flags=...) at kernel/qeventloop.cpp:204
#8  0xb6393fec in QThread::exec (this=0x929c730) at thread/qthread.cpp:542
#9  0xb6487f2d in QInotifyFileSystemWatcherEngine::run (this=0x929c730) at io/qfilesystemwatcher_inotify.cpp:256
#10 0xb6396b18 in QThreadPrivate::start (arg=0x929c730) at thread/qthread_unix.cpp:338
#11 0xb519ad78 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb76723de in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb3f06740 (LWP 24902)):
[KCrash Handler]
#7  0xb62113f7 in KParts::ReadWritePart::isModified (this=0xbcc58f0) at ../../kparts/part.cpp:1031
#8  0xb7410834 in KoDocument::isModified (this=0xc0879a0) at /build/buildd/calligra-2.6.2/libs/main/KoDocument.cpp:556
#9  0xb7416515 in KoDocument::slotAutoSave (this=0xc0879a0) at /build/buildd/calligra-2.6.2/libs/main/KoDocument.cpp:481
#10 0xb74168cc in KoDocument::qt_static_metacall (_o=0xc0879a0, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0xbfd0809c) at /build/buildd/calligra-2.6.2/obj-i686-linux-gnu/libs/main/KoDocument.moc:97
#11 0xb64bfb56 in QMetaObject::activate (sender=0xc07ae20, m=0xb66144b8 <QTimer::staticMetaObject>, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3539
#12 0xb6512ee5 in QTimer::timeout (this=0xc07ae20) at .moc/release-shared/moc_qtimer.cpp:148
#13 0xb64c9126 in QTimer::timerEvent (this=0xc07ae20, e=0xbfd08590) at kernel/qtimer.cpp:280
#14 0xb64c52d4 in QObject::event (this=0xc07ae20, e=0xbfd08590) at kernel/qobject.cpp:1156
#15 0xb6a1dc7c in QApplicationPrivate::notify_helper (this=0x8fba3a8, receiver=0xc07ae20, e=0xbfd08590) at kernel/qapplication.cpp:4567
#16 0xb6a20b94 in QApplication::notify (this=0xbfd08590, receiver=0xc07ae20, e=0xbfd08590) at kernel/qapplication.cpp:3949
#17 0xb740710a in KoApplication::notify (this=0x0, receiver=0xc07ae20, event=0xbfd08590) at /build/buildd/calligra-2.6.2/libs/main/KoApplication.cpp:522
#18 0xb64a990e in QCoreApplication::notifyInternal (this=0xbfd08880, receiver=0xc07ae20, event=0xbfd08590) at kernel/qcoreapplication.cpp:946
#19 0xb64de8c0 in sendEvent (event=0xbfd08590, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#20 QTimerInfoList::activateTimers (this=0x8fba374) at kernel/qeventdispatcher_unix.cpp:622
#21 0xb64db5a8 in timerSourceDispatch (source=0x8fba340) at kernel/qeventdispatcher_glib.cpp:186
#22 timerSourceDispatch (source=0x8fba340) at kernel/qeventdispatcher_glib.cpp:180
#23 0xb50c13b3 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0xb50c1750 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#25 0xb50c1831 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#26 0xb64dbc3f in QEventDispatcherGlib::processEvents (this=0x8f53ef0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#27 0xb6ad4a5a in QGuiEventDispatcherGlib::processEvents (this=0x8f53ef0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#28 0xb64a83ec in QEventLoop::processEvents (this=this@entry=0xbfd087f8, flags=...) at kernel/qeventloop.cpp:149
#29 0xb64a86e1 in QEventLoop::exec (this=0xbfd087f8, flags=...) at kernel/qeventloop.cpp:204
#30 0xb64ae3fa in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#31 0xb6a1bfc4 in QApplication::exec () at kernel/qapplication.cpp:3828
#32 0xb7736bcd in kdemain (argc=1, argv=0xbfd08964) at /build/buildd/calligra-2.6.2/words/part/main.cpp:43
#33 0x0804855b in main (argc=1, argv=0xbfd08964) at /build/buildd/calligra-2.6.2/obj-i686-linux-gnu/words/part/calligrawords_dummy.cpp:3

Possible duplicates by query: bug 315267.

Reported using DrKonqi
Comment 1 Camilla Boemann 2013-04-04 11:05:25 UTC
it's not related to what you were doing but to autosave kicking in - it's a bug we get several reports about but that we (developers) so far are unable to reproduce
Comment 2 Jekyll Wu 2013-04-18 09:59:05 UTC

*** This bug has been marked as a duplicate of bug 310310 ***