Bug 322911 - Calligra Plan crash
Summary: Calligra Plan crash
Status: RESOLVED DUPLICATE of bug 310310
Alias: None
Product: calligraplan
Classification: Applications
Component: general (show other bugs)
Version: 2.6.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Friedrich W. H. Kossebau
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-28 14:28 UTC by soeren_h
Modified: 2013-07-28 15:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description soeren_h 2013-07-28 14:28:49 UTC
Application: calligraplan (2.6.3)
KDE Platform Version: 4.10.5
Qt Version: 4.8.4
Operating System: Linux 3.8.0-26-generic x86_64
Distribution: Ubuntu 13.04

-- Information about the crash:
I was switching between firefox browser and Calligra when the crash happend.
Performing chart showing PV,AC and EV was selected.
Before there was also a crash while adding a new milestone to the task list.

-- Backtrace:
Application: Plan (calligraplan), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fcbf74017c0 (LWP 18768))]

Thread 3 (Thread 0x7fcbd8744700 (LWP 18769)):
#0  0x00007fff0b7f6af7 in ?? ()
#1  0x8000800080008000 in ?? ()
#2  0x00000002d0002f30 in ?? ()
#3  0x00007fcbd0002860 in ?? ()
#4  0x00007fcbd8743ac0 in ?? ()
#5  0x00007fcbd8743b78 in ?? ()
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fcbd6add700 (LWP 18773)):
#0  __GI___pthread_mutex_unlock (mutex=0x7fcbc8000a90) at pthread_mutex_unlock.c:297
#1  0x00007fcbf0f545f1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fcbf0f148f3 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fcbf0f150fe in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fcbf0f15304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fcbf53ec036 in QEventDispatcherGlib::processEvents (this=0x7fcbc80008f0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fcbf53bc38f in QEventLoop::processEvents (this=this@entry=0x7fcbd6adccd0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fcbf53bc618 in QEventLoop::exec (this=this@entry=0x7fcbd6adccd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fcbf52be410 in QThread::exec (this=this@entry=0x2514de0) at thread/qthread.cpp:542
#9  0x00007fcbf539dedf in QInotifyFileSystemWatcherEngine::run (this=0x2514de0) at io/qfilesystemwatcher_inotify.cpp:256
#10 0x00007fcbf52c0bec in QThreadPrivate::start (arg=0x2514de0) at thread/qthread_unix.cpp:338
#11 0x00007fcbe9d53764 in ?? () from /usr/lib/nvidia-304/libGL.so.1
#12 0x00007fcbf13e7f8e in start_thread (arg=0x7fcbd6add700) at pthread_create.c:311
#13 0x00007fcbf6d57e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7fcbf74017c0 (LWP 18768)):
[KCrash Handler]
#6  0x00007fcbf4d12834 in KParts::ReadWritePart::isModified (this=0x1e87d80) at ../../kparts/part.cpp:1031
#7  0x00007fcbf69051e0 in KoDocument::isModified (this=this@entry=0x1e8bb00) at /build/buildd/calligra-2.6.3/libs/main/KoDocument.cpp:556
#8  0x00007fcbf690a7cd in KoDocument::slotAutoSave (this=0x1e8bb00) at /build/buildd/calligra-2.6.3/libs/main/KoDocument.cpp:481
#9  0x00007fcbf690ab05 in KoDocument::qt_static_metacall (_o=0x1e87d80, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x7fff0b63fe50) at /build/buildd/calligra-2.6.3/obj-x86_64-linux-gnu/libs/main/KoDocument.moc:97
#10 0x00007fcbf53d20ef in QMetaObject::activate (sender=0x1e8bdc0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#11 0x00007fcbf53d73ec in QObject::event (this=0x1e8bdc0, e=<optimized out>) at kernel/qobject.cpp:1156
#12 0x00007fcbf5da78ec in QApplicationPrivate::notify_helper (this=this@entry=0x1c4c910, receiver=receiver@entry=0x1e8bdc0, e=e@entry=0x7fff0b640550) at kernel/qapplication.cpp:4567
#13 0x00007fcbf5daa25b in QApplication::notify (this=0x7fff0b640850, receiver=receiver@entry=0x1e8bdc0, e=e@entry=0x7fff0b640550) at kernel/qapplication.cpp:4428
#14 0x00007fcbf68fcd98 in KoApplication::notify (this=<optimized out>, receiver=0x1e8bdc0, event=0x7fff0b640550) at /build/buildd/calligra-2.6.3/libs/main/KoApplication.cpp:528
#15 0x00007fcbf53bd63e in QCoreApplication::notifyInternal (this=0x7fff0b640850, receiver=0x1e8bdc0, event=event@entry=0x7fff0b640550) at kernel/qcoreapplication.cpp:946
#16 0x00007fcbf53eeb72 in sendEvent (event=0x7fff0b640550, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#17 QTimerInfoList::activateTimers (this=0x1c50ed0) at kernel/qeventdispatcher_unix.cpp:622
#18 0x00007fcbf53eb9a4 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#19 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#20 0x00007fcbf53eb9c1 in idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:233
#21 0x00007fcbf0f14f05 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fcbf0f15248 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fcbf0f15304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fcbf53ec016 in QEventDispatcherGlib::processEvents (this=0x1b73340, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0x00007fcbf5e4d1ae in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00007fcbf53bc38f in QEventLoop::processEvents (this=this@entry=0x7fff0b6407d0, flags=...) at kernel/qeventloop.cpp:149
#27 0x00007fcbf53bc618 in QEventLoop::exec (this=this@entry=0x7fff0b6407d0, flags=...) at kernel/qeventloop.cpp:204
#28 0x00007fcbf53c1cf6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#29 0x00007fcbf5da5ffc in QApplication::exec () at kernel/qapplication.cpp:3828
#30 0x00007fcbf7027845 in kdemain (argc=<optimized out>, argv=0x7fff0b640968) at /build/buildd/calligra-2.6.3/plan/main.cpp:41
#31 0x00007fcbf6c7fea5 in __libc_start_main (main=0x4006d0 <main(int, char**)>, argc=1, ubp_av=0x7fff0b640968, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff0b640958) at libc-start.c:260
#32 0x0000000000400701 in _start ()

Reported using DrKonqi
Comment 1 Friedrich W. H. Kossebau 2013-07-28 15:53:32 UTC
Thanks for the report. This is a known bug that plagues all of Calligra :/ and which so far could not be located, as it only happens for a few, but not developers.
Please just disable Autosave for now.
Looks like things are better with the upcoming 2.7, fingers crossed.

*** This bug has been marked as a duplicate of bug 310310 ***