Bug 314733 - Calligra word crashes when adding a reference to an article in a document.
Summary: Calligra word crashes when adding a reference to an article in a document.
Status: RESOLVED DUPLICATE of bug 310310
Alias: None
Product: calligrawords
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Calligra Words Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-08 23:51 UTC by Benoit Leffray
Modified: 2013-03-04 05:38 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benoit Leffray 2013-02-08 23:51:43 UTC
Application: calligrawords (2.6.0)
KDE Platform Version: 4.10.00
Qt Version: 4.8.3
Operating System: Linux 3.5.0-24-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed:

I was just playing with Calligra Word.
I was adding a random reference to an article, just to try out the feature.

-- Backtrace:
Application: Calligra Words (calligrawords), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8fa4a68780 (LWP 7736))]

Thread 4 (Thread 0x7f8f8bba1700 (LWP 7739)):
#0  0x00007f8f9e553d0a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f8f9e5541e2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f8f922f84a6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#3  0x00007f8f9e577645 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f8f9ea22e9a in start_thread (arg=0x7f8f8bba1700) at pthread_create.c:308
#5  0x00007f8fa437bccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f8f75608700 (LWP 7742)):
#0  0x00007f8fa4370313 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f8f9e553d84 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f8f9e553ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8fa2a1ec16 in QEventDispatcherGlib::processEvents (this=0x7f8f700008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f8fa29ef2bf in QEventLoop::processEvents (this=this@entry=0x7f8f75607dd0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f8fa29ef548 in QEventLoop::exec (this=0x7f8f75607dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f8fa28f0b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f8fa29cf9af in QInotifyFileSystemWatcherEngine::run (this=0xe9e660) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f8fa28f3aec in QThreadPrivate::start (arg=0xe9e660) at thread/qthread_unix.cpp:338
#9  0x00007f8f9ea22e9a in start_thread (arg=0x7f8f75608700) at pthread_create.c:308
#10 0x00007f8fa437bccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f8f74e07700 (LWP 7743)):
#0  0x00007f8fa436e8cd in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f8f9e59015f in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f8f9e553914 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8f9e553d22 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f8f9e553ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f8fa2a1ec16 in QEventDispatcherGlib::processEvents (this=0x7f8f680008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f8fa29ef2bf in QEventLoop::processEvents (this=this@entry=0x7f8f74e06dd0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f8fa29ef548 in QEventLoop::exec (this=0x7f8f74e06dd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f8fa28f0b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f8fa29cf9af in QInotifyFileSystemWatcherEngine::run (this=0xf4b990) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f8fa28f3aec in QThreadPrivate::start (arg=0xf4b990) at thread/qthread_unix.cpp:338
#11 0x00007f8f9ea22e9a in start_thread (arg=0x7f8f74e07700) at pthread_create.c:308
#12 0x00007f8fa437bccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8fa4a68780 (LWP 7736)):
[KCrash Handler]
#6  0x00007f8fa23466a4 in KParts::ReadWritePart::isModified (this=0xcabb90) at ../../kparts/part.cpp:1031
#7  0x00007f8fa3f35380 in KoDocument::slotAutoSave (this=0xcad5b0) at /build/buildd/calligra-2.6.0/libs/main/KoDocument.cpp:475
#8  0x00007f8fa3f356a5 in KoDocument::qt_static_metacall (_o=0xcabb90, _c=QMetaObject::InvokeMetaMethod, _id=-988544, _a=0x7ffff02d79e0) at /build/buildd/calligra-2.6.0/obj-x86_64-linux-gnu/libs/main/KoDocument.moc:97
#9  0x00007f8fa2a05f5f in QMetaObject::activate (sender=0xcb41e0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#10 0x00007f8fa2a0526c in QObject::event (this=0xcb41e0, e=<optimized out>) at kernel/qobject.cpp:1157
#11 0x00007f8fa33d2e9c in QApplicationPrivate::notify_helper (this=this@entry=0x8abb00, receiver=receiver@entry=0xcb41e0, e=e@entry=0x7ffff02d80e0) at kernel/qapplication.cpp:4562
#12 0x00007f8fa33d730a in QApplication::notify (this=0x7ffff02d83e0, receiver=0xcb41e0, e=0x7ffff02d80e0) at kernel/qapplication.cpp:4423
#13 0x00007f8fa3f25ba8 in KoApplication::notify (this=<optimized out>, receiver=0xcb41e0, event=0x7ffff02d80e0) at /build/buildd/calligra-2.6.0/libs/main/KoApplication.cpp:537
#14 0x00007f8fa29f056e in QCoreApplication::notifyInternal (this=0x7ffff02d83e0, receiver=0xcb41e0, event=0x7ffff02d80e0) at kernel/qcoreapplication.cpp:915
#15 0x00007f8fa2a21462 in sendEvent (event=0x7ffff02d80e0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#16 QTimerInfoList::activateTimers (this=0x8a4660) at kernel/qeventdispatcher_unix.cpp:611
#17 0x00007f8fa2a1e584 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#18 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#19 0x00007f8f9e553ab5 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f8f9e553de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f8f9e553ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f8fa2a1ebf6 in QEventDispatcherGlib::processEvents (this=0x89e9d0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#23 0x00007f8fa3477c1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#24 0x00007f8fa29ef2bf in QEventLoop::processEvents (this=this@entry=0x7ffff02d8350, flags=...) at kernel/qeventloop.cpp:149
#25 0x00007f8fa29ef548 in QEventLoop::exec (this=0x7ffff02d8350, flags=...) at kernel/qeventloop.cpp:204
#26 0x00007f8fa29f4708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#27 0x00007f8fa466ac85 in kdemain (argc=<optimized out>, argv=0x7ffff02d84f8) at /build/buildd/calligra-2.6.0/words/part/main.cpp:43
#28 0x00007f8fa42a976d in __libc_start_main (main=0x4006a0 <main(int, char**)>, argc=1, ubp_av=0x7ffff02d84f8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffff02d84e8) at libc-start.c:226
#29 0x00000000004006d1 in _start ()

Possible duplicates by query: bug 312307.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-03-04 05:38:57 UTC

*** This bug has been marked as a duplicate of bug 310310 ***