Bug 317086 - crash fsater opening a sheet
Summary: crash fsater opening a sheet
Status: RESOLVED DUPLICATE of bug 310310
Alias: None
Product: calligrasheets
Classification: Applications
Component: general (show other bugs)
Version: 2.6.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Calligra Sheets (KSpread) Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-20 16:02 UTC by Daniel Moyne
Modified: 2013-05-07 02:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Moyne 2013-03-20 16:02:16 UTC
Application: calligrasheets (2.6.2)
KDE Platform Version: 4.10.1
Qt Version: 4.8.4
Operating System: Linux 3.8.0-13-generic x86_64
Distribution: Ubuntu Raring Ringtail (development branch)

-- Information about the crash:
- What I was doing when the application crashed:
nothing special: only after opening a sheet wait until the application crashed. The crash was not just after opening. with another occurance I could enter data, save the sheet, until later the application crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: Feuilles Calligra (calligrasheets), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb9eb9d87c0 (LWP 2890))]

Thread 3 (Thread 0x7fb9c7297700 (LWP 2891)):
#0  0x00007fb9e5532619 in g_mutex_get_impl (mutex=0x7fb9c00009a0) at /build/buildd/glib2.0-2.35.8/./glib/gthread-posix.c:121
#1  0x00007fb9e55328a9 in g_mutex_unlock (mutex=mutex@entry=0x7fb9c00009a0) at /build/buildd/glib2.0-2.35.8/./glib/gthread-posix.c:229
#2  0x00007fb9e54f2873 in g_main_context_prepare (context=context@entry=0x7fb9c00009a0, priority=priority@entry=0x7fb9c7296c38) at /build/buildd/glib2.0-2.35.8/./glib/gmain.c:3326
#3  0x00007fb9e54f307e in g_main_context_iterate (context=context@entry=0x7fb9c00009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.35.8/./glib/gmain.c:3681
#4  0x00007fb9e54f3284 in g_main_context_iteration (context=0x7fb9c00009a0, may_block=1) at /build/buildd/glib2.0-2.35.8/./glib/gmain.c:3762
#5  0x00007fb9e99cb026 in QEventDispatcherGlib::processEvents (this=0x7fb9c00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fb9e999b37f in QEventLoop::processEvents (this=this@entry=0x7fb9c7296d90, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fb9e999b608 in QEventLoop::exec (this=0x7fb9c7296d90, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fb9e989d410 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#9  0x00007fb9e997cecf in QInotifyFileSystemWatcherEngine::run (this=0x4157c50) at io/qfilesystemwatcher_inotify.cpp:256
#10 0x00007fb9e989fbec in QThreadPrivate::start (arg=0x4157c50) at thread/qthread_unix.cpp:338
#11 0x00007fb9e59c5f8e in start_thread (arg=0x7fb9c7297700) at pthread_create.c:311
#12 0x00007fb9eb335e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7fb9c57d9700 (LWP 2897)):
#0  0x00007fb9eb3293cd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fb9e54f315c in g_main_context_poll (n_fds=1, fds=0x7fb9b80029b0, timeout=-1, context=0x7fb9b80009a0, priority=<optimized out>) at /build/buildd/glib2.0-2.35.8/./glib/gmain.c:3995
#2  g_main_context_iterate (context=context@entry=0x7fb9b80009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.35.8/./glib/gmain.c:3696
#3  0x00007fb9e54f3284 in g_main_context_iteration (context=0x7fb9b80009a0, may_block=1) at /build/buildd/glib2.0-2.35.8/./glib/gmain.c:3762
#4  0x00007fb9e99cb026 in QEventDispatcherGlib::processEvents (this=0x7fb9b80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007fb9e999b37f in QEventLoop::processEvents (this=this@entry=0x7fb9c57d8d90, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fb9e999b608 in QEventLoop::exec (this=0x7fb9c57d8d90, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fb9e989d410 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#8  0x00007fb9e997cecf in QInotifyFileSystemWatcherEngine::run (this=0x4422c40) at io/qfilesystemwatcher_inotify.cpp:256
#9  0x00007fb9e989fbec in QThreadPrivate::start (arg=0x4422c40) at thread/qthread_unix.cpp:338
#10 0x00007fb9e59c5f8e in start_thread (arg=0x7fb9c57d9700) at pthread_create.c:311
#11 0x00007fb9eb335e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7fb9eb9d87c0 (LWP 2890)):
[KCrash Handler]
#6  0x00007fb9e92f1834 in KParts::ReadWritePart::isModified (this=0x2625780) at ../../kparts/part.cpp:1031
#7  0x00007fb9eaee850d in KoDocument::slotAutoSave (this=0x262fd80) at /build/buildd/calligra-2.6.2/libs/main/KoDocument.cpp:481
#8  0x00007fb9eaee8845 in KoDocument::qt_static_metacall (_o=0x2625780, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x7fff9cb40390) at /build/buildd/calligra-2.6.2/obj-x86_64-linux-gnu/libs/main/KoDocument.moc:97
#9  0x00007fb9e99b10df in QMetaObject::activate (sender=0x2623cd0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#10 0x00007fb9e99b63dc in QObject::event (this=0x2623cd0, e=<optimized out>) at kernel/qobject.cpp:1156
#11 0x00007fb9ea3858ec in QApplicationPrivate::notify_helper (this=this@entry=0x237b300, receiver=receiver@entry=0x2623cd0, e=e@entry=0x7fff9cb40a90) at kernel/qapplication.cpp:4567
#12 0x00007fb9ea38825b in QApplication::notify (this=0x7fff9cb40d80, receiver=0x2623cd0, e=0x7fff9cb40a90) at kernel/qapplication.cpp:4428
#13 0x00007fb9eaedaad8 in KoApplication::notify (this=<optimized out>, receiver=0x2623cd0, event=0x7fff9cb40a90) at /build/buildd/calligra-2.6.2/libs/main/KoApplication.cpp:522
#14 0x00007fb9e999c62e in QCoreApplication::notifyInternal (this=0x7fff9cb40d80, receiver=0x2623cd0, event=0x7fff9cb40a90) at kernel/qcoreapplication.cpp:946
#15 0x00007fb9e99cdb62 in sendEvent (event=0x7fff9cb40a90, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#16 QTimerInfoList::activateTimers (this=0x23770e0) at kernel/qeventdispatcher_unix.cpp:622
#17 0x00007fb9e99ca994 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#18 timerSourceDispatch (source=source@entry=0x2377080) at kernel/qeventdispatcher_glib.cpp:180
#19 0x00007fb9e54f2e85 in g_main_dispatch (context=0x2376fc0) at /build/buildd/glib2.0-2.35.8/./glib/gmain.c:3054
#20 g_main_context_dispatch (context=context@entry=0x2376fc0) at /build/buildd/glib2.0-2.35.8/./glib/gmain.c:3630
#21 0x00007fb9e54f31c8 in g_main_context_iterate (context=context@entry=0x2376fc0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.35.8/./glib/gmain.c:3701
#22 0x00007fb9e54f3284 in g_main_context_iteration (context=0x2376fc0, may_block=1) at /build/buildd/glib2.0-2.35.8/./glib/gmain.c:3762
#23 0x00007fb9e99cb006 in QEventDispatcherGlib::processEvents (this=0x22d1b30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#24 0x00007fb9ea42b1ae in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x00007fb9e999b37f in QEventLoop::processEvents (this=this@entry=0x7fff9cb40d00, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007fb9e999b608 in QEventLoop::exec (this=0x7fff9cb40d00, flags=...) at kernel/qeventloop.cpp:204
#27 0x00007fb9e99a0ce6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#28 0x00007fb9eb6064ed in kdemain (argc=<optimized out>, argv=0x7fff9cb40e98) at /build/buildd/calligra-2.6.2/sheets/part/Main.cpp:43
#29 0x00007fb9eb25dea5 in __libc_start_main (main=0x4006d0 <main(int, char**)>, argc=1, ubp_av=0x7fff9cb40e98, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff9cb40e88) at libc-start.c:260
#30 0x0000000000400701 in _start ()

Reported using DrKonqi
Comment 1 Halla Rempt 2013-03-20 16:03:52 UTC
Thanks for your report. This issue has been reported for other calligra apps as well, and we are looking into it. As a workaround, you can disable autosave in the settings dialog.
Comment 2 Jekyll Wu 2013-05-07 02:59:55 UTC

*** This bug has been marked as a duplicate of bug 310310 ***