Bug 315267 - crash during autosave
Summary: crash during autosave
Status: RESOLVED DUPLICATE of bug 310310
Alias: None
Product: calligrawords
Classification: Applications
Component: general (show other bugs)
Version: 2.6.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Calligra Words Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-16 12:00 UTC by marytee
Modified: 2013-03-04 05:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description marytee 2013-02-16 12:00:19 UTC
Application: calligrawords (2.6.0)
KDE Platform Version: 4.10.00
Qt Version: 4.8.3
Operating System: Linux 3.5.0-23-generic i686
Distribution: Ubuntu 12.10

-- Information about the crash:
I had opened a document originally created in LibreOffice 3.6.22 and had made a few changes. Edited text, added header and footer, turned on the edit toolbar .  I then changed focus to my browser and within a couple of seconds, I got bug notice that Calligra Words had crashed.

-- Backtrace:
Application: Calligra Words (calligrawords), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb3f81a80 (LWP 2973))]

Thread 3 (Thread 0xaeb4bb40 (LWP 2974)):
#0  0xb76d6830 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#1  0xb517ced0 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb513be4a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb653d99f in QEventDispatcherGlib::processEvents (this=0xae200468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0xb650a26c in QEventLoop::processEvents (this=this@entry=0xaeb4b228, flags=...) at kernel/qeventloop.cpp:149
#5  0xb650a561 in QEventLoop::exec (this=0xaeb4b228, flags=...) at kernel/qeventloop.cpp:204
#6  0xb63f566c in QThread::exec (this=0xa319d98) at thread/qthread.cpp:501
#7  0xb64e87bd in QInotifyFileSystemWatcherEngine::run (this=0xa319d98) at io/qfilesystemwatcher_inotify.cpp:248
#8  0xb63f8a58 in QThreadPrivate::start (arg=0xa319d98) at thread/qthread_unix.cpp:338
#9  0xb5211d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#10 0xb76c8d3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xadb23b40 (LWP 2980)):
#0  0xb4cb7dcd in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb6456fb5 in do_gettime (frac=0xadb22f70, sec=0xadb22f68) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb653e36e in QTimerInfoList::updateCurrentTime (this=0xad202074) at kernel/qeventdispatcher_unix.cpp:343
#4  0x7fffffff in ?? ()
#5  0xb653e6fa in QTimerInfoList::timerWait (this=0xad202074, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x7fffffff in ?? ()

Thread 1 (Thread 0xb3f81a80 (LWP 2973)):
[KCrash Handler]
#7  0xb6274577 in KParts::ReadWritePart::isModified (this=0x9fd4480) at ../../kparts/part.cpp:1031
#8  0xb746afb4 in KoDocument::isModified() const () from /usr/lib/libkomain.so.11
#9  0xb747131a in KoDocument::slotAutoSave() () from /usr/lib/libkomain.so.11
#10 0xb747169c in ?? () from /usr/lib/libkomain.so.11
#11 0xb6523ed6 in QMetaObject::activate (sender=0xa078a38, m=0xb66704b8 <QTimer::staticMetaObject>, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3547
#12 0xb6574a55 in QTimer::timeout (this=0xa078a38) at .moc/release-shared/moc_qtimer.cpp:148
#13 0xb652aed6 in QTimer::timerEvent (this=0xa078a38, e=0xbf915b90) at kernel/qtimer.cpp:280
#14 0xb6521d34 in QObject::event (this=0xa078a38, e=0xbf915b90) at kernel/qobject.cpp:1157
#15 0xb6a7939c in QApplicationPrivate::notify_helper (this=0x9e71c20, receiver=0xa078a38, e=0xbf915b90) at kernel/qapplication.cpp:4562
#16 0xb6a7ddaf in QApplication::notify (this=0xbf915b90, receiver=0xa078a38, e=0xbf915b90) at kernel/qapplication.cpp:3944
#17 0xb746010a in KoApplication::notify(QObject*, QEvent*) () from /usr/lib/libkomain.so.11
#18 0xb650b78e in QCoreApplication::notifyInternal (this=0xbf915ea0, receiver=0xa078a38, event=0xbf915b90) at kernel/qcoreapplication.cpp:915
#19 0xb6540280 in sendEvent (event=0xbf915b90, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#20 QTimerInfoList::activateTimers (this=0x9e7230c) at kernel/qeventdispatcher_unix.cpp:611
#21 0xb653d308 in timerSourceDispatch (source=0x9e722d8) at kernel/qeventdispatcher_glib.cpp:186
#22 timerSourceDispatch (source=0x9e722d8) at kernel/qeventdispatcher_glib.cpp:180
#23 0xb653d342 in idleTimerSourceDispatch (source=0x9e72340) at kernel/qeventdispatcher_glib.cpp:233
#24 0xb513b9e3 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#25 0xb513bd80 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#26 0xb513be61 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#27 0xb653d981 in QEventDispatcherGlib::processEvents (this=0x9e16f08, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#28 0xb6b2f9aa in QGuiEventDispatcherGlib::processEvents (this=0x9e16f08, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#29 0xb650a26c in QEventLoop::processEvents (this=this@entry=0xbf915e18, flags=...) at kernel/qeventloop.cpp:149
#30 0xb650a561 in QEventLoop::exec (this=0xbf915e18, flags=...) at kernel/qeventloop.cpp:204
#31 0xb650fcba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#32 0xb6a76fc4 in QApplication::exec () at kernel/qapplication.cpp:3823
#33 0xb77a3bbd in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_calligrawords.so
#34 0x0804855b in ?? ()
#35 0xb75f34d3 in __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
#36 0x08048581 in _start ()

Possible duplicates by query: bug 312307.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-03-04 05:36:06 UTC

*** This bug has been marked as a duplicate of bug 310310 ***