Bug 319938 - Karbon14 crashed when double clicked a single-line text object
Summary: Karbon14 crashed when double clicked a single-line text object
Status: RESOLVED DUPLICATE of bug 310310
Alias: None
Product: karbon
Classification: Applications
Component: general (show other bugs)
Version: 2.6.1
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Jan Hambrecht
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-17 09:57 UTC by Daniel Rus Morales
Modified: 2013-05-17 11:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Rus Morales 2013-05-17 09:57:57 UTC
Application: karbon (2.6.1)
KDE Platform Version: 4.10.3
Qt Version: 4.8.2
Operating System: Linux 3.2.0-41-generic x86_64
Distribution: Ubuntu 12.04.2 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I was editing a large document when Karbon14 chrased right after double clicking on a single-line text object. The tool selected was the arrow-icon (the most left-top one in the toolbox).

Sorry if it's not descriptive enough. Hope it helps.

-- Backtrace:
Application: Karbon (karbon), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1ba3d9a780 (LWP 2584))]

Thread 3 (Thread 0x7f1b88cd4700 (LWP 2585)):
#0  0x00007f1ba36e4313 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f1b9c4e2036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1b9c4e2164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1ba27af926 in QEventDispatcherGlib::processEvents (this=0x7f1b840008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f1ba277ee62 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f1ba277f0b7 in QEventLoop::exec (this=0x7f1b88cd3dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f1ba267e077 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f1ba275eb6f in QInotifyFileSystemWatcherEngine::run (this=0x20650a0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f1ba268109b in QThreadPrivate::start (arg=0x20650a0) at thread/qthread_unix.cpp:307
#9  0x00007f1b9cda6e9a in start_thread (arg=0x7f1b88cd4700) at pthread_create.c:308
#10 0x00007f1ba36efccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f1b82e7c700 (LWP 2591)):
#0  0x00007f1ba36e4313 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f1b9c4e2036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f1b9c4e2164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f1ba27af926 in QEventDispatcherGlib::processEvents (this=0x7f1b7c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f1ba277ee62 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f1ba277f0b7 in QEventLoop::exec (this=0x7f1b82e7bdd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f1ba267e077 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f1ba275eb6f in QInotifyFileSystemWatcherEngine::run (this=0x2324210) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f1ba268109b in QThreadPrivate::start (arg=0x2324210) at thread/qthread_unix.cpp:307
#9  0x00007f1b9cda6e9a in start_thread (arg=0x7f1b82e7c700) at pthread_create.c:308
#10 0x00007f1ba36efccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f1ba3d9a780 (LWP 2584)):
[KCrash Handler]
#6  0x00007f1ba1250624 in KParts::ReadWritePart::isModified (this=0x6656090) at ../../kparts/part.cpp:1031
#7  0x00007f1ba3035071 in KoDocument::slotAutoSave (this=0x5a31a50) at /build/buildd/calligra-2.6.1/libs/main/KoDocument.cpp:475
#8  0x00007f1ba30353e5 in KoDocument::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /build/buildd/calligra-2.6.1/obj-x86_64-linux-gnu/libs/main/KoDocument.moc:97
#9  0x00007f1ba2794781 in QMetaObject::activate (sender=0x6831c30, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#10 0x00007f1ba2799679 in QObject::event (this=0x6831c30, e=<optimized out>) at kernel/qobject.cpp:1157
#11 0x00007f1ba1b017b4 in notify_helper (e=0x7fff86d566c0, receiver=0x6831c30, this=0x1ab6310) at kernel/qapplication.cpp:4556
#12 QApplicationPrivate::notify_helper (this=0x1ab6310, receiver=0x6831c30, e=0x7fff86d566c0) at kernel/qapplication.cpp:4528
#13 0x00007f1ba1b06583 in QApplication::notify (this=0x7fff86d56970, receiver=0x6831c30, e=0x7fff86d566c0) at kernel/qapplication.cpp:4417
#14 0x00007f1ba30247ee in KoApplication::notify (this=<optimized out>, receiver=0x6831c30, event=0x7fff86d566c0) at /build/buildd/calligra-2.6.1/libs/main/KoApplication.cpp:522
#15 0x00007f1ba278032c in QCoreApplication::notifyInternal (this=0x7fff86d56970, receiver=0x6831c30, event=0x7fff86d566c0) at kernel/qcoreapplication.cpp:915
#16 0x00007f1ba27b16f2 in sendEvent (event=0x7fff86d566c0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#17 QTimerInfoList::activateTimers (this=0x1abb1b0) at kernel/qeventdispatcher_unix.cpp:611
#18 0x00007f1ba27af10d in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#19 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#20 0x00007f1ba27af131 in idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:233
#21 0x00007f1b9c4e1d53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f1b9c4e20a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f1b9c4e2164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f1ba27af8bf in QEventDispatcherGlib::processEvents (this=0x1a31ad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#25 0x00007f1ba1ba9cde in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#26 0x00007f1ba277ee62 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#27 0x00007f1ba277f0b7 in QEventLoop::exec (this=0x7fff86d56930, flags=...) at kernel/qeventloop.cpp:204
#28 0x00007f1ba2784407 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#29 0x00007f1ba39bbd95 in kdemain (argc=<optimized out>, argv=0x7fff86d56b08) at /build/buildd/calligra-2.6.1/karbon/main.cpp:50
#30 0x00007f1ba361d76d in __libc_start_main (main=0x400630 <main(int, char**)>, argc=1, ubp_av=0x7fff86d56b08, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff86d56af8) at libc-start.c:226
#31 0x0000000000400661 in _start ()

Possible duplicates by query: bug 314871.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-05-17 11:54:43 UTC

*** This bug has been marked as a duplicate of bug 310310 ***