Bug 322864 - karbon crash while idle
Summary: karbon crash while idle
Status: RESOLVED DUPLICATE of bug 310310
Alias: None
Product: karbon
Classification: Applications
Component: general (show other bugs)
Version: 2.6.4
Platform: Debian unstable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Jan Hambrecht
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-26 21:23 UTC by Roger Leigh
Modified: 2013-07-26 23:31 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roger Leigh 2013-07-26 21:23:35 UTC
Application: karbon (2.6.4)
KDE Platform Version: 4.10.5
Qt Version: 4.8.5
Operating System: Linux 3.10-1-amd64 x86_64
Distribution: Debian GNU/Linux unstable (sid)

-- Information about the crash:
- What I was doing when the application crashed:

Absolutely nothing.  karbon did not have focus and I wasn't actively using it at all!  Maybe triggered by a periodic timer e.g. autosave?

The crash can be reproduced sometimes.

-- Backtrace:
Application: Karbon (karbon), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7feb738bc780 (LWP 15459))]

Thread 2 (Thread 0x7feb5942f700 (LWP 15460)):
#0  0x00007feb6cd66fdd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007feb6cd672b9 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007feb6cd27320 in g_main_context_acquire () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007feb6cd28055 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007feb6cd2829c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007feb722d7d06 in QEventDispatcherGlib::processEvents (this=0x7feb540008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#6  0x00007feb722a97bf in QEventLoop::processEvents (this=this@entry=0x7feb5942edb0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007feb722a9ab5 in QEventLoop::exec (this=this@entry=0x7feb5942edb0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007feb721a88cf in QThread::exec (this=this@entry=0xf697b0) at thread/qthread.cpp:536
#9  0x00007feb7228aee3 in QInotifyFileSystemWatcherEngine::run (this=0xf697b0) at io/qfilesystemwatcher_inotify.cpp:256
#10 0x00007feb721aaf6f in QThreadPrivate::start (arg=0xf697b0) at thread/qthread_unix.cpp:338
#11 0x00007feb6d3f7e0e in start_thread (arg=0x7feb5942f700) at pthread_create.c:311
#12 0x00007feb7322893d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7feb738bc780 (LWP 15459)):
[KCrash Handler]
#6  0x00007feb70d8d1a4 in KParts::ReadWritePart::isModified (this=0x4812880) at ../../kparts/part.cpp:1031
#7  0x00007feb72b71630 in KoDocument::isModified (this=this@entry=0x4cd7360) at ../../../libs/main/KoDocument.cpp:556
#8  0x00007feb72b751cf in KoDocument::slotAutoSave (this=0x4cd7360) at ../../../libs/main/KoDocument.cpp:481
#9  0x00007feb72b7550d in KoDocument::qt_static_metacall (_o=0x4812880, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x7fff7fae1700) at ./KoDocument.moc:96
#10 0x00007feb722becf8 in QMetaObject::activate (sender=0x4cdd850, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#11 0x00007feb722c2ec1 in QObject::event (this=0x4cdd850, e=<optimized out>) at kernel/qobject.cpp:1156
#12 0x00007feb7164870c in QApplicationPrivate::notify_helper (this=this@entry=0x99f750, receiver=receiver@entry=0x4cdd850, e=e@entry=0x7fff7fae1b10) at kernel/qapplication.cpp:4567
#13 0x00007feb7164ed80 in QApplication::notify (this=0x7fff7fae1e00, receiver=receiver@entry=0x4cdd850, e=e@entry=0x7fff7fae1b10) at kernel/qapplication.cpp:4353
#14 0x00007feb72b6e107 in KoApplication::notify (this=<optimized out>, receiver=0x4cdd850, event=0x7fff7fae1b10) at ../../../libs/main/KoApplication.cpp:528
#15 0x00007feb722aab5d in QCoreApplication::notifyInternal (this=0x7fff7fae1e00, receiver=0x4cdd850, event=0x7fff7fae1b10) at kernel/qcoreapplication.cpp:949
#16 0x00007feb722da7b3 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#17 QTimerInfoList::activateTimers (this=0x99e430) at kernel/qeventdispatcher_unix.cpp:621
#18 0x00007feb722d7ab1 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#19 0x00007feb6cd27ea6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007feb6cd281f8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007feb6cd2829c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007feb722d7ce5 in QEventDispatcherGlib::processEvents (this=0x90fa70, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#23 0x00007feb716e6846 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#24 0x00007feb722a97bf in QEventLoop::processEvents (this=this@entry=0x7fff7fae1d90, flags=...) at kernel/qeventloop.cpp:149
#25 0x00007feb722a9ab5 in QEventLoop::exec (this=this@entry=0x7fff7fae1d90, flags=...) at kernel/qeventloop.cpp:204
#26 0x00007feb722af0fb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1221
#27 0x00007feb71646ecc in QApplication::exec () at kernel/qapplication.cpp:3828
#28 0x00007feb734f0e33 in kdemain (argc=<optimized out>, argv=<optimized out>) at ../../karbon/main.cpp:50
#29 0x00007feb73161995 in __libc_start_main (main=0x4006d0 <main(int, char**)>, argc=1, ubp_av=0x7fff7fae1f28, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff7fae1f18) at libc-start.c:260
#30 0x00000000004006fe in _start ()

Possible duplicates by query: bug 321677.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-07-26 23:31:14 UTC

*** This bug has been marked as a duplicate of bug 310310 ***