Bug 152702 - Akregator column width problem
Summary: Akregator column width problem
Status: RESOLVED FIXED
Alias: None
Product: akregator
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 187 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 94286 153972 165946 166279 167197 171227 171613 173787 176262 182017 182776 182836 185521 186773 189076 194150 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-11-22 11:53 UTC by FiNeX
Modified: 2012-03-20 11:26 UTC (History)
40 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description FiNeX 2007-11-22 11:53:39 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
OS:                Linux

Akregator doesn't remember the width of the columns in the feed list panel.
Moreover The "article" column in the article list panel cannot be resized
Comment 1 Stefan Tittel 2007-11-26 15:34:25 UTC
I can confirm that the width of columns is not saved upon exit using the official KDE 3.5.7 packages of openSUSE 10.3. However, I can resize the "article" column.
Comment 2 Frank Osterfeld 2007-11-26 23:57:10 UTC
This bug report refers to the current development version (KDE 4) where the list view is fundamentally different (code-wise that is).
Comment 3 Teemu Rytilahti 2008-01-24 21:09:10 UTC
*** Bug 153972 has been marked as a duplicate of this bug. ***
Comment 4 Dario Panico 2008-01-26 12:32:27 UTC
KDE Version  1.2.50 (KDE 4.00.80 (KDE 4.0.80 >= 20080104), compiled sources)
I can confirm it, but article column it's resizable but it's starting width is way too small.
Comment 5 FiNeX 2008-02-04 13:36:42 UTC
Actually the column width is resizable again, but width is still not remembered.
Comment 6 Frank Osterfeld 2008-02-04 15:06:14 UTC
Thanks for the reports. To make them even more useful (trunk is constantly changing), please mention the SVN version you built from (see "svn info" in your checkout) .
Comment 7 FiNeX 2008-02-04 16:16:31 UTC
I've forgot to write the revision. It was a revision of 2 days ago.
I've just re-compiled the r770789 and now the width is remembered.

Moreover I've just see your SVN commit:
r770179: better column setup (now with optional author column) and persisting widths and sort settings
which confirm the resolution :-)

Thanks for the fix :-)
Comment 8 Christophe Giboudeaux 2008-02-04 17:40:18 UTC
There's still a problem with column width and rev. 770883 : The last column doesn't remind it's width.

Screenshot : http://pix.nofrag.com/0/a/a/a74b5c0bf0f77b6415ed617e46193.png
Comment 9 FiNeX 2008-02-04 18:19:17 UTC
Confirmed, the "date" column doesn't remember the size.
Comment 10 Dario Panico 2008-02-11 20:41:51 UTC
confirmed also here 4.00.61 >=20080207
Comment 11 Lukas Appelhans 2008-02-17 22:30:50 UTC
SVN commit 776345 by lappelhans:

Save the widths of the treeviews
This is only a workaround for a Qt-Bug

BUG:152702


 M  +2 -2      interfaces/akregator.kcfg  
 M  +31 -5     src/articlelistview.cpp  
 M  +18 -5     src/subscriptionlistview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=776345
Comment 12 Christophe Giboudeaux 2008-02-20 23:47:14 UTC
The problem is back in rev. 777574 with QT4.4 (although a bit different) :

When clicking on a folder in the feeds list, the "Feed" column has a zero width and is hidden next to the "Author" column.
Comment 13 FiNeX 2008-05-25 15:44:56 UTC
Confirmed, the feed column is not visible.
Comment 14 Christophe Giboudeaux 2008-07-08 17:19:09 UTC
*** Bug 165946 has been marked as a duplicate of this bug. ***
Comment 15 Christophe Giboudeaux 2008-07-11 09:04:59 UTC
*** Bug 166279 has been marked as a duplicate of this bug. ***
Comment 16 Dario Panico 2008-07-15 23:01:16 UTC
Everything confirmed but i found another issue: every time i open akregator i find that 'Title' and 'Date' columns are a bit larger than they were when i closed the app. After a few times those columns are really too large.

Rev. 830790
Comment 17 Christophe Giboudeaux 2008-07-22 12:40:36 UTC
*** Bug 167197 has been marked as a duplicate of this bug. ***
Comment 18 Kishore 2008-07-27 07:29:26 UTC
I confirm this bug too. It only partly remembers the column widhts and sorting. the feed column almost always resets to zero width and date column always become wider.

Sometimes after a crash, the column widths and sorting are all reset to default which is a narrow title column and sorted on the title column.
Comment 19 Sergei Andreev 2008-08-03 22:11:18 UTC
>Also, the same context-menu (the one to pick columns to be shown) is hard to close. Clicking anywhere outside of it won't close it and I have to click many times on the same item (i.e. "Feeds") to get the menu closed.

Steel in 4.1.0 - very strange and disappointment behavior.
Comment 20 Teemu Rytilahti 2008-08-22 05:11:32 UTC
Some fixes in trunk now, see http://lists.kde.org/?l=kde-commits&m=121937432621829&w=2

Articlelist's sizes are still broken, but the ordering of the columns should be saved now. Also the problem with opening multiple context-menus per one rmb click on a column has been fixed.
Comment 21 FiNeX 2008-09-27 11:25:43 UTC
*** Bug 171227 has been marked as a duplicate of this bug. ***
Comment 22 Julien Bigot 2008-09-30 01:00:21 UTC
Yeah, confirmed here too. Plus, I tend to remove the feed & author columns, but they keep coming back when I close & reopen akregator.
Another strange bug is thet the right click popup where you can remove these columns sometimes doesn't diappear after clicking ... Don't know if it's linked.
Comment 23 Robert Marmorstein 2008-10-08 19:31:35 UTC
I also have this bug.  I have also found that on occasion when I try to remove the Feed Column, the GUI will hang and no longer accept input.  By randomly clicking on things with the mouse I can sometimes get the menu to go away and the application becomes responsive again.  This doesn't seem to happen if I right click on a different column before I uncheck "Feed" from the list.  But if I right click on the Feed column after resizing other columns to make it visible, this usually happens.	  
Comment 24 Γιώργος Κυλάφας (Giorgos Kylafas) 2008-10-09 08:56:08 UTC
Concerning the RMB menu popup, I was experiencing the same bug (i.e. had to randomly click to make it disappear) up until 4.1.1. However, 4.1.2 seems to have this problem fixed, at least for me, possibly due to http://websvn.kde.org/?view=rev&revision=858690
Comment 25 Christophe Giboudeaux 2008-10-28 22:09:29 UTC
*** Bug 173787 has been marked as a duplicate of this bug. ***
Comment 26 Jonathan Marten 2008-12-04 17:52:18 UTC
*** Bug 171613 has been marked as a duplicate of this bug. ***
Comment 27 Blackpaw 2008-12-09 11:38:55 UTC
Also in 4.2 beta 1. Also the Feed column keeps returning despite me hiding it.
Comment 28 Γιώργος Κυλάφας (Giorgos Kylafas) 2008-12-09 18:20:04 UTC
I confirm that this bug still exists in 4.2 beta 1 (Kubuntu packages).
Comment 29 Robert Marmorstein 2008-12-09 19:32:01 UTC
Same here (KDE 4.2 beta built from svn trunk on Archlinux).
Comment 30 Dario Panico 2008-12-18 18:14:06 UTC
still in kde 4.1.85 (kde 4.2 beta 2) kubuntu packages
Comment 31 Blackpaw 2008-12-18 22:48:54 UTC
Still here (kde 4.2 beta 2) kubuntu packages
Comment 32 Roland Leißa 2009-01-05 19:16:32 UTC
Same problem here with KDE 4.1.3 and KDE 4.2 Beta 2.
Comment 33 Andreas Ermler 2009-01-15 09:42:22 UTC
Still doesn't remember column size in KDE 4.2 RC1 (4.1.96) / Akregator 1.3.50 (Kubuntu packages).
Comment 34 Panagiotis Papadopoulos 2009-01-17 19:37:53 UTC
On my computer (1 day old trunk version), Akregator doesn't remember the width of the Date column, either.

After every start, the width is reset to the default width.

thanks
Comment 35 Christophe Giboudeaux 2009-01-22 11:25:26 UTC
*** Bug 94286 has been marked as a duplicate of this bug. ***
Comment 36 Mark Ziegler 2009-01-22 17:25:04 UTC
I use akregator as module in kontact. Whenever I start kontact it does not remember my sorting and width of columns. I prefer sorting by date.

openSUSE 11.0 
Qt: 4.4.3
KDE: 4.1.96 (KDE 4.1.96 (KDE 4.2 RC1)) "release 78.1"
Akregator: 1.3.50
Comment 37 Quentin Jackson 2009-01-23 05:59:52 UTC
Guys, this bug was logged November 2007.  I think considering the lack of response it is safe to say this bug is not being looked at.  Incredible, considering the amount of 'me too's' in here.  This particular bug and the few other bugs in Akregator that cause user preferences to not be saved make Akregator unusable which is embarrassing for KDE IMO.  It would be nice if someone raised the priority of this as this should really have been fixed in the latest KDE4 release.
Comment 38 Christophe Giboudeaux 2009-01-23 11:08:02 UTC
More precisely, adding "me too" is just plain useless, we already know this issue is not fully fixed.

Read comment #2 (from the maintainer), comment #11 (some commits), comment #20 (other commits) and comment #24.

This issue is not forgotten.

Feel free to provide a patch.

Comment 39 Jonathan Marten 2009-01-23 13:38:59 UTC
From the comments in the source, this is apparently a bug in Qt.  Should it be reported upstream?
Comment 40 Frank Osterfeld 2009-01-23 14:26:30 UTC
From time to time I also have seen these issues with column widths and sorting orders not saved, but I can't reproduce them reliably. Whenever I try to debug this, it magically works (normal usage, no gdb attached etc.). Thus I cannot fix it (not with an amount of time and motivation I currently have for Akregator bugfixing). 

If anyone could
 - tell me how to reproduce it
 - send me the akregatorrc from between an akregator session which had  customized columns before closing and a restart which has the columns reset again
 
that could help significantly to speed up closing this bug.
Comment 41 Christophe Giboudeaux 2009-01-23 15:15:18 UTC
1/ - tell me how to reproduce it
Selecting another feed in normal or extended view

2/ - send me the akregatorrc from between an akregator session which had 
customized columns before closing and a restart which has the columns reset
again

If you quit Akregator with customized columns, they will be restored at the next startup. 
but changing the feed will have the same result as in 1/

akregatorrc with customized columns (size and sorting) :

[Appearance]
Fixed Font=Monospace
Sans Serif Font=Nimbus Sans L
Serif Font=Nimbus Sans L
Standard Font=Nimbus Sans L

[General]
ArticleListHeaders=AAAA/wAAAAAAAAABAAAAAQAAAAMBAAAAAAAAAAAAAAAEAgAAAAEAAAABAAAAZAAABicAAAAEAQEAAQAAAAAAAAAAAAAAAGT/////AAAAgQAAAAAAAAAEAAAClAAAAAEAAAAAAAAAAAAAAAEAAAAAAAAAxAAAAAEAAAAAAAACzwAAAAEAAAAA
SubscriptionListHeaders=AAAA/wAAAAAAAAABAAAAAQAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAU4AAAADAQAAAQAAAAAAAAAAAAAAAGT/////AAAAgQAAAAAAAAADAAAA3gAAAAEAAAAAAAAAQgAAAAEAAAAAAAAALgAAAAEAAAAA

[HTML Settings]
AutomaticDetectionLanguage=1
Fonts=Nimbus Sans L,Monospace,Nimbus Sans L,Nimbus Sans L,0
MediumFontSize=10
MinimumFontSize=8

[MainWindow]
Height 1200=1201
State=AAAA/wAAAAD9AAAAAAAABkAAAAP/AAAABAAAAAQAAAAIAAAACPwAAAABAAAAAgAAAAMAAAAWAG0AYQBpAG4AVABvAG8AbABCAGEAcgEAAAAA/////wAAAAAAAAAAAAAAHABiAHIAbwB3AHMAZQByAFQAbwBvAGwAQgBhAHIBAAABuP////8AAAAAAAAAAAAAACYAdABlAHgAdABUAG8AUwBwAGUAZQBjAGgAVABvAG8AbABCAGEAcgAAAAAA/////wAAAAAAAAAA
Width 1600=1601

[MainWindow][Toolbar browserToolBar]
Index=1
ToolButtonStyle=TextBesideIcon

[MainWindow][Toolbar mainToolBar]
Index=0

[MainWindow][Toolbar textToSpeechToolBar]
Index=2
ToolButtonStyle=TextBesideIcon

[View]
Splitter 1 Sizes=355,1239
Splitter 2 Sizes=293,683

---
After restarting (the intro screen is displayed and in the feeds list column, the "total" has a wrong size already :

[Appearance]
Fixed Font=Monospace
Sans Serif Font=Nimbus Sans L
Serif Font=Nimbus Sans L
Standard Font=Nimbus Sans L

[General]
ArticleListHeaders=AAAA/wAAAAAAAAABAAAAAQAAAAMBAAAAAAAAAAAAAAAEAgAAAAEAAAABAAAAZAAABicAAAAEAQEAAQAAAAAAAAAAAAAAAGT/////AAAAgQAAAAAAAAAEAAAClAAAAAEAAAAAAAAAAAAAAAEAAAAAAAAAxAAAAAEAAAAAAAACzwAAAAEAAAAA
SubscriptionListHeaders=AAAA/wAAAAAAAAABAAAAAQAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAU4AAAADAQAAAQAAAAAAAAAAAAAAAGT/////AAAAgQAAAAAAAAADAAAA3gAAAAEAAAAAAAAAQgAAAAEAAAAAAAAALgAAAAEAAAAA

[HTML Settings]
AutomaticDetectionLanguage=1
Fonts=Nimbus Sans L,Monospace,Nimbus Sans L,Nimbus Sans L,0
MediumFontSize=10
MinimumFontSize=8

[MainWindow]
Height 1200=1201
State=AAAA/wAAAAD9AAAAAAAABkAAAAP/AAAABAAAAAQAAAAIAAAACPwAAAABAAAAAgAAAAMAAAAWAG0AYQBpAG4AVABvAG8AbABCAGEAcgEAAAAA/////wAAAAAAAAAAAAAAHABiAHIAbwB3AHMAZQByAFQAbwBvAGwAQgBhAHIBAAABuP////8AAAAAAAAAAAAAACYAdABlAHgAdABUAG8AUwBwAGUAZQBjAGgAVABvAG8AbABCAGEAcgAAAAAA/////wAAAAAAAAAA
Width 1600=1601

[MainWindow][Toolbar browserToolBar]
Index=1
ToolButtonStyle=TextBesideIcon

[MainWindow][Toolbar mainToolBar]
Index=0

[MainWindow][Toolbar textToSpeechToolBar]
Index=2
ToolButtonStyle=TextBesideIcon

[View]
Splitter 1 Sizes=355,1239
Splitter 2 Sizes=293,683

---
At this point, clicking on a feed then an article will show a correct size (except for the "date" column.

but choosing another feed will reset the columns.

akregatorrc after clicking on the 2nd feed and exiting :

[Appearance]
Fixed Font=Monospace
Sans Serif Font=Nimbus Sans L
Serif Font=Nimbus Sans L
Standard Font=Nimbus Sans L

[General]
ArticleListHeaders=AAAA/wAAAAAAAAABAAAAAQAAAAMBAAAAAAAAAAAAAAAAAAAAAAAABicAAAAEAQEAAQAAAAAAAAAAAAAAAGT/////AAAAgQAAAAAAAAACAAABLAAAAAMAAAAAAAAE+wAAAAEAAAAA
SubscriptionListHeaders=AAAA/wAAAAAAAAABAAAAAQAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAYQAAAADAQAAAQAAAAAAAAAAAAAAAGT/////AAAAgQAAAAAAAAADAAAA3gAAAAEAAAAAAAAAQgAAAAEAAAAAAAAAZAAAAAEAAAAA

[HTML Settings]
AutomaticDetectionLanguage=1
Fonts=Nimbus Sans L,Monospace,Nimbus Sans L,Nimbus Sans L,0
MediumFontSize=10
MinimumFontSize=8

[MainWindow]
Height 1200=1201
State=AAAA/wAAAAD9AAAAAAAABkAAAAP/AAAABAAAAAQAAAAIAAAACPwAAAABAAAAAgAAAAMAAAAWAG0AYQBpAG4AVABvAG8AbABCAGEAcgEAAAAA/////wAAAAAAAAAAAAAAHABiAHIAbwB3AHMAZQByAFQAbwBvAGwAQgBhAHIBAAABuP////8AAAAAAAAAAAAAACYAdABlAHgAdABUAG8AUwBwAGUAZQBjAGgAVABvAG8AbABCAGEAcgAAAAAA/////wAAAAAAAAAA
Width 1600=1601

[MainWindow][Toolbar browserToolBar]
Index=1
ToolButtonStyle=TextBesideIcon

[MainWindow][Toolbar mainToolBar]
Index=0

[MainWindow][Toolbar textToSpeechToolBar]
Index=2
ToolButtonStyle=TextBesideIcon

[View]
Splitter 1 Sizes=355,1239
Splitter 2 Sizes=293,683


Comment 42 Frank Osterfeld 2009-01-23 16:08:26 UTC
Christophe: For you, it persists the settings correctly, but resets them when switching feeds. That's another, even more severe bug. I had a similar report on IRC. However, I cannot reproduce this one at all, in fact I've never seen it (where I also run into the persistency problem from time to time, just not reliably). Thanks for the akregatorrc, it won't help for this case though.
Comment 43 Tomas Åkesson 2009-01-23 17:20:25 UTC
For me the date column looks like in Christophe's screenshot in comment #8 (I have disabled the author and feed-columns so they arent visible).
If I in this situation resize the date-column so it fits in the view, and then exit Akregator (and make a copy of akregatorrc), then restart it again, the width is reset to the "too wide"-width in the screenshot. If I then exit again and run diff on the akregatorrc I saved, and the current one, there is no difference between the files.

A curious thing I discovered is this: when you have the "too wide date-column problem" like in the screenshot, if you resize the feeds-list, narrows it down until there's nothing left, the date-column almost fits in the view.
I don't know if it's important, but seems like a curious coincidence; maybe some width somewhere is calculated with a parameter missing?
Comment 44 Frank Osterfeld 2009-01-23 17:38:57 UTC
I think I identified the problem (for devs: QHeaderView loses its settings when the model is changed/when there is no model, they are not saved/restored correctly). Looking for a solution.
Comment 45 Frank Osterfeld 2009-01-23 18:07:24 UTC
SVN commit 915739 by osterfeld:

Try to fix the headerview amnesia.
QHeaderView::restoreState/saveState doesn't work properly if there is no model set
Also, with the Qt 4.5 snapshot, all header settings are lost each time when setting a new model.
This patch is for articleview, can be done for feed list view as well, if it solves the problem.
Please everyone test (if you use SVN)

CCBUG:152702


 _M            . (directory)  
 M  +17 -25    akregator/src/articlelistview.cpp  
 M  +3 -1      akregator/src/articlelistview.h  
 M  +9 -10     akregator/src/selectioncontroller.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=915739
Comment 46 Frank Osterfeld 2009-01-23 18:20:12 UTC
SVN commit 915740 by osterfeld:

backport, Christophe confirms it's fixed now. Please all test. Same fix for feed list to come.

SVN commit 915739 by osterfeld:

Try to fix the headerview amnesia.
QHeaderView::restoreState/saveState doesn't work properly if there is no model
set
Also, with the Qt 4.5 snapshot, all header settings are lost each time when
setting a new model.
This patch is for articleview, can be done for feed list view as well, if it
solves the problem.
Please everyone test (if you use SVN)

BUG:152702


 M  +17 -25    articlelistview.cpp  
 M  +3 -1      articlelistview.h  
 M  +4 -5      selectioncontroller.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=915740
Comment 47 Frank Osterfeld 2009-01-23 18:28:51 UTC
SVN commit 915741 by osterfeld:

correctly (as in: workaround Qt borkedness) store/restore headerstate for the feed list, too 
CCBUG: 152702


 _M            . (directory)  
 M  +27 -34    akregator/src/subscriptionlistview.cpp  
 M  +2 -1      akregator/src/subscriptionlistview.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=915741
Comment 48 Frank Osterfeld 2009-01-23 18:38:47 UTC
SVN commit 915745 by osterfeld:

also write out state the user made after the last feed switch
CCBUG:152702


 _M            . (directory)  
 M  +2 -0      akregator/src/articlelistview.cpp  
 M  +2 -0      akregator/src/subscriptionlistview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=915745
Comment 49 Frank Osterfeld 2009-01-23 18:41:09 UTC
SVN commit 915747 by osterfeld:

backport:
also write out state the user made after the last feed switch
CCBUG:152702 


 M  +2 -0      articlelistview.cpp  
 M  +2 -0      subscriptionlistview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=915747
Comment 50 Jonathan Marten 2009-01-24 13:26:28 UTC
See also bug 181742 for a related but separate problem: article list view columns resizing themselves of their own accord while Akregator is running.
Comment 51 Frank Osterfeld 2009-01-24 19:21:31 UTC
*** Bug 176262 has been marked as a duplicate of this bug. ***
Comment 52 Neal Becker 2009-01-26 21:07:43 UTC
*** Bug 182017 has been marked as a duplicate of this bug. ***
Comment 53 Dario Panico 2009-01-28 13:43:43 UTC
i'm i wrong or this fix didn't manage to be in 4.2.00?

because the bug is still present in kde 4.2.00
Comment 54 Blackpaw 2009-01-28 14:13:26 UTC
Yup, definitely not fixed on my KDE 4.20 either, no change at all. Bug Needs to be reopened.
Comment 55 Anders Lund 2009-01-28 19:15:07 UTC
This problem is *not* fixed.
I experience it every day.
I'm using akgregator inside kontact, and it starts everyday without remembering its configuration. Kontact is usually closed and opened by the session manager.
Comment 56 Jonathan Marten 2009-01-28 20:07:37 UTC
See http://lists.kde.org/?l=kde-pim&m=123316246418552&w=2 for a further patch (waiting to see if there are any comments on the list before committing).
Comment 57 Anders Lund 2009-01-28 20:42:50 UTC
Hi Jonathan, Your patch looks sensible to me.
I think the automatic resizing of the headers should be canceled when the user selects some sizes, it is completely unusable. There is the same issue in the file dialog.

Personally I want the title as wide as possible, and the date and feed columns set to a suitable widths. The author column is never used for anything sensible, so i would love for it to stay hidden.
Comment 58 eric 2009-01-29 04:51:21 UTC
The column width problem has disappeared for me. I must say that I'm using a snapshot of qt-4.5, but maybe the problem has disappeared too for qt<=4.5.

The commits of Frank Osterfeld were done after 4.2.0 was released... so I've patched and recompiled kdepim-4.2.0 with those commits and the akregator-patch from Jonathan Marten. I didn't use the qt-patch from Jonathan Marten because I couldn't apply the patch on my version of qt. I did have to modify the akregator-patch of Jonathan a little bit, because there was an other commit between his commit and the last commit of Frank.
Comment 59 Frank Osterfeld 2009-01-29 09:36:54 UTC
As Eric said, I fixed it after 4.2.0 was tagged. So I consider this still fixed. Jonathan's issue is different enough to deserve it's own bug report.
Eric: So the issue is gone for you with the current qt 4.5 snapshot? I'll have a look they did changes in headerview. Until now, the behavior when using 4.5 was even worse, as it lost the settings even when switching feeds (i.e., item models), not only on restart.
Comment 60 Blackpaw 2009-01-29 14:05:44 UTC
Well I have KDE: 4.2.60 (KDE 4.2.60 (KDE 4.3 >= 20090116)) built and its still broken in that. I'll update to latest.
Comment 61 Christophe Giboudeaux 2009-01-29 14:13:42 UTC
Well I have KDE: 4.2.60 (KDE 4.2.60 (KDE 4.3 >= 20090116)

You can't see the fix in this snapshot (they were applied the 23 jan.)
Comment 62 Jonathan Marten 2009-01-29 17:03:28 UTC
SVN commit 918196 by marten:

Work around possible Qt 4.4 bug causing the last column to expand beyond
the viewport width.  Re-evaluate this after the transition to Qt 4.5.

CCBUG:152702


 M  +12 -0     articlelistview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=918196
Comment 63 eric 2009-01-30 00:06:53 UTC
(In reply to comment #59)
> Eric: So the issue is gone for you with the current qt 4.5 snapshot? I'll have
> a look they did changes in headerview. Until now, the behavior when using 4.5
> was even worse, as it lost the settings even when switching feeds (i.e., item
> models), not only on restart.
 
My qt version is the qt-4.5 snapshot of 20090127. Before these patches I didn't have this issue after a restart, only when switching feeds. The "amnesia" only happened when switching feeds in the same session, not between closing and restarting kontact.
Now this issue is gone.
Comment 64 Frank Osterfeld 2009-02-01 12:38:40 UTC
SVN commit 919567 by osterfeld:

fix some issues I had with the feed/group settings separation:
Settings weren't saved when switching modes, also save state when saving settings
Remove useless "Unspecified" state and redundant m_aggregationMode flag. 
CCBUG:152702
CCMAIL:jjm@keelhaul.me.uk


 M  +19 -15    articlelistview.cpp  
 M  +1 -2      articlelistview.h  
 M  +1 -1      selectioncontroller.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=919567
Comment 65 Frank Osterfeld 2009-02-02 14:51:34 UTC
*** Bug 182836 has been marked as a duplicate of this bug. ***
Comment 66 georgi 2009-02-13 09:41:17 UTC
Will the fix be in 4.2.1?
Comment 67 Jonathan Marten 2009-02-17 17:01:43 UTC
*** Bug 182776 has been marked as a duplicate of this bug. ***
Comment 68 Christophe Giboudeaux 2009-02-25 13:44:22 UTC
*** Bug 185521 has been marked as a duplicate of this bug. ***
Comment 69 Igor Poboiko 2009-03-08 23:23:19 UTC
Bug still exists in KDE 4.2.1...
Comment 70 GML 2009-03-09 10:31:08 UTC
In my KDE 4.2.1, the bug is fixed.

Are you sure that your aKregator has been updated ? In my Gentoo, only kdebase was updated.
Comment 71 René Krell 2009-03-09 10:39:09 UTC
In OpenSUSE 11.1 / KDE 4.2 Factory updates the fix works fine.
The columns and column settings are saved and restored now normally.
Comment 72 Anders Lund 2009-03-09 14:06:42 UTC
My kontact says version 1.4.1, using KDE 4.2.1, and still haves problems. Sometimes columns are restored, sometimes it is attempted (but not succesfully), sometimes all configuration is lost. Kontact is allmost always opened by the session manager (except when i crashes).

About like the version that came with kde 4.0. So as fra as I am concerned, this is NOT fixed.
Comment 73 Mark Ziegler 2009-03-09 17:40:56 UTC
I use openSUSE 11.0 and KDE 4.2.1 and here it works fine now.
So it is fixed :-)

Which qt version do you use?
I installed 4.5 to solve my problem. 4.4 didn't work.

Regards
Comment 74 Anders Lund 2009-03-09 17:55:19 UTC
I have qt 4.4.3. KDE 4.2.1 does not require qt 4.5, so it is not fixed.
Comment 75 Blackpaw 2009-03-09 21:58:45 UTC
<i>"My kontact says version 1.4.1, using KDE 4.2.1, and still haves problems.
Sometimes columns are restored, sometimes it is attempted (but not
succesfully), sometimes all configuration is lost. Kontact is allmost always
opened by the session manager (except when i crashes)."</i>

I'm seeing exactly this behaviour in Kubuntu 8.10 (Intrepid) with backports (KDE 4.2.1/Qt 4.4.3), though my install is pretty crufty with test stuff :)

Kubuntu Jaunty Alpha 5 - KDE 4.2.1/Qt 4.5 works perfectly, Kmail/Akgregator all fixed.
Comment 76 Panagiotis Papadopoulos 2009-04-10 15:38:43 UTC
On my Akregator in KDE 4.2.2 with Qt 4.5 the width of the columns in the article list is fixed.

The problem now is:

The width of the "feeds list" (on the right side of the window) is not remembered.

On every startup, I resize the "Total" column in the feed list, and I end up in having to do it again on the next startup...
Comment 77 Blackpaw 2009-04-10 16:05:23 UTC
Same here as #76
Comment 78 Jonathan Marten 2009-04-10 16:17:42 UTC
Regarding comment #76:  The following patch fixes the feed list needing to be resized on startup.  According to Frank Osterfeld in http://lists.kde.org/?l=kde-pim&m=123322450608334&w=2 this should not be necessary, but it seems to be needed even with Qt 4.5.  I've been running Akregator with this fix included for several weeks, and have never had to do any column resizing.

--- src/subscriptionlistview.cpp        (revision 951401)
+++ src/subscriptionlistview.cpp        (working copy)
@@ -216,6 +217,7 @@
 {
     const KConfigGroup conf( Settings::self()->config(), "General" );
     m_headerState = QByteArray::fromBase64( conf.readEntry( "SubscriptionListHeaders" ).toAscii() );
+    header()->restoreState( m_headerState );           // needed, even with Qt 4.5
 }

 void Akregator::SubscriptionListView::slotPrevFeed()
Comment 79 Frank Osterfeld 2009-04-10 22:42:40 UTC
*** Bug 186773 has been marked as a duplicate of this bug. ***
Comment 80 Frank Osterfeld 2009-04-10 22:43:48 UTC
*** Bug 189076 has been marked as a duplicate of this bug. ***
Comment 81 Jonathan Marten 2009-05-04 08:23:27 UTC
SVN commit 963187 by marten:

Really really really make sure that the feed list header state is restored
on startup.  This should in theory not be necessary, but without it the
"Unread" column expands and the list gets a horizontal scroll bar every time
Akregator is started.

CCBUG:152702


 M  +1 -0      subscriptionlistview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=963187
Comment 82 Christophe Giboudeaux 2009-05-26 15:03:59 UTC
*** Bug 194150 has been marked as a duplicate of this bug. ***
Comment 83 M G Berberich 2009-05-29 10:28:49 UTC
if article list is reodered so that for feeds “Date” is the first column, “Title“ the second and all others hidden and for group the order is title, origin and date the date-column collapses to zero width every time one changes to a group and back to a feed.
Comment 84 Maciej Pilichowski 2009-06-23 21:10:49 UTC
In what version of KDE (I mean, release) this bug is fixed -- in opensuse 11.1 and KDE 4.3 beta 2 after every restart akregator layout is the default one, so I have to resize panes after first using it (in given day).

100% reproduceable. 
1) show akregator window
2) resize panes
3) restart computer, wait for KDE
4) show akregator window -- default sizes of panes
Comment 85 FiNeX 2009-06-24 10:13:17 UTC
I'm able to reproduce this bug using current trunk (r986082)
Comment 86 Jonathan Marten 2009-06-24 17:34:28 UTC
Can reproduce problem in comment #83 with current trunk (r986158).

However, cannot reproduce problem in comment #84.  Both column widths/configurations and splitter sizes are saved and restored correctly over a restart of Akregator or the computer.
Comment 87 Jonathan Marten 2009-06-26 12:12:04 UTC
For another instance of the problem in comment #83, see bug 184960 comment #2 "Another related problem".
Comment 88 Helge Deller 2009-07-14 20:00:52 UTC
isn't this bug similar to bug #176262 (or vice versa) ?
Comment 89 Christophe Giboudeaux 2010-02-22 01:56:36 UTC
*** Bug 176262 has been marked as a duplicate of this bug. ***
Comment 90 Christophe Giboudeaux 2010-02-22 01:57:49 UTC
No comment in 6 monthes, I suppose it is now fixed for everyone ? (in KDE 4.4/Akregator 1.6.0)
Comment 91 Blackpaw 2010-02-22 03:19:46 UTC
Yup, definitely fixed for me.
Comment 92 Anders Lund 2010-02-22 05:26:48 UTC
Yes, this seems to be fixed :-)
Comment 93 Γιώργος Κυλάφας (Giorgos Kylafas) 2010-02-22 06:41:06 UTC
Yes, it is fixed for me at least since KDE 4.3.4/Akregator 1.5.3.
Comment 94 Christophe Giboudeaux 2010-02-22 09:50:34 UTC
Thanks for the feedback.
Comment 95 FiNeX 2010-02-22 11:01:15 UTC
I confirm it works on KDE SC 4.4.0 :)
Comment 96 Graeme Hewson 2012-03-20 11:26:46 UTC
I'm seeing the problem in Akregator 4.7.3 using KDE Development Platform 4.7.4 under Kubuntu 11.10.

On my screen I see the dates and the first digit of the hours, with the rest of the time represented by three dots. I can adjust the width of the date column to show the complete time, but if I click in another feed I again see the truncated time. Going back to the feed where I adjusted the column, the date column has reverted to the default.

Changing the date sort order and removing the Author column affects all feeds, and is remembered when I stop and restart Akregator.