Bug 176262 - Akregator loses it's display settings
Summary: Akregator loses it's display settings
Status: RESOLVED DUPLICATE of bug 152702
Alias: None
Product: akregator
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal with 60 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 176265 179587 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-11-27 20:15 UTC by Silvian Cretu
Modified: 2010-02-22 01:56 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Silvian Cretu 2008-11-27 20:15:31 UTC
Version:           1.3.3 (using 4.1.3 (KDE 4.1.3), Kubuntu packages)
Compiler:          cc
OS:                Linux (x86_64) release 2.6.27-7-generic

Akregator 1.3.3 doesn't remember the
- the size of the columns,
- the visible/hidden columns (for example, I disable the Feed and Author columns, keeping only Title and Date),
- the size of the sidebar (containing the list of the feeds)

Every time I start it (after my computer was turned on, for example), I have to adjust these minor details to get rid of the horizontal scroll bars...

Please fix this annoying bug!

Thanks!
Comment 1 Christopher Neufeld 2008-11-28 02:32:04 UTC
Folding over my comments from bug 176265.

Also nice would be persistence of the sort order and the height of the articles window.
Comment 2 Christopher Neufeld 2008-11-28 02:34:49 UTC
*** Bug 176265 has been marked as a duplicate of this bug. ***
Comment 3 Frank Osterfeld 2008-11-30 22:56:45 UTC
SVN commit 891008 by osterfeld:

save settings from MainWidget::saveSettings, hopefully this fixes the issues with articlelistview settings not 
saved/restored reliably.
CCBUG:176262


 M  +0 -1      articlelistview.cpp  
 M  +2 -1      articlelistview.h  
 M  +2 -0      mainwidget.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=891008
Comment 4 Christopher Neufeld 2008-12-02 03:03:42 UTC
Those settings are now restored correctly, as of svn revision 891384.
Comment 5 Frank Osterfeld 2008-12-02 22:14:28 UTC
Please observe over some time. Restoring the settings always worked for me when I tried to debug it ;). But then, another time, they got lost again, I wasn't able to see any pattern.
So I don't yet trust it to be fixed.
Comment 6 Cyrill Helg 2008-12-12 13:09:23 UTC
Whenever kontact crashes, akregator loses those settings again.

From time to time akregator still loses display settings for no reason. This is the last most annoying kde4 bug for me... :S
Comment 7 Salvatore 2009-01-03 13:18:51 UTC
*** This bug has been confirmed by popular vote. ***
Comment 8 Milan Krivda 2009-01-07 09:45:20 UTC
*** Bug 179587 has been marked as a duplicate of this bug. ***
Comment 9 Milan Krivda 2009-01-07 09:47:07 UTC
I am using build from svn and that bug hasnt been fixed.
Comment 10 Cyrill Helg 2009-01-17 21:49:22 UTC
oh come on, please could someone have a look at this? Its totally annoying. I have to restore my settings daily by hand.

Comment 11 Frank Osterfeld 2009-01-24 19:21:31 UTC

*** This bug has been marked as a duplicate of bug 152702 ***
Comment 12 Silvian Cretu 2009-01-28 14:18:51 UTC
(In reply to comment #11)
> 
> 
> *** This bug has been marked as a duplicate of bug 152702 ***
> 

Pay attention! This bug is about the Akregator in KDE 4.x, while 152702 is related to the old Akregator in KDE 3.5.x!
So, the bug is not solved, yet...
Comment 13 Frank Osterfeld 2009-01-29 09:43:16 UTC
No, 152702 is about 4.x. Everyone except comment #1 talks about 4.x, and the fix is also for 4.x.

Note that the fix didn't make it into 4.2.0, as 4.2.0 was tagged before it.
So unless someone with current 4.2 branch/ >= 4.2.1 reports that it still doesn't work for him, I consider this one fixed.
Comment 14 Jonathan 2009-03-14 21:12:56 UTC
bad news. Still have some issues...

i'm using kubuntu 8.10 with KDE4.2.1 (from http://www.kubuntu.org/news/kde-4.2), akregator 1.4.1

maximized window
close it
click on the icon from taskbar

=> window size and position is lost everytime
Comment 15 Cyrill Helg 2009-04-10 18:51:11 UTC
This bug is still present in kde 4.2.2 in the feeds view on the left in akregator.
Comment 16 Cyrill Helg 2009-04-10 18:53:55 UTC
Additional note: The width of the column Unread is not saved. Steps to reproduce:
 
1. change the width to something smaller.
2. Close kontact with akregator in it.
3. Restart kontact
4. See the column width of Unread too wide again :S
Comment 17 Milan Krivda 2009-04-10 22:19:23 UTC
(In reply to comment #15)
> This bug is still present in kde 4.2.2 in the feeds view on the left in
> akregator.

I confirm that.
Comment 18 Ruchir Brahmbhatt 2009-04-11 13:48:15 UTC
I can confirm this is still present in kontact 1.4.2. Resize last column in left view in feeds to get rid of scroll bar, restart kontact and open feeds again, column settings are gone.

Resized:
http://imagebin.ca/view/VEOpXI.html

After restart:
http://imagebin.ca/view/hQMgYEZj.html
Comment 19 Florian Staudacher 2009-05-18 14:05:34 UTC
confirmed for 1.4.2 kubuntu packages, too!
very annoying...
Comment 20 Helge Deller 2009-05-23 21:43:18 UTC
I can confirm this really annoying behavior with the Fedora packages as well:
Fedora10, KDE 4.2.3, Akregator 1.4.2, kdepim-4.2.3-1.fc10.i386.rpm
Comment 21 Jonathan 2009-06-08 22:12:32 UTC
bug from Comment #18 is still present in akregator 1.4.4. Tested on Kubuntu 9.04 with KDE 2.4.4
Comment 22 Christophe Giboudeaux 2010-02-22 01:56:36 UTC

*** This bug has been marked as a duplicate of bug 152702 ***