Bug 182017 - sort by date almost impossible
Summary: sort by date almost impossible
Status: RESOLVED DUPLICATE of bug 152702
Alias: None
Product: akregator
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-26 20:36 UTC by Neal Becker
Modified: 2009-01-26 21:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Neal Becker 2009-01-26 20:36:08 UTC
Version:           1.4.0 (using 4.2.00 (KDE 4.2.0), 4.2.0-1.fc10 Fedora)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.27.9-159.fc10.x86_64

Just updated from kde4.2.0rc to 4.2.0.  Was NOT a problem with 4.2.0rc.

I can easily sort by title, and clicking on 'title' will switch between sort forward/backward, indicated by an arrow.  All good.

Not for date.
1) Never shows an arrow
2) Wants to sort with most recent at bottom.  Only by randomly clicking all over the place did I manage to get it to sort with most recent on top.

I tried killing/restarting akregator 2 times and it did not fix this problem.

This is especially annoying because often when ak is started, it decides to ignore my previous settings, enable all the fields (which I had disabled), and sort by title.
Comment 1 Frank Osterfeld 2009-01-26 20:52:14 UTC
> 1) Never shows an arrow 

That's probably because the date is the last column and often too wide (still unsolved), so the arrow is outside of the current visible area. Try to scroll horizontally.

> This is especially annoying because often when ak is started, it decides to
> ignore my previous settings, enable all the fields (which I had disabled), and 
> sort by title. 

This part should be fixed now, in 4.2 branch and trunk, see https://bugs.kde.org/show_bug.cgi?id=152702 .

Which should reduce your problem to "date column is too wide" I think
Comment 2 Neal Becker 2009-01-26 21:07:43 UTC
Confirmed.

*** This bug has been marked as a duplicate of bug 152702 ***