Bug 253584 - Plasma crash when I disabled/enabled wireless in plasma-networkmanager plugin [invalid qobject_cast<RemoteInterfaceConnection*>, ActivatableItem::interfaceConnection, ActivatableListWidget::hoverEnter]
Summary: Plasma crash when I disabled/enabled wireless in plasma-networkmanager plugin...
Status: RESOLVED FIXED
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: Plasma Widget (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Kügler
URL:
Keywords:
: 255566 257574 257701 257886 261019 263955 264382 264793 265553 267206 268516 268823 268862 269407 269821 270336 271670 281282 283238 285727 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-08 13:21 UTC by Clemens Eisserer
Modified: 2011-11-04 14:45 UTC (History)
19 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (10.49 KB, text/plain)
2011-02-14 12:38 UTC, omega
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Clemens Eisserer 2010-10-08 13:21:00 UTC
Version:           unspecified (using KDE 4.5.1) 
OS:                Linux

When I clicked disabled and the re-enabled wireless networking in the plasma-networkmanager-plugin I got the following crash.
Because there isn't a single line which mentions the plugin, I report this under "general":

Thread 1 (Thread 0xb78349b0 (LWP 1797)):
[KCrash Handler]
#7  0x06ad23d4 in vtable for QtSharedPointer::ExternalRefCountData () from /usr/lib/libQtCore.so.4
#8  0x0b04d950 in ?? ()
#9  0x012ef26b in qobject_cast<RemoteInterfaceConnection*> (this=0xaf2a8b8) at /usr/include/QtCore/qobject.h:455
#10 ActivatableItem::interfaceConnection (this=0xaf2a8b8) at /usr/src/debug/networkmanagement-0.9/applet/activatableitem.cpp:88
#11 0x012e4c0c in ActivatableListWidget::hoverEnter (this=0xa4d5bf8, uni=...) at /usr/src/debug/networkmanagement-0.9/applet/activatablelistwidget.cpp:286
#12 0x012dbe45 in ActivatableListWidget::qt_metacall (this=0xa4d5bf8, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0xbfa37968)
    at /usr/src/debug/networkmanagement-0.9/i686-redhat-linux-gnu/applet/moc_activatablelistwidget.cpp:101
#13 0x069a7f8b in QMetaObject::metacall (object=0xa4d5bf8, cl=QMetaObject::InvokeMetaMethod, idx=44, argv=0xbfa37968) at kernel/qmetaobject.cpp:237
#14 0x069ba39d in QMetaObject::activate (sender=0xa53f148, m=0x12fa0a4, local_signal_index=4, argv=0xbfa37968) at kernel/qobject.cpp:3272
#15 0x012daab4 in InterfaceItem::hoverEnter (this=0xa53f148, _t1=...) at /usr/src/debug/networkmanagement-0.9/i686-redhat-linux-gnu/applet/moc_interfaceitem.cpp:164
#16 0x012e64b4 in InterfaceItem::hoverEnterEvent (this=0xa53f148, event=0xbfa37afc) at /usr/src/debug/networkmanagement-0.9/applet/interfaceitem.cpp:457
#17 0x02793fd2 in QGraphicsItem::sceneEvent (this=0xa53f150, event=0xbfa37afc) at graphicsview/qgraphicsitem.cpp:6654
#18 0x027e7e38 in QGraphicsWidget::sceneEvent (this=0xa53f148, event=0xbfa37afc) at graphicsview/qgraphicswidget.cpp:1173
#19 0x027ab337 in QGraphicsScenePrivate::sendEvent (this=0x904fca0, item=0xa53f150, event=0xbfa37afc) at graphicsview/qgraphicsscene.cpp:1211
#20 0x027ab6a8 in QGraphicsScenePrivate::sendHoverEvent (this=0x904fca0, type=QEvent::GraphicsSceneHoverEnter, item=0xa53f150, hoverEvent=0xbfa37c0c) at graphicsview/qgraphicsscene.cpp:1258
#21 0x027b1304 in QGraphicsScenePrivate::dispatchHoverEvent (this=0x904fca0, hoverEvent=0xbfa37c0c) at graphicsview/qgraphicsscene.cpp:3921
#22 0x027b1688 in QGraphicsScene::mouseMoveEvent (this=0x9047ee8, mouseEvent=0xbfa38194) at graphicsview/qgraphicsscene.cpp:4080
#23 0x027c56b5 in QGraphicsScene::event (this=0x9047ee8, event=0xbfa38194) at graphicsview/qgraphicsscene.cpp:3437
#24 0x0214347c in QApplicationPrivate::notify_helper (this=0x9056b98, receiver=0x9047ee8, e=0xbfa38194) at kernel/qapplication.cpp:4396
#25 0x02149a26 in QApplication::notify (this=0x9042578, receiver=0x9047ee8, e=0xbfa38194) at kernel/qapplication.cpp:3798
#26 0x07393f7b in KApplication::notify (this=0x9042578, receiver=0x9047ee8, event=0xbfa38194) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#27 0x069a2ba3 in QCoreApplication::notifyInternal (this=0x9042578, receiver=0x9047ee8, event=0xbfa38194) at kernel/qcoreapplication.cpp:732
#28 0x0214303f in sendSpontaneousEvent (receiver=0x9047ee8, event=0xbfa38194) at ../../src/corelib/kernel/qcoreapplication.h:218
#29 qt_sendSpontaneousEvent (receiver=0x9047ee8, event=0xbfa38194) at kernel/qapplication.cpp:5388
#30 0x027e1e22 in QGraphicsViewPrivate::mouseMoveEventHandler (this=0xa56a020, event=0xbfa389e0) at graphicsview/qgraphicsview.cpp:647
#31 0x027e2067 in QGraphicsView::mouseMoveEvent (this=0xa56a008, event=0xbfa389e0) at graphicsview/qgraphicsview.cpp:3272
#32 0x0219610f in QWidget::event (this=0xa56a008, event=0xbfa389e0) at kernel/qwidget.cpp:8172
#33 0x02588354 in QFrame::event (this=0xa56a008, e=0xbfa389e0) at widgets/qframe.cpp:557
#34 0x02619283 in QAbstractScrollArea::viewportEvent (this=0xa56a008, e=0xbfa389e0) at widgets/qabstractscrollarea.cpp:1043
#35 0x027df833 in QGraphicsView::viewportEvent (this=0xa56a008, event=0xbfa389e0) at graphicsview/qgraphicsview.cpp:2862
#36 0x0261b8b5 in viewportEvent (this=0xa56b0b0, o=0xa569730, e=0xbfa389e0) at widgets/qabstractscrollarea_p.h:100
#37 QAbstractScrollAreaFilter::eventFilter (this=0xa56b0b0, o=0xa569730, e=0xbfa389e0) at widgets/qabstractscrollarea_p.h:116
#38 0x069a229a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9056b98, receiver=0xa569730, event=0xbfa389e0) at kernel/qcoreapplication.cpp:847
#39 0x0214345a in QApplicationPrivate::notify_helper (this=0x9056b98, receiver=0xa569730, e=0xbfa389e0) at kernel/qapplication.cpp:4392
#40 0x0214a5ce in QApplication::notify (this=0x9042578, receiver=0xa569730, e=0xbfa389e0) at kernel/qapplication.cpp:3959
#41 0x07393f7b in KApplication::notify (this=0x9042578, receiver=0xa569730, event=0xbfa389e0) at /usr/src/debug/kdelibs-4.5.2/kdeui/kernel/kapplication.cpp:310
#42 0x069a2ba3 in QCoreApplication::notifyInternal (this=0x9042578, receiver=0xa569730, event=0xbfa389e0) at kernel/qcoreapplication.cpp:732
#43 0x021482c8 in sendEvent (receiver=0xa569730, event=0xbfa389e0, alienWidget=0xa569730, nativeWidget=0xa5682f0, buttonDown=0x2a88b00, lastMouseReceiver=..., spontaneous=true)
    at ../../src/corelib/kernel/qcoreapplication.h:215
#44 QApplicationPrivate::sendMouseEvent (receiver=0xa569730, event=0xbfa389e0, alienWidget=0xa569730, nativeWidget=0xa5682f0, buttonDown=0x2a88b00, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:3058
#45 0x021c8e70 in QETWidget::translateMouseEvent (this=0xa5682f0, event=0xbfa38efc) at kernel/qapplication_x11.cpp:4403
#46 0x021c8205 in QApplication::x11ProcessEvent (this=0x9042578, event=0xbfa38efc) at kernel/qapplication_x11.cpp:3414
#47 0x021f3d52 in x11EventSourceDispatch (s=0x9059840, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#48 0x00b76525 in g_main_dispatch (context=0x9058c90) at gmain.c:1960
#49 IA__g_main_context_dispatch (context=0x9058c90) at gmain.c:2513
#50 0x00b7a268 in g_main_context_iterate (context=0xae8490, block=1, dispatch=1, self=0x90567e8) at gmain.c:2591
#51 0x00b7a449 in IA__g_main_context_iteration (context=0x9058c90, may_block=1) at gmain.c:2654
#52 0x069cd5b6 in QEventDispatcherGlib::processEvents (this=0x902c9d0, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#53 0x021f37c6 in QGuiEventDispatcherGlib::processEvents (this=0x902c9d0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#54 0x069a171a in QEventLoop::processEvents (this=0xbfa391f4, flags=...) at kernel/qeventloop.cpp:149
#55 0x069a1a7a in QEventLoop::exec (this=0xbfa391f4, flags=...) at kernel/qeventloop.cpp:201
#56 0x069a69d7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#57 0x02142458 in QApplication::exec () at kernel/qapplication.cpp:3672
#58 0x07c50d20 in kdemain (argc=1, argv=0xbfa39404) at /usr/src/debug/kdebase-workspace-4.5.2/plasma/desktop/shell/main.cpp:118
#59 0x080487bc in main (argc=1, argv=0xbfa39404) at /usr/src/debug/kdebase-workspace-4.5.2/i686-redhat-linux-gnu/plasma/desktop/shell/plasma-desktop_dummy.cpp:3

Reproducible: Didn't try
Comment 1 Clemens Eisserer 2010-10-08 13:21:41 UTC
fotgot to mention, this was under 4.5.2 - bugstill still doesn't have an entry for that one.
Comment 2 Dario Andres 2010-11-18 16:35:06 UTC
[Comment from a bug triager]
From bug 255566:
I tried to disable wireless in plasma-widget-networkmanagement
0.9~svn1176084-0ubuntu1 and got this crash.
Comment 3 Dario Andres 2010-11-18 16:35:17 UTC
*** Bug 255566 has been marked as a duplicate of this bug. ***
Comment 4 Dario Andres 2010-11-24 19:27:22 UTC
*** Bug 257701 has been marked as a duplicate of this bug. ***
Comment 5 Dario Andres 2010-11-27 22:59:41 UTC
*** Bug 257886 has been marked as a duplicate of this bug. ***
Comment 6 Dario Andres 2010-12-23 00:59:34 UTC
[Comment from a bug triager]
From bug 261019:
- What I was doing when the application crashed:
i was trying to view some changelog for Jack2 on launchpad.net then i
deconnected Internet and then crash!
Comment 7 Dario Andres 2010-12-23 00:59:45 UTC
*** Bug 261019 has been marked as a duplicate of this bug. ***
Comment 8 Dario Andres 2011-01-22 12:33:42 UTC
*** Bug 263955 has been marked as a duplicate of this bug. ***
Comment 9 Dario Andres 2011-01-29 14:27:29 UTC
*** Bug 264382 has been marked as a duplicate of this bug. ***
Comment 10 Dario Andres 2011-01-30 02:54:20 UTC
*** Bug 264793 has been marked as a duplicate of this bug. ***
Comment 11 Dario Andres 2011-02-06 18:02:26 UTC
*** Bug 265553 has been marked as a duplicate of this bug. ***
Comment 12 Lamarque V. Souza 2011-02-11 02:57:29 UTC
*** Bug 257574 has been marked as a duplicate of this bug. ***
Comment 13 omega 2011-02-14 12:38:20 UTC
Created attachment 57244 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.6.00 (4.6.0) using Qt 4.7.1

- What I was doing when the application crashed:

When I clicked disabled and the re-enabled wireless networking in the plasma-networkmanager I got the following crash.

-- Backtrace (Reduced):
#7  0x00007f09307108ac in ActivatableListWidget::hoverEnter (this=<value optimized out>, uni=...) at ../../applet/activatablelistwidget.cpp:286
#8  0x00007f0930707821 in ActivatableListWidget::qt_metacall (this=0x2376860, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff473bf100) at moc_activatablelistwidget.cpp:101
[...]
#10 0x00007f09307080f5 in InterfaceItem::hoverEnter (this=<value optimized out>, _t1=<value optimized out>) at moc_interfaceitem.cpp:164
#11 0x00007f0930712f80 in InterfaceItem::hoverEnterEvent (this=0x7f0938020760, event=0x7fff473bf1b0) at ../../applet/interfaceitem.cpp:457
#12 0x00007f095814fb58 in QGraphicsItem::sceneEvent (this=0x7f0938020770, event=0x7fff473bf1b0) at graphicsview/qgraphicsitem.cpp:6686
Comment 14 Lamarque V. Souza 2011-02-27 20:07:05 UTC
Git commit f32ca1059a67f6e854658063ab6ac9be028429a0 by Lamarque V. Souza.
Committed on 27/02/2011 at 19:56.
Pushed by lvsouza into branch 'master'.

Prevent potential crash if ActivatableListWidget::setHasWireless(false)
is called after ActivatableListWidget::listDisappeared().

CCBUG: 253584

M  +1    -0    applet/activatablelistwidget.cpp     

http://commits.kde.org/networkmanagement/f32ca1059a67f6e854658063ab6ac9be028429a0
Comment 15 Dario Andres 2011-03-08 19:37:48 UTC
*** Bug 267206 has been marked as a duplicate of this bug. ***
Comment 16 Lamarque V. Souza 2011-03-14 23:02:38 UTC
*** Bug 268516 has been marked as a duplicate of this bug. ***
Comment 17 Lamarque V. Souza 2011-03-18 22:16:12 UTC
*** Bug 268823 has been marked as a duplicate of this bug. ***
Comment 18 Lamarque V. Souza 2011-03-26 00:03:45 UTC
*** Bug 269407 has been marked as a duplicate of this bug. ***
Comment 19 Lamarque V. Souza 2011-03-31 17:00:30 UTC
*** Bug 269821 has been marked as a duplicate of this bug. ***
Comment 20 Lamarque V. Souza 2011-04-07 19:01:15 UTC
*** Bug 270336 has been marked as a duplicate of this bug. ***
Comment 21 Lamarque V. Souza 2011-04-26 03:11:59 UTC
*** Bug 271670 has been marked as a duplicate of this bug. ***
Comment 22 Lamarque V. Souza 2011-04-26 03:30:27 UTC
Git commit 2f53877dda7981a64fd014c862c6777ae457dbeb by Lamarque V. Souza.
Committed on 26/04/2011 at 03:37.
Pushed by lvsouza into branch 'master'.

This was missing from the previous commit.

CCBUG: 253584

M  +1    -1    applet/activatableitem.cpp     
M  +4    -1    applet/wirelessnetworkitem.cpp     

http://commits.kde.org/networkmanagement/2f53877dda7981a64fd014c862c6777ae457dbeb
Comment 23 Lamarque V. Souza 2011-04-26 03:30:27 UTC
Git commit c9db71b706b981abafae0b0152700809f87ed123 by Lamarque V. Souza.
Committed on 26/04/2011 at 03:37.
Pushed by lvsouza into branch 'nm09'.

This was missing from the previous commit.

CCBUG: 253584
(cherry picked from commit 2f53877dda7981a64fd014c862c6777ae457dbeb)

M  +1    -1    applet/activatableitem.cpp     
M  +4    -1    applet/wirelessnetworkitem.cpp     

http://commits.kde.org/networkmanagement/c9db71b706b981abafae0b0152700809f87ed123
Comment 24 Lamarque V. Souza 2011-04-26 03:30:27 UTC
Git commit 7bed1941280fffa8a545879207587c9e490782b8 by Lamarque V. Souza.
Committed on 26/04/2011 at 03:23.
Pushed by lvsouza into branch 'master'.

Try to avoid dangling pointer when deleting RemoteInterfaceConnection
objects.

CCBUG: 253584

M  +1    -0    applet/activatableitem.cpp     
M  +2    -2    libs/client/remoteactivatablelist.cpp     

http://commits.kde.org/networkmanagement/7bed1941280fffa8a545879207587c9e490782b8
Comment 25 Lamarque V. Souza 2011-04-26 03:30:27 UTC
Git commit b3715e40ea224e32b0bf1205e4f087fdb49e9e65 by Lamarque V. Souza.
Committed on 26/04/2011 at 03:23.
Pushed by lvsouza into branch 'nm09'.

Try to avoid dangling pointer when deleting RemoteInterfaceConnection
objects.

CCBUG: 253584

M  +1    -0    applet/activatableitem.cpp     
M  +2    -2    libs/client/remoteactivatablelist.cpp     

http://commits.kde.org/networkmanagement/b3715e40ea224e32b0bf1205e4f087fdb49e9e65
Comment 26 Lamarque V. Souza 2011-05-09 04:02:02 UTC
*** Bug 268862 has been marked as a duplicate of this bug. ***
Comment 27 Lamarque V. Souza 2011-05-26 18:20:32 UTC
Can someone test if this problem is really fixed? I cannot reproduce it, so I will close this bug if nobody can reproduce it.
Comment 28 Lamarque V. Souza 2011-06-23 22:55:30 UTC
Closing bug. Reopen if it happens again.
Comment 29 Christoph Feck 2011-09-05 02:14:23 UTC
*** Bug 281282 has been marked as a duplicate of this bug. ***
Comment 30 Lamarque V. Souza 2011-10-05 13:47:21 UTC
*** Bug 283238 has been marked as a duplicate of this bug. ***
Comment 31 Lamarque V. Souza 2011-11-04 14:45:41 UTC
*** Bug 285727 has been marked as a duplicate of this bug. ***