Bug 267206 - Plasma crashed when I was disabling UMTS connection from Network Management
Summary: Plasma crashed when I was disabling UMTS connection from Network Management
Status: RESOLVED DUPLICATE of bug 253584
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-26 22:17 UTC by Giuseppe Mameli
Modified: 2011-03-08 19:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Backtrace (20.07 KB, application/octet-stream)
2011-03-03 10:26 UTC, Sebastian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Giuseppe Mameli 2011-02-26 22:17:14 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-25-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed: when I disable UMTS connection (Option Qualcomm card) plasma crashed with no apparent reason

-- Backtrace:
Application: Spazio di lavoro di Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7862a00 (LWP 1850))]

Thread 2 (Thread 0xae7b9b70 (LWP 1853)):
#0  0x00b91e36 in clock_gettime () from /lib/librt.so.1
#1  0x045bc50b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x046936e5 in QTimerInfoList::updateCurrentTime (this=0xa259d94) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0469372a in QTimerInfoList::timerWait (this=0xa259d94, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x046917a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xae7b909c) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0469183d in timerSourcePrepare (source=0x0, timeout=0xb95ff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x04ef1e6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x04ef2279 in ?? () from /lib/libglib-2.0.so.0
#9  0x04ef2848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x0469159f in QEventDispatcherGlib::processEvents (this=0xa20cdb8, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x04661609 in QEventLoop::processEvents (this=0xae7b9270, flags=) at kernel/qeventloop.cpp:149
#12 0x04661a8a in QEventLoop::exec (this=0xae7b9270, flags=...) at kernel/qeventloop.cpp:201
#13 0x0455db7e in QThread::exec (this=0xa245ea8) at thread/qthread.cpp:490
#14 0x0464035b in QInotifyFileSystemWatcherEngine::run (this=0xa245ea8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x04560df9 in QThreadPrivate::start (arg=0xa245ea8) at thread/qthread_unix.cpp:266
#16 0x001b5cc9 in start_thread () from /lib/libpthread.so.0
#17 0x003fb69e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7862a00 (LWP 1850)):
[KCrash Handler]
#7  0x046688f7 in QMetaObject::cast (this=0x2103740, obj=0xa328648) at kernel/qmetaobject.cpp:266
#8  0x04885c0a in qobject_cast<RemoteInterfaceConnection*> (this=0xa38b1c0) at /usr/include/qt4/QtCore/qobject.h:455
#9  ActivatableItem::interfaceConnection (this=0xa38b1c0) at ../../applet/activatableitem.cpp:88
#10 0x04878f7c in ActivatableListWidget::hoverEnter (this=0xa1382c8, uni=...) at ../../applet/activatablelistwidget.cpp:286
#11 0x0486fa35 in ActivatableListWidget::qt_metacall (this=0xa1382c8, _c=QMetaObject::InvokeMetaMethod, _id=44, _a=0xbff04d08) at moc_activatablelistwidget.cpp:101
#12 0x046688ca in QMetaObject::metacall (object=0xa1382c8, cl=QMetaObject::InvokeMetaMethod, idx=44, argv=0xbff04d08) at kernel/qmetaobject.cpp:237
#13 0x0467b6ad in QMetaObject::activate (sender=0xa16cec0, m=0x488da2c, local_signal_index=4, argv=0x0) at kernel/qobject.cpp:3280
#14 0x0486eba3 in InterfaceItem::hoverEnter (this=0xa16cec0, _t1=...) at moc_interfaceitem.cpp:164
#15 0x0487b1f2 in InterfaceItem::hoverEnterEvent (this=0xa16cec0, event=0xbff04e9c) at ../../applet/interfaceitem.cpp:457
#16 0x036eb1a2 in QGraphicsItem::sceneEvent (this=0xa16cec8, event=0xbff04e9c) at graphicsview/qgraphicsitem.cpp:6654
#17 0x037424d7 in QGraphicsWidget::sceneEvent (this=0xa16cec0, event=0xbff04e9c) at graphicsview/qgraphicswidget.cpp:1173
#18 0x03703569 in QGraphicsScenePrivate::sendEvent (this=0x9a9a9c8, item=0xa16cec8, event=0xbff04e9c) at graphicsview/qgraphicsscene.cpp:1211
#19 0x037038ae in QGraphicsScenePrivate::sendHoverEvent (this=0x9a9a9c8, type=QEvent::GraphicsSceneHoverEnter, item=0xa16cec8, hoverEvent=0xbff04fac) at graphicsview/qgraphicsscene.cpp:1258
#20 0x03709b04 in QGraphicsScenePrivate::dispatchHoverEvent (this=0x9a9a9c8, hoverEvent=0xbff04fac) at graphicsview/qgraphicsscene.cpp:3921
#21 0x03709e68 in QGraphicsScene::mouseMoveEvent (this=0x99c9618, mouseEvent=0xbff05534) at graphicsview/qgraphicsscene.cpp:4080
#22 0x0371e57d in QGraphicsScene::event (this=0x99c9618, event=0xbff05534) at graphicsview/qgraphicsscene.cpp:3437
#23 0x03038fdc in QApplicationPrivate::notify_helper (this=0x99d8dd0, receiver=0x99c9618, e=0xbff05534) at kernel/qapplication.cpp:4396
#24 0x0303f04e in QApplication::notify (this=0x99c89d8, receiver=0x99c9618, e=0xbff05534) at kernel/qapplication.cpp:3798
#25 0x0111e68a in KApplication::notify (this=0x99c89d8, receiver=0x99c9618, event=0xbff05534) at ../../kdeui/kernel/kapplication.cpp:310
#26 0x04662b3b in QCoreApplication::notifyInternal (this=0x99c89d8, receiver=0x99c9618, event=0xbff05534) at kernel/qcoreapplication.cpp:732
#27 0x03038b9e in sendSpontaneousEvent (receiver=0x99c9618, event=0xa1edcf4) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#28 qt_sendSpontaneousEvent (receiver=0x99c9618, event=0xa1edcf4) at kernel/qapplication.cpp:5388
#29 0x0373c282 in QGraphicsViewPrivate::mouseMoveEventHandler (this=0xa22f6d8, event=0xbff05d80) at graphicsview/qgraphicsview.cpp:647
#30 0x0373c4c6 in QGraphicsView::mouseMoveEvent (this=0xa23f8a8, event=0xbff05d80) at graphicsview/qgraphicsview.cpp:3272
#31 0x03096caa in QWidget::event (this=0xa23f8a8, event=0xbff05d80) at kernel/qwidget.cpp:8172
#32 0x034b8763 in QFrame::event (this=0xa23f8a8, e=0xbff05d80) at widgets/qframe.cpp:557
#33 0x03555a82 in QAbstractScrollArea::viewportEvent (this=0x0, e=0xa1edcf4) at widgets/qabstractscrollarea.cpp:1043
#34 0x03739ccb in QGraphicsView::viewportEvent (this=0xa23f8a8, event=0xbff05d80) at graphicsview/qgraphicsview.cpp:2862
#35 0x035584d5 in viewportEvent (this=0xa210ee8, o=0xa20c7f0, e=0xbff05d80) at widgets/qabstractscrollarea_p.h:100
#36 QAbstractScrollAreaFilter::eventFilter (this=0xa210ee8, o=0xa20c7f0, e=0xbff05d80) at widgets/qabstractscrollarea_p.h:116
#37 0x0466229a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x99d8dd0, receiver=0xa20c7f0, event=0xbff05d80) at kernel/qcoreapplication.cpp:847
#38 0x03038fb9 in QApplicationPrivate::notify_helper (this=0x99d8dd0, receiver=0xa20c7f0, e=0xbff05d80) at kernel/qapplication.cpp:4392
#39 0x0303fc2e in QApplication::notify (this=0x99c89d8, receiver=0xa20c7f0, e=0xbff05d80) at kernel/qapplication.cpp:3959
#40 0x0111e68a in KApplication::notify (this=0x99c89d8, receiver=0xa20c7f0, event=0xbff05d80) at ../../kdeui/kernel/kapplication.cpp:310
#41 0x04662b3b in QCoreApplication::notifyInternal (this=0x99c89d8, receiver=0xa20c7f0, event=0xbff05d80) at kernel/qcoreapplication.cpp:732
#42 0x0303e094 in sendEvent (receiver=0xa20c7f0, event=0xbff05d80, alienWidget=0xa20c7f0, nativeWidget=0xa202b28, buttonDown=0x39d33c0, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#43 QApplicationPrivate::sendMouseEvent (receiver=0xa20c7f0, event=0xbff05d80, alienWidget=0xa20c7f0, nativeWidget=0xa202b28, buttonDown=0x39d33c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3058
#44 0x030ccd10 in QETWidget::translateMouseEvent (this=0xa202b28, event=0xbff0629c) at kernel/qapplication_x11.cpp:4403
#45 0x030cc151 in QApplication::x11ProcessEvent (this=0x99c89d8, event=0xbff0629c) at kernel/qapplication_x11.cpp:3414
#46 0x030fb36a in x11EventSourceDispatch (s=0x99dc040, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#47 0x04eee855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#48 0x04ef2668 in ?? () from /lib/libglib-2.0.so.0
#49 0x04ef2848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#50 0x04691565 in QEventDispatcherGlib::processEvents (this=0x99b1ce8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#51 0x030fabe5 in QGuiEventDispatcherGlib::processEvents (this=0x99b1ce8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#52 0x04661609 in QEventLoop::processEvents (this=0xbff06594, flags=) at kernel/qeventloop.cpp:149
#53 0x04661a8a in QEventLoop::exec (this=0xbff06594, flags=...) at kernel/qeventloop.cpp:201
#54 0x0466600f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#55 0x03037e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#56 0x0057f86e in kdemain (argc=1, argv=0xbff067a4) at ../../../../plasma/desktop/shell/main.cpp:118
#57 0x080485bb in main (argc=1, argv=0xbff067a4) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 265553, bug 263955.

Reported using DrKonqi
Comment 1 Sebastian 2011-03-03 10:26:42 UTC
Created attachment 57634 [details]
Backtrace

This is a backtrace I managed to save to file.
Comment 2 Sebastian 2011-03-03 10:27:46 UTC
Comment on attachment 57634 [details]
Backtrace

Sorry, wrong bug
Comment 3 Dario Andres 2011-03-08 19:37:48 UTC
[Comment from a bug triager]
This issue is being tracked at bug 253584.
Merging. Thanks

*** This bug has been marked as a duplicate of bug 253584 ***