Bug 285727 - Plasma desktop crash
Summary: Plasma desktop crash
Status: RESOLVED DUPLICATE of bug 253584
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: Plasma Widget (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-04 05:58 UTC by Jupiman
Modified: 2011-11-04 14:45 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jupiman 2011-11-04 05:58:16 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.5 (KDE 4.5.5)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-30-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:

Just logged in and then clicked on net settings on bottom panel of plasma desktop

-- Backtrace:
Application: Pracovní plocha Plasma (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7864720 (LWP 1746))]

Thread 2 (Thread 0xae8b9b70 (LWP 1749)):
#0  0x00fc2e36 in clock_gettime () from /lib/librt.so.1
#1  0x0625050b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x063276e5 in QTimerInfoList::updateCurrentTime (this=0x957ef3c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0632772a in QTimerInfoList::timerWait (this=0x957ef3c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x063257a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xae8b90ac) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0632583d in timerSourcePrepare (source=0x0, timeout=0xfc6ff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x058cae6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x058cb279 in ?? () from /lib/libglib-2.0.so.0
#9  0x058cb848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x0632559f in QEventDispatcherGlib::processEvents (this=0x957efe0, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x062f5609 in QEventLoop::processEvents (this=0xae8b9280, flags=) at kernel/qeventloop.cpp:149
#12 0x062f5a8a in QEventLoop::exec (this=0xae8b9280, flags=...) at kernel/qeventloop.cpp:201
#13 0x061f1b7e in QThread::exec (this=0x956ad48) at thread/qthread.cpp:490
#14 0x062d435b in QInotifyFileSystemWatcherEngine::run (this=0x956ad48) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x061f4df9 in QThreadPrivate::start (arg=0x956ad48) at thread/qthread_unix.cpp:266
#16 0x008e1cc9 in start_thread () from /lib/libpthread.so.0
#17 0x007d669e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7864720 (LWP 1746)):
[KCrash Handler]
#7  0x06427089 in vtable for BackEase () from /usr/lib/libQtCore.so.4
#8  0x09ed8768 in ?? ()
#9  0x01b6bc0a in qobject_cast<RemoteInterfaceConnection*> (this=0x9eda2c8) at /usr/include/qt4/QtCore/qobject.h:455
#10 ActivatableItem::interfaceConnection (this=0x9eda2c8) at ../../applet/activatableitem.cpp:88
#11 0x01b5ef7c in ActivatableListWidget::hoverEnter (this=0x9496290, uni=...) at ../../applet/activatablelistwidget.cpp:286
#12 0x01b55a35 in ActivatableListWidget::qt_metacall (this=0x9496290, _c=QMetaObject::InvokeMetaMethod, _id=44, _a=0xbf96bbf8) at moc_activatablelistwidget.cpp:101
#13 0x062fc8ca in QMetaObject::metacall (object=0x9496290, cl=4294967295, idx=44, argv=0xbf96bbf8) at kernel/qmetaobject.cpp:237
#14 0x0630f6ad in QMetaObject::activate (sender=0x94cc6c0, m=0x1b73a2c, local_signal_index=4, argv=0xffffebb0) at kernel/qobject.cpp:3280
#15 0x01b54ba3 in InterfaceItem::hoverEnter (this=0x94cc6c0, _t1=...) at moc_interfaceitem.cpp:164
#16 0x01b611f2 in InterfaceItem::hoverEnterEvent (this=0x94cc6c0, event=0xbf96bd8c) at ../../applet/interfaceitem.cpp:457
#17 0x03aea1a2 in QGraphicsItem::sceneEvent (this=0x94cc6c8, event=0xbf96bd8c) at graphicsview/qgraphicsitem.cpp:6654
#18 0x03b414d7 in QGraphicsWidget::sceneEvent (this=0x94cc6c0, event=0xbf96bd8c) at graphicsview/qgraphicswidget.cpp:1173
#19 0x03b02569 in QGraphicsScenePrivate::sendEvent (this=0x9049060, item=0x94cc6c8, event=0xbf96bd8c) at graphicsview/qgraphicsscene.cpp:1211
#20 0x03b028ae in QGraphicsScenePrivate::sendHoverEvent (this=0x9049060, type=QEvent::GraphicsSceneHoverEnter, item=0x94cc6c8, hoverEvent=0xbf96be9c) at graphicsview/qgraphicsscene.cpp:1258
#21 0x03b08b04 in QGraphicsScenePrivate::dispatchHoverEvent (this=0x9049060, hoverEvent=0xbf96be9c) at graphicsview/qgraphicsscene.cpp:3921
#22 0x03b08e68 in QGraphicsScene::mouseMoveEvent (this=0x8f98dc8, mouseEvent=0xbf96c424) at graphicsview/qgraphicsscene.cpp:4080
#23 0x03b1d57d in QGraphicsScene::event (this=0x8f98dc8, event=0xbf96c424) at graphicsview/qgraphicsscene.cpp:3437
#24 0x03437fdc in QApplicationPrivate::notify_helper (this=0x8f9c4c0, receiver=0x8f98dc8, e=0xbf96c424) at kernel/qapplication.cpp:4396
#25 0x0343e04e in QApplication::notify (this=0x8f907a8, receiver=0x8f98dc8, e=0xbf96c424) at kernel/qapplication.cpp:3798
#26 0x011a9d8a in KApplication::notify (this=0x8f907a8, receiver=0x8f98dc8, event=0xbf96c424) at ../../kdeui/kernel/kapplication.cpp:310
#27 0x062f6b3b in QCoreApplication::notifyInternal (this=0x8f907a8, receiver=0x8f98dc8, event=0xbf96c424) at kernel/qcoreapplication.cpp:732
#28 0x03437b9e in sendSpontaneousEvent (receiver=0x8f98dc8, event=0x94a0de4) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#29 qt_sendSpontaneousEvent (receiver=0x8f98dc8, event=0x94a0de4) at kernel/qapplication.cpp:5388
#30 0x03b3b282 in QGraphicsViewPrivate::mouseMoveEventHandler (this=0x9556da0, event=0xbf96cc70) at graphicsview/qgraphicsview.cpp:647
#31 0x03b3b4c6 in QGraphicsView::mouseMoveEvent (this=0x94a4b68, event=0xbf96cc70) at graphicsview/qgraphicsview.cpp:3272
#32 0x03495caa in QWidget::event (this=0x94a4b68, event=0xbf96cc70) at kernel/qwidget.cpp:8172
#33 0x038b7763 in QFrame::event (this=0x94a4b68, e=0xbf96cc70) at widgets/qframe.cpp:557
#34 0x03954a82 in QAbstractScrollArea::viewportEvent (this=0xffffffff, e=0x94a0de4) at widgets/qabstractscrollarea.cpp:1043
#35 0x03b38ccb in QGraphicsView::viewportEvent (this=0x94a4b68, event=0xbf96cc70) at graphicsview/qgraphicsview.cpp:2862
#36 0x039574d5 in viewportEvent (this=0x95327a0, o=0x956a180, e=0xbf96cc70) at widgets/qabstractscrollarea_p.h:100
#37 QAbstractScrollAreaFilter::eventFilter (this=0x95327a0, o=0x956a180, e=0xbf96cc70) at widgets/qabstractscrollarea_p.h:116
#38 0x062f629a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8f9c4c0, receiver=0x956a180, event=0xbf96cc70) at kernel/qcoreapplication.cpp:847
#39 0x03437fb9 in QApplicationPrivate::notify_helper (this=0x8f9c4c0, receiver=0x956a180, e=0xbf96cc70) at kernel/qapplication.cpp:4392
#40 0x0343ec2e in QApplication::notify (this=0x8f907a8, receiver=0x956a180, e=0xbf96cc70) at kernel/qapplication.cpp:3959
#41 0x011a9d8a in KApplication::notify (this=0x8f907a8, receiver=0x956a180, event=0xbf96cc70) at ../../kdeui/kernel/kapplication.cpp:310
#42 0x062f6b3b in QCoreApplication::notifyInternal (this=0x8f907a8, receiver=0x956a180, event=0xbf96cc70) at kernel/qcoreapplication.cpp:732
#43 0x0343d094 in sendEvent (receiver=0x956a180, event=0xbf96cc70, alienWidget=0x956a180, nativeWidget=0x95285e0, buttonDown=0x3dd23c0, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#44 QApplicationPrivate::sendMouseEvent (receiver=0x956a180, event=0xbf96cc70, alienWidget=0x956a180, nativeWidget=0x95285e0, buttonDown=0x3dd23c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3058
#45 0x034cbd10 in QETWidget::translateMouseEvent (this=0x95285e0, event=0xbf96d18c) at kernel/qapplication_x11.cpp:4403
#46 0x034cb151 in QApplication::x11ProcessEvent (this=0x8f907a8, event=0xbf96d18c) at kernel/qapplication_x11.cpp:3414
#47 0x034fa36a in x11EventSourceDispatch (s=0x8f9f6a8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#48 0x058c7855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#49 0x058cb668 in ?? () from /lib/libglib-2.0.so.0
#50 0x058cb848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#51 0x06325565 in QEventDispatcherGlib::processEvents (this=0x8f79cd0, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#52 0x034f9be5 in QGuiEventDispatcherGlib::processEvents (this=0x8f79cd0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#53 0x062f5609 in QEventLoop::processEvents (this=0xbf96d484, flags=) at kernel/qeventloop.cpp:149
#54 0x062f5a8a in QEventLoop::exec (this=0xbf96d484, flags=...) at kernel/qeventloop.cpp:201
#55 0x062fa00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#56 0x03436e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#57 0x0062f8e7 in kdemain (argc=1, argv=0xbf96d694) at ../../../../plasma/desktop/shell/main.cpp:118
#58 0x080485bb in main (argc=1, argv=0xbf96d694) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 265553.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-11-04 14:45:41 UTC

*** This bug has been marked as a duplicate of bug 253584 ***