Bug 265553 - Plasma crashed for no apparent reason
Summary: Plasma crashed for no apparent reason
Status: RESOLVED DUPLICATE of bug 253584
Alias: None
Product: plasma4
Classification: Plasma
Component: plasma-netbook (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-05 22:47 UTC by Filipe
Modified: 2011-02-06 18:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Filipe 2011-02-05 22:47:05 UTC
Application: plasma-netbook (0.1)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-25-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- Unusual behavior I noticed:

Laptop:
Asus EeePc 1008HA
The Plasma crash most of the time without doing nothing.
I was opennig amsn when Plasma crashed before i make this report.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Netbook (plasma-netbook), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78afad0 (LWP 1768))]

Thread 3 (Thread 0xaf2f3b70 (LWP 2013)):
#0  0x002cbf31 in pthread_mutex_lock () from /lib/libc.so.6
#1  0x0843eea3 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#2  0x0843f279 in ?? () from /lib/libglib-2.0.so.0
#3  0x0843f848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x0331659f in QEventDispatcherGlib::processEvents (this=0x8b01528, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#5  0x032e6609 in QEventLoop::processEvents (this=0xaf2f3280, flags=) at kernel/qeventloop.cpp:149
#6  0x032e6a8a in QEventLoop::exec (this=0xaf2f3280, flags=...) at kernel/qeventloop.cpp:201
#7  0x031e2b7e in QThread::exec (this=0x8a1f360) at thread/qthread.cpp:490
#8  0x032c535b in QInotifyFileSystemWatcherEngine::run (this=0x8a1f360) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x031e5df9 in QThreadPrivate::start (arg=0x8a1f360) at thread/qthread_unix.cpp:266
#10 0x015a5cc9 in start_thread () from /lib/libpthread.so.0
#11 0x002be69e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xaeae9b70 (LWP 2015)):
#0  0x009e8416 in __kernel_vsyscall ()
#1  0x015aa4dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x002cbd9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x025753a5 in ?? () from /usr/lib/libQtWebKit.so.4
#4  0x02575481 in ?? () from /usr/lib/libQtWebKit.so.4
#5  0x015a5cc9 in start_thread () from /lib/libpthread.so.0
#6  0x002be69e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb78afad0 (LWP 1768)):
[KCrash Handler]
#7  0x03418092 in vtable for BackEase () from /usr/lib/libQtCore.so.4
#8  0x032ed8f9 in QMetaObject::cast (this=0x3e95740, obj=0x8c13b50) at kernel/qmetaobject.cpp:266
#9  0x06c68c0a in qobject_cast<RemoteInterfaceConnection*> (this=0x92f61d0) at /usr/include/qt4/QtCore/qobject.h:455
#10 ActivatableItem::interfaceConnection (this=0x92f61d0) at ../../applet/activatableitem.cpp:88
#11 0x06c5bf7c in ActivatableListWidget::hoverEnter (this=0x8cc8778, uni=...) at ../../applet/activatablelistwidget.cpp:286
#12 0x06c52a35 in ActivatableListWidget::qt_metacall (this=0x8cc8778, _c=QMetaObject::InvokeMetaMethod, _id=44, _a=0xbf819fe8) at moc_activatablelistwidget.cpp:101
#13 0x032ed8ca in QMetaObject::metacall (object=0x8cc8778, cl=147655911, idx=44, argv=0xbf819fe8) at kernel/qmetaobject.cpp:237
#14 0x033006ad in QMetaObject::activate (sender=0x93c7000, m=0x6c70a2c, local_signal_index=4, argv=0x92954f8) at kernel/qobject.cpp:3280
#15 0x06c51ba3 in InterfaceItem::hoverEnter (this=0x93c7000, _t1=...) at moc_interfaceitem.cpp:164
#16 0x06c5e1f2 in InterfaceItem::hoverEnterEvent (this=0x93c7000, event=0xbf81a17c) at ../../applet/interfaceitem.cpp:457
#17 0x078e41a2 in QGraphicsItem::sceneEvent (this=0x93c7008, event=0xbf81a17c) at graphicsview/qgraphicsitem.cpp:6654
#18 0x0793b4d7 in QGraphicsWidget::sceneEvent (this=0x93c7000, event=0xbf81a17c) at graphicsview/qgraphicswidget.cpp:1173
#19 0x078fc569 in QGraphicsScenePrivate::sendEvent (this=0x8686940, item=0x93c7008, event=0xbf81a17c) at graphicsview/qgraphicsscene.cpp:1211
#20 0x078fc8ae in QGraphicsScenePrivate::sendHoverEvent (this=0x8686940, type=QEvent::GraphicsSceneHoverEnter, item=0x93c7008, hoverEvent=0xbf81a28c) at graphicsview/qgraphicsscene.cpp:1258
#21 0x07902b04 in QGraphicsScenePrivate::dispatchHoverEvent (this=0x8686940, hoverEvent=0xbf81a28c) at graphicsview/qgraphicsscene.cpp:3921
#22 0x07902e68 in QGraphicsScene::mouseMoveEvent (this=0x8694a20, mouseEvent=0xbf81a814) at graphicsview/qgraphicsscene.cpp:4080
#23 0x0791757d in QGraphicsScene::event (this=0x8694a20, event=0xbf81a814) at graphicsview/qgraphicsscene.cpp:3437
#24 0x07231fdc in QApplicationPrivate::notify_helper (this=0x85d3420, receiver=0x8694a20, e=0xbf81a814) at kernel/qapplication.cpp:4396
#25 0x0723804e in QApplication::notify (this=0x85d23a0, receiver=0x8694a20, e=0xbf81a814) at kernel/qapplication.cpp:3798
#26 0x0109668a in KApplication::notify (this=0x85d23a0, receiver=0x8694a20, event=0xbf81a814) at ../../kdeui/kernel/kapplication.cpp:310
#27 0x032e7b3b in QCoreApplication::notifyInternal (this=0x85d23a0, receiver=0x8694a20, event=0xbf81a814) at kernel/qcoreapplication.cpp:732
#28 0x07231b9e in sendSpontaneousEvent (receiver=0x8694a20, event=0x8cd0ce8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#29 qt_sendSpontaneousEvent (receiver=0x8694a20, event=0x8cd0ce8) at kernel/qapplication.cpp:5388
#30 0x07935282 in QGraphicsViewPrivate::mouseMoveEventHandler (this=0x8d61d90, event=0xbf81b060) at graphicsview/qgraphicsview.cpp:647
#31 0x079354c6 in QGraphicsView::mouseMoveEvent (this=0x8d5a070, event=0xbf81b060) at graphicsview/qgraphicsview.cpp:3272
#32 0x0728fcaa in QWidget::event (this=0x8d5a070, event=0xbf81b060) at kernel/qwidget.cpp:8172
#33 0x076b1763 in QFrame::event (this=0x8d5a070, e=0xbf81b060) at widgets/qframe.cpp:557
#34 0x0774ea82 in QAbstractScrollArea::viewportEvent (this=0x8cd0ce7, e=0x8cd0ce8) at widgets/qabstractscrollarea.cpp:1043
#35 0x07932ccb in QGraphicsView::viewportEvent (this=0x8d5a070, event=0xbf81b060) at graphicsview/qgraphicsview.cpp:2862
#36 0x077514d5 in viewportEvent (this=0x8e0a5e8, o=0x8d62aa8, e=0xbf81b060) at widgets/qabstractscrollarea_p.h:100
#37 QAbstractScrollAreaFilter::eventFilter (this=0x8e0a5e8, o=0x8d62aa8, e=0xbf81b060) at widgets/qabstractscrollarea_p.h:116
#38 0x032e729a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x85d3420, receiver=0x8d62aa8, event=0xbf81b060) at kernel/qcoreapplication.cpp:847
#39 0x07231fb9 in QApplicationPrivate::notify_helper (this=0x85d3420, receiver=0x8d62aa8, e=0xbf81b060) at kernel/qapplication.cpp:4392
#40 0x07238c2e in QApplication::notify (this=0x85d23a0, receiver=0x8d62aa8, e=0xbf81b060) at kernel/qapplication.cpp:3959
#41 0x0109668a in KApplication::notify (this=0x85d23a0, receiver=0x8d62aa8, event=0xbf81b060) at ../../kdeui/kernel/kapplication.cpp:310
#42 0x032e7b3b in QCoreApplication::notifyInternal (this=0x85d23a0, receiver=0x8d62aa8, event=0xbf81b060) at kernel/qcoreapplication.cpp:732
#43 0x07237094 in sendEvent (receiver=0x8d62aa8, event=0xbf81b060, alienWidget=0x8d62aa8, nativeWidget=0x8d55fa0, buttonDown=0x7bcc3c0, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#44 QApplicationPrivate::sendMouseEvent (receiver=0x8d62aa8, event=0xbf81b060, alienWidget=0x8d62aa8, nativeWidget=0x8d55fa0, buttonDown=0x7bcc3c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3058
#45 0x072c5d10 in QETWidget::translateMouseEvent (this=0x8d55fa0, event=0xbf81b57c) at kernel/qapplication_x11.cpp:4403
#46 0x072c5151 in QApplication::x11ProcessEvent (this=0x85d23a0, event=0xbf81b57c) at kernel/qapplication_x11.cpp:3414
#47 0x072f436a in x11EventSourceDispatch (s=0x85dff68, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#48 0x0843b855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#49 0x0843f668 in ?? () from /lib/libglib-2.0.so.0
#50 0x0843f848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#51 0x03316565 in QEventDispatcherGlib::processEvents (this=0x85b8ce8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#52 0x072f3be5 in QGuiEventDispatcherGlib::processEvents (this=0x85b8ce8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#53 0x032e6609 in QEventLoop::processEvents (this=0xbf81b874, flags=) at kernel/qeventloop.cpp:149
#54 0x032e6a8a in QEventLoop::exec (this=0xbf81b874, flags=...) at kernel/qeventloop.cpp:201
#55 0x032eb00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#56 0x07230e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#57 0x001de96d in kdemain (argc=1, argv=0xbf81ba94) at ../../../../plasma/netbook/shell/main.cpp:67
#58 0x080485bb in main (argc=1, argv=0xbf81ba94) at plasma-netbook_dummy.cpp:3

Reported using DrKonqi
Comment 1 Dario Andres 2011-02-06 18:02:26 UTC
[Comment from a bug triager]
This issue is being tracked at bug 253584. Merging. Thanks

*** This bug has been marked as a duplicate of bug 253584 ***