Bug 268516 - Crash disabling wireless network
Summary: Crash disabling wireless network
Status: RESOLVED DUPLICATE of bug 253584
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-14 21:17 UTC by Tais P. Hansen
Modified: 2011-03-14 23:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tais P. Hansen 2011-03-14 21:17:22 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-27-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
I disabled wireless networking using the Network Manager applet.

- Unusual behavior I noticed:
Wireless networking stopped working properly and kept asking for WPA secret.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[KCrash Handler]
#7  0x036390ac in vtable for QSystemLocale () from /usr/lib/libQtCore.so.4
#8  0x0350e8f9 in QMetaObject::cast (this=0x408b740, obj=0x9c99cf0) at kernel/qmetaobject.cpp:266
#9  0x03f6fc0a in qobject_cast<RemoteInterfaceConnection*> (this=0x9e9f158) at /usr/include/qt4/QtCore/qobject.h:455
#10 ActivatableItem::interfaceConnection (this=0x9e9f158) at ../../applet/activatableitem.cpp:88
#11 0x03f62f7c in ActivatableListWidget::hoverEnter (this=0x98ae270, uni=...) at ../../applet/activatablelistwidget.cpp:286
#12 0x03f59a35 in ActivatableListWidget::qt_metacall (this=0x98ae270, _c=QMetaObject::InvokeMetaMethod, _id=44, _a=0xbf954e68) at moc_activatablelistwidget.cpp:101
#13 0x0350e8ca in QMetaObject::metacall (object=0x98ae270, cl=4294967295, idx=44, argv=0xbf954e68) at kernel/qmetaobject.cpp:237
#14 0x035216ad in QMetaObject::activate (sender=0x9970678, m=0x3f77a2c, local_signal_index=4, argv=0x9d3de18) at kernel/qobject.cpp:3280
#15 0x03f58ba3 in InterfaceItem::hoverEnter (this=0x9970678, _t1=...) at moc_interfaceitem.cpp:164
#16 0x03f651f2 in InterfaceItem::hoverEnterEvent (this=0x9970678, event=0xbf954ffc) at ../../applet/interfaceitem.cpp:457
#17 0x01cda1a2 in QGraphicsItem::sceneEvent (this=0x9970680, event=0xbf954ffc) at graphicsview/qgraphicsitem.cpp:6654
#18 0x01d314d7 in QGraphicsWidget::sceneEvent (this=0x9970678, event=0xbf954ffc) at graphicsview/qgraphicswidget.cpp:1173
#19 0x01cf2569 in QGraphicsScenePrivate::sendEvent (this=0x95a2fa8, item=0x9970680, event=0xbf954ffc) at graphicsview/qgraphicsscene.cpp:1211
#20 0x01cf28ae in QGraphicsScenePrivate::sendHoverEvent (this=0x95a2fa8, type=QEvent::GraphicsSceneHoverEnter, item=0x9970680, hoverEvent=0xbf95510c) at graphicsview/qgraphicsscene.cpp:1258
#21 0x01cf8b04 in QGraphicsScenePrivate::dispatchHoverEvent (this=0x95a2fa8, hoverEvent=0xbf95510c) at graphicsview/qgraphicsscene.cpp:3921
#22 0x01cf8e68 in QGraphicsScene::mouseMoveEvent (this=0x968e280, mouseEvent=0xbf955694) at graphicsview/qgraphicsscene.cpp:4080
#23 0x01d0d57d in QGraphicsScene::event (this=0x968e280, event=0xbf955694) at graphicsview/qgraphicsscene.cpp:3437
#24 0x01627fdc in QApplicationPrivate::notify_helper (this=0x95a6560, receiver=0x968e280, e=0xbf955694) at kernel/qapplication.cpp:4396
#25 0x0162e04e in QApplication::notify (this=0x9598598, receiver=0x968e280, e=0xbf955694) at kernel/qapplication.cpp:3798
#26 0x00f6068a in KApplication::notify (this=0x9598598, receiver=0x968e280, event=0xbf955694) at ../../kdeui/kernel/kapplication.cpp:310
#27 0x03508b3b in QCoreApplication::notifyInternal (this=0x9598598, receiver=0x968e280, event=0xbf955694) at kernel/qcoreapplication.cpp:732
#28 0x01627b9e in sendSpontaneousEvent (receiver=0x968e280, event=0x9ec00e8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#29 qt_sendSpontaneousEvent (receiver=0x968e280, event=0x9ec00e8) at kernel/qapplication.cpp:5388
#30 0x01d2b282 in QGraphicsViewPrivate::mouseMoveEventHandler (this=0x9997870, event=0xbf955ee0) at graphicsview/qgraphicsview.cpp:647
#31 0x01d2b4c6 in QGraphicsView::mouseMoveEvent (this=0x99974c0, event=0xbf955ee0) at graphicsview/qgraphicsview.cpp:3272
#32 0x01685caa in QWidget::event (this=0x99974c0, event=0xbf955ee0) at kernel/qwidget.cpp:8172
#33 0x01aa7763 in QFrame::event (this=0x99974c0, e=0xbf955ee0) at widgets/qframe.cpp:557
#34 0x01b44a82 in QAbstractScrollArea::viewportEvent (this=0xffffffff, e=0x9ec00e8) at widgets/qabstractscrollarea.cpp:1043
#35 0x01d28ccb in QGraphicsView::viewportEvent (this=0x99974c0, event=0xbf955ee0) at graphicsview/qgraphicsview.cpp:2862
#36 0x01b474d5 in viewportEvent (this=0x9996090, o=0x999a7c0, e=0xbf955ee0) at widgets/qabstractscrollarea_p.h:100
#37 QAbstractScrollAreaFilter::eventFilter (this=0x9996090, o=0x999a7c0, e=0xbf955ee0) at widgets/qabstractscrollarea_p.h:116
#38 0x0350829a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x95a6560, receiver=0x999a7c0, event=0xbf955ee0) at kernel/qcoreapplication.cpp:847
#39 0x01627fb9 in QApplicationPrivate::notify_helper (this=0x95a6560, receiver=0x999a7c0, e=0xbf955ee0) at kernel/qapplication.cpp:4392
#40 0x0162ec2e in QApplication::notify (this=0x9598598, receiver=0x999a7c0, e=0xbf955ee0) at kernel/qapplication.cpp:3959
#41 0x00f6068a in KApplication::notify (this=0x9598598, receiver=0x999a7c0, event=0xbf955ee0) at ../../kdeui/kernel/kapplication.cpp:310
#42 0x03508b3b in QCoreApplication::notifyInternal (this=0x9598598, receiver=0x999a7c0, event=0xbf955ee0) at kernel/qcoreapplication.cpp:732
#43 0x0162d094 in sendEvent (receiver=0x999a7c0, event=0xbf955ee0, alienWidget=0x999a7c0, nativeWidget=0x9986780, buttonDown=0x1fc23c0, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#44 QApplicationPrivate::sendMouseEvent (receiver=0x999a7c0, event=0xbf955ee0, alienWidget=0x999a7c0, nativeWidget=0x9986780, buttonDown=0x1fc23c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3058
#45 0x016bbd10 in QETWidget::translateMouseEvent (this=0x9986780, event=0xbf9563fc) at kernel/qapplication_x11.cpp:4403
#46 0x016bb151 in QApplication::x11ProcessEvent (this=0x9598598, event=0xbf9563fc) at kernel/qapplication_x11.cpp:3414
#47 0x016ea36a in x11EventSourceDispatch (s=0x95a97a8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#48 0x04df5855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#49 0x04df9668 in ?? () from /lib/libglib-2.0.so.0
#50 0x04df9848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#51 0x03537565 in QEventDispatcherGlib::processEvents (this=0x9581ce8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#52 0x016e9be5 in QGuiEventDispatcherGlib::processEvents (this=0x9581ce8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#53 0x03507609 in QEventLoop::processEvents (this=0xbf9566f4, flags=) at kernel/qeventloop.cpp:149
#54 0x03507a8a in QEventLoop::exec (this=0xbf9566f4, flags=...) at kernel/qeventloop.cpp:201
#55 0x0350c00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#56 0x01626e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#57 0x001c686e in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#58 0x080485bb in _start ()

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-03-14 23:02:38 UTC

*** This bug has been marked as a duplicate of bug 253584 ***