Bug 257574 - Plasma Crash
Summary: Plasma Crash
Status: RESOLVED DUPLICATE of bug 253584
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: Plasma Widget (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-22 02:42 UTC by Jamey Price
Modified: 2011-02-11 02:57 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jamey Price 2010-11-22 02:42:09 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.6.3
Operating System: Linux 2.6.34.7-61.fc13.x86_64 x86_64
Distribution: "Fedora release 13 (Goddard)"

-- Information about the crash:
- What I was doing when the application crashed:
I had the Network Management applet open and I disconnected from the wireless and wired interfaces while a ping was running in a konsole session.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f8d1b756860 (LWP 2350))]

Thread 5 (Thread 0x7f8cfdf03710 (LWP 29774)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x0000003c9047212b in wait (this=<value optimized out>, mutex=0x1b4daf0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1b4daf0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x0000003330c0a096 in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x0000003330c0c56b in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x0000003330c0af4f in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x0000003330c0b428 in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#7  0x0000003c904711a5 in QThreadPrivate::start (arg=0x279e200) at thread/qthread_unix.cpp:248
#8  0x000000332e8999a3 in ?? () from /usr/lib64/nvidia/libGL.so.1
#9  0x0000003c86007761 in start_thread (arg=0x7f8cfdf03710) at pthread_create.c:301
#10 0x0000003c858e14fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 4 (Thread 0x7f8d075e7710 (LWP 29775)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x0000003c9047212b in wait (this=<value optimized out>, mutex=0x1b4daf0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1b4daf0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x0000003330c0a096 in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x0000003330c0c56b in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x0000003330c0af4f in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x0000003330c0b428 in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#7  0x0000003c904711a5 in QThreadPrivate::start (arg=0x2741150) at thread/qthread_unix.cpp:248
#8  0x000000332e8999a3 in ?? () from /usr/lib64/nvidia/libGL.so.1
#9  0x0000003c86007761 in start_thread (arg=0x7f8d075e7710) at pthread_create.c:301
#10 0x0000003c858e14fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7f8ceffff710 (LWP 29776)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x0000003c9047212b in wait (this=<value optimized out>, mutex=0x1b4daf0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1b4daf0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x0000003330c0a096 in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x0000003330c0c56b in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x0000003330c0af4f in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x0000003330c0b428 in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#7  0x0000003c904711a5 in QThreadPrivate::start (arg=0x280dee0) at thread/qthread_unix.cpp:248
#8  0x000000332e8999a3 in ?? () from /usr/lib64/nvidia/libGL.so.1
#9  0x0000003c86007761 in start_thread (arg=0x7f8ceffff710) at pthread_create.c:301
#10 0x0000003c858e14fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f8cef5fe710 (LWP 29777)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x0000003c9047212b in wait (this=<value optimized out>, mutex=0x1b4daf0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1b4daf0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x0000003330c0a096 in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x0000003330c0c56b in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x0000003330c0af4f in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x0000003330c0b428 in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#7  0x0000003c904711a5 in QThreadPrivate::start (arg=0x1e29c50) at thread/qthread_unix.cpp:248
#8  0x000000332e8999a3 in ?? () from /usr/lib64/nvidia/libGL.so.1
#9  0x0000003c86007761 in start_thread (arg=0x7f8cef5fe710) at pthread_create.c:301
#10 0x0000003c858e14fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f8d1b756860 (LWP 2350)):
[KCrash Handler]
#6  0x0000003c90558237 in QMetaObject::cast (this=0x7f8d04f85140, obj=0x24688d0) at kernel/qmetaobject.cpp:266
#7  0x00007f8d04fa50b0 in ActivatableListWidget::hoverLeave (this=<value optimized out>, uni=...) at /usr/src/debug/networkmanagement-0.9/applet/activatablelistwidget.cpp:344
#8  0x00007f8d04f9d0c1 in ActivatableListWidget::qt_metacall (this=0x17ff290, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff2c5edf0)
    at /usr/src/debug/networkmanagement-0.9/x86_64-redhat-linux-gnu/applet/moc_activatablelistwidget.cpp:104
#9  0x0000003c90566a36 in QMetaObject::activate (sender=0x186cf90, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7ffff2c5edf0) at kernel/qobject.cpp:3295
#10 0x00007f8d04f9c085 in InterfaceItem::hoverLeave (this=<value optimized out>, _t1=<value optimized out>)
    at /usr/src/debug/networkmanagement-0.9/x86_64-redhat-linux-gnu/applet/moc_interfaceitem.cpp:171
#11 0x00007f8d04fa7015 in InterfaceItem::hoverLeaveEvent (this=0x186cf90, event=0x7ffff2c5eea0) at /usr/src/debug/networkmanagement-0.9/applet/interfaceitem.cpp:465
#12 0x0000003c93748d94 in QGraphicsItem::sceneEvent (this=0x186cfa0, event=0x7ffff2c5eea0) at graphicsview/qgraphicsitem.cpp:6536
#13 0x0000003c9375d5bf in QGraphicsScenePrivate::sendHoverEvent (this=0xde13a0, type=<value optimized out>, item=0x186cfa0, hoverEvent=0x7ffff2c5f030) at graphicsview/qgraphicsscene.cpp:1237
#14 0x0000003c93762535 in QGraphicsScenePrivate::dispatchHoverEvent (this=0xde13a0, hoverEvent=0x7ffff2c5f030) at graphicsview/qgraphicsscene.cpp:3863
#15 0x0000003c93762944 in QGraphicsScene::mouseMoveEvent (this=<value optimized out>, mouseEvent=0x7ffff2c5f700) at graphicsview/qgraphicsscene.cpp:4041
#16 0x0000003c93774cfb in QGraphicsScene::event (this=0xdc7f80, event=0x7ffff2c5f700) at graphicsview/qgraphicsscene.cpp:3400
#17 0x0000003c931ab39c in QApplicationPrivate::notify_helper (this=0xcd9280, receiver=0xdc7f80, e=0x7ffff2c5f700) at kernel/qapplication.cpp:4306
#18 0x0000003c931b165b in QApplication::notify (this=<value optimized out>, receiver=0xdc7f80, e=0x7ffff2c5f700) at kernel/qapplication.cpp:4189
#19 0x000000332941d126 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#20 0x0000003c90553ddc in QCoreApplication::notifyInternal (this=0xcbfcb0, receiver=0xdc7f80, event=0x7ffff2c5f700) at kernel/qcoreapplication.cpp:726
#21 0x0000003c9378e927 in QGraphicsViewPrivate::mouseMoveEventHandler (this=0x1930a70, event=0x7ffff2c60260) at graphicsview/qgraphicsview.cpp:645
#22 0x0000003c9378eb1e in QGraphicsView::mouseMoveEvent (this=0x19301e0, event=0x7ffff2c60260) at graphicsview/qgraphicsview.cpp:3197
#23 0x0000003c931f60e7 in QWidget::event (this=0x19301e0, event=0x7ffff2c60260) at kernel/qwidget.cpp:8029
#24 0x0000003c935730c6 in QFrame::event (this=0x19301e0, e=0x7ffff2c60260) at widgets/qframe.cpp:557
#25 0x0000003c9378c5db in QGraphicsView::viewportEvent (this=0x19301e0, event=0x7ffff2c60260) at graphicsview/qgraphicsview.cpp:2787
#26 0x0000003c905531f7 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x1946b70, event=0x7ffff2c60260) at kernel/qcoreapplication.cpp:841
#27 0x0000003c931ab36c in QApplicationPrivate::notify_helper (this=0xcd9280, receiver=0x1946b70, e=0x7ffff2c60260) at kernel/qapplication.cpp:4302
#28 0x0000003c931b1e2d in QApplication::notify (this=<value optimized out>, receiver=0x1946b70, e=0x7ffff2c60260) at kernel/qapplication.cpp:3871
#29 0x000000332941d126 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#30 0x0000003c90553ddc in QCoreApplication::notifyInternal (this=0xcbfcb0, receiver=0x1946b70, event=0x7ffff2c60260) at kernel/qcoreapplication.cpp:726
#31 0x0000003c931b101e in sendEvent (receiver=0x1946b70, event=0x7ffff2c60260, alienWidget=0x1946b70, nativeWidget=0x192cee0, buttonDown=0x3c93c2f088, lastMouseReceiver=..., spontaneous=true)
    at ../../src/corelib/kernel/qcoreapplication.h:215
#32 QApplicationPrivate::sendMouseEvent (receiver=0x1946b70, event=0x7ffff2c60260, alienWidget=0x1946b70, nativeWidget=0x192cee0, buttonDown=0x3c93c2f088, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:2971
#33 0x0000003c93223155 in QETWidget::translateMouseEvent (this=0x192cee0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4380
#34 0x0000003c93221acc in QApplication::x11ProcessEvent (this=0xcbfcb0, event=0x7ffff2c60b80) at kernel/qapplication_x11.cpp:3513
#35 0x0000003c9324ab92 in x11EventSourceDispatch (s=0xcdca30, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#36 0x0000003c87c3bd02 in g_main_dispatch (context=0xcdb920) at gmain.c:1960
#37 IA__g_main_context_dispatch (context=0xcdb920) at gmain.c:2513
#38 0x0000003c87c3fae8 in g_main_context_iterate (context=0xcdb920, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2591
#39 0x0000003c87c3fc9c in IA__g_main_context_iteration (context=0xcdb920, may_block=1) at gmain.c:2654
#40 0x0000003c90579863 in QEventDispatcherGlib::processEvents (this=0xca5bd0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#41 0x0000003c9324a84e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x0000003c90552822 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#43 0x0000003c90552aec in QEventLoop::exec (this=0x7ffff2c60eb0, flags=...) at kernel/qeventloop.cpp:201
#44 0x0000003c905561bb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#45 0x000000332bc38846 in kdemain () from /usr/lib64/libkdeinit4_plasma-desktop.so
#46 0x0000003c8581ec5d in __libc_start_main (main=0x400910 <_start+240>, argc=1, ubp_av=0x7ffff2c61288, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, 
    stack_end=0x7ffff2c61278) at libc-start.c:226
#47 0x0000000000400849 in _start ()

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-02-11 02:57:29 UTC

*** This bug has been marked as a duplicate of bug 253584 ***