Bug 269407 - knetworkmanager crash when disconnecting umts
Summary: knetworkmanager crash when disconnecting umts
Status: RESOLVED DUPLICATE of bug 253584
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-25 19:01 UTC by modulistic
Modified: 2011-03-26 00:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description modulistic 2011-03-25 19:01:12 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.00 (4.6.0) "release 6"
Qt Version: 4.7.1
Operating System: Linux 2.6.37.1-1.2-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
clicked the red cross button (w/'disconnect' tooltip) besides the umts connection under 'interfaces' in the tray icon

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f426f179760 (LWP 4013))]

Thread 6 (Thread 0x7f4253df8700 (LWP 4015)):
#0  0xffffffffff600177 in ?? ()
#1  0x00007fffacf1f7a1 in ?? ()
#2  0x00007f42699932b3 in clock_gettime () from /lib64/librt.so.1
#3  0x00007f426dda02b2 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#5  0x00007f426de6333d in QTimerInfoList::updateCurrentTime (this=0x7f424c001ed0) at kernel/qeventdispatcher_unix.cpp:339
#6  0x00007f426de636b5 in QTimerInfoList::timerWait (this=0x7f424c001ed0, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#7  0x00007f426de6217c in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7f4253df7c4c) at kernel/qeventdispatcher_glib.cpp:136
#8  0x00007f426de62225 in timerSourcePrepare (source=<value optimized out>, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#9  0x00007f42696e2087 in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#10 0x00007f42696e2fa9 in ?? () from /lib64/libglib-2.0.so.0
#11 0x00007f42696e3650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#12 0x00007f426de62976 in QEventDispatcherGlib::processEvents (this=0xacfce0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#13 0x00007f426de37052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#14 0x00007f426de37265 in QEventLoop::exec (this=0x7f4253df7de0, flags=...) at kernel/qeventloop.cpp:201
#15 0x00007f426dd4c1e4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#16 0x00007f426de18968 in QInotifyFileSystemWatcherEngine::run (this=0xaafab0) at io/qfilesystemwatcher_inotify.cpp:248
#17 0x00007f426dd4ea5e in QThreadPrivate::start (arg=0xaafab0) at thread/qthread_unix.cpp:285
#18 0x00007f426dabfa3f in start_thread () from /lib64/libpthread.so.0
#19 0x00007f426c87a67d in clone () from /lib64/libc.so.6
#20 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f42452f3700 (LWP 8675)):
#0  0x00007f426dac438c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f426dd4f14b in wait (this=<value optimized out>, mutex=0x12f9010, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x12f9010, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f426227d254 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x13900a0, th=0x1af97d0) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f42622802a5 in waitForAvailableJob (this=0x12efbf0, th=0x1af97d0) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WeaverImpl.cpp:356
#5  ThreadWeaver::WorkingHardState::applyForWork (this=0x12efbf0, th=0x1af97d0) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WorkingHardState.cpp:71
#6  0x00007f426227d64f in ThreadWeaver::ThreadRunHelper::run (this=0x7f42452f2e30, parent=0x13900a0, th=0x1af97d0) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:87
#7  0x00007f426227d6d8 in ThreadWeaver::Thread::run (this=0x1af97d0) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:142
#8  0x00007f426dd4ea5e in QThreadPrivate::start (arg=0x1af97d0) at thread/qthread_unix.cpp:285
#9  0x00007f426dabfa3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f426c87a67d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f4250ba5700 (LWP 8676)):
#0  0x00007f426dac438c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f426dd4f14b in wait (this=<value optimized out>, mutex=0x12f9010, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x12f9010, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f426227d254 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x13900a0, th=0xf959a0) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f42622802a5 in waitForAvailableJob (this=0x12efbf0, th=0xf959a0) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WeaverImpl.cpp:356
#5  ThreadWeaver::WorkingHardState::applyForWork (this=0x12efbf0, th=0xf959a0) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WorkingHardState.cpp:71
#6  0x00007f426227d64f in ThreadWeaver::ThreadRunHelper::run (this=0x7f4250ba4e30, parent=0x13900a0, th=0xf959a0) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:87
#7  0x00007f426227d6d8 in ThreadWeaver::Thread::run (this=0xf959a0) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:142
#8  0x00007f426dd4ea5e in QThreadPrivate::start (arg=0xf959a0) at thread/qthread_unix.cpp:285
#9  0x00007f426dabfa3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f426c87a67d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f42416de700 (LWP 8677)):
#0  0x00007f426dac438c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f426dd4f14b in wait (this=<value optimized out>, mutex=0x12f9010, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x12f9010, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f426227d254 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x13900a0, th=0x1696450) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f42622802a5 in waitForAvailableJob (this=0x12efbf0, th=0x1696450) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WeaverImpl.cpp:356
#5  ThreadWeaver::WorkingHardState::applyForWork (this=0x12efbf0, th=0x1696450) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WorkingHardState.cpp:71
#6  0x00007f426227d64f in ThreadWeaver::ThreadRunHelper::run (this=0x7f42416dde30, parent=0x13900a0, th=0x1696450) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:87
#7  0x00007f426227d6d8 in ThreadWeaver::Thread::run (this=0x1696450) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:142
#8  0x00007f426dd4ea5e in QThreadPrivate::start (arg=0x1696450) at thread/qthread_unix.cpp:285
#9  0x00007f426dabfa3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f426c87a67d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f4240edd700 (LWP 8678)):
#0  0x00007f426dac438c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f426dd4f14b in wait (this=<value optimized out>, mutex=0x12f9010, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x12f9010, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f426227d254 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x13900a0, th=0x7640c0) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f42622802a5 in waitForAvailableJob (this=0x12efbf0, th=0x7640c0) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WeaverImpl.cpp:356
#5  ThreadWeaver::WorkingHardState::applyForWork (this=0x12efbf0, th=0x7640c0) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/WorkingHardState.cpp:71
#6  0x00007f426227d64f in ThreadWeaver::ThreadRunHelper::run (this=0x7f4240edce30, parent=0x13900a0, th=0x7640c0) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:87
#7  0x00007f426227d6d8 in ThreadWeaver::Thread::run (this=0x7640c0) at /usr/src/debug/kdelibs-4.6.0/threadweaver/Weaver/Thread.cpp:142
#8  0x00007f426dd4ea5e in QThreadPrivate::start (arg=0x7640c0) at thread/qthread_unix.cpp:285
#9  0x00007f426dabfa3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f426c87a67d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f426f179760 (LWP 4013)):
[KCrash Handler]
#6  0x00007f426de3db37 in QMetaObject::cast (this=0x7f4252d5e000, obj=0x771150) at kernel/qmetaobject.cpp:266
#7  0x00007f4252d817fc in ActivatableListWidget::hoverLeave (this=<value optimized out>, uni=...) at /usr/src/debug/networkmanagement/applet/activatablelistwidget.cpp:344
#8  0x00007f4252d77871 in ActivatableListWidget::qt_metacall (this=0xf92980, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffface39ac0) at /usr/src/debug/networkmanagement/build/applet/moc_activatablelistwidget.cpp:104
#9  0x00007f426de4cdef in QMetaObject::activate (sender=0x1026a00, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7ffface39ac0) at kernel/qobject.cpp:3272
#10 0x00007f4252d78635 in InterfaceItem::hoverLeave (this=<value optimized out>, _t1=<value optimized out>) at /usr/src/debug/networkmanagement/build/applet/moc_interfaceitem.cpp:171
#11 0x00007f4252d84325 in InterfaceItem::hoverLeaveEvent (this=0x1026a00, event=0x7ffface39b70) at /usr/src/debug/networkmanagement/applet/interfaceitem.cpp:465
#12 0x00007f426d5a89ca in QGraphicsItem::sceneEvent (this=0x1026a10, event=0x7ffface39b70) at graphicsview/qgraphicsitem.cpp:6692
#13 0x00007f426d5d241f in QGraphicsScenePrivate::sendHoverEvent (this=0x735e80, type=<value optimized out>, item=0x1026a10, hoverEvent=0x7ffface39d00) at graphicsview/qgraphicsscene.cpp:1254
#14 0x00007f426d5d289b in QGraphicsScenePrivate::dispatchHoverEvent (this=0x735e80, hoverEvent=0x7ffface39d00) at graphicsview/qgraphicsscene.cpp:3898
#15 0x00007f426d5d2dd4 in QGraphicsScene::mouseMoveEvent (this=<value optimized out>, mouseEvent=0x7ffface3a3d0) at graphicsview/qgraphicsscene.cpp:4076
#16 0x00007f426d5e4eab in QGraphicsScene::event (this=0x7368a0, event=0x7ffface3a3d0) at graphicsview/qgraphicsscene.cpp:3433
#17 0x00007f426cfe6d14 in QApplicationPrivate::notify_helper (this=0x6a5080, receiver=0x7368a0, e=0x7ffface3a3d0) at kernel/qapplication.cpp:4445
#18 0x00007f426cfef22a in QApplication::notify (this=<value optimized out>, receiver=0x7368a0, e=0x7ffface3a3d0) at kernel/qapplication.cpp:4324
#19 0x00007f426eadb9e6 in KApplication::notify (this=0x69b0d0, receiver=0x7368a0, event=0x7ffface3a3d0) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#20 0x00007f426de37bfc in QCoreApplication::notifyInternal (this=0x69b0d0, receiver=0x7368a0, event=0x7ffface3a3d0) at kernel/qcoreapplication.cpp:732
#21 0x00007f426d5fb67f in QGraphicsViewPrivate::mouseMoveEventHandler (this=0x10c6380, event=0x7ffface3af90) at graphicsview/qgraphicsview.cpp:647
#22 0x00007f426d5fb87e in QGraphicsView::mouseMoveEvent (this=0x1022460, event=0x7ffface3af90) at graphicsview/qgraphicsview.cpp:3274
#23 0x00007f426d03856c in QWidget::event (this=0x1022460, event=0x7ffface3af90) at kernel/qwidget.cpp:8185
#24 0x00007f426d3dc906 in QFrame::event (this=0x1022460, e=0x7ffface3af90) at widgets/qframe.cpp:557
#25 0x00007f426d5ff8bb in QGraphicsView::viewportEvent (this=0x1022460, event=0x7ffface3af90) at graphicsview/qgraphicsview.cpp:2864
#26 0x00007f426de37d87 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x10c9e00, event=0x7ffface3af90) at kernel/qcoreapplication.cpp:847
#27 0x00007f426cfe6ce1 in QApplicationPrivate::notify_helper (this=0x6a5080, receiver=0x10c9e00, e=0x7ffface3af90) at kernel/qapplication.cpp:4441
#28 0x00007f426cfefaac in QApplication::notify (this=<value optimized out>, receiver=0x10c9e00, e=0x7ffface3af90) at kernel/qapplication.cpp:4006
#29 0x00007f426eadb9e6 in KApplication::notify (this=0x69b0d0, receiver=0x10c9e00, event=0x7ffface3af90) at /usr/src/debug/kdelibs-4.6.0/kdeui/kernel/kapplication.cpp:311
#30 0x00007f426de37bfc in QCoreApplication::notifyInternal (this=0x69b0d0, receiver=0x10c9e00, event=0x7ffface3af90) at kernel/qcoreapplication.cpp:732
#31 0x00007f426cfe7d25 in sendEvent (receiver=0x10c9e00, event=0x7ffface3af90, alienWidget=0x10c9e00, nativeWidget=0x101d170, buttonDown=0x7f426dab6178, lastMouseReceiver=..., spontaneous=true) at ../../src/corelib/kernel/qcoreapplication.h:215
#32 QApplicationPrivate::sendMouseEvent (receiver=0x10c9e00, event=0x7ffface3af90, alienWidget=0x10c9e00, nativeWidget=0x101d170, buttonDown=0x7f426dab6178, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3105
#33 0x00007f426d065e08 in QETWidget::translateMouseEvent (this=0x101d170, event=<value optimized out>) at kernel/qapplication_x11.cpp:4438
#34 0x00007f426d0644c9 in QApplication::x11ProcessEvent (this=0x69b0d0, event=0x7ffface3b8f0) at kernel/qapplication_x11.cpp:3564
#35 0x00007f426d08c0f2 in x11EventSourceDispatch (s=0x6a8860, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#36 0x00007f42696e2bd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#37 0x00007f42696e33b0 in ?? () from /lib64/libglib-2.0.so.0
#38 0x00007f42696e3650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#39 0x00007f426de6291f in QEventDispatcherGlib::processEvents (this=0x69bb30, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#40 0x00007f426d08bd8e in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x00007f426de37052 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#42 0x00007f426de37265 in QEventLoop::exec (this=0x7ffface3bc10, flags=...) at kernel/qeventloop.cpp:201
#43 0x00007f426de3b6ab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#44 0x00007f425e4e0da8 in kdemain (argc=1, argv=0x697560) at /usr/src/debug/kdebase-workspace-4.6.0/plasma/desktop/shell/main.cpp:118
#45 0x00000000004075e9 in _start ()

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-03-26 00:03:45 UTC

*** This bug has been marked as a duplicate of bug 253584 ***