Bug 264382 - Crash when disabling wireless network from kde's network manager applet
Summary: Crash when disabling wireless network from kde's network manager applet
Status: RESOLVED DUPLICATE of bug 253584
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: Plasma Widget (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Kügler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-26 23:54 UTC by João Eiras
Modified: 2011-01-29 14:27 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description João Eiras 2011-01-26 23:54:23 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
1) I clicked the network manager icon in the system tray
2) Next to "WLAN Interface" clicked on the red X button to disconnect that network interface
3) Plasma crashed

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb6092a30 (LWP 1924))]

Thread 6 (Thread 0xadd7db70 (LWP 1928)):
#0  0x04798f1a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#1  0x04799279 in ?? () from /lib/libglib-2.0.so.0
#2  0x04799848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x0824359f in QEventDispatcherGlib::processEvents (this=0x983ba60, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#4  0x08213609 in QEventLoop::processEvents (this=0xadd7d1d0, flags=) at kernel/qeventloop.cpp:149
#5  0x08213a8a in QEventLoop::exec (this=0xadd7d1d0, flags=...) at kernel/qeventloop.cpp:201
#6  0x0810fb7e in QThread::exec (this=0x983b638) at thread/qthread.cpp:490
#7  0x081f235b in QInotifyFileSystemWatcherEngine::run (this=0x983b638) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x08112df9 in QThreadPrivate::start (arg=0x983b638) at thread/qthread_unix.cpp:266
#9  0x08b7cba8 in ?? () from /usr/lib/nvidia-current/libGL.so.1

Thread 5 (Thread 0xac377b70 (LWP 2481)):
#0  0x00c9d416 in __kernel_vsyscall ()
#1  0x008994dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x009f0d9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x081139c7 in wait (this=0x9b76db0, mutex=0x9b766c0, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x9b76db0, mutex=0x9b766c0, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0x008f3030 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9b76d98, th=0x9e9fe08) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0x008f67dc in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x9b76de8, th=0x9e9fe08) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0x008f255b in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9b76d98, th=0x9e9fe08) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0x008f68d2 in ThreadWeaver::WorkingHardState::applyForWork (this=0x9b76de8, th=0x9e9fe08) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0x008f3533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9b76d98, th=0x9e9fe08, previous=0xa3abf08) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0x008f495e in ThreadWeaver::ThreadRunHelper::run (this=0xac377234, parent=0x9b76d98, th=0x9e9fe08) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0x008f507b in ThreadWeaver::Thread::run (this=0x9e9fe08) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0x08112df9 in QThreadPrivate::start (arg=0x9e9fe08) at thread/qthread_unix.cpp:266
#13 0x08b7cba8 in ?? () from /usr/lib/nvidia-current/libGL.so.1

Thread 4 (Thread 0xacbffb70 (LWP 2482)):
#0  0x00c9d416 in __kernel_vsyscall ()
#1  0x008994dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x009f0d9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x081139c7 in wait (this=0x9b76db0, mutex=0x9b766c0, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x9b76db0, mutex=0x9b766c0, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0x008f3030 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9b76d98, th=0x95d8f08) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0x008f67dc in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x9b76de8, th=0x95d8f08) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0x008f255b in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9b76d98, th=0x95d8f08) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0x008f68d2 in ThreadWeaver::WorkingHardState::applyForWork (this=0x9b76de8, th=0x95d8f08) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0x008f3533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9b76d98, th=0x95d8f08, previous=0x978cba0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0x008f495e in ThreadWeaver::ThreadRunHelper::run (this=0xacbff234, parent=0x9b76d98, th=0x95d8f08) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0x008f507b in ThreadWeaver::Thread::run (this=0x95d8f08) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0x08112df9 in QThreadPrivate::start (arg=0x95d8f08) at thread/qthread_unix.cpp:266
#13 0x08b7cba8 in ?? () from /usr/lib/nvidia-current/libGL.so.1

Thread 3 (Thread 0xa94c5b70 (LWP 2483)):
#0  0x00c9d416 in __kernel_vsyscall ()
#1  0x008994dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x009f0d9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x081139c7 in wait (this=0x9b76db0, mutex=0x9b766c0, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x9b76db0, mutex=0x9b766c0, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0x008f3030 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9b76d98, th=0x9e93b70) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0x008f67dc in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x9b76de8, th=0x9e93b70) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0x008f255b in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9b76d98, th=0x9e93b70) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0x008f68d2 in ThreadWeaver::WorkingHardState::applyForWork (this=0x9b76de8, th=0x9e93b70) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0x008f3533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9b76d98, th=0x9e93b70, previous=0xa69cdb8) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0x008f495e in ThreadWeaver::ThreadRunHelper::run (this=0xa94c5234, parent=0x9b76d98, th=0x9e93b70) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0x008f507b in ThreadWeaver::Thread::run (this=0x9e93b70) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0x08112df9 in QThreadPrivate::start (arg=0x9e93b70) at thread/qthread_unix.cpp:266
#13 0x08b7cba8 in ?? () from /usr/lib/nvidia-current/libGL.so.1

Thread 2 (Thread 0xa8cc4b70 (LWP 2484)):
#0  0x00c9d416 in __kernel_vsyscall ()
#1  0x008994dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0x009f0d9d in pthread_cond_wait () from /lib/libc.so.6
#3  0x081139c7 in wait (this=0x9b76db0, mutex=0x9b766c0, time=4294967295) at thread/qwaitcondition_unix.cpp:88
#4  QWaitCondition::wait (this=0x9b76db0, mutex=0x9b766c0, time=4294967295) at thread/qwaitcondition_unix.cpp:160
#5  0x008f3030 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x9b76d98, th=0x97bcde8) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0x008f67dc in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x9b76de8, th=0x97bcde8) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0x008f255b in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x9b76d98, th=0x97bcde8) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0x008f68d2 in ThreadWeaver::WorkingHardState::applyForWork (this=0x9b76de8, th=0x97bcde8) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0x008f3533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x9b76d98, th=0x97bcde8, previous=0xa666c30) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0x008f495e in ThreadWeaver::ThreadRunHelper::run (this=0xa8cc4234, parent=0x9b76d98, th=0x97bcde8) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0x008f507b in ThreadWeaver::Thread::run (this=0x97bcde8) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0x08112df9 in QThreadPrivate::start (arg=0x97bcde8) at thread/qthread_unix.cpp:266
#13 0x08b7cba8 in ?? () from /usr/lib/nvidia-current/libGL.so.1

Thread 1 (Thread 0xb6092a30 (LWP 1924)):
[KCrash Handler]
#7  0x0821a8f7 in QMetaObject::cast (this=0x2172740, obj=0x9e28788) at kernel/qmetaobject.cpp:266
#8  0x02150c0a in qobject_cast<RemoteInterfaceConnection*> (this=0x9f66ed0) at /usr/include/qt4/QtCore/qobject.h:455
#9  ActivatableItem::interfaceConnection (this=0x9f66ed0) at ../../applet/activatableitem.cpp:88
#10 0x02143cac in ActivatableListWidget::hoverLeave (this=0x98920c0, uni=...) at ../../applet/activatablelistwidget.cpp:301
#11 0x0213aa0d in ActivatableListWidget::qt_metacall (this=0x98920c0, _c=QMetaObject::InvokeMetaMethod, _id=45, _a=0xbfc2c608) at moc_activatablelistwidget.cpp:102
#12 0x0821a8ca in QMetaObject::metacall (object=0x98920c0, cl=160179944, idx=45, argv=0xbfc2c608) at kernel/qmetaobject.cpp:237
#13 0x0822d6ad in QMetaObject::activate (sender=0x98fb7e8, m=0x2158a2c, local_signal_index=5, argv=0x0) at kernel/qobject.cpp:3280
#14 0x02139b53 in InterfaceItem::hoverLeave (this=0x98fb7e8, _t1=...) at moc_interfaceitem.cpp:171
#15 0x02146162 in InterfaceItem::hoverLeaveEvent (this=0x98fb7e8, event=0xbfc2c79c) at ../../applet/interfaceitem.cpp:465
#16 0x0528e176 in QGraphicsItem::sceneEvent (this=0x98fb7f0, event=0xbfc2c79c) at graphicsview/qgraphicsitem.cpp:6660
#17 0x052e54d7 in QGraphicsWidget::sceneEvent (this=0x98fb7e8, event=0xbfc2c79c) at graphicsview/qgraphicswidget.cpp:1173
#18 0x052a6569 in QGraphicsScenePrivate::sendEvent (this=0x9590d48, item=0x98fb7f0, event=0xbfc2c79c) at graphicsview/qgraphicsscene.cpp:1211
#19 0x052a68ae in QGraphicsScenePrivate::sendHoverEvent (this=0x9590d48, type=QEvent::GraphicsSceneHoverLeave, item=0x98fb7f0, hoverEvent=0xbfc2c8ac) at graphicsview/qgraphicsscene.cpp:1258
#20 0x052ac9e3 in QGraphicsScenePrivate::dispatchHoverEvent (this=0x9590d48, hoverEvent=0xbfc2c8ac) at graphicsview/qgraphicsscene.cpp:3902
#21 0x052ace68 in QGraphicsScene::mouseMoveEvent (this=0x958b860, mouseEvent=0xbfc2ce34) at graphicsview/qgraphicsscene.cpp:4080
#22 0x052c157d in QGraphicsScene::event (this=0x958b860, event=0xbfc2ce34) at graphicsview/qgraphicsscene.cpp:3437
#23 0x04bdbfdc in QApplicationPrivate::notify_helper (this=0x9598bd0, receiver=0x958b860, e=0xbfc2ce34) at kernel/qapplication.cpp:4396
#24 0x04be204e in QApplication::notify (this=0x95896e0, receiver=0x958b860, e=0xbfc2ce34) at kernel/qapplication.cpp:3798
#25 0x0118668a in KApplication::notify (this=0x95896e0, receiver=0x958b860, event=0xbfc2ce34) at ../../kdeui/kernel/kapplication.cpp:310
#26 0x08214b3b in QCoreApplication::notifyInternal (this=0x95896e0, receiver=0x958b860, event=0xbfc2ce34) at kernel/qcoreapplication.cpp:732
#27 0x04bdbb9e in sendSpontaneousEvent (receiver=0x958b860, event=0x0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#28 qt_sendSpontaneousEvent (receiver=0x958b860, event=0x0) at kernel/qapplication.cpp:5388
#29 0x052df282 in QGraphicsViewPrivate::mouseMoveEventHandler (this=0x9948d48, event=0xbfc2d680) at graphicsview/qgraphicsview.cpp:647
#30 0x052df4c6 in QGraphicsView::mouseMoveEvent (this=0x9948850, event=0xbfc2d680) at graphicsview/qgraphicsview.cpp:3272
#31 0x04c39caa in QWidget::event (this=0x9948850, event=0xbfc2d680) at kernel/qwidget.cpp:8172
#32 0x0505b763 in QFrame::event (this=0x9948850, e=0xbfc2d680) at widgets/qframe.cpp:557
#33 0x050f8a82 in QAbstractScrollArea::viewportEvent (this=0x98c26e8, e=0x0) at widgets/qabstractscrollarea.cpp:1043
#34 0x052dcccb in QGraphicsView::viewportEvent (this=0x9948850, event=0xbfc2d680) at graphicsview/qgraphicsview.cpp:2862
#35 0x050fb4d5 in viewportEvent (this=0x9946910, o=0x994bbd0, e=0xbfc2d680) at widgets/qabstractscrollarea_p.h:100
#36 QAbstractScrollAreaFilter::eventFilter (this=0x9946910, o=0x994bbd0, e=0xbfc2d680) at widgets/qabstractscrollarea_p.h:116
#37 0x0821429a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9598bd0, receiver=0x994bbd0, event=0xbfc2d680) at kernel/qcoreapplication.cpp:847
#38 0x04bdbfb9 in QApplicationPrivate::notify_helper (this=0x9598bd0, receiver=0x994bbd0, e=0xbfc2d680) at kernel/qapplication.cpp:4392
#39 0x04be2c2e in QApplication::notify (this=0x95896e0, receiver=0x994bbd0, e=0xbfc2d680) at kernel/qapplication.cpp:3959
#40 0x0118668a in KApplication::notify (this=0x95896e0, receiver=0x994bbd0, event=0xbfc2d680) at ../../kdeui/kernel/kapplication.cpp:310
#41 0x08214b3b in QCoreApplication::notifyInternal (this=0x95896e0, receiver=0x994bbd0, event=0xbfc2d680) at kernel/qcoreapplication.cpp:732
#42 0x04be1094 in sendEvent (receiver=0x994bbd0, event=0xbfc2d680, alienWidget=0x994bbd0, nativeWidget=0x9947a40, buttonDown=0x55763c0, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#43 QApplicationPrivate::sendMouseEvent (receiver=0x994bbd0, event=0xbfc2d680, alienWidget=0x994bbd0, nativeWidget=0x9947a40, buttonDown=0x55763c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3058
#44 0x04c6fd10 in QETWidget::translateMouseEvent (this=0x9947a40, event=0xbfc2db9c) at kernel/qapplication_x11.cpp:4403
#45 0x04c6f151 in QApplication::x11ProcessEvent (this=0x95896e0, event=0xbfc2db9c) at kernel/qapplication_x11.cpp:3414
#46 0x04c9e36a in x11EventSourceDispatch (s=0x959b8f8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#47 0x04795855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#48 0x04799668 in ?? () from /lib/libglib-2.0.so.0
#49 0x04799848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#50 0x08243565 in QEventDispatcherGlib::processEvents (this=0x9534ce8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#51 0x04c9dbe5 in QGuiEventDispatcherGlib::processEvents (this=0x9534ce8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#52 0x08213609 in QEventLoop::processEvents (this=0xbfc2de94, flags=) at kernel/qeventloop.cpp:149
#53 0x08213a8a in QEventLoop::exec (this=0xbfc2de94, flags=...) at kernel/qeventloop.cpp:201
#54 0x0821800f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#55 0x04bdae07 in QApplication::exec () at kernel/qapplication.cpp:3672
#56 0x00c5586e in kdemain (argc=1, argv=0xbfc2e0a4) at ../../../../plasma/desktop/shell/main.cpp:118
#57 0x080485bb in main (argc=1, argv=0xbfc2e0a4) at plasma-desktop_dummy.cpp:3

Reported using DrKonqi
Comment 1 Dario Andres 2011-01-29 14:27:29 UTC
[Comment from a bug triager]
This issue is being tracked at bug 253584. Merging. Thanks

*** This bug has been marked as a duplicate of bug 253584 ***