Bug 270336 - Closing wifi connexion with network plasmoid lead to crash
Summary: Closing wifi connexion with network plasmoid lead to crash
Status: RESOLVED DUPLICATE of bug 253584
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-07 18:09 UTC by Bruno Friedmann
Modified: 2011-04-07 19:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Friedmann 2011-04-07 18:09:32 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-4-desktop x86_64
Distribution: "openSUSE 11.5 Milestone 0 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed: I was browsing internet with konqueror.
when I closed konqueror a dialog box said one error appear in javascript ! I close it.
Then disconnect the wifi connexion by clicking on red cros in plamoid-networkmanager

At that time plasma crash, and restart automatically.

-- Backtrace:
Application: Outil de gestion de fenêtres Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f275d4c0760 (LWP 8501))]

Thread 2 (Thread 0x7f27382cb700 (LWP 8533)):
#0  0x00007f275abdc503 in __poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f2757a3f114 in g_main_context_poll (n_fds=1, fds=0x1308570, priority=<optimized out>, timeout=-1, context=0x1556740) at gmain.c:3404
#2  g_main_context_iterate (context=0x1556740, block=1, dispatch=1, self=<optimized out>) at gmain.c:3086
#3  0x00007f2757a3f650 in g_main_context_iteration (context=0x1556740, may_block=1) at gmain.c:3154
#4  0x00007f275c1d2286 in QEventDispatcherGlib::processEvents (this=0x154d900, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f275c1a68d2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f275c1a6ae5 in QEventLoop::exec (this=0x7f27382cade0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f275c0bb7a4 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:492
#8  0x00007f275c188008 in QInotifyFileSystemWatcherEngine::run (this=0x154b280) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f275c0be095 in QThreadPrivate::start (arg=0x154b280) at thread/qthread_unix.cpp:320
#10 0x00007f275be2da3f in start_thread (arg=0x7f27382cb700) at pthread_create.c:297
#11 0x00007f275abe567d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f275d4c0760 (LWP 8501)):
[KCrash Handler]
#6  0x00007f275c4d4490 in vtable for QtSharedPointer::ExternalRefCountData () from /usr/lib64/libQtCore.so.4
#7  0x00007f275c1ad3b9 in QMetaObject::cast (this=0x7f273b6b7000, obj=0x93e3a0) at kernel/qmetaobject.cpp:266
#8  0x00007f273b6da7fc in ActivatableListWidget::hoverLeave (this=<optimized out>, uni=...) at /usr/src/debug/networkmanagement/applet/activatablelistwidget.cpp:344
#9  0x00007f273b6d0871 in ActivatableListWidget::qt_metacall (this=0x1c39880, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff10c37710) at /usr/src/debug/networkmanagement/build/applet/moc_activatablelistwidget.cpp:104
#10 0x00007f275c1bba5f in QMetaObject::activate (sender=0x1cb7730, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff10c37710) at kernel/qobject.cpp:3278
#11 0x00007f273b6d1635 in InterfaceItem::hoverLeave (this=<optimized out>, _t1=<optimized out>) at /usr/src/debug/networkmanagement/build/applet/moc_interfaceitem.cpp:171
#12 0x00007f273b6dd325 in InterfaceItem::hoverLeaveEvent (this=0x1cb7730, event=0x7fff10c377c0) at /usr/src/debug/networkmanagement/applet/interfaceitem.cpp:465
#13 0x00007f275b914f4a in QGraphicsItem::sceneEvent (this=0x1cb7740, event=0x7fff10c377c0) at graphicsview/qgraphicsitem.cpp:6712
#14 0x00007f275b93ec8f in QGraphicsScenePrivate::sendHoverEvent (this=0x84c9b0, type=<optimized out>, item=0x1cb7740, hoverEvent=0x7fff10c37950) at graphicsview/qgraphicsscene.cpp:1254
#15 0x00007f275b93f10b in QGraphicsScenePrivate::dispatchHoverEvent (this=0x84c9b0, hoverEvent=0x7fff10c37950) at graphicsview/qgraphicsscene.cpp:3898
#16 0x00007f275b93f644 in QGraphicsScene::mouseMoveEvent (this=<optimized out>, mouseEvent=0x7fff10c38020) at graphicsview/qgraphicsscene.cpp:4076
#17 0x00007f275b951d6b in QGraphicsScene::event (this=0x7fdaa0, event=0x7fff10c38020) at graphicsview/qgraphicsscene.cpp:3433
#18 0x00007f275b352144 in QApplicationPrivate::notify_helper (this=0x6f60f0, receiver=0x7fdaa0, e=0x7fff10c38020) at kernel/qapplication.cpp:4462
#19 0x00007f275b35a6fa in QApplication::notify (this=<optimized out>, receiver=0x7fdaa0, e=0x7fff10c38020) at kernel/qapplication.cpp:4341
#20 0x00007f275ce4cd46 in KApplication::notify (this=0x6e7610, receiver=0x7fdaa0, event=0x7fff10c38020) at /usr/src/debug/kdelibs-4.6.2/kdeui/kernel/kapplication.cpp:311
#21 0x00007f275c1a747c in QCoreApplication::notifyInternal (this=0x6e7610, receiver=0x7fdaa0, event=0x7fff10c38020) at kernel/qcoreapplication.cpp:731
#22 0x00007f275b9684ef in QGraphicsViewPrivate::mouseMoveEventHandler (this=0x1d3a980, event=0x7fff10c38be0) at graphicsview/qgraphicsview.cpp:647
#23 0x00007f275b9686ee in QGraphicsView::mouseMoveEvent (this=0x1d39be0, event=0x7fff10c38be0) at graphicsview/qgraphicsview.cpp:3274
#24 0x00007f275b3a3c90 in QWidget::event (this=0x1d39be0, event=0x7fff10c38be0) at kernel/qwidget.cpp:8244
#25 0x00007f275b748a86 in QFrame::event (this=0x1d39be0, e=0x7fff10c38be0) at widgets/qframe.cpp:557
#26 0x00007f275b96c73b in QGraphicsView::viewportEvent (this=0x1d39be0, event=0x7fff10c38be0) at graphicsview/qgraphicsview.cpp:2864
#27 0x00007f275c1a7607 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x1d41040, event=0x7fff10c38be0) at kernel/qcoreapplication.cpp:846
#28 0x00007f275b352111 in QApplicationPrivate::notify_helper (this=0x6f60f0, receiver=0x1d41040, e=0x7fff10c38be0) at kernel/qapplication.cpp:4458
#29 0x00007f275b35af7c in QApplication::notify (this=<optimized out>, receiver=0x1d41040, e=0x7fff10c38be0) at kernel/qapplication.cpp:4023
#30 0x00007f275ce4cd46 in KApplication::notify (this=0x6e7610, receiver=0x1d41040, event=0x7fff10c38be0) at /usr/src/debug/kdelibs-4.6.2/kdeui/kernel/kapplication.cpp:311
#31 0x00007f275c1a747c in QCoreApplication::notifyInternal (this=0x6e7610, receiver=0x1d41040, event=0x7fff10c38be0) at kernel/qcoreapplication.cpp:731
#32 0x00007f275b353155 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:215
#33 QApplicationPrivate::sendMouseEvent (receiver=0x1d41040, event=0x7fff10c38be0, alienWidget=0x1d41040, nativeWidget=0x1d375a0, buttonDown=0x7f275be24198, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3122
#34 0x00007f275b3d1b48 in QETWidget::translateMouseEvent (this=0x1d375a0, event=<optimized out>) at kernel/qapplication_x11.cpp:4461
#35 0x00007f275b3d0209 in QApplication::x11ProcessEvent (this=0x6e7610, event=0x7fff10c39540) at kernel/qapplication_x11.cpp:3587
#36 0x00007f275b3f7f12 in x11EventSourceDispatch (s=0x6fbc60, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#37 0x00007f2757a3ebd3 in g_main_dispatch (context=0x6fa9b0) at gmain.c:2440
#38 g_main_context_dispatch (context=0x6fa9b0) at gmain.c:3013
#39 0x00007f2757a3f3b0 in g_main_context_iterate (context=0x6fa9b0, block=1, dispatch=1, self=<optimized out>) at gmain.c:3091
#40 0x00007f2757a3f650 in g_main_context_iteration (context=0x6fa9b0, may_block=1) at gmain.c:3154
#41 0x00007f275c1d222f in QEventDispatcherGlib::processEvents (this=0x6ed5c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#42 0x00007f275b3f7bae in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x00007f275c1a68d2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#44 0x00007f275c1a6ae5 in QEventLoop::exec (this=0x7fff10c39860, flags=...) at kernel/qeventloop.cpp:201
#45 0x00007f275c1aaf2b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#46 0x00007f274aea2028 in kdemain (argc=1, argv=0x6bfd30) at /usr/src/debug/kdebase-workspace-4.6.2/plasma/desktop/shell/main.cpp:118
#47 0x00000000004075c9 in launch (argc=1, _name=0x693a18 "/usr/bin/plasma-desktop", args=<optimized out>, cwd=0x0, envc=<optimized out>, envs=<optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40b357 "0") at /usr/src/debug/kdelibs-4.6.2/kinit/kinit.cpp:734
#48 0x00000000004080bd in handle_launcher_request (sock=8, who=<optimized out>) at /usr/src/debug/kdelibs-4.6.2/kinit/kinit.cpp:1226
#49 0x000000000040885a in handle_requests (waitForPid=<optimized out>) at /usr/src/debug/kdelibs-4.6.2/kinit/kinit.cpp:1419
#50 0x00000000004094b0 in main (argc=4, argv=0x7fff10c3ad48, envp=0x7fff10c3ad70) at /usr/src/debug/kdelibs-4.6.2/kinit/kinit.cpp:1907

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-04-07 19:01:15 UTC

*** This bug has been marked as a duplicate of bug 253584 ***