Bug 255566 - Plasma crashed when disabling wireless
Summary: Plasma crashed when disabling wireless
Status: RESOLVED DUPLICATE of bug 253584
Alias: None
Product: Network Management
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Will Stephenson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-29 09:03 UTC by Philip Muškovac
Modified: 2010-11-18 16:35 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philip Muškovac 2010-10-29 09:03:04 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.2 (KDE 4.5.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.36-1-generic i686
Distribution: Ubuntu natty (development branch)

-- Information about the crash:
- What I was doing when the application crashed:

I tried to disable wireless in plasma-widget-networkmanagement 0.9~svn1176084-0ubuntu1 and got this crash. Not sure if that's plasma or Qt..

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb787b9f0 (LWP 2683))]

Thread 2 (Thread 0xaeab9b70 (LWP 2686)):
#0  __pthread_mutex_unlock_usercnt (mutex=0xafa011ac, decr=1) at pthread_mutex_unlock.c:38
#1  0x00646fb6 in pthread_mutex_unlock (mutex=0xafa011ac) at forward.c:184
#2  0x01f0567a in g_main_context_prepare (context=<value optimized out>, priority=0xaeab913c) at /build/buildd/glib2.0-2.27.0/glib/gmain.c:2467
#3  0x01f06503 in g_main_context_iterate (context=0xafa011a8, block=1, dispatch=1, self=<value optimized out>) at /build/buildd/glib2.0-2.27.0/glib/gmain.c:2760
#4  0x01f06bc4 in g_main_context_iteration (context=0xafa011a8, may_block=1) at /build/buildd/glib2.0-2.27.0/glib/gmain.c:2843
#5  0x03c0dc57 in QEventDispatcherGlib::processEvents (this=0x98c9dc0, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x03bdf999 in QEventLoop::processEvents (this=0xaeab9280, flags=...) at kernel/qeventloop.cpp:149
#7  0x03bdfc32 in QEventLoop::exec (this=0xaeab9280, flags=...) at kernel/qeventloop.cpp:201
#8  0x03ae9b98 in QThread::exec (this=0x98c9d28) at thread/qthread.cpp:490
#9  0x03bc133b in QInotifyFileSystemWatcherEngine::run (this=0x98c9d28) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x03aec619 in QThreadPrivate::start (arg=0x98c9d28) at thread/qthread_unix.cpp:266
#11 0x0023ecc9 in start_thread (arg=0xaeab9b70) at pthread_create.c:304
#12 0x006396ae in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb787b9f0 (LWP 2683)):
[KCrash Handler]
#7  0x03d1906b in vtable for BounceEase () from /usr/lib/libQtCore.so.4
#8  0x03be6dd9 in QMetaObject::cast (this=0x6509740, obj=0x9de8c38) at kernel/qmetaobject.cpp:266
#9  0x05b6ac0a in qobject_cast<RemoteInterfaceConnection*> (this=0xa31a740) at /usr/include/qt4/QtCore/qobject.h:455
#10 ActivatableItem::interfaceConnection (this=0xa31a740) at ../../applet/activatableitem.cpp:88
#11 0x05b5df7c in ActivatableListWidget::hoverEnter (this=0x9e3c5f0, uni=...) at ../../applet/activatablelistwidget.cpp:286
#12 0x05b54a35 in ActivatableListWidget::qt_metacall (this=0x9e3c5f0, _c=QMetaObject::InvokeMetaMethod, _id=44, _a=0xbfc71a28) at moc_activatablelistwidget.cpp:101
#13 0x03be6daa in QMetaObject::metacall (object=0x9e3c5f0, cl=QMetaObject::InvokeMetaMethod, idx=44, argv=0xbfc71a28) at kernel/qmetaobject.cpp:237
#14 0x03bf6b9f in QMetaObject::activate (sender=0x9ec4f08, m=0x5b72a2c, local_signal_index=4, argv=0xbfc71a28) at kernel/qobject.cpp:3280
#15 0x05b53ba3 in InterfaceItem::hoverEnter (this=0x9ec4f08, _t1=...) at moc_interfaceitem.cpp:164
#16 0x05b601f2 in InterfaceItem::hoverEnterEvent (this=0x9ec4f08, event=0xbfc71bbc) at ../../applet/interfaceitem.cpp:457
#17 0x01a0a588 in QGraphicsItem::sceneEvent (this=0x9ec4f10, event=0xbfc71bbc) at graphicsview/qgraphicsitem.cpp:6654
#18 0x01a650c7 in QGraphicsWidget::sceneEvent (this=0x9ec4f08, event=0xbfc71bbc) at graphicsview/qgraphicswidget.cpp:1173
#19 0x01a33200 in QGraphicsScenePrivate::sendEvent (this=0x98966c8, item=0x9ec4f10, event=0xbfc71bbc) at graphicsview/qgraphicsscene.cpp:1211
#20 0x01a33fb7 in QGraphicsScenePrivate::sendHoverEvent (this=0x98966c8, type=QEvent::GraphicsSceneHoverEnter, item=0x9ec4f10, hoverEvent=0xbfc71cbc) at graphicsview/qgraphicsscene.cpp:1258
#21 0x01a34590 in QGraphicsScenePrivate::dispatchHoverEvent (this=0x98966c8, hoverEvent=0xbfc71cbc) at graphicsview/qgraphicsscene.cpp:3921
#22 0x01a349b5 in QGraphicsScene::mouseMoveEvent (this=0x9995bf8, mouseEvent=0xbfc72234) at graphicsview/qgraphicsscene.cpp:4080
#23 0x01a4682d in QGraphicsScene::event (this=0x9995bf8, event=0xbfc72234) at graphicsview/qgraphicsscene.cpp:3437
#24 0x013d4584 in QApplicationPrivate::notify_helper (this=0x989a9e0, receiver=0x9995bf8, e=0xbfc72234) at kernel/qapplication.cpp:4396
#25 0x013d8fde in QApplication::notify (this=0x988d548, receiver=0x9995bf8, e=0xbfc72234) at kernel/qapplication.cpp:3798
#26 0x010ec4aa in KApplication::notify (this=0x988d548, receiver=0x9995bf8, event=0xbfc72234) at ../../kdeui/kernel/kapplication.cpp:310
#27 0x03be07cb in QCoreApplication::notifyInternal (this=0x988d548, receiver=0x9995bf8, event=0xbfc72234) at kernel/qcoreapplication.cpp:732
#28 0x013d26ae in sendSpontaneousEvent (receiver=0x9995bf8, event=0xbfc72234) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#29 qt_sendSpontaneousEvent (receiver=0x9995bf8, event=0xbfc72234) at kernel/qapplication.cpp:5388
#30 0x01a5f06a in QGraphicsViewPrivate::mouseMoveEventHandler (this=0x9ef2530, event=0xbfc72a94) at graphicsview/qgraphicsview.cpp:647
#31 0x01a5f266 in QGraphicsView::mouseMoveEvent (this=0x9ef0278, event=0xbfc72a94) at graphicsview/qgraphicsview.cpp:3272
#32 0x0142c552 in QWidget::event (this=0x9ef0278, event=0xbfc72a94) at kernel/qwidget.cpp:8172
#33 0x018184e3 in QFrame::event (this=0x9ef0278, e=0xbfc72a94) at widgets/qframe.cpp:557
#34 0x018a63e2 in QAbstractScrollArea::viewportEvent (this=0x9ef0278, e=0xbfc72a94) at widgets/qabstractscrollarea.cpp:1043
#35 0x01a6386f in QGraphicsView::viewportEvent (this=0x9ef0278, event=0xbfc72a94) at graphicsview/qgraphicsview.cpp:2862
#36 0x018a8cd5 in viewportEvent (this=0x9ef2108, o=0x9f07ad0, e=0xbfc72a94) at widgets/qabstractscrollarea_p.h:100
#37 QAbstractScrollAreaFilter::eventFilter (this=0x9ef2108, o=0x9f07ad0, e=0xbfc72a94) at widgets/qabstractscrollarea_p.h:116
#38 0x03be096a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x989a9e0, receiver=0x9f07ad0, event=0xbfc72a94) at kernel/qcoreapplication.cpp:847
#39 0x013d4560 in QApplicationPrivate::notify_helper (this=0x989a9e0, receiver=0x9f07ad0, e=0xbfc72a94) at kernel/qapplication.cpp:4392
#40 0x013d9911 in QApplication::notify (this=0x988d548, receiver=0x9f07ad0, e=0xbfc72a94) at kernel/qapplication.cpp:3959
#41 0x010ec4aa in KApplication::notify (this=0x988d548, receiver=0x9f07ad0, event=0xbfc72a94) at ../../kdeui/kernel/kapplication.cpp:310
#42 0x03be07cb in QCoreApplication::notifyInternal (this=0x988d548, receiver=0x9f07ad0, event=0xbfc72a94) at kernel/qcoreapplication.cpp:732
#43 0x013d549b in sendSpontaneousEvent (receiver=0x9f07ad0, event=0xbfc72a94, alienWidget=0x9f07ad0, nativeWidget=0x9ef6070, buttonDown=0x1d2c3c0, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#44 QApplicationPrivate::sendMouseEvent (receiver=0x9f07ad0, event=0xbfc72a94, alienWidget=0x9f07ad0, nativeWidget=0x9ef6070, buttonDown=0x1d2c3c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3056
#45 0x0145c27c in QETWidget::translateMouseEvent (this=0x9ef6070, event=0xbfc72fbc) at kernel/qapplication_x11.cpp:4403
#46 0x0145a777 in QApplication::x11ProcessEvent (this=0x988d548, event=0xbfc72fbc) at kernel/qapplication_x11.cpp:3536
#47 0x01485804 in x11EventSourceDispatch (s=0x989dc40, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#48 0x01f06148 in g_main_dispatch (context=0x989cc90) at /build/buildd/glib2.0-2.27.0/glib/gmain.c:2149
#49 g_main_context_dispatch (context=0x989cc90) at /build/buildd/glib2.0-2.27.0/glib/gmain.c:2702
#50 0x01f06910 in g_main_context_iterate (context=0x989cc90, block=32598944, dispatch=1, self=<value optimized out>) at /build/buildd/glib2.0-2.27.0/glib/gmain.c:2780
#51 0x01f06bc4 in g_main_context_iteration (context=0x989cc90, may_block=1) at /build/buildd/glib2.0-2.27.0/glib/gmain.c:2843
#52 0x03c0dc1c in QEventDispatcherGlib::processEvents (this=0x9876d00, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#53 0x014853f5 in QGuiEventDispatcherGlib::processEvents (this=0x9876d00, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#54 0x03bdf999 in QEventLoop::processEvents (this=0xbfc73284, flags=...) at kernel/qeventloop.cpp:149
#55 0x03bdfc32 in QEventLoop::exec (this=0xbfc73284, flags=...) at kernel/qeventloop.cpp:201
#56 0x03be45bc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#57 0x013d2457 in QApplication::exec () at kernel/qapplication.cpp:3672
#58 0x00ef386e in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-desktop.so
#59 0x080485bb in _start ()

Reported using DrKonqi
Comment 1 Dario Andres 2010-11-18 16:35:17 UTC
[Comment from a bug triager]
This issue is being tracked at bug 253584. Merging. Thanks

*** This bug has been marked as a duplicate of bug 253584 ***