Bug 261019 - plasma-desktop crashed after deconnecting KnetworkManager
Summary: plasma-desktop crashed after deconnecting KnetworkManager
Status: RESOLVED DUPLICATE of bug 253584
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-23 00:24 UTC by Lewkow Brigitte
Modified: 2010-12-23 00:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lewkow Brigitte 2010-12-23 00:24:40 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.3 (KDE 4.5.3)
Qt Version: 4.7.0
Operating System: Linux 2.6.32-27-generic x86_64
Distribution: KXStudio 10.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

i was trying to view some changelog for Jack2 on launchpad.net then i deconnected Internet and then crash! Muon was open for selecting updates and Muon disappear while crash!

-- Backtrace:
Application: Espace de travail Plasma (plasma-desktop), signal: Segmentation fault
[KCrash Handler]
#6  0x00007ffd8d8c0707 in QMetaObject::cast (this=0x7ffd727feee0, obj=0x37fac30) at kernel/qmetaobject.cpp:266
#7  0x00007ffd728203d0 in ActivatableListWidget::hoverEnter (this=<value optimized out>, uni=...) at ../../applet/activatablelistwidget.cpp:286
#8  0x00007ffd72817e61 in ActivatableListWidget::qt_metacall (this=0x3113530, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffef1e07c0) at moc_activatablelistwidget.cpp:101
#9  0x00007ffd8d8d2da7 in QMetaObject::activate (sender=0x3154440, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x3120a50) at kernel/qobject.cpp:3280
#10 0x00007ffd728172a5 in InterfaceItem::hoverEnter (this=0x37fac30, _t1=<value optimized out>) at moc_interfaceitem.cpp:164
#11 0x00007ffd72822395 in InterfaceItem::hoverEnterEvent (this=0x3154440, event=0x7fffef1e0870) at ../../applet/interfaceitem.cpp:457
#12 0x00007ffd8d02d4b2 in QGraphicsItem::sceneEvent (this=0x3154450, event=0x37fac30) at graphicsview/qgraphicsitem.cpp:6654
#13 0x00007ffd8d04282f in QGraphicsScenePrivate::sendHoverEvent (this=0x2574990, type=<value optimized out>, item=0x3154450, hoverEvent=0x7fffef1e0a00) at graphicsview/qgraphicsscene.cpp:1258
#14 0x00007ffd8d048588 in QGraphicsScenePrivate::dispatchHoverEvent (this=0x2574990, hoverEvent=<value optimized out>) at graphicsview/qgraphicsscene.cpp:3921
#15 0x00007ffd8d0488a4 in QGraphicsScene::mouseMoveEvent (this=<value optimized out>, mouseEvent=0x7fffef1e10d0) at graphicsview/qgraphicsscene.cpp:4080
#16 0x00007ffd8d0595ab in QGraphicsScene::event (this=0x267b000, event=0x7fffef1e10d0) at graphicsview/qgraphicsscene.cpp:3437
#17 0x00007ffd8ca096ec in QApplicationPrivate::notify_helper (this=0x25828d0, receiver=0x267b000, e=0x7fffef1e10d0) at kernel/qapplication.cpp:4396
#18 0x00007ffd8ca0f1dd in QApplication::notify (this=0x2564790, receiver=0x267b000, e=0x7fffef1e10d0) at kernel/qapplication.cpp:4277
#19 0x00007ffd8e573926 in KApplication::notify (this=0x2564790, receiver=0x267b000, event=0x7fffef1e10d0) at ../../kdeui/kernel/kapplication.cpp:310
#20 0x00007ffd8d8bb0ac in QCoreApplication::notifyInternal (this=0x2564790, receiver=0x267b000, event=0x7fffef1e10d0) at kernel/qcoreapplication.cpp:732
#21 0x00007ffd8d077e77 in QGraphicsViewPrivate::mouseMoveEventHandler (this=0x318bb70, event=0x7fffef1e1c30) at graphicsview/qgraphicsview.cpp:647
#22 0x00007ffd8d07806e in QGraphicsView::mouseMoveEvent (this=0x318bb40, event=0x7fffef1e1c30) at graphicsview/qgraphicsview.cpp:3272
#23 0x00007ffd8ca5f0eb in QWidget::event (this=0x318bb40, event=0x7fffef1e1c30) at kernel/qwidget.cpp:8172
#24 0x00007ffd8ce25e76 in QFrame::event (this=0x318bb40, e=0x7fffef1e1c30) at widgets/qframe.cpp:557
#25 0x00007ffd8d075afb in QGraphicsView::viewportEvent (this=0x318bb40, event=0x7fffef1e1c30) at graphicsview/qgraphicsview.cpp:2862
#26 0x00007ffd8d8ba8d7 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x318dc70, event=0x7fffef1e1c30) at kernel/qcoreapplication.cpp:847
#27 0x00007ffd8ca096bc in QApplicationPrivate::notify_helper (this=0x25828d0, receiver=0x318dc70, e=0x7fffef1e1c30) at kernel/qapplication.cpp:4392
#28 0x00007ffd8ca0f9fe in QApplication::notify (this=0x2564790, receiver=0x318dc70, e=0x7fffef1e1c30) at kernel/qapplication.cpp:3959
#29 0x00007ffd8e573926 in KApplication::notify (this=0x2564790, receiver=0x318dc70, event=0x7fffef1e1c30) at ../../kdeui/kernel/kapplication.cpp:310
#30 0x00007ffd8d8bb0ac in QCoreApplication::notifyInternal (this=0x2564790, receiver=0x318dc70, event=0x7fffef1e1c30) at kernel/qcoreapplication.cpp:732
#31 0x00007ffd8ca0e4ae in QCoreApplication::sendEvent (receiver=0x318dc70, event=0x7fffef1e1c30, alienWidget=0x318dc70, nativeWidget=0x317f8e0, buttonDown=<value optimized out>, 
    lastMouseReceiver=<value optimized out>, spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#32 QApplicationPrivate::sendMouseEvent (receiver=0x318dc70, event=0x7fffef1e1c30, alienWidget=0x318dc70, nativeWidget=0x317f8e0, buttonDown=<value optimized out>, 
    lastMouseReceiver=<value optimized out>, spontaneous=true) at kernel/qapplication.cpp:3058
#33 0x00007ffd8ca914a5 in QETWidget::translateMouseEvent (this=0x317f8e0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4403
#34 0x00007ffd8ca8fddc in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fffef1e2550) at kernel/qapplication_x11.cpp:3536
#35 0x00007ffd8cabc012 in x11EventSourceDispatch (s=0x2586220, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#36 0x00007ffd84f328c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#37 0x00007ffd84f36748 in ?? () from /lib/libglib-2.0.so.0
#38 0x00007ffd84f368fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#39 0x00007ffd8d8e7183 in QEventDispatcherGlib::processEvents (this=0x2549860, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#40 0x00007ffd8cabb97e in QGuiEventDispatcherGlib::processEvents (this=0x37fac30, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x00007ffd8d8b9dd2 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#42 0x00007ffd8d8ba1bc in QEventLoop::exec (this=0x7fffef1e2880, flags=) at kernel/qeventloop.cpp:201
#43 0x00007ffd8d8be26b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#44 0x00007ffd9054e083 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:118
#45 0x00007ffd901acc4d in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fffef1e2c58) at libc-start.c:226
#46 0x00000000004006c9 in _start ()

Reported using DrKonqi
Comment 1 Lewkow Brigitte 2010-12-23 00:28:53 UTC
No Muon did not disappear.. sorry!
Comment 2 Dario Andres 2010-12-23 00:59:45 UTC
[Comment from a bug triager]
This issue is being tracked at bug 253584. Merging. Thanks

*** This bug has been marked as a duplicate of bug 253584 ***