Bug 263955 - Plasma crashed when I disabled wireless connections
Summary: Plasma crashed when I disabled wireless connections
Status: RESOLVED DUPLICATE of bug 253584
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-22 11:57 UTC by marko.gabriel.cz
Modified: 2011-01-22 12:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description marko.gabriel.cz 2011-01-22 11:57:09 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.5 (KDE 4.5.5)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-24-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed: After boot and login to KDE 4.5 I disabled wireless connections, when plasma suddenly crashed.

-- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb787f720 (LWP 2157))]

Thread 2 (Thread 0xae9b9b70 (LWP 2160)):
#0  0x02bc0e36 in clock_gettime (clock_id=45895668, tp=0xae9b8f80) at ../sysdeps/unix/clock_gettime.c:100
#1  0x0428750b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x0435e6e5 in QTimerInfoList::updateCurrentTime (this=0x9f24adc) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0435e72a in QTimerInfoList::timerWait (this=0x9f24adc, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x0435c7a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xae9b90ac) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0435c83d in timerSourcePrepare (source=0x0, timeout=0x2bc4ff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x03dffe6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x03e00279 in ?? () from /lib/libglib-2.0.so.0
#9  0x03e00848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x0435c59f in QEventDispatcherGlib::processEvents (this=0x9f24610, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x0432c609 in QEventLoop::processEvents (this=0xae9b9280, flags=) at kernel/qeventloop.cpp:149
#12 0x0432ca8a in QEventLoop::exec (this=0xae9b9280, flags=...) at kernel/qeventloop.cpp:201
#13 0x04228b7e in QThread::exec (this=0x9f241c8) at thread/qthread.cpp:490
#14 0x0430b35b in QInotifyFileSystemWatcherEngine::run (this=0x9f241c8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x0422bdf9 in QThreadPrivate::start (arg=0x9f241c8) at thread/qthread_unix.cpp:266
#16 0x00201cc9 in start_thread (arg=0xae9b9b70) at pthread_create.c:304
#17 0x0034469e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb787f720 (LWP 2157)):
[KCrash Handler]
#7  0x0445e0f2 in vtable for QTimeLinePrivate () from /usr/lib/libQtCore.so.4
#8  0x043338f9 in QMetaObject::cast (this=0x34a0740, obj=0x9d99378) at kernel/qmetaobject.cpp:266
#9  0x0347ec0a in qobject_cast<RemoteInterfaceConnection*> (this=0x9e44a78) at /usr/include/qt4/QtCore/qobject.h:455
#10 ActivatableItem::interfaceConnection (this=0x9e44a78) at ../../applet/activatableitem.cpp:88
#11 0x03471f7c in ActivatableListWidget::hoverEnter (this=0x9e36648, uni=...) at ../../applet/activatablelistwidget.cpp:286
#12 0x03468a35 in ActivatableListWidget::qt_metacall (this=0x9e36648, _c=QMetaObject::InvokeMetaMethod, _id=44, _a=0xbfb7db08) at moc_activatablelistwidget.cpp:101
#13 0x043338ca in QMetaObject::metacall (object=0x9e36648, cl=166100391, idx=44, argv=0xbfb7db08) at kernel/qmetaobject.cpp:237
#14 0x043466ad in QMetaObject::activate (sender=0x9ea7980, m=0x3486a2c, local_signal_index=4, argv=0x9e45828) at kernel/qobject.cpp:3280
#15 0x03467ba3 in InterfaceItem::hoverEnter (this=0x9ea7980, _t1=...) at moc_interfaceitem.cpp:164
#16 0x034741f2 in InterfaceItem::hoverEnterEvent (this=0x9ea7980, event=0xbfb7dc9c) at ../../applet/interfaceitem.cpp:457
#17 0x05e281a2 in QGraphicsItem::sceneEvent (this=0x9ea7988, event=0xbfb7dc9c) at graphicsview/qgraphicsitem.cpp:6654
#18 0x05e7f4d7 in QGraphicsWidget::sceneEvent (this=0x9ea7980, event=0xbfb7dc9c) at graphicsview/qgraphicswidget.cpp:1173
#19 0x05e40569 in QGraphicsScenePrivate::sendEvent (this=0x97c8038, item=0x9ea7988, event=0xbfb7dc9c) at graphicsview/qgraphicsscene.cpp:1211
#20 0x05e408ae in QGraphicsScenePrivate::sendHoverEvent (this=0x97c8038, type=QEvent::GraphicsSceneHoverEnter, item=0x9ea7988, hoverEvent=0xbfb7ddac) at graphicsview/qgraphicsscene.cpp:1258
#21 0x05e46b04 in QGraphicsScenePrivate::dispatchHoverEvent (this=0x97c8038, hoverEvent=0xbfb7ddac) at graphicsview/qgraphicsscene.cpp:3921
#22 0x05e46e68 in QGraphicsScene::mouseMoveEvent (this=0x98a1638, mouseEvent=0xbfb7e334) at graphicsview/qgraphicsscene.cpp:4080
#23 0x05e5b57d in QGraphicsScene::event (this=0x98a1638, event=0xbfb7e334) at graphicsview/qgraphicsscene.cpp:3437
#24 0x05775fdc in QApplicationPrivate::notify_helper (this=0x97d3508, receiver=0x98a1638, e=0xbfb7e334) at kernel/qapplication.cpp:4396
#25 0x0577c04e in QApplication::notify (this=0x97c5508, receiver=0x98a1638, e=0xbfb7e334) at kernel/qapplication.cpp:3798
#26 0x00d1dd8a in KApplication::notify (this=0x97c5508, receiver=0x98a1638, event=0xbfb7e334) at ../../kdeui/kernel/kapplication.cpp:310
#27 0x0432db3b in QCoreApplication::notifyInternal (this=0x97c5508, receiver=0x98a1638, event=0xbfb7e334) at kernel/qcoreapplication.cpp:732
#28 0x05775b9e in sendSpontaneousEvent (receiver=0x98a1638, event=0x9e67da8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#29 qt_sendSpontaneousEvent (receiver=0x98a1638, event=0x9e67da8) at kernel/qapplication.cpp:5388
#30 0x05e79282 in QGraphicsViewPrivate::mouseMoveEventHandler (this=0x9f406e8, event=0xbfb7eb80) at graphicsview/qgraphicsview.cpp:647
#31 0x05e794c6 in QGraphicsView::mouseMoveEvent (this=0x9f3fba8, event=0xbfb7eb80) at graphicsview/qgraphicsview.cpp:3272
#32 0x057d3caa in QWidget::event (this=0x9f3fba8, event=0xbfb7eb80) at kernel/qwidget.cpp:8172
#33 0x05bf5763 in QFrame::event (this=0x9f3fba8, e=0xbfb7eb80) at widgets/qframe.cpp:557
#34 0x05c92a82 in QAbstractScrollArea::viewportEvent (this=0x9e67da7, e=0x9e67da8) at widgets/qabstractscrollarea.cpp:1043
#35 0x05e76ccb in QGraphicsView::viewportEvent (this=0x9f3fba8, event=0xbfb7eb80) at graphicsview/qgraphicsview.cpp:2862
#36 0x05c954d5 in viewportEvent (this=0x9f41118, o=0x9f42d78, e=0xbfb7eb80) at widgets/qabstractscrollarea_p.h:100
#37 QAbstractScrollAreaFilter::eventFilter (this=0x9f41118, o=0x9f42d78, e=0xbfb7eb80) at widgets/qabstractscrollarea_p.h:116
#38 0x0432d29a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x97d3508, receiver=0x9f42d78, event=0xbfb7eb80) at kernel/qcoreapplication.cpp:847
#39 0x05775fb9 in QApplicationPrivate::notify_helper (this=0x97d3508, receiver=0x9f42d78, e=0xbfb7eb80) at kernel/qapplication.cpp:4392
#40 0x0577cc2e in QApplication::notify (this=0x97c5508, receiver=0x9f42d78, e=0xbfb7eb80) at kernel/qapplication.cpp:3959
#41 0x00d1dd8a in KApplication::notify (this=0x97c5508, receiver=0x9f42d78, event=0xbfb7eb80) at ../../kdeui/kernel/kapplication.cpp:310
#42 0x0432db3b in QCoreApplication::notifyInternal (this=0x97c5508, receiver=0x9f42d78, event=0xbfb7eb80) at kernel/qcoreapplication.cpp:732
#43 0x0577b094 in sendEvent (receiver=0x9f42d78, event=0xbfb7eb80, alienWidget=0x9f42d78, nativeWidget=0x9ef3b18, buttonDown=0x61103c0, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#44 QApplicationPrivate::sendMouseEvent (receiver=0x9f42d78, event=0xbfb7eb80, alienWidget=0x9f42d78, nativeWidget=0x9ef3b18, buttonDown=0x61103c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3058
#45 0x05809d10 in QETWidget::translateMouseEvent (this=0x9ef3b18, event=0xbfb7f09c) at kernel/qapplication_x11.cpp:4403
#46 0x05809151 in QApplication::x11ProcessEvent (this=0x97c5508, event=0xbfb7f09c) at kernel/qapplication_x11.cpp:3414
#47 0x0583836a in x11EventSourceDispatch (s=0x97d6740, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#48 0x03dfc855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#49 0x03e00668 in ?? () from /lib/libglib-2.0.so.0
#50 0x03e00848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#51 0x0435c565 in QEventDispatcherGlib::processEvents (this=0x97aece8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#52 0x05837be5 in QGuiEventDispatcherGlib::processEvents (this=0x97aece8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#53 0x0432c609 in QEventLoop::processEvents (this=0xbfb7f394, flags=) at kernel/qeventloop.cpp:149
#54 0x0432ca8a in QEventLoop::exec (this=0xbfb7f394, flags=...) at kernel/qeventloop.cpp:201
#55 0x0433100f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#56 0x05774e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#57 0x00a3a8e7 in kdemain (argc=1, argv=0xbfb7f5a4) at ../../../../plasma/desktop/shell/main.cpp:118
#58 0x080485bb in main (argc=1, argv=0xbfb7f5a4) at plasma-desktop_dummy.cpp:3

Reported using DrKonqi
Comment 1 Dario Andres 2011-01-22 12:33:42 UTC
[Comment from a bug triager]
This issue is being tracked at bug 253584. Merging. Thanks

*** This bug has been marked as a duplicate of bug 253584 ***