Bug 269821 - Plasma Desktop crashed After Disabling Connections
Summary: Plasma Desktop crashed After Disabling Connections
Status: RESOLVED DUPLICATE of bug 253584
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-31 14:37 UTC by Lewkow Brigitte
Modified: 2011-03-31 17:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lewkow Brigitte 2011-03-31 14:37:55 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.5.3 (KDE 4.5.3)
Qt Version: 4.7.0
Operating System: Linux 2.6.32-26-preempt x86_64
Distribution: KXStudio 10.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I was downloading and installing packages with synaptic. After it  finished i deconnect internet (network widget).... then crashed!

-- Backtrace:
Application: Espace de travail Plasma (plasma-desktop), signal: Segmentation fault
[KCrash Handler]
#6  0x00007f37cd0ce707 in QMetaObject::cast (this=0x7f37b46eaee0, obj=0x2cff6c0) at kernel/qmetaobject.cpp:266
#7  0x00007f37b47353d0 in ActivatableListWidget::hoverEnter (this=<value optimized out>, uni=...) at ../../applet/activatablelistwidget.cpp:286
#8  0x00007f37b472ce61 in ActivatableListWidget::qt_metacall (this=0x1e9a5d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff57922630) at moc_activatablelistwidget.cpp:101
#9  0x00007f37cd0e0da7 in QMetaObject::activate (sender=0x1e3cc00, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1dd9050) at kernel/qobject.cpp:3280
#10 0x00007f37b472c2a5 in InterfaceItem::hoverEnter (this=0x2cff6c0, _t1=<value optimized out>) at moc_interfaceitem.cpp:164
#11 0x00007f37b4737395 in InterfaceItem::hoverEnterEvent (this=0x1e3cc00, event=0x7fff579226e0) at ../../applet/interfaceitem.cpp:457
#12 0x00007f37cc83b4b2 in QGraphicsItem::sceneEvent (this=0x1e3cc10, event=0x2cff6c0) at graphicsview/qgraphicsitem.cpp:6654
#13 0x00007f37cc85082f in QGraphicsScenePrivate::sendHoverEvent (this=0x14d0270, type=<value optimized out>, item=0x1e3cc10, hoverEvent=0x7fff57922870) at graphicsview/qgraphicsscene.cpp:1258
#14 0x00007f37cc856588 in QGraphicsScenePrivate::dispatchHoverEvent (this=0x14d0270, hoverEvent=<value optimized out>) at graphicsview/qgraphicsscene.cpp:3921
#15 0x00007f37cc8568a4 in QGraphicsScene::mouseMoveEvent (this=<value optimized out>, mouseEvent=0x7fff57922f40) at graphicsview/qgraphicsscene.cpp:4080
#16 0x00007f37cc8675ab in QGraphicsScene::event (this=0x14cacb0, event=0x7fff57922f40) at graphicsview/qgraphicsscene.cpp:3437
#17 0x00007f37cc2176ec in QApplicationPrivate::notify_helper (this=0x14e0c80, receiver=0x14cacb0, e=0x7fff57922f40) at kernel/qapplication.cpp:4396
#18 0x00007f37cc21d1dd in QApplication::notify (this=0x14c0aa0, receiver=0x14cacb0, e=0x7fff57922f40) at kernel/qapplication.cpp:4277
#19 0x00007f37cdd81926 in KApplication::notify (this=0x14c0aa0, receiver=0x14cacb0, event=0x7fff57922f40) at ../../kdeui/kernel/kapplication.cpp:310
#20 0x00007f37cd0c90ac in QCoreApplication::notifyInternal (this=0x14c0aa0, receiver=0x14cacb0, event=0x7fff57922f40) at kernel/qcoreapplication.cpp:732
#21 0x00007f37cc885e77 in QGraphicsViewPrivate::mouseMoveEventHandler (this=0x1f16040, event=0x7fff57923aa0) at graphicsview/qgraphicsview.cpp:647
#22 0x00007f37cc88606e in QGraphicsView::mouseMoveEvent (this=0x1f16b70, event=0x7fff57923aa0) at graphicsview/qgraphicsview.cpp:3272
#23 0x00007f37cc26d0eb in QWidget::event (this=0x1f16b70, event=0x7fff57923aa0) at kernel/qwidget.cpp:8172
#24 0x00007f37cc633e76 in QFrame::event (this=0x1f16b70, e=0x7fff57923aa0) at widgets/qframe.cpp:557
#25 0x00007f37cc883afb in QGraphicsView::viewportEvent (this=0x1f16b70, event=0x7fff57923aa0) at graphicsview/qgraphicsview.cpp:2862
#26 0x00007f37cd0c88d7 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x1f2b6e0, event=0x7fff57923aa0) at kernel/qcoreapplication.cpp:847
#27 0x00007f37cc2176bc in QApplicationPrivate::notify_helper (this=0x14e0c80, receiver=0x1f2b6e0, e=0x7fff57923aa0) at kernel/qapplication.cpp:4392
#28 0x00007f37cc21d9fe in QApplication::notify (this=0x14c0aa0, receiver=0x1f2b6e0, e=0x7fff57923aa0) at kernel/qapplication.cpp:3959
#29 0x00007f37cdd81926 in KApplication::notify (this=0x14c0aa0, receiver=0x1f2b6e0, event=0x7fff57923aa0) at ../../kdeui/kernel/kapplication.cpp:310
#30 0x00007f37cd0c90ac in QCoreApplication::notifyInternal (this=0x14c0aa0, receiver=0x1f2b6e0, event=0x7fff57923aa0) at kernel/qcoreapplication.cpp:732
#31 0x00007f37cc21c4ae in QCoreApplication::sendEvent (receiver=0x1f2b6e0, event=0x7fff57923aa0, alienWidget=0x1f2b6e0, nativeWidget=0x1f17460, buttonDown=<value optimized out>, 
    lastMouseReceiver=<value optimized out>, spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#32 QApplicationPrivate::sendMouseEvent (receiver=0x1f2b6e0, event=0x7fff57923aa0, alienWidget=0x1f2b6e0, nativeWidget=0x1f17460, buttonDown=<value optimized out>, 
    lastMouseReceiver=<value optimized out>, spontaneous=true) at kernel/qapplication.cpp:3058
#33 0x00007f37cc29f4a5 in QETWidget::translateMouseEvent (this=0x1f17460, event=<value optimized out>) at kernel/qapplication_x11.cpp:4403
#34 0x00007f37cc29dddc in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff579243c0) at kernel/qapplication_x11.cpp:3536
#35 0x00007f37cc2ca012 in x11EventSourceDispatch (s=0x14e45e0, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#36 0x00007f37c47318c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#37 0x00007f37c4735748 in ?? () from /lib/libglib-2.0.so.0
#38 0x00007f37c47358fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#39 0x00007f37cd0f5183 in QEventDispatcherGlib::processEvents (this=0x14a5860, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#40 0x00007f37cc2c997e in QGuiEventDispatcherGlib::processEvents (this=0x2cff6c0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x00007f37cd0c7dd2 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#42 0x00007f37cd0c81bc in QEventLoop::exec (this=0x7fff579246f0, flags=) at kernel/qeventloop.cpp:201
#43 0x00007f37cd0cc26b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#44 0x00007f37cfd5c083 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../../plasma/desktop/shell/main.cpp:118
#45 0x00007f37cf9bac4d in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff57924ac8) at libc-start.c:226
#46 0x00000000004006c9 in _start ()

This bug may be a duplicate of or related to bug 261019.

Possible duplicates by query: bug 268823, bug 268516, bug 267206, bug 265553, bug 263955.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-03-31 17:00:30 UTC

*** This bug has been marked as a duplicate of bug 253584 ***