Bug 271670 - Plasma Desktop Shell (disconnect from wi-fi network)
Summary: Plasma Desktop Shell (disconnect from wi-fi network)
Status: RESOLVED DUPLICATE of bug 253584
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-25 09:14 UTC by Sergey Kostenko
Modified: 2011-04-26 03:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Kostenko 2011-04-25 09:14:05 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-28-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
Plasma Desktop Shell crashed after disconnect from wi-fi network

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7805ad0 (LWP 1780))]

Thread 3 (Thread 0xaf9d1b70 (LWP 1783)):
#0  0x00331fa6 in pthread_mutex_unlock () from /lib/libc.so.6
#1  0x01f884f9 in ?? () from /lib/libglib-2.0.so.0
#2  0x01f88848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x0251359f in QEventDispatcherGlib::processEvents (this=0x8b08a28, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#4  0x024e3609 in QEventLoop::processEvents (this=0xaf9d1280, flags=) at kernel/qeventloop.cpp:149
#5  0x024e3a8a in QEventLoop::exec (this=0xaf9d1280, flags=...) at kernel/qeventloop.cpp:201
#6  0x023dfb7e in QThread::exec (this=0x90ccb18) at thread/qthread.cpp:490
#7  0x024c235b in QInotifyFileSystemWatcherEngine::run (this=0x90ccb18) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x023e2df9 in QThreadPrivate::start (arg=0x90ccb18) at thread/qthread_unix.cpp:266
#9  0x087c6cc9 in start_thread () from /lib/libpthread.so.0
#10 0x0032469e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xae275b70 (LWP 1784)):
#0  0x01f87ec0 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#1  0x01f88279 in ?? () from /lib/libglib-2.0.so.0
#2  0x01f88848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x0251359f in QEventDispatcherGlib::processEvents (this=0x9182480, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#4  0x024e3609 in QEventLoop::processEvents (this=0xae275280, flags=) at kernel/qeventloop.cpp:149
#5  0x024e3a8a in QEventLoop::exec (this=0xae275280, flags=...) at kernel/qeventloop.cpp:201
#6  0x023dfb7e in QThread::exec (this=0x91823e8) at thread/qthread.cpp:490
#7  0x024c235b in QInotifyFileSystemWatcherEngine::run (this=0x91823e8) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x023e2df9 in QThreadPrivate::start (arg=0x91823e8) at thread/qthread_unix.cpp:266
#9  0x087c6cc9 in start_thread () from /lib/libpthread.so.0
#10 0x0032469e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb7805ad0 (LWP 1780)):
[KCrash Handler]
#7  0x024ea8f7 in QMetaObject::cast (this=0x3bd4740, obj=0x9089580) at kernel/qmetaobject.cpp:266
#8  0x039c8c0a in qobject_cast<RemoteInterfaceConnection*> (this=0x9577298) at /usr/include/qt4/QtCore/qobject.h:455
#9  ActivatableItem::interfaceConnection (this=0x9577298) at ../../applet/activatableitem.cpp:88
#10 0x039bbcac in ActivatableListWidget::hoverLeave (this=0x8fe4428, uni=...) at ../../applet/activatablelistwidget.cpp:301
#11 0x039b2a0d in ActivatableListWidget::qt_metacall (this=0x8fe4428, _c=QMetaObject::InvokeMetaMethod, _id=45, _a=0xbf88ac88) at moc_activatablelistwidget.cpp:102
#12 0x024ea8ca in QMetaObject::metacall (object=0x8fe4428, cl=150911592, idx=45, argv=0xbf88ac88) at kernel/qmetaobject.cpp:237
#13 0x024fd6ad in QMetaObject::activate (sender=0x91671a8, m=0x39d0a2c, local_signal_index=5, argv=0x0) at kernel/qobject.cpp:3280
#14 0x039b1b53 in InterfaceItem::hoverLeave (this=0x91671a8, _t1=...) at moc_interfaceitem.cpp:171
#15 0x039be162 in InterfaceItem::hoverLeaveEvent (this=0x91671a8, event=0xbf88ae1c) at ../../applet/interfaceitem.cpp:465
#16 0x01af4176 in QGraphicsItem::sceneEvent (this=0x91671b0, event=0xbf88ae1c) at graphicsview/qgraphicsitem.cpp:6660
#17 0x01b4b4d7 in QGraphicsWidget::sceneEvent (this=0x91671a8, event=0xbf88ae1c) at graphicsview/qgraphicswidget.cpp:1173
#18 0x01b0c569 in QGraphicsScenePrivate::sendEvent (this=0x8aad750, item=0x91671b0, event=0xbf88ae1c) at graphicsview/qgraphicsscene.cpp:1211
#19 0x01b0c8ae in QGraphicsScenePrivate::sendHoverEvent (this=0x8aad750, type=QEvent::GraphicsSceneHoverLeave, item=0x91671b0, hoverEvent=0xbf88af2c) at graphicsview/qgraphicsscene.cpp:1258
#20 0x01b129e3 in QGraphicsScenePrivate::dispatchHoverEvent (this=0x8aad750, hoverEvent=0xbf88af2c) at graphicsview/qgraphicsscene.cpp:3902
#21 0x01b12e68 in QGraphicsScene::mouseMoveEvent (this=0x8aa7468, mouseEvent=0xbf88b4b4) at graphicsview/qgraphicsscene.cpp:4080
#22 0x01b2757d in QGraphicsScene::event (this=0x8aa7468, event=0xbf88b4b4) at graphicsview/qgraphicsscene.cpp:3437
#23 0x01441fdc in QApplicationPrivate::notify_helper (this=0x8aa7588, receiver=0x8aa7468, e=0xbf88b4b4) at kernel/qapplication.cpp:4396
#24 0x0144804e in QApplication::notify (this=0x8a9af20, receiver=0x8aa7468, e=0xbf88b4b4) at kernel/qapplication.cpp:3798
#25 0x0112782a in KApplication::notify (this=0x8a9af20, receiver=0x8aa7468, event=0xbf88b4b4) at ../../kdeui/kernel/kapplication.cpp:311
#26 0x024e4b3b in QCoreApplication::notifyInternal (this=0x8a9af20, receiver=0x8aa7468, event=0xbf88b4b4) at kernel/qcoreapplication.cpp:732
#27 0x01441b9e in sendSpontaneousEvent (receiver=0x8aa7468, event=0x0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#28 qt_sendSpontaneousEvent (receiver=0x8aa7468, event=0x0) at kernel/qapplication.cpp:5388
#29 0x01b45282 in QGraphicsViewPrivate::mouseMoveEventHandler (this=0x9183580, event=0xbf88bd00) at graphicsview/qgraphicsview.cpp:647
#30 0x01b454c6 in QGraphicsView::mouseMoveEvent (this=0x90bcbf8, event=0xbf88bd00) at graphicsview/qgraphicsview.cpp:3272
#31 0x0149fcaa in QWidget::event (this=0x90bcbf8, event=0xbf88bd00) at kernel/qwidget.cpp:8172
#32 0x018c1763 in QFrame::event (this=0x90bcbf8, e=0xbf88bd00) at widgets/qframe.cpp:557
#33 0x0195ea82 in QAbstractScrollArea::viewportEvent (this=0x8feba68, e=0x0) at widgets/qabstractscrollarea.cpp:1043
#34 0x01b42ccb in QGraphicsView::viewportEvent (this=0x90bcbf8, event=0xbf88bd00) at graphicsview/qgraphicsview.cpp:2862
#35 0x019614d5 in viewportEvent (this=0x8fe9958, o=0x91954a0, e=0xbf88bd00) at widgets/qabstractscrollarea_p.h:100
#36 QAbstractScrollAreaFilter::eventFilter (this=0x8fe9958, o=0x91954a0, e=0xbf88bd00) at widgets/qabstractscrollarea_p.h:116
#37 0x024e429a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8aa7588, receiver=0x91954a0, event=0xbf88bd00) at kernel/qcoreapplication.cpp:847
#38 0x01441fb9 in QApplicationPrivate::notify_helper (this=0x8aa7588, receiver=0x91954a0, e=0xbf88bd00) at kernel/qapplication.cpp:4392
#39 0x01448c2e in QApplication::notify (this=0x8a9af20, receiver=0x91954a0, e=0xbf88bd00) at kernel/qapplication.cpp:3959
#40 0x0112782a in KApplication::notify (this=0x8a9af20, receiver=0x91954a0, event=0xbf88bd00) at ../../kdeui/kernel/kapplication.cpp:311
#41 0x024e4b3b in QCoreApplication::notifyInternal (this=0x8a9af20, receiver=0x91954a0, event=0xbf88bd00) at kernel/qcoreapplication.cpp:732
#42 0x01447094 in sendEvent (receiver=0x91954a0, event=0xbf88bd00, alienWidget=0x91954a0, nativeWidget=0x918f548, buttonDown=0x1ddc3c0, lastMouseReceiver=..., spontaneous=true) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#43 QApplicationPrivate::sendMouseEvent (receiver=0x91954a0, event=0xbf88bd00, alienWidget=0x91954a0, nativeWidget=0x918f548, buttonDown=0x1ddc3c0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3058
#44 0x014d5d10 in QETWidget::translateMouseEvent (this=0x918f548, event=0xbf88c21c) at kernel/qapplication_x11.cpp:4403
#45 0x014d5151 in QApplication::x11ProcessEvent (this=0x8a9af20, event=0xbf88c21c) at kernel/qapplication_x11.cpp:3414
#46 0x0150436a in x11EventSourceDispatch (s=0x8aaae50, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#47 0x01f84855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#48 0x01f88668 in ?? () from /lib/libglib-2.0.so.0
#49 0x01f88848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#50 0x02513565 in QEventDispatcherGlib::processEvents (this=0x8a6dfa8, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#51 0x01503be5 in QGuiEventDispatcherGlib::processEvents (this=0x8a6dfa8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#52 0x024e3609 in QEventLoop::processEvents (this=0xbf88c514, flags=) at kernel/qeventloop.cpp:149
#53 0x024e3a8a in QEventLoop::exec (this=0xbf88c514, flags=...) at kernel/qeventloop.cpp:201
#54 0x024e800f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#55 0x01440e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#56 0x00edf1e7 in kdemain (argc=1, argv=0xbf88c724) at ../../../../plasma/desktop/shell/main.cpp:118
#57 0x080485bb in main (argc=1, argv=0xbf88c724) at plasma-desktop_dummy.cpp:3

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-04-26 03:11:59 UTC

*** This bug has been marked as a duplicate of bug 253584 ***